Contenu | Rechercher | Menus

Annonce

L'équipe des administrateurs et modérateurs du forum vous invite à prendre connaissance des nouvelles règles.
En cas de besoin, vous pouvez intervenir dans cette discussion.

Ubuntu 18.04 LTS
Ubuntu-fr propose des clés USB de Ubuntu et toutes ses « saveurs » ainsi qu'un magnifique t-shirt pour cette toute nouvelle version d'Ubuntu !

Si vous avez des soucis pour rester connecté, déconnectez-vous puis reconnectez-vous depuis ce lien en cochant la case
Me connecter automatiquement lors de mes prochaines visites.

À propos de l'équipe du forum.

#1 Le 19/05/2013, à 21:01

Vicolaships

Règle udev

Salut,

J'ai un problème avec la création d'une règle udev. L'objectif final est de créer une règle pour activer/désactiver le touchpad à la de/connexion d'une souris USB.

Je créé une règle simple pour tester :

victor@X301A1:~$ ls /etc/udev/rules.d/
70-persistent-cd.rules  70-persistent-net.rules  README

On créé la règle :

victor@X301A1:~$ sudo gedit /etc/udev/rules.d/01-my-first-udev.rules

La règle en question :

ACTION=="add", RUN+="echo HELLO ! > /home/victor/udev_test_log.txt"

Je recharge les règles

 sudo udevadm control --reload-rules

Malgré ça à la connexion d'un périphérique USB le fichier udev_test_log.txt n'est pas créé. Ou est l'erreur ?


Ubuntu 14.04 x64

Hors ligne

#2 Le 19/05/2013, à 21:28

LapiGNU

Re : Règle udev

Salut, tu devrais essayer d'enlever le ! du texte que tu envoie à la commande echo, qui sera sûrement moins contrariée.

Pour voir de tes yeux la différence, dans un terminal tape "echo hello !", puis eval $(echo hello !), le résultat n'est pas le même. Dans le cas de ta règle, le cas de figure est le même qu'avec eval depuis la ligne de commande.

Hoplà ?


frenchKISS sur www.tchitcha.info, Ubuntu clé en main pour les réseaux de postes de travail.
et surtout : Sauvez les arbres, mangez des castors. Sauvez les castors, ne mangez pas d'arbres !

Hors ligne

#3 Le 19/05/2013, à 22:15

Vicolaships

Re : Règle udev

Merci pour ta réponse ! J'ai essayé ce que tu m'as conseillé mais cela ne marche pas.

Comment "debugger" udev ?


Ubuntu 14.04 x64

Hors ligne