Contenu | Rechercher | Menus

Annonce

Si vous rencontrez des soucis à rester connecté sur le forum (ou si vous avez perdu votre mot de passe) déconnectez-vous et reconnectez-vous depuis cette page, en cochant la case "Me connecter automatiquement lors de mes prochaines visites".

#1 Le 20/05/2013, à 12:33

Menagex

[Xubuntu] Français pas complètement installé

Bonjour à tous,

J'utilise Xubuntu 12.10 sur mon PC (il est installé sur le disque dur). Jusqu'à pas longtemps, il était en Français globalement (par exemple, quand je cliquais sur ma session, c'était inscrit "Éteindre", Synaptic était en Français...
Après utilisation de localepurge, il n'est plus en Français complètement : par exemple "Système de fichiers" est "File System", "Corbeille" est resté "Corbeille"... Synaptic est en anglais...

J'ai bien réinstallé les paquets de langue (language-pack-fr, language-pack-fr-base, language-pack-fr-gnome, language-pack-fr-gnome-base, kde-l10n-fr), je suis allé régler les paramètres de langue dans les réglages.

J'ai aussi suivi la procédure expliquée ici : http://forum.ubuntu-fr.org/viewtopic.php?id=1106071
Mais je reste avec des logiciels en anglais (Synaptic, K3b, ...) alors qu'ils ont été en Français à un moment donné.

Pensez-vous que passer à la version 13.04 puisse apporter une solution ?

Merci par avance.


EeeBox B202 sous Xubuntu 12.10 LTS

Hors ligne

#2 Le 20/05/2013, à 13:41

kurapika29

Re : [Xubuntu] Français pas complètement installé

Avez-vous été faire un tour dans le gestionnaire de paramètres puis dans Prise en charge des langues
Si il manque des traductions il vous le dira, après un petit redémarrage et ça roule wink

Dernière modification par kurapika29 (Le 20/05/2013, à 13:42)


Disponible sur IRC, sur le serveur irc.freenode.net salon ##ubuntu-voyager (et aussi sur plein d'autre serveur/salon)
Venez si vous avec besoin d'aide ou pour causer ;) suffit d'avoir Xchat ou un autre client IRC
Où sinon en cliquant sur se lien http://kiwiirc.com/client/irc.freenode. … tu-voyager

Hors ligne

#3 Le 20/05/2013, à 13:44

k-bag

Re : [Xubuntu] Français pas complètement installé

Bonjour cool

Après changement de langue, il est nécessaire de redémarrer sa machine pour que ces derniers soient pris en compte (Je crois bien que ça a déjà été fait).

Aussi, beaucoup de logiciels KDE permettent de changer la langue à la volée (Si le pack de langue adéquat est installé).
Tu trouveras ça dans le menu: Aide -> Changer la langue de l'application.
1369049903.png

Vérifie aussi qu'il n'y a pas de problèmes au niveau des paquets installés:

sudo apt-get check && sudo apt-get -f install

Si jamais rien ne marche, copie/colle le retour de la commande locale ici.


Xubuntu 12 (Taste of perfection) -- Win7 (1/2)
Blog >> Couscous, Open-source et système binaire
" L'intelligence, c'est pas sorcier, il suffit de penser à une connerie et de dire l'inverse. "

Hors ligne

#4 Le 20/05/2013, à 14:03

Menagex

Re : [Xubuntu] Français pas complètement installé

Merci pour vos réponses rapides.

J'ai bien vérifié que tout soit parfait dans le gestionnaire et ai redémarré moult fois.
Chose intéressante, avec locale, j'ai ceci :

LANG=fr_FR.UTF-8
LANGUAGE=fr:en
LC_CTYPE="fr_FR.UTF-8"
LC_NUMERIC=fr_FR.UTF-8
LC_TIME=fr_FR.UTF-8
LC_COLLATE="fr_FR.UTF-8"
LC_MONETARY=fr_FR.UTF-8
LC_MESSAGES="fr_FR.UTF-8"
LC_PAPER=fr_FR.UTF-8
LC_NAME=fr_FR.UTF-8
LC_ADDRESS=fr_FR.UTF-8
LC_TELEPHONE=fr_FR.UTF-8
LC_MEASUREMENT=fr_FR.UTF-8
LC_IDENTIFICATION=fr_FR.UTF-8
LC_ALL=fr_FR.UTF-8

Je n'ai rien dans LC_ALL...
Cette ligne n'apparait pas dan etc/defaut/locale. Je viens de rajouter LC_ALL=fr_FR.UTF-8, je redémarre et je vous dis.


EeeBox B202 sous Xubuntu 12.10 LTS

Hors ligne

#5 Le 20/05/2013, à 14:11

nam1962

Re : [Xubuntu] Français pas complètement installé

Essaie de refaire la procédure que tu cites en remplaçant intégralement ton locale par celui indiqué.

LANG="fr_FR.UTF-8"
LANGUAGE="fr_FR:fr"
LC_NUMERIC="fr_FR.UTF-8"
LC_TIME="fr_FR.UTF-8"
LC_MONETARY="fr_FR.UTF-8"
LC_PAPER="fr_FR.UTF-8"
LC_IDENTIFICATION="fr_FR.UTF-8"
LC_NAME="fr_FR.UTF-8"
LC_ADDRESS="fr_FR.UTF-8"
LC_TELEPHONE="fr_FR.UTF-8"
LC_MEASUREMENT="fr_FR.UTF-8"

edit : refait entièrement le tuto en supprimant le contenu de ton locale et le remplaçant par celui çi-dessus

Dernière modification par nam1962 (Le 20/05/2013, à 14:13)


Mon tuto pour optimiser / finaliser une install : http://forum.ubuntu-fr.org/viewtopic.ph … #p15041961
Xubuntu 14.04 sur portable, Xub 12.04.3 sur fixe.
Score : 44 convertis (leur ai pas donné le choix, aussi...).
Un jeune site que j'aime bien pour ses T-shirts élégants à coton épais et bio : http://goudronblanc.com

Hors ligne

#6 Le 20/05/2013, à 15:02

Menagex

Re : [Xubuntu] Français pas complètement installé

C'est fait, j'ai suivi ta procédure. Pas de changement, sauf que firefox est en anglais maintenant... mais j'ai pu rectifier ceci.

Dernière modification par Menagex (Le 20/05/2013, à 15:04)


EeeBox B202 sous Xubuntu 12.10 LTS

Hors ligne

#7 Le 20/05/2013, à 16:19

k-bag

Re : [Xubuntu] Français pas complètement installé

La 2ème ligne n'est pas tout à fait correcte, elle doit normalement lister les packs de langues installés sur ta machine (Équivaut à la variable $LANGUAGE), ce qui donne par exemple chez moi (En sachant que le français est la langue principale, suivi de l'anglais et du russe):

LANGUAGE="fr_FR:en:ru"

Quelles sont concrètement les applications non francisées?


Xubuntu 12 (Taste of perfection) -- Win7 (1/2)
Blog >> Couscous, Open-source et système binaire
" L'intelligence, c'est pas sorcier, il suffit de penser à une connerie et de dire l'inverse. "

Hors ligne

#8 Le 20/05/2013, à 16:25

Menagex

Re : [Xubuntu] Français pas complètement installé

Merci pour ta réponse.
Je vais donc remettre fr:en dans la ligne.

Pour les logiciels, synaptic, K3b (gravure), Xcas (mathématiques), et d'autres sont en anglais. Je dirais un sur deux.

Curieusement, en réinstallant certains logiciels, comme Synaptic, ils reviennent en français.
Mais s'il faut tout réinstaller, pourquoi ne pas finalement faire une réinstallation de Xubuntu...


EeeBox B202 sous Xubuntu 12.10 LTS

Hors ligne

#9 Le 20/05/2013, à 17:06

nam1962

Re : [Xubuntu] Français pas complètement installé

k-bag a écrit :

La 2ème ligne n'est pas tout à fait correcte, elle doit normalement lister les packs de langues installés sur ta machine (Équivaut à la variable $LANGUAGE), ce qui donne par exemple chez moi (En sachant que le français est la langue principale, suivi de l'anglais et du russe):

LANGUAGE="fr_FR:en:ru"

(...)

Sauf si on vire l'anglais avec la prise en charge des langues & bleachbit root (ce que j'ai fais chez moi et recommandais à Menagex)

@Menagex : as tu relancé la prise en charge des langues, d'ailleurs?


Mon tuto pour optimiser / finaliser une install : http://forum.ubuntu-fr.org/viewtopic.ph … #p15041961
Xubuntu 14.04 sur portable, Xub 12.04.3 sur fixe.
Score : 44 convertis (leur ai pas donné le choix, aussi...).
Un jeune site que j'aime bien pour ses T-shirts élégants à coton épais et bio : http://goudronblanc.com

Hors ligne

#10 Le 20/05/2013, à 17:20

k-bag

Re : [Xubuntu] Français pas complètement installé

Je ne conseille vraiment pas de virer le pack de langue anglaise, beaucoup d'applications non traduites ou pas complètement l'utilisent, d'ailleurs ça ne prend pas beaucoup de place.


Xubuntu 12 (Taste of perfection) -- Win7 (1/2)
Blog >> Couscous, Open-source et système binaire
" L'intelligence, c'est pas sorcier, il suffit de penser à une connerie et de dire l'inverse. "

Hors ligne

#11 Le 20/05/2013, à 17:58

Menagex

Re : [Xubuntu] Français pas complètement installé

Merci à tous pour vos réponses, mais malheureusement la méthode de nam1962 n'a pas fonctionné chez moi, j'avais pourtant bien relancé la prise en charge des langues. Comme cela fait un moment que je suis sur ce problème sans résultat, je vais réinstaller tout, car étant un nouvel utilisateur, cela devrait aller vite...


EeeBox B202 sous Xubuntu 12.10 LTS

Hors ligne

#12 Le 20/05/2013, à 18:09

nam1962

Re : [Xubuntu] Français pas complètement installé

Profite pour faire une partition propre avec un /home séparé. bizarre ton truc : chez moi et plusieurs autres ça a remis le locale d’aplomb.. La poésie de l'informatique on dira.

@k-bag, j'ai fais ça sur toutes mes install, quand l'appli est en anglais je n'ai pas de problème.
Mais tu as raison, c'est une coquetterie wink


Mon tuto pour optimiser / finaliser une install : http://forum.ubuntu-fr.org/viewtopic.ph … #p15041961
Xubuntu 14.04 sur portable, Xub 12.04.3 sur fixe.
Score : 44 convertis (leur ai pas donné le choix, aussi...).
Un jeune site que j'aime bien pour ses T-shirts élégants à coton épais et bio : http://goudronblanc.com

Hors ligne

#13 Le 20/05/2013, à 22:14

Menagex

Re : [Xubuntu] Français pas complètement installé

Me revoilà, avec un Xubuntu bien en français :-)
Curieux ce bug... Je pense que je vais laisser locale purge tranquille :-)


EeeBox B202 sous Xubuntu 12.10 LTS

Hors ligne

#14 Le 21/05/2013, à 08:06

nam1962

Re : [Xubuntu] Français pas complètement installé

wink


Mon tuto pour optimiser / finaliser une install : http://forum.ubuntu-fr.org/viewtopic.ph … #p15041961
Xubuntu 14.04 sur portable, Xub 12.04.3 sur fixe.
Score : 44 convertis (leur ai pas donné le choix, aussi...).
Un jeune site que j'aime bien pour ses T-shirts élégants à coton épais et bio : http://goudronblanc.com

Hors ligne

#15 Le 21/05/2013, à 16:22

k-bag

Re : [Xubuntu] Français pas complètement installé

Menagex a écrit :

Curieux ce bug... Je pense que je vais laisser locale purge tranquille :-)

Sage décision big_smile

Bonne journée.


Xubuntu 12 (Taste of perfection) -- Win7 (1/2)
Blog >> Couscous, Open-source et système binaire
" L'intelligence, c'est pas sorcier, il suffit de penser à une connerie et de dire l'inverse. "

Hors ligne

  • Accueil
  • » Forum
  • » XFCE
  • » [Xubuntu] Français pas complètement installé

Haut de page ↑