Contenu | Rechercher | Menus

Annonce

Si vous rencontrez des soucis à rester connecté sur le forum (ou si vous avez perdu votre mot de passe) déconnectez-vous et reconnectez-vous depuis cette page, en cochant la case "Me connecter automatiquement lors de mes prochaines visites". Attention, le forum rencontre actuellement quelques difficultés. En cas d'erreur 502, il ne faut pas re-valider l'envoi d'un message ou l'ouverture d'une discussion, au risque de créer un doublon.

La section divers se réorganise ! De nouvelles sous-sections à venir. (plus d'infos + donner son avis)

#1 Le 26/05/2013, à 10:51

Gyp

Problème avec Inkscape, image rognée après Découpe et Motif.

Bonjour,

Un problème m'est apparu avec Inkscape lorsque je tente de réaliser un motif après une découpe (voir tuto Motifs partie 2 à l'adresse Motifs 2).

Plus précisément : J'ai quelques figures (disons des ballons). Je les pose sur un carré duquel les ballons débordent. Je clone le carré de fond qui se place au-dessus. Je fais Définir une découpe entre les 2 objets. La découpe se passe bien.
Par contre, quand de cette découpe je fais un motif --> Objet > Motifs > Objet en motif, et qu'après avoir dupliquer/cloner l'objet découpé, j'essaie de l'agrandir, de le bouger, des blancs apparaissent, des parties sont comme gommées.

Quelqu'un aurait-il une idée sur ce qui se passe (problème de visionneur, erreur dans la réalisation...)

Merci,

Gyp


ubuntu-studio 14.04

Hors ligne

#2 Le 26/05/2013, à 10:58

brucyn

Re : Problème avec Inkscape, image rognée après Découpe et Motif.

Bonjour

Peut-être que quelqu'un pourra plus facilement t'aider si tu joint ton fichier .svg

Cordialement


Une edute mtnroe que peu ipmrote l'odre des ltretes, suel la pemriree et la dreinere cmotpe
Rien n'est impossible, il suffit juste de savoir comment faire !

Hors ligne

#3 Le 26/05/2013, à 12:47

Gyp

Re : Problème avec Inkscape, image rognée après Découpe et Motif.

Bonjour,

Veux-tu le code du fichier svg ?

Sinon, voici la démarche :
1) Créer 3 ballons de couleurs différentes (sans contour).
2) Créer un carré de fond (derrière les autres) d'une autre couleur et sans contour.
3) Disposer 2 des ballons à l'intérieur du carré et le 3ème, cloné 3 fois, aux coins en dépassant du carré.
4) Grouper les 6 ballons.
5) Cloner le fond.
6) Sélectionner le clone du fond et le groupe de 6 ballons, clic droit Définir une découpe ; grouper l'ensemble

Jusqu'ici tout va bien.

7) Dupliquer l'objet découpé, le déplacer et faire Objet > Motifs > Objet en motif.

C'est là que ça coince, l'image n'est pas complète, des rectangles blanc apparaissent.

Si tu veux le code ou l'image, je te l'enverrai.

Merci,

Gyp


ubuntu-studio 14.04

Hors ligne

#4 Le 27/05/2013, à 13:12

fabkzo

Re : Problème avec Inkscape, image rognée après Découpe et Motif.

ça le fait aussi chez moi;
il faudrait que je continue l'expérimentation, un bon bug d'affichage, qui se retrouve à l'export en .png;
je pense que cela puisse venir de "définir une découpe" puisque à ce moment là tu retrouves toujours tes chemins entiers, et non découpés; essaye en convertissant tout en chemins dès le début - c'est à dire qu'au lieu de bosser avec des objets ( rect, circle etc... ) tu bosseras avec des chemins , ce qui devrait normalement limiter les problemes.

edit:

Testé avec la version dev d'inkscape ( Inkscape 0.48.4 r9939 ) : même problème quand tu définis une découpe et qu'ensuite tu veux en faire un motif.

Solution:

==> Tu sélectionnes tes chemins et fais une division ( Chemin -> Division  ) plutôt qu'une découpe; ensuite tu groupes le tout et en fais un motif.

Dernière modification par fabkzo (Le 27/05/2013, à 22:10)


pinterest ==> fabkzo!
Python beginner on Rpi
http://www.fabkzo.com

Hors ligne

#5 Le 28/05/2013, à 11:39

Gyp

Re : Problème avec Inkscape, image rognée après Découpe et Motif.

Salut,

Le bug d'affichage n'apparaît pas seulement dans l'export en png.

J'ai refait les mêmes manips et, suivant ton idée, j'ai tout passé en chemins préalablement, mais même résultat.

Le problème apparaît lorsqu'on fait découpe puis transformation en motif. La découpe toute seule ne pose pas de problème et la transformation en motif non plus.

Je travaille sous Ubuntu13.04 avec Inkscape 0.48.4 r9939 ; j'ai fait mes essais avec l'ordi de mon fils sous Win7, même résultat.

J'ai essayé ta solution, à laquelle j'avais aussi pensé, d'utiliser une opération sur des chemins, mais je rencontre encore des problèmes : Lorsque je groupe mes ballons, même si je les ai transformés en chemin, j'ai un message d'erreur, "Un des objets au moins n'est pas un chemin". Si je ne prends que 2 objets (un ballon chevauchant un carré, les deux en chemin), aucune des opérations de chemin ne me donne ce que j'obtiens avec la découpe, la division non plus.

Je vais continuer à essayer, je dois sortir maintenant.

Merci et à + j'espère,

Gyp


ubuntu-studio 14.04

Hors ligne

#6 Le 28/05/2013, à 13:10

fabkzo

Re : Problème avec Inkscape, image rognée après Découpe et Motif.

Il est normal qu'un groupe de chemins en tant qu'objets ne soit pas reconnus comme un seul chemin
==> pour cela tu dois les combiner ( chemin -> combiner ) là tu n'auras plus de souci.

C'est ce que j'aime avec inkscape: il y a plein de solutions simples pour arriver au même résultat.


pinterest ==> fabkzo!
Python beginner on Rpi
http://www.fabkzo.com

Hors ligne

#7 Le 28/05/2013, à 19:17

Gyp

Re : Problème avec Inkscape, image rognée après Découpe et Motif.

Merci de ton aide.

J'ai déjà essayé de combiner les 6 ballons-chemins (pour rester dans mon exemple) pour que le groupe de chemins n'en fasse qu'un. Le problème est que j'ai besoin de cloner un des ballons 3 fois , les placer sur chacun des coins, pour pouvoir après coup les réajuster (en clonant 8 fois le carré découpé et en les plaçant tout autour - je ne suis pas certain d'être suffisamment clair, mais je peux expliquer).

Or, si je clone 3 fois le 1er ballon-chemin et que je sélectionne les 6 ballons pour les combiner, les 3 clones ne sont pas inclus dans la combinaison.

A part cela, je partage ton enthousiasme pour Inkscape.

A+,

Gyp


ubuntu-studio 14.04

Hors ligne

#8 Le 28/05/2013, à 21:51

fabkzo

Re : Problème avec Inkscape, image rognée après Découpe et Motif.

Ok j'ai compris, mais aucun souci en fait:

=> ton 'ballon' différent, rien  ne t'empêche de le grouper avec l'ensemble et de prendre ce groupe pour en faire un motif ; à partir du moment où tu n'utilises pas l'outil découpe ça le fait.
Et effectivement si tu cherches à tout combiner les couleurs, contours etc vont être unifiés.

Regarde ce que j'ai fait rapidement en images :

http://fabkzo.com/inkscape-patterns-les … e-decoupe/


pinterest ==> fabkzo!
Python beginner on Rpi
http://www.fabkzo.com

Hors ligne

#9 Le 29/05/2013, à 17:04

Gyp

Re : Problème avec Inkscape, image rognée après Découpe et Motif.

Salut fabkzo,

Sympa ton tuto et ta disposition à trouver des solutions. Quelques remarques :

1) Img4 : Si je clone le fond et que j'essaie de faire une opération de chemin (division, en l'occurrence), j'ai un message d'erreur : Un des objets au moins n'est pas un chemin.
Le problème se résout si je duplique.

2) Img9 : Si je transforme en motif et que les objets recouvrant les angles ne coïncident pas, il y a bien-sûr un problème.
J'ai essayé de cloner 8 fois tout autour l'objet qui doit devenir motif et fait varier les positions pour que les 4 parties coïncident, mais cela engendre des problèmes, des choses ont bougé.

La solution que j'ai trouvée est d'activer le magnétisme et de placer l'objet sur les coins en faisant coïncider son centre de rotation avec le coin du carré, puis dupliquer et faire de même 3 fois.
De plus, si on ne veut pas que le centre de l'objet soit exactement sur l'angle, il n'y a qu'à déplacer son centre de rotation et ensuite de le positionner de même par le magnétisme.

J'ai voulu placer une étoile dans les ballons d'angle. Une fois l'objet "divisé" avec les ballons, j'ai placé les étoiles (id. en jouant sur la magnétisme du centre de rotation) et recommencer les étapes. Cela fonctionne bien.
Il faut recommencer l'opération autant de fois que l'on a d'éléments dans l'objet de coin.

Y a-t-il plus simple, en attendant la fixation du bug ?

Merci et à+,

Gyp


ubuntu-studio 14.04

Hors ligne

#10 Le 29/05/2013, à 21:45

fabkzo

Re : Problème avec Inkscape, image rognée après Découpe et Motif.

Ce n'est rien, j'en profite également pour revoir certaines techniques;

Notamment celle-ci dont je ne suis pas rappelé et qui devrait t'aider grandement : (merci tavmjong bah )

http://tavmjong.free.fr/INKSCAPE/MANUAL … ttern.html

Tu gagnes vraiment en rapidité et précision; pour l'élément que tu veux retrouver aux 4 coins ==> clones simples ( ctrl+D) + translations en calculant  les nouvelles coordonnées en fonction de la taille de ton fond.

J'avais testé un truc il y a une paire d'années de cette manière :

http://fabkzo.com/?attachment_id=392

A+


pinterest ==> fabkzo!
Python beginner on Rpi
http://www.fabkzo.com

Hors ligne

#11 Le 31/05/2013, à 14:09

Gyp

Re : Problème avec Inkscape, image rognée après Découpe et Motif.

Salut,

J'avais déjà fait ce tuto lorsque j'ai commencé avec Inkscape. Je l'ai revu, des points se sont éclaircis, d'autres restent un peu flous, mais cette méthode répond aux principaux besoins en matière de remplissage par motif.
Je suis parvenu aussi à transformer un objet en motif en farfouillant dans l’Éditeur XML.

C'est vrai que l'on gagne en rapidité et en précision en passant par la translation. Cependant pour un objet complexe sur les coins, je rencontre des difficultés à le réaliser correctement, mais je vais continuer à essayer.

J'ai vu ton graphisme avec des étoiles, vraiment sympa. Je n'ai pas compris ce que tu avais fait.

A+,

Gyp


ubuntu-studio 14.04

Hors ligne

#12 Le 31/05/2013, à 16:30

Papy Octet

Re : Problème avec Inkscape, image rognée après Découpe et Motif.

Bon, ceci n'a peut-être rien à voir avec le problème soulevé ici, mais c'est un tuto sur l'utilisation des clones qui est vraiment surprenant.

Ici le tuto sur les clones.

Ça m'aidera à retrouve l'adresse plus tard tongue et informera les autres utilisateurs de Inkscape.
Oui, bon. C'est en anglais mais c'est très explicite tout de même.

A+

Dernière modification par Papy Octet (Le 31/05/2013, à 16:31)


AMD A6-3500 HD6530D 2.1 ghz Triple core FM1 3mb - CM GIGABYTE GA-A75M-UD2H - 8 GiO ram DDR3 - HDD 1TO WD GREEN + WD Gaviar Black 1TO + externe IOMEGA 500GiO - Carte écran nvidia GeForce 210 Silent avec 1GiO cache DDR3 - Ubuntu
Portable HP - Intel Centrino - 1 Go DDR2 - DD 120 Go - Mint 14
Imprim. Samsung ML-1670 et CLP-315, scanner Epson Perfection V30, ... Linuxgraphic.org, LibreOffice.org

Hors ligne

#13 Le 31/05/2013, à 19:08

fabkzo

Re : Problème avec Inkscape, image rognée après Découpe et Motif.

Ah merci Papy Octet, si tu as d'autres trucs comme ça je suis preneur ^^


pinterest ==> fabkzo!
Python beginner on Rpi
http://www.fabkzo.com

Hors ligne

#14 Le 01/06/2013, à 16:26

Gyp

Re : Problème avec Inkscape, image rognée après Découpe et Motif.

Très intéressant le tuto. Les diverses options de pavages avec clones méritent d'être connues.

Merci Papy Octet smile.

Gyp


ubuntu-studio 14.04

Hors ligne

Haut de page ↑