Contenu | Rechercher | Menus

Annonce

Si vous rencontrez des soucis à rester connecté sur le forum (ou si vous avez perdu votre mot de passe) déconnectez-vous et reconnectez-vous depuis cette page, en cochant la case "Me connecter automatiquement lors de mes prochaines visites".
Test de l'ISO d'Ubuntu francophone : nous avons besoin de testeurs pour la version francophone d'Ubuntu 14.04. Liens et informations ici.

#1 Le 04/06/2013, à 17:55

djinnie

serveur de documents ubuntu

Bonjour à tous,

J'avais commencé un post, mais je crois ne l'avoir pas mis dans la bonne rubrique (d'ailleurs, pas de réponse édifiante...)

J'explique donc :
On est 4 à partager des données sur un petit serveur de documents (qui est en fait un bête ordi).
Suite à la mort de mon précédent disque dur, j'ai tenté de réinstaller XP (qui me suffisait amplement) mais souci de fin de suivi de mise-à-jour par Windows, bref, je passe les détails : trop galère, j'abandonne...

Pourquoi pas Ubuntu alors que j'aime beaucoup bien que je n'arrive pas encore à me passer de Windows...

J'ai donc installé Ubuntu 12.10, Samba et l'outil de configuration de samba, puis après avoir pas mal galéré (c'est dingue comme c'est difficile de deviner quel code utiliser quand on n'y connaît rien wink ) j'ai suivi pas à pas ce  :  tuto
Ça marche, mais pas exactement comme je voudrais et je ne sais pas quoi modifier (j'ai fait du copier-coller, mais visiblement j'ai pas tout compris) : actuellement, je peux me connecter de windows sur /home dans un dossier /user, alors que je souhaiterais qu'on puisse se connecter 2 par 2 sur des partitions différentes (comme la partition /pro)

Voilà mon smb.conf si jamais ça parle à quelqu'un :

[global]
	workgroup = workgroup
	server string = %h
	dns proxy = no
	log file = /var/log/samba/log.%m
	max log size = 1000
	syslog = 0
	panic action = /usr/share/samba/panic-action %d

	security = user
	encrypt passwords = true
	passdb backend = tdbsam
	obey pam restrictions = yes
	unix password sync = yes
	passwd program = /usr/bin/passwd %u
	passwd chat = *Enter\snew\s*\spassword:* %n\n *Retype\snew\s*\spassword:* %n\n *password\supdated\ssuccessfully* .
	pam password change = yes
	domain master = yes
	os level = 33
	preferred master = yes
	domain logons = yes
	logon path = \\%N\profiles\%U
	logon drive = H:
	logon home = \\%n\%u

	add user script = /usr/sbin/adduser -g dom_users -c Utilisateur -d /dev/null -s /bin/false ’%u’
	add machine script = /usr/sbin/useradd -g dom_pc -c "%u machine account" -d /dev/null -s /bin/false ’%u’
	add group script = /usr/sbin/groupadd ’%g’
	delete user script = /usr/sbin/userdel -r ’%u’
	delete group script = /usr/sbin/groupdel ’%g’
	delete user from group script = /usr/bin/gpasswd -d ’%u’ ’%g’
	set primary group script = /usr/sbin/usermod -g ’%g’ ’%u’
	username map = /etc/samba/smbusers


##share##

[homes]
	comment = Home Directories
	browseable = no
	read only = no
	create mask = 0700
	directory mask = 0700
	valid users = %S

[netlogon]
	comment = Network Logon Service
	path = /home/samba/netlogon
	guest ok = yes
	read only = yes

[profiles]
	comment = Users profiles
	path = /home/samba/profiles
	create mask = 0600
	directory mask = 0700
	writeable = yes

[printers]
	comment = All Printers
	browseable = no
	path = /var/spool/samba
	printable = yes
	guest ok = no
	read only = yes
	create mask = 0700

[print$]
	comment = Printer Drivers
	path = /var/lib/samba/printers
	browseable = yes
	read only = yes
	guest ok = no


[serveur]
	path = /media/serveur/pro
	browseable = yes
	read only = no
	create mask = 0700
	directory mask = 0700	
	valid users = %S

Il m'est impossible de me connecter sur serveur, alors que j'accède sous souci aux autres partages...

Avez-vous des solutions ? Des tutos à me proposer ?

Merci d'avance


Virginie

Hors ligne

#2 Le 04/06/2013, à 19:55

toutafai

Re : serveur de documents ubuntu

Bonsoir,

Avant de te repondre pourrais tu préciser un peu mieux.

Déja, qu'entends-tu par "je souhaiterais qu'on puisse se connecter 2 par 2 sur des partitions différentes", c'est pas clair ?

Ensuite que veux tu faire exactement ? Si c'est juste creer sur ton ubuntu un repertoire partagé pour tous les utilisateurs de ton réseau, ou bien veux tu que chaque utilisateurs aient un dossier partagé personnel (=toto a le dossier toto, tata a le dossier tata, etc etc) ?

Enfin pareil que plus haut, qu'entend tu par "Il m'est impossible de me connecter sur serveur, alors que j'accède sous souci aux autres partages..." , précise plutot par exemple :"depuis windows je peux voir ou pas les dossier partagés sous ubuntu" ?

Dernière modification par toutafai (Le 04/06/2013, à 19:55)


Ubuntu Server 12.04 x32 sur IBM P4. - XP / Seven / Ubuntu 14.04 x64 sur Lenovo ThinkPad. Purée d'unity...difficile de s'y faire - canon MG5350 - Logitech Quickcam 3000 - TNT Intuix S800 - Freebox v6 révolution (Trop de la balle !!!)
Utilisateur d'Ubuntu depuis novembre 2006.
23 PC libérés grâce aux OS libres...et de 24 et quel 24 ...car pc au taff et pour le taff ^^

Hors ligne

#3 Le 04/06/2013, à 20:39

djinnie

Re : serveur de documents ubuntu

Bonsoir Toutafai !

Je n'ai sans doute pas été explicite :
on est 4 -> 2 bossent pour la boite X et 2 bossent pour la boite Y,
on souhaite partager un même serveur de documents et pour ce faire, j'ai partionné mon disque pour que la boite X ait sa propre partition, idem pour Y.
Evidemment, les 2 qui bossent pour X doivent accéder aux mêmes fichiers sans que les 2 qui bossent pour Y y accèdent... et réciproquement.

Quand je disais que je ne pouvais pas accéder au dossier /serveur, je voulais dire par là, mon login et mon mot de passe ne me permettent pas d'accéder à ce dossier partagé, alors qu'ils m'autorisent à accéder aux autres dossiers partagés (tous sur le même serveur, mais pas sur la même partition).

Comme j'étais un peu serrée au niveau du temps (hé ! c'est pas mon métier l'informatique et donc faut que je retourne bosser pour de vrai !!!), j'ai réussi à trouver une solution qui me convient à peu près :
j'ai conservé l'accès login réseau windows = login session ubuntu avec accès direct au dossier /user et j'ai fait des mount bind dans chaque dossier /user vers les partitions de chaque entreprise -> j'ai donc bien 4 dossiers /user avec des liens vers uniquement 2 partitions du disque, une pour chaque entreprise, chacune partagée par 2 personnes et le tout protégé par des mots de passe.

Par contre, j'aimerais toujours comprendre ce qui empêchait que j'accède à mon dossier /serveur...

Bonne soirée

Dernière modification par djinnie (Le 04/06/2013, à 20:40)


Virginie

Hors ligne

#4 Le 06/06/2013, à 03:26

AlexandreP

Re : serveur de documents ubuntu

Re,

djinnie a écrit :

[serveur]
    path = /media/serveur/pro
    browseable = yes
    read only = no
    create mask = 0700
    directory mask = 0700   
    valid users = %S

Le paramètre valid users précise quel ou quels utilisateurs peuvent entrer dans le dossier partagé. (http://www.samba.org/samba/docs/using_samba/ch09.html)
La variable %S est remplacée par le nom du dossier partagé en cours. (http://www.samba.org/samba/docs/using_s … -6-TABLE-2)

Selon cette configuration, l'accès au dossier partagé serveur ne serait alors permise qu'à un seul utilisateur dont l'identifiant serait serveur. Or, ce n'est pas (il me semble) une configuration désirée dans ton cas, car il n'y a pas d'utilisateur appelé serveur et d'autres utilisateurs devraient pouvoir accéder à ce dossier partagé.


Si tu veux limiter l'accès à des utilisateurs spécifiques, tu peux préciser leur noms d'utilisateurs sous la forme suivante. Prenons par exemple 4 utilisateurs: hansolo, chewbacca, spock et kirk:

[starwars]
    path = /media/serveur/starwars
    browseable = yes
    read only = no
    create mask = 0700
    directory mask = 0700   
    valid users = hansolo, chewbacca

[startrek]
    path = /media/serveur/startrek
    browseable = yes
    read only = no
    create mask = 0700
    directory mask = 0700   
    valid users = spock, kirk


Un autre moyen, qui peut être plus flexible si vos deux entreprises sont appelées à grandir et donc voir des nouveaux employés arriver ou des anciens employés quitter l'entreprise, pourrait être de préciser des groupes d'utilisateurs autorisés à se connecter aux dossiers partagés. Les groupes sont des groupes Unix. Donc, par exemple, dans un terminal sur le serveur, on exécuterait quelque chose comme:

sudo addgroup milleniumfalcon
sudo adduser hansolo milleniumfalcon
sudo adduser chewbacca milleniumfalcon

sudo addgroup enterprise
sudo adduser spock enterprise
sudo adduser kirk enterprise

Ceci te permettrait de préciser des groupes d'utilisateurs autorisés à accéder aux dossiers partagés. L'exemple ci-dessous serait identique à l'exemple précédent:

[starwars]
    path = /media/serveur/starwars
    browseable = yes
    read only = no
    create mask = 0700
    directory mask = 0700   
    valid users = @milleniumfalcon

[startrek]
    path = /media/serveur/startrek
    browseable = yes
    read only = no
    create mask = 0700
    directory mask = 0700   
    valid users = @enterprise


«La capacité d'apprendre est un don; La faculté d'apprendre est un talent; La volonté d'apprendre est un choix.» -Frank Herbert
93,8% des gens sont capables d'inventer des statistiques sans fournir d'études à l'appui.

Hors ligne

#5 Le 06/06/2013, à 13:25

djinnie

Re : serveur de documents ubuntu

Hmmm... ça me plait bien l'idée des groupes (quoique, ce serait pour la beauté de la chose, car à 4 je risque de me prendre la tête pour pas grand chose wink)
Je teste et je reviens !

Merci, merci smile


Virginie

Hors ligne

#6 Le 06/06/2013, à 15:41

djinnie

Re : serveur de documents ubuntu

Bon, après quelques tests, je suis pas plus éclairée...

J'ai d'abord essayé ça :

[carabox]
    path = /media/serveur/pro
    browseable = yes
    read only = no
    create mask = 0700
    directory mask = 0700   
    valid users = @carabox

Mais impossible d'accéder au dossier partagé, j'ai le message "vous n'avez pas l'autorisation d'accéder à \\SERVEUR\carabox.
Contactez l'administrateur réseau pour demander l'accès" (mais le hic, c'est que c'est moi qui joue de le rôle de l’administrateur réseau wink)

Pour voir, j'ai ensuite testé ça :

[carabox]
    path = /home/carabox
    browseable = yes
    read only = no
    create mask = 0700
    directory mask = 0700   
    valid users = @carabox

Et là, j'accède
Donc j'imagine que dans mon [global] j'ai d'une façon ou d'une autre fait des restrictions de path, mais je ne sais ni où, ni comment modifier ça...

Une idée ?


Virginie

Hors ligne

#7 Le 07/06/2013, à 04:10

AlexandreP

Re : serveur de documents ubuntu

Re,

Je ne suis pas sûr si le problème provient de l'authentification ou d'un problème de droits d'accès sur le dossier en question. J'émets cette hypothèse en regard de cette information, tirée du chapitre 9 (Users and Security) livre en ligne Using Samba, 2nd Edition:

When client users access a Samba share, they have to pass two levels of restriction. Unix permissions on files and directories apply as usual, and configuration parameters specified in the Samba configuration file apply as well. In other words, a client must first pass Samba's security mechanisms (e.g., authenticating with a valid username and password, passing the check for the valid users parameter and the read only parameter, etc.), as well as the normal Unix file and directory permissions of its Unix-side user, before it can gain read/write access to a share.

Avant qu'un utilisateur puisse accéder à un dossier partagé en lecture/écriture, il doit donc passer deux niveaux d'authentification:
  - le premier est évidemment Samba: l'utilisateur doit être valide et la configuration d'un dossier partagé doit autoriser l'utilisateur à y accéder en lecture/écriture;
  - le second est les droits d'accès tels que définis sur le dossier partagé dans le système Linux: le dossier partagé (et les fichiers qu'il contient) doivent avoir des droits suffisants pour permettre à l'utilisateur d'y accéder en lecture et écriture.

Puisque tu es capable de permettre au groupe carabox d'accéder à son dossier personnel tout en conservant l'ensemble des autres paramètres de manière intacte, peut-être que le problème se situe au niveau des droits d'accès sur le dossier /media/serveur/pro?

Tu peux lister les droits d'accès à l'aide de la commande suivante:

ls -l --directory /media/serveur/pro

«La capacité d'apprendre est un don; La faculté d'apprendre est un talent; La volonté d'apprendre est un choix.» -Frank Herbert
93,8% des gens sont capables d'inventer des statistiques sans fournir d'études à l'appui.

Hors ligne

#8 Le 07/06/2013, à 13:13

djinnie

Re : serveur de documents ubuntu

Hum... je sais pas car j'y accède sans problème par mon mount bind (enfin moi depuis mon PC, car depuis le mac de mon associé, c'est lecture seule pour le dossier lié, alors qu'on a les mêmes droits et qu'il peut sans problème écrire sur le dossier user...)
D'ailleurs c'est comme ça que je bosse en ce moment (j'aurais pété un câble sinon !!!). J'ai expliqué la manip sur l'autre post (auquel tu avais aussi répondu)

Voilà ce que ça me retourne :

drwxrwxrwx 1 serveur serveur 4096 juin   5 18:29 /media/serveur/pro

(exactement la même chose que pour mon dossier lié...)


Virginie

Hors ligne

#9 Le 08/06/2013, à 02:41

AlexandreP

Re : serveur de documents ubuntu

D'après les droits d'accès précisés sur le point de montage de ton volume, toutes les permissions (lecture, écriture et exécution) sont autorisées pour les trois niveaux de propriétaires (propriétaire, membres du groupe propriétaire et tous les autres). Le problème ne provient donc pas de là: tout le monde devrait pouvoir tout faire dans ce dossier au niveau des droits du système de fichiers. hmm


«La capacité d'apprendre est un don; La faculté d'apprendre est un talent; La volonté d'apprendre est un choix.» -Frank Herbert
93,8% des gens sont capables d'inventer des statistiques sans fournir d'études à l'appui.

Hors ligne

Haut de page ↑