Contenu | Rechercher | Menus

Annonce

Si vous rencontrez des soucis à rester connecté sur le forum (ou si vous avez perdu votre mot de passe) déconnectez-vous et reconnectez-vous depuis cette page, en cochant la case "Me connecter automatiquement lors de mes prochaines visites".

#1 Le 11/06/2013, à 22:50

pamorvan

[RESOLU] Virtualbox Problème

Bonjour,
J'utilise Ubuntu 13.04, et j'aimerai virtualiser Windows XP.

J'ai donc installé dans un premier temps la version des dépots,
mais ça ne fonctionnait pas et je suis donc passé à la dernière version Oracle.



J'ai ce message d'erreur lorsque je veux lancer ma machine virtuelle :
Échec de l'ouverture de session pour la machine virtuelle Windows XP.

The virtual machine 'Windows XP' has terminated unexpectedly during startup with exit code 1.

Code d'erreur : NS_ERROR_FAILURE (0x80004005)
Composant : Machine
Interface : IMachine {22781af3-1c96-4126-9edf-67a020e0e858}

J'ai donc essayé quelques solutions mais sans succès.

La commande : sudo /etc/init.d/vboxdrv setup
me donne :
* Stopping VirtualBox kernel modules                                    [ OK ]
* Uninstalling old VirtualBox DKMS kernel modules                       [ OK ]
* Trying to register the VirtualBox kernel modules using DKMS                  Error! Your kernel headers for kernel 3.8.0-23-generic cannot be found.
Please install the linux-headers-3.8.0-23-generic package,
or use the --kernelsourcedir option to tell DKMS where it's located

* Failed, trying without DKMS
* Recompiling VirtualBox kernel modules                                       
* Look at /var/log/vbox-install.log to find out what went wrong

Il me semble pourtant avoir ce noyau, la commande dpkg -l | cut -f 3 -d " " | grep linux-
me donne :
linux-firmware
linux-headers-3.8.3-030803
linux-headers-3.8.3-030803-generic
linux-image-3.5.0-17-generic
linux-image-3.5.0-27-generic
linux-image-3.8.0-21-generic
linux-image-3.8.0-22-generic
linux-image-3.8.0-23-generic
linux-image-extra-3.5.0-17-generic
linux-image-extra-3.5.0-27-generic
linux-image-extra-3.8.0-21-generic
linux-image-extra-3.8.0-22-generic
linux-image-extra-3.8.0-23-generic
linux-image-generic
linux-libc-dev:amd64
linux-sound-base
syslinux-common
syslinux-legacy


Pouvez m'aider ?
Merci
PAM

Dernière modification par pamorvan (Le 12/06/2013, à 12:19)

Hors ligne

#2 Le 12/06/2013, à 00:50

richardgilbert

Re : [RESOLU] Virtualbox Problème

Bonsoir;
Je me demande s'il problème ne vient pas de la version. Ton ubuntu 13.04 est 32 ou 64 bits (si tu es sur 32 bits autre chose est le problème par contre s'il est 64 bits...)
A vérifier


Debian, Ubuntu, Crunchbang, etc...

Hors ligne

#3 Le 12/06/2013, à 08:18

tiramiseb

Re : [RESOLU] Virtualbox Problème

Salut,

mais ça ne fonctionnait pas et je suis donc passé à la dernière version Oracle.

Donc plutôt que de te dire « tiens, la version officielle livrée par l'éditeur de mon système ne fonctionne pas, essayons de résoudre le problème » tu t'es dit « tiens, la version officielle livrée par l'éditeur de mon système ne fonctionne pas, essayons une autre version ça serait rigolo de voir qu'elle ne fonctionne pas non plus » ? lol


Please install the linux-headers-3.8.0-23-generic package,

L'erreur est claire, non ? Il te demande d'installer le paquet pour lequel il donne précisément le nom. Dans la liste que tu donnes, ce paquet n'apparaît pas.


Sébastien Maccagnoni-Munch - administrateur Linux depuis le XXème siècle
Consultant informatique indépendant - http://www.smm-informatique.fr
Geek et tout plein d'autres choses - http://www.tiramiseb.fr

Hors ligne

#4 Le 12/06/2013, à 10:50

src

Re : [RESOLU] Virtualbox Problème

Installe le paquet build-essential.


Actuellement sur Xubuntu 14.04 (amd64)
Serveur sur FreeBSD 9.2 (i386)
http://maniatux.fr

Hors ligne

#5 Le 12/06/2013, à 11:24

pamorvan

Re : [RESOLU] Virtualbox Problème

Merci pour vos réponse rapide, j'avance !
Maintenant virtual box se lance, mais j'ai à nouveau des problèmes.
A priori le problème vient de l'USB. Je compte donc modifier le fichier  /etc/udev/rules.d/10-vboxdrv.rules comme indiqué dans la documentation, mais je ne trouve pas les bonnes lignes, voici mon fichier :

KERNEL=="vboxdrv", NAME="vboxdrv", OWNER="root", GROUP="root", MODE="0600"
KERNEL=="vboxnetctl", NAME="vboxnetctl", OWNER="root", GROUP="root", MODE="0600"
SUBSYSTEM=="usb_device", ACTION=="add", RUN+="/usr/share/virtualbox/VBoxCreateUSBNode.sh $major $minor $attr{bDeviceClass}"
SUBSYSTEM=="usb", ACTION=="add", ENV{DEVTYPE}=="usb_device", RUN+="/usr/share/virtualbox/VBoxCreateUSBNode.sh $major $minor $attr{bDeviceClass}"
SUBSYSTEM=="usb_device", ACTION=="remove", RUN+="/usr/share/virtualbox/VBoxCreateUSBNode.sh --remove $major $minor"
SUBSYSTEM=="usb", ACTION=="remove", ENV{DEVTYPE}=="usb_device", RUN+="/usr/share/virtualbox/VBoxCreateUSBNode.sh --remove $major $minor"

Que dois-je modifier ?
Merci
PAM

Hors ligne

#6 Le 12/06/2013, à 11:26

pamorvan

Re : [RESOLU] Virtualbox Problème

Pour info, j'ai déjà fait : sudo usermod -G vboxusers -a $USER

Hors ligne

#7 Le 12/06/2013, à 11:40

pamorvan

Re : [RESOLU] Virtualbox Problème

J'ai finalement résolu ce problème d'USB en installant le une extension Oracle, mais j'ai un nouveau problème :

Impossible d'ouvrir le CD/DVD virtuel /home/pam/Téléchargements/WinXP_Corporate_SP3_FR.iso.

Could not get the storage format of the medium '/home/pam/Téléchargements/WinXP_Corporate_SP3_FR.iso' (VERR_NOT_SUPPORTED).

Code d'erreur : VBOX_E_IPRT_ERROR (0x80BB0005)
Composant : Medium
Interface : IMedium {29989373-b111-4654-8493-2e1176cba890}
Fonction appelée : IVirtualBox {3b2f08eb-b810-4715-bee0-bb06b9880ad2}
Code retourné : VBOX_E_OBJECT_NOT_FOUND (0x80BB0001)

J'ai essayé en plaçant ce .iso dans un autre dossier, mais cela ne change rien.

Hors ligne

#8 Le 12/06/2013, à 11:45

michel_04

Re : [RESOLU] Virtualbox Problème

Bonjour,

pamorvan a écrit :

Maintenant virtual box se lance, mais j'ai à nouveau des problèmes.
A priori le problème vient de l'USB

Tu as installé le pack d'extension ( http://doc.ubuntu-fr.org/virtualbox#per … rtualbox_4 ) correspondant à ta version de VirtualBox ?

A+

Hors ligne

#9 Le 12/06/2013, à 12:03

pamorvan

Re : [RESOLU] Virtualbox Problème

En fait mon problème d'USB n'est pas résolu, il arrive lorsque je clique sur configuration.
Voilà mon message d'erreur :

Code d'erreur :
NS_ERROR_FAILURE (0x00004005)
Composant :
Host
Interface :
IHost {30678943-32df-4830-b413-931b25ac86a0}
Fonction appelée :
IMachine {22781af3-1c96-4126-9edf-67a020e0e858}

J'ai bien installé l'extension

Hors ligne

#10 Le 12/06/2013, à 12:07

michel_04

Re : [RESOLU] Virtualbox Problème

Re,
As tu redémarré ta session après avoir fait :

sudo usermod -G vboxusers -a $USER

Est ce que tu est sur que ton image XP.iso est correcte ?

A+

Dernière modification par michel_04 (Le 12/06/2013, à 12:08)

Hors ligne

#11 Le 12/06/2013, à 12:11

pamorvan

Re : [RESOLU] Virtualbox Problème

J'ai bien redémarrer ma session, je vais essayer avec un autre fichier .iso.

Hors ligne

#12 Le 12/06/2013, à 12:19

pamorvan

Re : [RESOLU] Virtualbox Problème

Le problème venait de mon fichier iso !
Merci pour votre aide

Hors ligne

Haut de page ↑