Contenu | Rechercher | Menus

Annonce

Si vous rencontrez des soucis à rester connecté sur le forum (ou si vous avez perdu votre mot de passe) déconnectez-vous et reconnectez-vous depuis cette page, en cochant la case "Me connecter automatiquement lors de mes prochaines visites".

#1 Le 12/01/2013, à 13:45

primus

Problème de connexion DAC (convertisseur de son externe) en USB ?!!

Salut les linuxiens !

Bon alors semaine passée j'ai reçu un convertisseur audiophile pour brancher mon ordinateur sur ma chaine hifi (jusque là c'était un jack pourri sur ma carte son basique).

Il a été reconnu (pulse audio me donnait son nom) directement, mais zéro son.

Ensuite j'ai passé 3 soirs à bricoler mon ordinateur et linux pour éviter les questions fastidieuses et chiantes aux membres de cette communauté honorable (:D).

Donc dans le désordre, j'ai installé pas mal de logiciels, pulse audio en premier, et un tas d'autre tous aussi inefficaces (enfin surtout moi) pour qu'au final je perde le son sur tout (et que l'ordinateur ne reconnaisse plus rien, pas de trace de carte son dans pulse audio).

Hier soir, coup de bol, je suis tombé sur un fil qui m'a fait comprendre que j'étais un boulet, et donc j'ai balancé la commande sudo gedit /etc/modules pour m'apercevoir que le fichier était vide.

j'ai ajouté les lignes suivantes:

snd_hda_intel
snd_hda_codec_realtek

pour que ma carte réapparaisse dans pulse audio et que j'aie de nouveau du son.

Seulement voilà, mon DAC n'est toujours pas plus reconnu.

que dois-je ajouter dans ce fichier (si c'est bien là l'embrouille) pour que ce soit le cas ?
ensuite que faut-il que je fasse pour que le son soit dirigé automatiquement et systématiquement sur ce convertisseur, vu que la chaine hifi estMerci de me lire, déjà, et  la seule sortie audio que j'utilise ?

merci de me lire et de me répondre.

vous pouvez me demander des commandes à faire dans le terminal ou des paquets à installer, en 3 jours je suis passé du niveau 0 linux au niveau 1 big_smile

Hors ligne

#2 Le 12/01/2013, à 14:06

primus

Re : Problème de connexion DAC (convertisseur de son externe) en USB ?!!

Ah oui et tiens tant que j'y suis, j'ai aussi perdu mon icône de réglage de sons dans ma barre des menus à côté de l'horloge (linux 12.04)

Je continue à creuser dans les fils du forum cool

Dernière modification par primus (Le 12/01/2013, à 14:07)

Hors ligne

#3 Le 12/01/2013, à 15:29

primus

Re : Problème de connexion DAC (convertisseur de son externe) en USB ?!!

yipaaaaaaaaaaaaaaa !

en ajoutant snd_usb_audio dans le bordel des modules, je trouve le DAC dans pulseaudio lol

Par contre pas de son qui en sort....

HELP !!!

Dernière modification par primus (Le 12/01/2013, à 15:32)

Hors ligne

#4 Le 12/01/2013, à 16:18

primus

Re : Problème de connexion DAC (convertisseur de son externe) en USB ?!!

lancement d'alsamixer, choix de la carte son, je vois la micromega, et si je le sélectionne, terminal me renvoie:

les commandes de mixage ne peuvent pas être chargés: Argument invalide

Hors ligne

#5 Le 12/01/2013, à 19:26

primus

Re : Problème de connexion DAC (convertisseur de son externe) en USB ?!!

PLease big_smile Help a linux noob not to get back this device ! I want to listent to hifi music smile

à priori, alsa doit être à jour et fonctionnel, le problème doit venir de la déclaration de ce matériel soit vis à vis de linux, soit vis à vis des applications qui sortent du son...

Hors ligne

#6 Le 12/01/2013, à 21:15

primus

Re : Problème de connexion DAC (convertisseur de son externe) en USB ?!!

Et hop, retour de l'applet de notification complet, après désinstall et install ! lol

Reste que je n'ai toujours pas de son du DAC !  roll

Hors ligne

#7 Le 16/04/2013, à 12:01

Pharyon

Re : Problème de connexion DAC (convertisseur de son externe) en USB ?!!

Moi aussi j'ai un dac (MyDac micromega).
Bien visible dans le paramétrage mais aucun son quand je le sélectionne dans le menu de configuration (S/PDIF).

Quand je le branche par cable USB audio class2 : pas de son
Quand je le branche par cable optique : j'ai le son.

J'ai l'impression que ça a marché quelque temps avant une récente mise à jours d'Ubuntu.


Ubuntu 12.04 (64bit) - unity
Voyager 13.04 (http://voyager.legtux.org/)

Hors ligne

#8 Le 18/04/2013, à 15:08

Fanch37

Re : Problème de connexion DAC (convertisseur de son externe) en USB ?!!

Bonjour,

J'ai le même soucis que Pharyon avec le même DAC en 12.10 depuis une mise à jour récente sur deux ordinateurs différents. Tout fonctionnait sur les deux avant la mise à jour. Je viens de refaire l'installation en 12.04 pour voir, le problème est le même :
Le DAC (Mydac micromega) branché en USB est reconnu (on peut le sélectionner dans le choix de cartes son). Sa loupiote s'allume comme si le son "passait" lorsqu'on lance de la musique. Mais aucun son ne sort des enceintes. Je n'ai pas de câble optique pour faire le test.
Sous windows, le DAC fonctionne.

Hors ligne

#9 Le 18/04/2013, à 15:13

Fanch37

Re : Problème de connexion DAC (convertisseur de son externe) en USB ?!!

À noter que le son fonctionne en sortie casque reliée à l'ampli sur la carte son d'origine.

Hors ligne

#10 Le 19/04/2013, à 11:09

Pharyon

Re : Problème de connexion DAC (convertisseur de son externe) en USB ?!!

J'ai tenté la réinstallation d'ubuntu 12.04 et 12.10. En sortie d'installation tout remarche parfaitement.
Le problème c'est que dès qu'on mets les paquets à jour (plus de 200), bing! ça marche plus.

J'ai trouvé une similitude avec le bug suivant : https://bugs.launchpad.net/ubuntu/+sour … ug/1136110

Mais booter sur un ancien kernel ne m'a pas permis de retrouver le son sur USB... à suivre.


Ubuntu 12.04 (64bit) - unity
Voyager 13.04 (http://voyager.legtux.org/)

Hors ligne

#11 Le 13/06/2013, à 09:54

Pharyon

Re : Problème de connexion DAC (convertisseur de son externe) en USB ?!!

J'ai trouvé la solution à notre problème concernant l'excellent DAC MyDac de micromega et son branchement USB.

Résumé du problème :
- Ubuntu en livecd : Mydac fonctionne sans problème en USB
- Après installation : le Mydac ne fonctionne plus du tout en USB

Je croyais initialement que cela pouvait venir des MAJ de la distribution ou d'un bug kernel qui touche certains DAC (https://bugs.launchpad.net/ubuntu/+sour … ug/1136110)
Depuis ce bug a été corrigé et mon problème persistait quelque soit le kernel utilisé. La piste n'était pas la bonne.

Le problème :
alsa désactive automatiquement par défaut ce matériel après installation. De plus aucun outil ubuntu ne permet de le réactiver via l'interface.

Solution :
- Le dac est allumé et branché sur USB
- Ouvrir une fenetre terminal
- Lancer alsamixer
- Retrouver la barre qui correspond au dac MyDac à l'aide des flèches droite/gauche du clavier. Si besoin changer d'onglet avec les touches Fx (je n'ai pas la fenêtre devant les yeux ce matin. Je compléterai plus précisément ce soir)
Juste sous la jauge on peut apercevoir "MM" ce qui veut dire que la sortie est désactivé. C'est notre problème.
- Une fois la jauge sélectionnée (en surbrillance) appuyer sur la touche 'm' du clavier pour activer. La jauge passe de 'MM' à '00'. Le son fonctionne alors.

wink


Ubuntu 12.04 (64bit) - unity
Voyager 13.04 (http://voyager.legtux.org/)

Hors ligne

#12 Le 24/06/2013, à 18:42

Fanch37

Re : Problème de connexion DAC (convertisseur de son externe) en USB ?!!

J'essaye ça de ce pas !

Hors ligne

#13 Le 24/06/2013, à 19:00

Fanch37

Re : Problème de connexion DAC (convertisseur de son externe) en USB ?!!

Lorsque je suis dans alsamixer et que je fais défiler les barres avec droite/gauche, la puce indiquée reste toujours hda intel, à aucun moment je ne vois mydac. Il y a 9 barres en tout. Si je sélectionne mydac dans le choix de la carte son (F6), il n'y a plus que deux colonnes, toutes deux actives sad

Hors ligne

#14 Le 09/08/2013, à 10:15

Pharyon

Re : Problème de connexion DAC (convertisseur de son externe) en USB ?!!

Fanch37 a écrit :

Lorsque je suis dans alsamixer et que je fais défiler les barres avec droite/gauche, la puce indiquée reste toujours hda intel, à aucun moment je ne vois mydac. Il y a 9 barres en tout. Si je sélectionne mydac dans le choix de la carte son (F6), il n'y a plus que deux colonnes, toutes deux actives sad

Essaye de me faire une capture d'écran si c'est possible que je puisse comparer à ce qu'il y a chez moi ?


Ubuntu 12.04 (64bit) - unity
Voyager 13.04 (http://voyager.legtux.org/)

Hors ligne

Haut de page ↑