Contenu | Rechercher | Menus

Annonce

DVD, clés USB et t-shirts Ubuntu-fr disponibles sur la boutique En Vente Libre

Si vous avez des soucis pour rester connecté, déconnectez-vous puis reconnectez-vous depuis ce lien en cochant la case
Me connecter automatiquement lors de mes prochaines visites.

À propos de l'équipe du forum.

#1 Le 20/06/2013, à 15:26

fantomette00

Dual boot Ubuntu 13.04 Windows 8 préinstallé sur Dell UEFI

Bonjour,
Après avoir bien galéré, je viens enfin de réussir à installer Ubuntu 13.04 en dual boot sur un Dell Inspiron 660 (UEFI) préinstallé w8 (+ toutes les partitions de secours Dell)..., et c'est bien grâce à tous les messages lus sur ce forum notamment (merci !!!). Donc si jamais ça peut aider quelqu'un dans la même situation que moi, voici les étapes, piochées ici et là, qui m'ont permis d'y arriver. Je ne sais pas si c'est très académique, mais bon, ça marche.
(n'hésitez pas à me dire si ce n'est pas le bon endroit pour poster)

1. Préparer une clé avec LinuxSecure 13.04 64 bits
2. Depuis windows, réduire le disque C (outil accessible depuis Rechercher « partitions »). On ne peut apparemment pas réduire de plus de la moitié.
3. Dans windows, supprimer le fast startup : cliquer sur Rechercher puis Panneau de config / Système et sécurité / Options d'alimentation / Choisir les boutons d'alimentation / décocher « Activer le démarrage rapide » (si pas accessible, cliquer avant sur « Modifier les paramètres actuellement non disponibles »)
4. Redémarrer sur la clé (via F12 après le logo Dell)
5. Installer Ubuntu avec l'option « Autre choix » : partitionner l'espace libre avec
- partition de boot efi 35 Mo (mini). Faire pointer le chargeur d'amorçage sur cette partition.
- partition swap 6Go
- partition ext4 avec le reste (montée sur /, formatée)
6. Après l'instal, rebooter sur Linux et lancer boot repair, noter le chemin indiqué (sda1/EFI/ubuntu/shimx64.efi dans mon cas)
7. Ici Grub est ok au redémarrage, mais chaque lancement de Windows semble l'écraser, obligeant à redémarrer sur la clé et relancer boot repair...
8. Donc pour fixer le grub : sous Windows, ouvrir la console (via clic droit / ouvrir en tant qu'admin) et taper :
- « powercfg.exe -h off » (indispensable ? Fait que « Activer le démarrage rapide », cf.3, n'apparaît plus)
- « bcdedit.exe /set {bootmgr} path \EFI\ubuntu\shimx64.efi » (cad le chemin donné par boot repair, sans l'indication de la partition et avec des « \ » au lieu des « / »)
9. Redémarrer. Enjoy :-)

PS : je n'ai pas eu besoin de désactiver le SecureBoot

Hors ligne

#2 Le 20/06/2013, à 22:07

Slystone

Re : Dual boot Ubuntu 13.04 Windows 8 préinstallé sur Dell UEFI

Génial merci ! smile
N'hésite pas à regarder si tu peux compléter la doc existante aussi, ça sera plus visible comme ça. wink
Les petites mains (et les gros cœurs) sont toujours les bienvenus. ^^


«Rigid, the skeleton of habit alone upholds the human frame.» - Virginia Woolf.

Hors ligne

#3 Le 21/06/2013, à 06:30

malbo

Re : Dual boot Ubuntu 13.04 Windows 8 préinstallé sur Dell UEFI

fantomette00 a écrit :

7. Ici Grub est ok au redémarrage, mais chaque lancement de Windows semble l'écraser, obligeant à redémarrer sur la clé et relancer boot repair...
8. Donc pour fixer le grub : sous Windows, ouvrir la console (via clic droit / ouvrir en tant qu'admin) et taper :
- « powercfg.exe -h off » (indispensable ? Fait que « Activer le démarrage rapide », cf.3, n'apparaît plus)
- « bcdedit.exe /set {bootmgr} path \EFI\ubuntu\shimx64.efi » (cad le chemin donné par boot repair, sans l'indication de la partition et avec des « \ » au lieu des « / »)

Je suis très intrigué par le point 7 et le point 8. A présent que ton démarrage semble maîtrisé, pourrais-tu rétablir le démarrage rapide et vérifier si ça a une influence sur le dual-boot ?
Explications : je pense que la fonctionnalité "démarrage rapide" de Windows 8 devait s'opposer à tout changement que pouvait faire Boot-Repair dans son dos : quand tu redémarrais sous Windows, cette fonctionnalité défaisait ce qui avait été construit par Boot-Repair. Mais à présent, si tu rétablis le démarrage rapide, la situation actuelle sera prise en référence par cette fonctionnalité et il ne devrait plus y avoir de problème.

Hors ligne

#4 Le 21/06/2013, à 13:22

fantomette00

Re : Dual boot Ubuntu 13.04 Windows 8 préinstallé sur Dell UEFI

Effectivement, après "powercfg.exe -h on" -> dual boot ok, puis réactivation dans le panneau de config du démarrage rapide -> toujours ok. Donc je laisse comme ça, merci.
Ce qui m'étonne, c'est que j'avais dès le départ désactivé le fast startup (en 3), en plus je passais toujours par l'action Redémarrer et non Arrêt (ce qui, d'après ce que j'ai compris, permet justement une "vraie" fermeture de windows). Mais apparemment c'était pas suffisant...

Hors ligne

#5 Le 16/11/2013, à 13:18

Valezan

Re : Dual boot Ubuntu 13.04 Windows 8 préinstallé sur Dell UEFI

« bcdedit.exe /set {bootmgr} path \EFI\ubuntu\shimx64.efi » m'a tout simplement évité la dépression !
Merci beaucoup fantomette00

Hors ligne

#6 Le 07/12/2013, à 16:06

slaveak47

Re : Dual boot Ubuntu 13.04 Windows 8 préinstallé sur Dell UEFI

Bonjour,

Alors en ce qui me concerne j'ai quelques soucis sur un PC Dell Inspiron (14z 5423) :
- D'ailleurs pour info j'ai deux DD, un de 500Go ou (si je me gourre pas) W8 installé dessus et un SSD de 32 Go qui n'apparait pas dans l'explorateur W8 mais qui apparait bien dans le gestionnaire de périphérique, mais je ne sais pas du tout à quoi il sert ...

- Pour le coup moi c'est un DVD bootable de Linux secure boot 64bit mais je pense pas que c'est de cette différence que vient le soucis

- J'ai bien partitionné mon disque dur comme tu le décris, à une petite différence près... j'ai laissé 30 Go pour la futur install de Linux mais que je n'ai pas formaté, pour la laissé vierge de tout.
       Pour résumer j'ai donc actuellement comme partition sur mon DD celui de 500Go
       - les différentes partitions recovery de DELL auxquelles je n'ai pas touché
       - Une partition C:\OS de 120Go
       - Une partition E:\Data de 300 Go
       - Une partition d'environ 30 Go encore non formaté et prête à accueillir Ubuntu.

- Je trouve bien le DVD à booter mais en legacy, pas en UEFI mais je pense que toi aussi dans ce cas. Et j'ai bien essayer de config un boot UEFI sur le DVD mais pas possible, quand j’essaie d'ajouter une option de boot UEFI, je n'ai pas d'option dvd.

- J'ai donc tenté sans en me disant que je ferais par la suite une réparation du boot une fois Ubuntu installé.

- Bon par contre quand je boot sur le dvd, l'install se lance sans soucis mais quand j'arrive sur le choix que tu décris par "5. Installer Ubuntu avec l'option « Autre choix »" là par contre je n'ai pas cette option et j'ai uniquement \deb\dav et point final ... il ne me détecte pas ni la partition Windows 8 ni Data ...

Donc j'ai un peu peur en lancant l'install d'écraser W8 ou de l'endommager. De plus même si il vise bien uniquement ma partition dédiée pour son install, pas moyen de faire une install propre pour créer les partition \, \swap, \root, etc...

Auriez-vous une idée pour régler mes petits soucis ?

Et merci d'avance pour vos réponses.

Hors ligne

#7 Le 07/12/2013, à 16:12

malbo

Re : Dual boot Ubuntu 13.04 Windows 8 préinstallé sur Dell UEFI

slaveak47,
Je te prie de créer une nouvelle discussion pour ton cas perso. Les explications pour le faire sont données là : 4.1 Initier une nouvelle discussion
Quand ce sera fait, poste ici pour donner le lien vers cette nouvelle discussion comme ça je serai prévenu et je pourrai intervenir.

Hors ligne

#8 Le 07/12/2013, à 16:25

slaveak47

Re : Dual boot Ubuntu 13.04 Windows 8 préinstallé sur Dell UEFI

Bonjour,

Comme tu me l'as proposé, voici le nouveau sujet créé : http://forum.ubuntu-fr.org/viewtopic.ph … #p15402541

Merci d'avance.

Dernière modification par slaveak47 (Le 07/12/2013, à 16:26)

Hors ligne

#9 Le 08/02/2014, à 16:55

debutant999

Re : Dual boot Ubuntu 13.04 Windows 8 préinstallé sur Dell UEFI

Bonjour,
Un grand MERCI pour ce tuto qui m'a enfin permis d'installer Ubuntu 13.10 64bits sur ce foutu nouvelle ordinateur (Dell Inspiron 15r SE 7520, Windows 8.1) !

J'ai tenté plusieurs technique, notamment celle du forum qui ce sont soldées par moult échec.
Pour ma part j'ai pris deux liberté en suivant ton tuto :
- désactivé le SecureBoot
- pas créé partition de boot efi 35 Mo , j'ai laissé le chargeur d'amorçage de Ubuntu pointer tout seul

Merci encore !

J'espère ardemment que Ubuntu va trouver une solution à ce problème car cela à été pour moi une raison pour un arrêt total de son utilisation ... En effet, si Ubuntu n'est pas facile à installer, bon nombre de futur utilisateur risque de même pas avoir le temps d'y prendre goût !

Bonne journée à tous !

Hors ligne