Contenu | Rechercher | Menus

Annonce

Si vous rencontrez des soucis à rester connecté sur le forum (ou si vous avez perdu votre mot de passe) déconnectez-vous et reconnectez-vous depuis cette page, en cochant la case "Me connecter automatiquement lors de mes prochaines visites".
Test de l'ISO d'Ubuntu francophone : nous avons besoin de testeurs pour la version francophone d'Ubuntu 14.04. Liens et informations ici.

Attention, une faille de sécurité dans bash a récemment été rapportée, il est recommandé de mettre à jour son système (plus de détails)

#426 Le 30/12/2012, à 22:34

Lifesaver

Re : [IMPORTANT] Vieilles cartes ATI et pilote proprio

Bon, j'ai tenté le coup de "radeon.audio=1" rajouté dans les entrées de Grub2.
ça a bien fait quelquechose : dans smplayer alsa n'appairait qu'une seule fois (alors qu'avant il y en avait 2, un pour la sortie analogique, un autre pour la sortie hdmi).
Si je choisis la sortie alsa ou pulse (alors que j'ai préalablement désactivé dans phonon ma sortie analogique et activé ma sortie hdmi), la vidéo défile bien trop vite, mais toujours sans son.
Dans vlc, j'ai un message d'erreur, également sans son.
"La sortie audio a échoué:
Le périphérique audio « hdmi:CARD=HDMI,DEV=0 » ne peut pas être utilisé :
Périphérique ou ressource occupé."


Dell Studio 17, Core2Duo P8600, 4Go RAM, ATI HD3650 avec pilotes libres, Rosa Desktop Fresh 2012 64 bits KDE 4.9

Hors ligne

#427 Le 31/12/2012, à 11:21

classdroogies

Re : [IMPORTANT] Vieilles cartes ATI et pilote proprio

Question (j'aurai du commencer par ça), dans alsamixer as tu vérifiés que la sortie hdmi n'était pas sur mute, avant de faire l'ajout du paramètre ?

Peut-être que tester avec aplay donnera plus d'infos... La doc Archlinux donne pas mal d'infos sur le pilote libre.

Hors ligne

#428 Le 31/12/2012, à 14:51

Lifesaver

Re : [IMPORTANT] Vieilles cartes ATI et pilote proprio

la sortie hdmi n'est pas sur mute dans alsamixer. Mais suis-je vraiment obligé d'utiliser alsa ? Pulse ne permet pas de sortir le son sur l'hdmi ?
Et puis cette entrée dans grub2 provoque l'emballement des processus systemd et systemd-journald, je l'ai donc virée...


Dell Studio 17, Core2Duo P8600, 4Go RAM, ATI HD3650 avec pilotes libres, Rosa Desktop Fresh 2012 64 bits KDE 4.9

Hors ligne

#429 Le 31/12/2012, à 15:21

classdroogies

Re : [IMPORTANT] Vieilles cartes ATI et pilote proprio

Lifesaver a écrit :

Mais suis-je vraiment obligé d'utiliser alsa ? Pulse ne permet pas de sortir le son sur l'hdmi ?

Pulseaudio utilise alsa, ce n'est qu'une couche applicative supplémentaire permettant d'intéragir avec alsa.

Lifesaver a écrit :

Et puis cette entrée dans grub2 provoque l'emballement des processus systemd et systemd-journald, je l'ai donc virée...

C'est à dire, qu'entend tu par emballement ?

De toute façon cela ne semble pas résoudre ton problème, pourtant d'après ceci le support du hdmi audio est dispo pour ta carte (R600) en ajoutant le paramètre radeon.audio=1 sur un noyau version 3.3, tu as la version 3.4 ça devrait fonctionner.

Dernière modification par classdroogies (Le 31/12/2012, à 15:27)

Hors ligne

#430 Le 01/01/2013, à 03:12

Lifesaver

Re : [IMPORTANT] Vieilles cartes ATI et pilote proprio

Emballement ? C'est prendre 100% de mon cpu, affoler mon ventilo, et rendre mon pc peu utilisable. Donc je pense que cette entrée dans Grub2 n'était pas utilisable dans mon cas.
Mais comme toi je pense que le support audio devrait être pris en charge. Je vais déposer un bug auprès de rosa et je viens vous tenir au courant !
thx ! wink


Dell Studio 17, Core2Duo P8600, 4Go RAM, ATI HD3650 avec pilotes libres, Rosa Desktop Fresh 2012 64 bits KDE 4.9

Hors ligne

#431 Le 09/01/2013, à 19:25

Isayama

Re : [IMPORTANT] Vieilles cartes ATI et pilote proprio

Lifesaver, j'ai également un Dell Studio 17, avec une CG ATI Radeon Mobility HD 4650 qui n'est plus supportée par Catalyst v. >12.6.
La solution a été d'installer cette version de fglrx, qui rétrograde x-server à la dernière version compatible avec Catalyst 12.6 (1.12.4), et patche celui-ci pour fonctionner avec le kernel 3.5.
J'ai fini par trouver cette solution (qui dans mon cas répondait avant tout à un problème de ventilateur fou) en parcourant le forum ainsi que d'autres sites (cf ce sujet). Je l'utilise depuis 1 mois, en HDMI ou non, "sans aucun souci" (une fois cochée l'option "bureau sans déchirement" dans Catalyst qui évite les lignes horizontales dans les vidéos avec mouvements). Il suffit de sélectionner la bonne sortie son à chaque fois que tu branches et débranches ton périphérique (s'il y a une option à ajouter au noyau pour faire fonctionner la reconnaissance automatique, je suis preneur!).

Je n'ai pas encore trouvé comment obtenir la résolution maximale de mon moniteur externe (TV LCD Panasonic 1080p) quand c'est le seul écran, puisque xrandr ou Catalyst ne reconnaissent pas cette option de résolution (qui marchait sous Windows, ainsi que le rafraîchissement à 24Hz...), et limite donc à la résolution de mon écran de protable (1600x900). Mais bon, on peut survivre wink

N'oublie pas de désinstaller complètement toute précédente version de fglrx présente sur ta machine!


Ubuntu GNOME Remix 12.10 x64 (Gnome-shell) sur Dell Studio 1745

Hors ligne

#432 Le 10/01/2013, à 11:12

Lifesaver

Re : [IMPORTANT] Vieilles cartes ATI et pilote proprio

Super ta solution ! Il me reste plus qu'à demander un portage de cette version de fglrx vers Rosa.
Je vois en parcourant le topic que tu m'indiques qu'il y a bien des difficultés à sortir le son (ou l'image même dans certains cas même si ce n'est pas mon cas) avec le pilote radeon libre via le port HDMI. C'est bien dommage et bizarre pour une carte graphique ancienne et répandue...

Dernière modification par Lifesaver (Le 10/01/2013, à 11:33)


Dell Studio 17, Core2Duo P8600, 4Go RAM, ATI HD3650 avec pilotes libres, Rosa Desktop Fresh 2012 64 bits KDE 4.9

Hors ligne

#433 Le 10/01/2013, à 17:39

Isayama

Re : [IMPORTANT] Vieilles cartes ATI et pilote proprio

Je ne connaissais pas ta distribution et n'avais pas vu qu'elle était pas basée sur rpm, désolé smile

Tout à fait d'accord pour cette incompréhension face au manque de compatibilité de matériel assez standard. En même temps, on sait que la vente liée ça s'appuie sur des constructeurs... Ce serait dommage de ne pas avantager l'OS qui rapporte des revenus big_smile Je redoute déjà le changement de version lors de la sortie de 13.04, s'il faut à nouveau attendre un patch pour avoir un ventilo qui tourne normalement... En attendant les progrès du pilote libre! smile


Ubuntu GNOME Remix 12.10 x64 (Gnome-shell) sur Dell Studio 1745

Hors ligne

#434 Le 10/01/2013, à 18:38

Lifesaver

Re : [IMPORTANT] Vieilles cartes ATI et pilote proprio

Perso, mon ventilo tourne normalement (en tous cas je n'entends rein de suspect à l'oreille)
Reste que le pb de son via la sortie HDMI...


Dell Studio 17, Core2Duo P8600, 4Go RAM, ATI HD3650 avec pilotes libres, Rosa Desktop Fresh 2012 64 bits KDE 4.9

Hors ligne

#435 Le 15/01/2013, à 23:29

Lifesaver

Re : [IMPORTANT] Vieilles cartes ATI et pilote proprio

Tout fonctionne désormais sur Rosa. Certainement une maj sur cette jeune distrib qui a résolu un conflit. Du coup, ce système s'approche de la perfection. A coup sur, ma plus belle distrib linux que j'ai eu entre les mains !


Dell Studio 17, Core2Duo P8600, 4Go RAM, ATI HD3650 avec pilotes libres, Rosa Desktop Fresh 2012 64 bits KDE 4.9

Hors ligne

#436 Le 21/01/2013, à 19:11

henry-006

Re : [IMPORTANT] Vieilles cartes ATI et pilote proprio

SALUT
petite MàJ, on est en 2013 et il y a ceci:
Pilotes AMD pour "vieilles cartes"

A bon entendeur salut, et bonne bourre !!!...


OS: Ubuntu 12.10 (Quetzal quantal ) 64 bits + Windows XP pro SP2 x32 en double boot
PC Medion / Processeur: Intel core2 Duo (CPU 2.80GHz) Mémoire vive:3029 MiB
Carte Graph. ATI Radeon HD 2600 series  (nee ATI RV630) 512Mo
Débutant mais curieux, et furieusement convaincu que: "Rien n'est vrai, tout est possible"...

Hors ligne

#437 Le 27/01/2013, à 20:54

Quasoo

Re : [IMPORTANT] Vieilles cartes ATI et pilote proprio

Bonne nouvelles, je vais pouvoir enfin essayer Steam et peut-être régler mes problèmes de video flash !

Lien : http://support.amd.com/us/gpudownload/Pages/index.aspx
Le sujet sur le forum de Photonix : http://phoronix.com/forums/showthread.p … 000-is-out

J'ai vu pas mal de questions sur le matos, perso je suis sur Ubuntu 12.04 avec le kernel 3.2 et xorg 1.11, il ne vaut pas mieux mettre à jour le kernel ou Xorg en 1.12 avant ?

Dernière modification par Quasoo (Le 28/01/2013, à 01:49)

Hors ligne

#438 Le 28/01/2013, à 17:11

henry-006

Re : [IMPORTANT] Vieilles cartes ATI et pilote proprio

Quasoo a écrit :

Bonne nouvelles, je vais pouvoir enfin essayer Steam et peut-être régler mes problèmes de video flash !

Lien : http://support.amd.com/us/gpudownload/Pages/index.aspx
Le sujet sur le forum de Photonix : http://phoronix.com/forums/showthread.p … 000-is-out

J'ai vu pas mal de questions sur le matos, perso je suis sur Ubuntu 12.04 avec le kernel 3.2 et xorg 1.11, il ne vaut pas mieux mettre à jour le kernel ou Xorg en 1.12 avant ?

au contraire, si j'ai bien pigé les différentes docs du site il vaut mieux une vieille config car les nouvelles ont du mal avec les pilotes...
à voir, moi on m'a carrément conseillé de réinstaller une ancienne version d'Ubuntu pour que mes pilotes soient acceptés...


OS: Ubuntu 12.10 (Quetzal quantal ) 64 bits + Windows XP pro SP2 x32 en double boot
PC Medion / Processeur: Intel core2 Duo (CPU 2.80GHz) Mémoire vive:3029 MiB
Carte Graph. ATI Radeon HD 2600 series  (nee ATI RV630) 512Mo
Débutant mais curieux, et furieusement convaincu que: "Rien n'est vrai, tout est possible"...

Hors ligne

#439 Le 08/02/2013, à 02:12

Quasoo

Re : [IMPORTANT] Vieilles cartes ATI et pilote proprio

Effectivement, la 12.10 posaient des problèmes initialement mais ça a été corrigé je crois.
Pour le reste j'ai du me monter la tête en lisant un topic ou ils parlaient de MAJ de kernel et autres !

Hors ligne

#440 Le 23/06/2013, à 00:20

Quasoo

Re : [IMPORTANT] Vieilles cartes ATI et pilote proprio

Passage à la 13.04, toujours avec une ATI 4850, aucun souci grâce à ce ppa : https://launchpad.net/~makson96/+archive/fglrx

Hors ligne

#441 Le 06/01/2014, à 12:54

Quasoo

Re : [IMPORTANT] Vieilles cartes ATI et pilote proprio

Hum, sous 14.04 on arrête de se prendre la tête avec les Catalyst legacy ? smile
http://www.phoronix.com/scan.php?page=a … 2013&num=1

Dernière modification par Quasoo (Le 06/01/2014, à 12:59)

Hors ligne

#442 Le 05/04/2014, à 00:37

Quasoo

Re : [IMPORTANT] Vieilles cartes ATI et pilote proprio

Confirmé !

Hâte de faire la mise à jours vers la prochaine LTS...

Pour les cartes ATI récentes, les Catalyst sont toujours plus performants par contre (au niveau et parfois au dessus des perfs sous Windows)

Hors ligne

Haut de page ↑