Contenu | Rechercher | Menus

Annonce

Si vous rencontrez des soucis à rester connecté sur le forum (ou si vous avez perdu votre mot de passe) déconnectez-vous et reconnectez-vous depuis cette page, en cochant la case "Me connecter automatiquement lors de mes prochaines visites".

#1 Le 20/06/2013, à 18:50

Sébastiend01

Le système de packet est cassé [Résolu]

Bonjour, j'ai un souci: j'ai déjà cherché des problème équivalent au mien dans le forum, ils ont bien entendu été résolu. Seulement lorsque je suit la manipulation à suivre, je n y arrive pas. Dans les dialogues, ils disent souvent de supprimer complètement la source du problème sauf que ça met impossible. Voilà mon problème plus en détail:

Le système de paquets est cassé

Vérifiez si vous utilisez des dépôts de tierces parties. Si c'est le cas, désactivez-les car ils sont parfois source de problèmes.
De plus, exécutez la commande suivante dans un  terminal : sudo apt-get install -f

v détail

Les paquets suivants ont des dépendances non satisfaites :

libxcursor1: libxcursor1:i386: Depends: libx11-6 (>= 2:1.4.99.1) mais la version 2:1.4.99.1-0ubuntu2.1 est installée

Aidé-moi s'il vous plaît?

Dernière modification par Sébastiend01 (Le 29/06/2013, à 18:38)

Hors ligne

#2 Le 20/06/2013, à 18:53

Spitfire 95

Re : Le système de packet est cassé [Résolu]

Tu as essayé de lancer sudo apt-get install -f en terminal ?


Trisquel GNU/Linux 6.0 / Fedora 19 & rawhide.
joueur ryzom et wesnoth
Développeur livewallpaper
Membre déserteur et traître de la brigade des S.

Hors ligne

#3 Le 20/06/2013, à 19:32

Korak

Re : Le système de packet est cassé [Résolu]

Bonjour,

Ouvre un terminal et donne le retour complet (de la commande en elle-même jusqu'au retour au prompt) de la commande:

sudo apt-get update

OS: Ubuntu 12.04.3 64 bits + Windows 8 64 bits en dualboot
PC portable: Processeur: AMD A4-4300M APU   Carte graphique: AMD Radeon HD 7420G   Mémoire vive: 6 Go RAM
Je suis Parrain-Linux

En ligne

#4 Le 20/06/2013, à 21:15

Sébastiend01

Re : Le système de packet est cassé [Résolu]

Lorsque je mets "sudo apt-get install -f", j'obtiens ce résultats:

ordipass@ORDIPASS:~$ sudo apt-get install -f
[sudo] password for ordipass:
^[[1;2D^[[1;2CSorry, try again.
[sudo] password for ordipass:
Sorry, try again.
[sudo] password for ordipass:
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances       
Lecture des informations d'état... Fait
Correction des dépendances... Fait
Les paquets suivants ont été installés automatiquement et ne sont plus nécessaires :
  linux-headers-3.2.0-39-generic python-numpy kde-l10n-fr linux-headers-3.2.0-33 linux-headers-3.2.0-40 linux-headers-3.2.0-38
  linux-headers-3.2.0-39 m4 libmagick++4 python-uniconvertor python-lxml language-pack-kde-fr-base fortune-mod libc6-i386 librecode0
  linux-headers-3.2.0-40-generic pax language-pack-kde-en language-pack-kde-fr kde-l10n-engb rpm librpmbuild2 linux-headers-3.2.0-38-generic
  fortunes-min libqt4-webkit:i386 lib32z1 libgc1c2 librpmsign0 linux-headers-3.2.0-33-generic libgsl0ldbl lsb-core perlmagick
  language-pack-kde-en-base alien ncurses-term libsdl-sound1.2
Veuillez utiliser « apt-get autoremove » pour les supprimer.
Les paquets supplémentaires suivants seront installés :
  libxcursor1
Les paquets suivants seront mis à jour :
  libxcursor1
1 mis à jour, 0 nouvellement installés, 0 à enlever et 10 non mis à jour.
2 partiellement installés ou enlevés.
Il est nécessaire de prendre 0 o/22,7 ko dans les archives.
Après cette opération, 17,4 ko d'espace disque seront libérés.
Souhaitez-vous continuer [O/n] ? O
dpkg : erreur de traitement de libxcursor1 (--configure) :
libxcursor1:amd64 1:1.1.12-1 cannot be configured because libxcursor1:i386 is in a different version (1:1.1.12-1ubuntu0.1)
dpkg : erreur de traitement de libxcursor1:i386 (--configure) :
libxcursor1:i386 1:1.1.12-1ubuntu0.1 cannot be configured because libxcursor1:amd64 is in a different version (1:1.1.12-1)
Aucun rapport « apport » écrit car MaxReports a déjà été atteint
                                                                Des erreurs ont été rencontrées pendant l'exécution :
libxcursor1
libxcursor1:i386
E: Sub-process /usr/bin/dpkg returned an error code (1)
ordipass@ORDIPASS:~$


Et pour sudo apt-get update j'obtiens ce résultat:

ordipass@ORDIPASS:~$ sudo apt-get install -f
[sudo] password for ordipass:
^[[1;2D^[[1;2CSorry, try again.
[sudo] password for ordipass:
Sorry, try again.
[sudo] password for ordipass:
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances       
Lecture des informations d'état... Fait
Correction des dépendances... Fait
Les paquets suivants ont été installés automatiquement et ne sont plus nécessaires :
  linux-headers-3.2.0-39-generic python-numpy kde-l10n-fr linux-headers-3.2.0-33 linux-headers-3.2.0-40 linux-headers-3.2.0-38
  linux-headers-3.2.0-39 m4 libmagick++4 python-uniconvertor python-lxml language-pack-kde-fr-base fortune-mod libc6-i386 librecode0
  linux-headers-3.2.0-40-generic pax language-pack-kde-en language-pack-kde-fr kde-l10n-engb rpm librpmbuild2 linux-headers-3.2.0-38-generic
  fortunes-min libqt4-webkit:i386 lib32z1 libgc1c2 librpmsign0 linux-headers-3.2.0-33-generic libgsl0ldbl lsb-core perlmagick
  language-pack-kde-en-base alien ncurses-term libsdl-sound1.2
Veuillez utiliser « apt-get autoremove » pour les supprimer.
Les paquets supplémentaires suivants seront installés :
  libxcursor1
Les paquets suivants seront mis à jour :
  libxcursor1
1 mis à jour, 0 nouvellement installés, 0 à enlever et 10 non mis à jour.
2 partiellement installés ou enlevés.
Il est nécessaire de prendre 0 o/22,7 ko dans les archives.
Après cette opération, 17,4 ko d'espace disque seront libérés.
Souhaitez-vous continuer [O/n] ? O
dpkg : erreur de traitement de libxcursor1 (--configure) :
libxcursor1:amd64 1:1.1.12-1 cannot be configured because libxcursor1:i386 is in a different version (1:1.1.12-1ubuntu0.1)
dpkg : erreur de traitement de libxcursor1:i386 (--configure) :
libxcursor1:i386 1:1.1.12-1ubuntu0.1 cannot be configured because libxcursor1:amd64 is in a different version (1:1.1.12-1)
Aucun rapport « apport » écrit car MaxReports a déjà été atteint
                                                                Des erreurs ont été rencontrées pendant l'exécution :
libxcursor1
libxcursor1:i386
E: Sub-process /usr/bin/dpkg returned an error code (1)
ordipass@ORDIPASS:~$

Je ne peut toujours pas installer les mises à jour et il me remets ce fameux message.

Dernière modification par Sébastiend01 (Le 20/06/2013, à 21:17)

Hors ligne

#5 Le 20/06/2013, à 22:35

Korak

Re : Le système de packet est cassé [Résolu]

Ouvre un terminal et donne le retour complet (de la commande en elle-même jusqu'au retour au prompt) de la commande:

sudo apt-get autoremove

OS: Ubuntu 12.04.3 64 bits + Windows 8 64 bits en dualboot
PC portable: Processeur: AMD A4-4300M APU   Carte graphique: AMD Radeon HD 7420G   Mémoire vive: 6 Go RAM
Je suis Parrain-Linux

En ligne

#6 Le 22/06/2013, à 13:36

Sébastiend01

Re : Le système de packet est cassé [Résolu]

Bonjour, je tape la comande "sudo apt-get autoremove" et j'obtiens ça:
ordipass@ORDIPASS:~$ sudo apt-get autoremove
[sudo] password for ordipass:
Sorry, try again.
[sudo] password for ordipass:
Sorry, try again.
[sudo] password for ordipass:
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances       
Lecture des informations d'état... Fait
Vous pouvez lancer « apt-get -f install » pour corriger ces problèmes.
Les paquets suivants contiennent des dépendances non satisfaites :
libxcursor1 : Casse: libxcursor1:i386 (!= 1:1.1.12-1) mais 1:1.1.12-1ubuntu0.1 est installé
libxcursor1:i386 : Casse: libxcursor1 (!= 1:1.1.12-1ubuntu0.1) mais 1:1.1.12-1 est installé
E: Dépendances manquantes. Essayez d'utiliser l'option -f.
ordipass@ORDIPASS:~$

Je ne peut toujours pas faire de mise à jour.

Hors ligne

#7 Le 29/06/2013, à 18:33

Sébastiend01

Re : Le système de packet est cassé [Résolu]

J'ai finalement trouvé la solution. Je suis allé dans le Gestionnaire de packets Synaptic, et j'ai désinstaller le logiciel à partir de là. Merci à Spitfire 95 et à Korak qui m'ont aidé pour résoudre le problème.

Hors ligne

Haut de page ↑