Contenu | Rechercher | Menus

Annonce

Si vous rencontrez des soucis à rester connecté sur le forum (ou si vous avez perdu votre mot de passe) déconnectez-vous et reconnectez-vous depuis cette page, en cochant la case "Me connecter automatiquement lors de mes prochaines visites". Attention, le forum rencontre actuellement quelques difficultés. En cas d'erreur 502, il ne faut pas re-valider l'envoi d'un message ou l'ouverture d'une discussion, au risque de créer un doublon.

La section divers se réorganise ! De nouvelles sous-sections à venir. (plus d'infos + donner son avis)

#1 Le 11/07/2013, à 15:19

kratos13

installation separate+ pour gimp à partir des sources

Bonjour,
J'essaye d'installer le greffon pour gimp separate+ en suivant les instructions sur la page http://doc.ubuntu-fr.org/separate mais je rencontre une erreur au moment de la compilation, je ne comprend pas ce que ça veut dire.
Qu'est-ce que je doit faire exactement ?

cmoi@monordi:~/Téléchargements/separate+-0.5.8$ make
gcc -g `pkg-config gimp-2.0 --cflags` `pkg-config gimpui-2.0 --cflags` `pkg-config gtk+-2.0 --cflags` `pkg-config lcms --cflags` -DENABLE_COLOR_MANAGEMENT -DENABLE_NLS -DGETTEXT_PACKAGE="\"gimp20-separate\"" -DUSE_ICC_BUTTON -c separate-core.c
gcc -g `pkg-config gimp-2.0 --cflags` `pkg-config gimpui-2.0 --cflags` `pkg-config gtk+-2.0 --cflags` `pkg-config lcms --cflags` -DENABLE_COLOR_MANAGEMENT -DENABLE_NLS -DGETTEXT_PACKAGE="\"gimp20-separate\"" -DUSE_ICC_BUTTON -c separate-gui.c
gcc -g `pkg-config gimp-2.0 --cflags` `pkg-config gimpui-2.0 --cflags` `pkg-config gtk+-2.0 --cflags` `pkg-config lcms --cflags` -DENABLE_COLOR_MANAGEMENT -DENABLE_NLS -DGETTEXT_PACKAGE="\"gimp20-separate\"" -DUSE_ICC_BUTTON -c separate-export.c
separate-export.c: In function ‘create_psd_path_resource’:
separate-export.c:155:42: attention : initialization discards ‘const’ qualifier from pointer target type [enabled by default]
gcc -g `pkg-config gimp-2.0 --cflags` `pkg-config gimpui-2.0 --cflags` `pkg-config gtk+-2.0 --cflags` `pkg-config lcms --cflags` -DENABLE_COLOR_MANAGEMENT -DENABLE_NLS -DGETTEXT_PACKAGE="\"gimp20-separate\"" -DUSE_ICC_BUTTON -c util.c
gcc -g `pkg-config gimp-2.0 --cflags` `pkg-config gimpui-2.0 --cflags` `pkg-config gtk+-2.0 --cflags` `pkg-config lcms --cflags` -DENABLE_COLOR_MANAGEMENT -DENABLE_NLS -DGETTEXT_PACKAGE="\"gimp20-separate\"" -DUSE_ICC_BUTTON -c tiff.c
gcc -g `pkg-config gimp-2.0 --cflags` `pkg-config gimpui-2.0 --cflags` `pkg-config gtk+-2.0 --cflags` `pkg-config lcms --cflags` -DENABLE_COLOR_MANAGEMENT -DENABLE_NLS -DGETTEXT_PACKAGE="\"gimp20-separate\"" -DUSE_ICC_BUTTON -c psd.c
gcc -g `pkg-config gimp-2.0 --cflags` `pkg-config gimpui-2.0 --cflags` `pkg-config gtk+-2.0 --cflags` `pkg-config lcms --cflags` -DENABLE_COLOR_MANAGEMENT -DENABLE_NLS -DGETTEXT_PACKAGE="\"gimp20-separate\"" -DUSE_ICC_BUTTON -c jpeg.c
jpeg.c: In function ‘jpeg_write_image_data’:
jpeg.c:239:7: attention : passing argument 2 of ‘jpeg_write_scanlines’ from incompatible pointer type [enabled by default]
In file included from jpeg.c:31:0:
/usr/include/jpeglib.h:1041:20: note: expected ‘JSAMPARRAY’ but argument is of type ‘gchar **’
gcc -g `pkg-config gimp-2.0 --cflags` `pkg-config gimpui-2.0 --cflags` `pkg-config gtk+-2.0 --cflags` `pkg-config lcms --cflags` -DENABLE_COLOR_MANAGEMENT -DENABLE_NLS -DGETTEXT_PACKAGE="\"gimp20-separate\"" -DUSE_ICC_BUTTON -c iccbutton.c
gcc -g `pkg-config gimp-2.0 --cflags` `pkg-config gimpui-2.0 --cflags` `pkg-config gtk+-2.0 --cflags` `pkg-config lcms --cflags` -DENABLE_COLOR_MANAGEMENT -DENABLE_NLS -DGETTEXT_PACKAGE="\"gimp20-separate\"" -DUSE_ICC_BUTTON -c lcms_wrapper.c
gcc -g  separate-core.o separate-gui.o separate-export.o util.o tiff.o psd.o jpeg.o iccbutton.o lcms_wrapper.o -o separate `pkg-config gimp-2.0 --libs` `pkg-config gimpui-2.0 --libs` `pkg-config gtk+-2.0 --libs` `pkg-config lcms --libs` -ltiff -ljpeg
/usr/bin/ld: separate-core.o: référence au symbole non défini «pow@@GLIBC_2.2.5»
/usr/bin/ld: note: «pow@@GLIBC_2.2.5» est défini dans le DSO /lib/x86_64-linux-gnu/libm.so.6 donc essayez de l'ajouter à la ligne de commande du lieur
/lib/x86_64-linux-gnu/libm.so.6: could not read symbols: Opération invalide
collect2: erreur: ld a retourné 1 code d'état d'exécution
make: *** [separate] Erreur 1
cmoi@monordi:~/Téléchargements/separate+-0.5.8$ 

Dernière modification par kratos13 (Le 11/07/2013, à 15:31)

Hors ligne

#2 Le 17/10/2014, à 10:00

goug

Re : installation separate+ pour gimp à partir des sources

j'ai la même erreur malgré un :
export LDFLAGS="$LDFLAGS -lm"
avant le make
Quelqu'un a-t-il pu installer separate+0.5.8 depuis les sources récemment ?? (depuis 2013?)


Fai virar leis babolins e leis ideias ! : )

Hors ligne

Haut de page ↑