Contenu | Rechercher | Menus

Annonce

Si vous rencontrez des soucis à rester connecté sur le forum (ou si vous avez perdu votre mot de passe) déconnectez-vous et reconnectez-vous depuis cette page, en cochant la case "Me connecter automatiquement lors de mes prochaines visites".
Test de l'ISO d'Ubuntu francophone : nous avons besoin de testeurs pour la version francophone d'Ubuntu 14.04. Liens et informations ici.

Attention, une faille de sécurité dans bash a récemment été rapportée, il est recommandé de mettre à jour son système (plus de détails) *** mise à jour 12/10/2014 ***

#1 Le 12/07/2013, à 04:34

fiatskol

[RESOLU] mot de passe qui ne fonctionne plus

Bonjour,

Je suis sous Ubuntu 13.04 et j'ai un souci depuis hier quand j'ai créé un compte pour mon épouse.

J'ai l'accès en root, mon mot de passe est reconnu et en administrateur. 

Mais depuis la création du compte "normal" pour mon épouse, je ne peux plus rien faire comme administration sur mon pc.  Ni mise à jour, ni installation de nouveau logiciel, même pas déverrouiller le tableau des comptes utilisateurs...  A chaque fois, le mot de passe est refusé.  Pourtant, je n'ai rien changé à mon mot de passe.

J'espère que quelqu'un aura une solution à mon problème car ce que j'ai lu pour l'instant ne m'a pas bp aidé.

Merci.

Ps : je viens de voir que quand je tape sudo passwd root, j'ai le message "Sorry, try again" et si j'essaie 3 fois, c'est terminé... Donc là aussi souci de mot de passe...

Dernière modification par fiatskol (Le 14/07/2013, à 19:01)

Hors ligne

#2 Le 12/07/2013, à 04:54

nesthib

Re : [RESOLU] mot de passe qui ne fonctionne plus

Tu peux redémarrer ton ordinateur en mode de restauration (recovery_mode), active l'option remount et lance la commande suivante :

passwd flatskol

où flatskol est ton nom d'utilisateur.
Tu pourras choisir un nouveau mot de passe (à taper en aveugle).


GUL Bordeaux : GirollServices libres : TdCT.org
Hide in your shell, scripts & astuces :  applications dans un tunnelsmart wgettrouver des pdfinstall. auto de paquetssauvegarde auto♥ awk
  ⃛ɹǝsn xnuᴉꞁ uʍop-ǝpᴉsdn

Hors ligne

#3 Le 12/07/2013, à 05:02

fiatskol

Re : [RESOLU] mot de passe qui ne fonctionne plus

Bonjour Merci pour ta réponse, je suis déjà allé en restauration mais je ne vois pas le remount comme tu l'indiques.  J'ai trouvé root et quand je tape le password, j'ai la phrase suivant qui apparaît : erreur de manipulation du jeton d'authentification.

Chose qui m'étonne, quand je démarre mon ordinateur en mode normal, à chaque allumage, et ça depuis le début, il me demande mon mot de passe pour déverrouiller le trousseau de clés par défaut... et ça fonctionne mais ensuite, le même mot de passe est refusé pour le reste alors qu'avant tout allait bien...


nesthib a écrit :

Tu peux redémarrer ton ordinateur en mode de restauration (recovery_mode), active l'option remount et lance la commande suivante :

passwd flatskol

où flatskol est ton nom d'utilisateur.
Tu pourras choisir un nouveau mot de passe (à taper en aveugle).

Hors ligne

#4 Le 12/07/2013, à 05:13

nesthib

Re : [RESOLU] mot de passe qui ne fonctionne plus

Est-ce que ton home est chiffré ? As-tu changé ton mot de passe récemment ? As-tu manipulé les commandes chmod ou chown récemment ?
Que te donnent les commandes :

ls -l /etc/passwd*
ls -l /etc/shadow*

NB. nul besoin de citer l'intégralité de mon message pour y répondre wink


GUL Bordeaux : GirollServices libres : TdCT.org
Hide in your shell, scripts & astuces :  applications dans un tunnelsmart wgettrouver des pdfinstall. auto de paquetssauvegarde auto♥ awk
  ⃛ɹǝsn xnuᴉꞁ uʍop-ǝpᴉsdn

Hors ligne

#5 Le 12/07/2013, à 05:23

fiatskol

Re : [RESOLU] mot de passe qui ne fonctionne plus

didier-ubuntu@didierubuntu-imedia-S3210:~$ ls -l /etc/passwd*
-rw-r--r-- 1 root root 2201 jui 11 13:42 /etc/passwd
-rw------- 1 root root 2191 jui 11 13:42 /etc/passwd-
didier-ubuntu@didierubuntu-imedia-S3210:~$ ls -l /etc/shadow*
-rw-r----- 1 root shadow 1324 jui 11 13:49 /etc/shadow
-rw------- 1 root root   1422 jui 11 13:44 /etc/shadow-
didier-ubuntu@didierubuntu-imedia-S3210:~$

Hors ligne

#6 Le 12/07/2013, à 05:32

nesthib

Re : [RESOLU] mot de passe qui ne fonctionne plus

Il est probable que tu aies supprimé ton utilisateur, les deux fichiers ont été modifiés hier. Vérifie que tu as bien une ligne « didier-ubuntu » dans /etc/passwd et dans /etc/shadow (pour le second tu as besoin des droits root, donc éventuellement besoin de redémarrer en mode de restauration).

Je te recommande de sauvegarder les fichiers existants avant toute opération (en mode de restauration) :

cp /etc/passwd{,.bak20130712}
cp /etc/passwd-{,.bak20130712}
cp /etc/shadow{,.bak20130712}
cp /etc/shadow-{,.bak20130712}

Ensuite, si tu as bien ton utilisateur dans /etc/passwd, mais pas dans /etc/shadow, lance (toujours en restauration) :

cd /etc/
pwconv

pour recréer le fichier /etc/shadow

NB. si tu as une erreur d'écriture en mode de restauration et que tu ne vois pas l'option pour remonter le disque, lance :

mount -o rw,remount /

Si ça ne fonctionne pas, donne le contenu du fichier /etc/passwd


GUL Bordeaux : GirollServices libres : TdCT.org
Hide in your shell, scripts & astuces :  applications dans un tunnelsmart wgettrouver des pdfinstall. auto de paquetssauvegarde auto♥ awk
  ⃛ɹǝsn xnuᴉꞁ uʍop-ǝpᴉsdn

Hors ligne

#7 Le 12/07/2013, à 05:36

fiatskol

Re : [RESOLU] mot de passe qui ne fonctionne plus

question de novice, je trouve où le /etc/passwd ?

Hors ligne

#8 Le 12/07/2013, à 05:37

nesthib

Re : [RESOLU] mot de passe qui ne fonctionne plus

Dans /etc wink

Pour savoir si ton as ton utilisateur, lance :

grep didier /etc/passwd

GUL Bordeaux : GirollServices libres : TdCT.org
Hide in your shell, scripts & astuces :  applications dans un tunnelsmart wgettrouver des pdfinstall. auto de paquetssauvegarde auto♥ awk
  ⃛ɹǝsn xnuᴉꞁ uʍop-ǝpᴉsdn

Hors ligne

#9 Le 12/07/2013, à 05:40

fiatskol

Re : [RESOLU] mot de passe qui ne fonctionne plus

Voilà la réponse pour le passwd, pour le shadow, je passe en mode restauration...

didier-ubuntu@didierubuntu-imedia-S3210:~$ grep didier-ubuntu /etc/passwd
didier-ubuntu:x:1000:1000:Didier,,,:/home/didier-ubuntu:/bin/bash

Hors ligne

#10 Le 12/07/2013, à 05:44

nesthib

Re : [RESOLU] mot de passe qui ne fonctionne plus

Suis les indications du message #6 pour la suite.


GUL Bordeaux : GirollServices libres : TdCT.org
Hide in your shell, scripts & astuces :  applications dans un tunnelsmart wgettrouver des pdfinstall. auto de paquetssauvegarde auto♥ awk
  ⃛ɹǝsn xnuᴉꞁ uʍop-ǝpᴉsdn

Hors ligne

#11 Le 12/07/2013, à 05:45

fiatskol

Re : [RESOLU] mot de passe qui ne fonctionne plus

ok mais j'ai qql chose dans le etc/shadow... didier-ubuntu::15137:0:99999:7:::

Hors ligne

#12 Le 12/07/2013, à 05:52

nesthib

Re : [RESOLU] mot de passe qui ne fonctionne plus

Effectivement, mais il manque le mot de passe entre les deux premiers « : »
Tu devrais avoir une ligne du genre :

didier-ubuntu:$6$olGD4HNBJtZCam$2wLdEAthUmXlQMGutf8kHfjopilyhhRVyYGYkX/B.IwWNHzpLhI0je8gCOTqCYUHGvycCRfULu1gBTaqzshZO0:15137:0:99999:7:::

La suite de caractères étant le mot de passe salé et digéré.

Pour générer une nouvelle chaîne :

mkpasswd -m sha-512

NB. Celle que j'ai mise en exemple correspond au mot de passe « test », si cela peut t'aider.


GUL Bordeaux : GirollServices libres : TdCT.org
Hide in your shell, scripts & astuces :  applications dans un tunnelsmart wgettrouver des pdfinstall. auto de paquetssauvegarde auto♥ awk
  ⃛ɹǝsn xnuᴉꞁ uʍop-ǝpᴉsdn

Hors ligne

#13 Le 12/07/2013, à 06:01

fiatskol

Re : [RESOLU] mot de passe qui ne fonctionne plus

ok, j'ai fait tout ce qui est était indiqué au post #6 sans changement dans le shadow.  Je viens de générer une nouvelle suite de caractères avec mon password mais comment le mettre dans le shadow ensuite ?

Hors ligne

#14 Le 12/07/2013, à 13:35

nesthib

Re : [RESOLU] mot de passe qui ne fonctionne plus

Tout simplement en modifiant le fichier avec un éditeur de texte. Tu peux utiliser la commande nano qui est assez facile d'accès.

nano /etc/shadow

Autre solution, essaie de générer le mot de passe à la volée :

hash=$(mkpasswd -m sha-512)
sed '/didier/s|\([^:]*:\).\(:.*\)|\1'"${hash}"'\2|' /etc/shadow

Attention à bien respecter chaque caractère !
Si la commande semble bien ajouter le mot de passe, ajouter l'option « -i » après sed pour effectivement inscrire la modification dans le fichier.


GUL Bordeaux : GirollServices libres : TdCT.org
Hide in your shell, scripts & astuces :  applications dans un tunnelsmart wgettrouver des pdfinstall. auto de paquetssauvegarde auto♥ awk
  ⃛ɹǝsn xnuᴉꞁ uʍop-ǝpᴉsdn

Hors ligne

#15 Le 13/07/2013, à 04:43

pingouinux

Re : [RESOLU] mot de passe qui ne fonctionne plus

Bonjour,

nesthib   #14 a écrit :
sed '/didier/s|\([^:]*:\).\(:.*\)|\1'"${hash}"'\2|' /etc/shadow

Je crois qu'il y a une petite erreur dans la commande. J'aurais mis
sed '/^didier:/s|\([^:]*:\)[^:]*\(:.*\)|\1'"${hash}"'\2|' /etc/shadow
(en rouge, ce que j'ai modifié)

Ajouté : Il faut évidemment remplacer didier par le nom complet de login.

Dernière modification par pingouinux (Le 13/07/2013, à 04:46)

En ligne

#16 Le 13/07/2013, à 05:06

nesthib

Re : [RESOLU] mot de passe qui ne fonctionne plus

Exact en ce qui concerne le « . », il faut mettre « [^:]* » (ou simplement « .\? »).
Pour le reste, à moins qu'il y ait plusieurs comptes comportant le nom « didier », ça devrait faire l'affaire wink


GUL Bordeaux : GirollServices libres : TdCT.org
Hide in your shell, scripts & astuces :  applications dans un tunnelsmart wgettrouver des pdfinstall. auto de paquetssauvegarde auto♥ awk
  ⃛ɹǝsn xnuᴉꞁ uʍop-ǝpᴉsdn

Hors ligne

#17 Le 13/07/2013, à 09:10

fiatskol

Re : [RESOLU] mot de passe qui ne fonctionne plus

Merci pour tes infos.  J'ai à chaque fois le même message selon les deux procédures (nano et l'autre plus longue...) : sed: impossible de lire /etc/shadow: Permission non accordée

Hors ligne

#18 Le 13/07/2013, à 14:53

nesthib

Re : [RESOLU] mot de passe qui ne fonctionne plus

Je pense que le message est assez clair…
Je t'ai déjà dit précédemment que pour tout ce qui touche /etc/shadow tu as besoin des droits root, et que donc, dans ton cas, l'opération est à réaliser en mode de restauration.

Idéalement, si tu as deux machines, affiche la commande sur l'autre pour ne pas te tromper, ou imprime là :

hash=$(mkpasswd -m sha-512)
sed '/^didier:/s|\([^:]*:\)[^:]*\(:.*\)|\1'"${hash}"'\2|' /etc/shadow

et n'oublie pas que pour lancer effectivement le script tu dois ajouter l'option « -i » à sed :

hash=$(mkpasswd -m sha-512)
sed -i '/^didier:/s|\([^:]*:\)[^:]*\(:.*\)|\1'"${hash}"'\2|' /etc/shadow

Autre solution :
SI tu veux être sûr de ne pas te tromper tu peux aussi générer un script :

cat > ~/script_restauration.sh <<EOF
#!/bin/bash
hash=$(mkpasswd -m sha-512)
sed -n '/^didier:/s|\([^:]*:\)[^:]*\(:.*\)|\1'"${hash}"'\2|p' /etc/shadow
read -p 'ok? ' a
[[ $a == 'o' ]] && sed -i '/^didier:/s|\([^:]*:\)[^:]*\(:.*\)|\1'"${hash}"'\2|' /etc/shadow
EOF

puis redémarrer en mode de restauration et lancer le script :

bash /home/didier…/script_restauration.sh

(en mettant le bon nom pour ton /home)
Le script va afficher la ligne changée et te demander confirmation (il faut répondre « o » si la modification te paraît bonne, il doit y avoir une seule ligne avec le mot de passe ajouté) avant de modifier le fichier.


GUL Bordeaux : GirollServices libres : TdCT.org
Hide in your shell, scripts & astuces :  applications dans un tunnelsmart wgettrouver des pdfinstall. auto de paquetssauvegarde auto♥ awk
  ⃛ɹǝsn xnuᴉꞁ uʍop-ǝpᴉsdn

Hors ligne

#19 Le 14/07/2013, à 19:01

fiatskol

Re : [RESOLU] mot de passe qui ne fonctionne plus

Tout est réparé, mon beau-fils m'a aidé en suivant le fil du forum et toutes tes informations.  Merci de ton aide nesthib.

Hors ligne

#20 Le 14/07/2013, à 19:07

nesthib

Re : [RESOLU] mot de passe qui ne fonctionne plus

Ravi de voir que tout est rentré dans l'ordre smile

Par curiosité, et aussi pour les éventuelles personnes qui viendrait à lire ce fil à l'avenir, quelle solution as-tu utilisée ?


GUL Bordeaux : GirollServices libres : TdCT.org
Hide in your shell, scripts & astuces :  applications dans un tunnelsmart wgettrouver des pdfinstall. auto de paquetssauvegarde auto♥ awk
  ⃛ɹǝsn xnuᴉꞁ uʍop-ǝpᴉsdn

Hors ligne

#21 Le 14/07/2013, à 20:11

fiatskol

Re : [RESOLU] mot de passe qui ne fonctionne plus

Mon beau-fils a généré le mot de passe comme tu l'indiquais et ensuite il a édité le shadow pour y insérer le mot de passe manquant.  Je n'arrivais pas à le faire via le mode récupération.  Il a réussi à le faire en utilisant le mode normal et en utilisant "su" au lieu de "sudo" et puis il a utilisé un éditeur de mot de passe... Je peux lui demander de me faire un petit résumé car c'est plus sa branche que la mienne, il fait un doctorat en ingénieur civil option informatique...

Hors ligne

Haut de page ↑