Contenu | Rechercher | Menus

Annonce

Si vous rencontrez des soucis à rester connecté sur le forum (ou si vous avez perdu votre mot de passe) déconnectez-vous et reconnectez-vous depuis cette page, en cochant la case "Me connecter automatiquement lors de mes prochaines visites". Attention, le forum rencontre actuellement quelques difficultés. En cas d'erreur 502, il ne faut pas re-valider l'envoi d'un message ou l'ouverture d'une discussion, au risque de créer un doublon.

La section divers se réorganise ! De nouvelles sous-sections à venir. (plus d'infos + donner son avis)

#1 Le 08/07/2013, à 18:06

Ferdinand75

[Résolu] Liaison ssh vers Rasberry pi

Bonsoir,

J'espère être dans la bonne section pour poser ma question.

Je voudrais commander un carte Raspberry pi par l'intermédiaire de mon pc portable qui fonctionne sous kubuntu.
Si j'ai bien tout compris à tout ce que j'ai pu lire:
Ma carte Raspberry pi est le serveur et Mon PC portable est le client.
Une chose sûr, le ssh de la Raspberry pi est fonctionnel. Je l'ai expérimenté avec Putty sous PC windows via une boxe avec un câble RJ45 droit et la carte répond tout à fait bien.

Dand le cas présent la Raspberry pi est directement relié au PC portable (Kubuntu) avec un câble RJ45 croisé.
sous console  j'écris:
sudo ssh pi@192.168.0.6 -p666
il me répond:
Network is unreachable

Faut il que je configure quelque chose ?

Fefer

Dernière modification par Ferdinand75 (Le 13/07/2013, à 12:53)

Hors ligne

#2 Le 08/07/2013, à 19:06

Nasman

Re : [Résolu] Liaison ssh vers Rasberry pi

Peux tu faire un ping vers ton Raspberry pi ?
Quelles sont les ip des deux PC ?


PC fixe et portable avec Precise 64 bits

Hors ligne

#3 Le 08/07/2013, à 19:34

Ferdinand75

Re : [Résolu] Liaison ssh vers Rasberry pi

Non je ne peux pas faire de ping vers le Raspberry pi. J'obtiens la même réponse: Network is unreachable

Je n'ai qu'un PC et le Raspberry pi. L'IP du Raspberry pi est 192.168.0.6. Le PC n'a pas d'IP fixe. Faudrait il que je lui attribue un IP fixe ?

A+
Ferdinand

Hors ligne

#4 Le 08/07/2013, à 23:23

nesthib

Re : [Résolu] Liaison ssh vers Rasberry pi

Si la connexion est directe il faut que tu configure ta machine Ubuntu en « partagé avec d'autres ordinateurs » pour qu'elle attribue une IP à ton raspberry pi.
Réseau > Modifier > Choisis ta connexion filaire ou crées-en une nouvelle > Paramètres IPv4 > Méthode > Partagé avec d'autres ordinateurs

Maintenant tu devrais pouvoir communiquer avec ton RPi.

Autre solution, si tu as un routeur ou une box, ajoute le RPi sur un des ports wink


GUL Bordeaux : GirollServices libres : TdCT.org
Hide in your shell, scripts & astuces :  applications dans un tunnelsmart wgettrouver des pdfinstall. auto de paquetssauvegarde auto♥ awk
  ⃛ɹǝsn xnuᴉꞁ uʍop-ǝpᴉsdn

Hors ligne

#5 Le 09/07/2013, à 12:26

Ferdinand75

Re : [Résolu] Liaison ssh vers Rasberry pi

Je répond d'abord à la fin de ton poste.
Effectivement avec une box (routeur) ça marche impeccable mais ce n'est pas ce que je veux faire.
Je veux utiliser mon portable et le RPi seuls dans un endroit où il n'y a ni box ni routeur.

Alors, j'ai suivi ton conseil sans comprendre ce que je faisais.
Je suis allé dans la fenêtre "Configuration de:Gestion de réseau", créé une connexion filaire. Dans l'onglet "Adresse IPv4" en "Réglages de base" j'ai choisi "Partagé" dans le champ "Méthode".
Apparemment la fenêtre "Configuration de:Gestion de réseau" m'indique que cette liaison est connectée.
Malheureusement j'ai toujours:
Network is unreachable

Il y a-t-il, sous Kubuntu, de faire un ping ou voir les liaisons sur le connecteur RJ45 autre qu'en ligne de commande ?

A+
Ferdinand

Hors ligne

#6 Le 09/07/2013, à 12:35

Ferdinand75

Re : [Résolu] Liaison ssh vers Rasberry pi

Bon en fait comme je ne sais pas d'où vient le dysfonctionnement j'en viens à tout soupçonner.
Je viens de regarder mon câble RJ45 et aidé de wikipédia je viens de m’apercevoir que mon câble n'est pas un câble croisé mais un câble croisé partiel et d'après ce qui est dit dans l'article «ce câble est compatible de la même façon que les câbles droits».
Je change de câble et je vous tiens au courant.

A+
Ferdinand

Hors ligne

#7 Le 09/07/2013, à 12:36

sosmayo

Re : [Résolu] Liaison ssh vers Rasberry pi

Bonjour,
Si tu es en IP fixe sur ta raspberry (192.168.0.6), il faut que tu sois aussi en IP fixe sur ton PC dans la même gamme d'IP que celle de la raspberry : par exemple 192.168.0.10 avec un masque 255.255.255.0
De cette manière le PC et la raspberry seront sur le même réseau et devraient pouvoir communiquer.
Sinon tu peux activer l'attribution automatique de l'IP au niveau de la raspberry et appliquer la manip expliquée par nesthib

Hors ligne

#8 Le 09/07/2013, à 14:10

nesthib

Re : [Résolu] Liaison ssh vers Rasberry pi

Exactement, si tu as mis ton RPi en IP fixe, cela peut poser problème wink


GUL Bordeaux : GirollServices libres : TdCT.org
Hide in your shell, scripts & astuces :  applications dans un tunnelsmart wgettrouver des pdfinstall. auto de paquetssauvegarde auto♥ awk
  ⃛ɹǝsn xnuᴉꞁ uʍop-ǝpᴉsdn

Hors ligne

#9 Le 11/07/2013, à 17:59

Ferdinand75

Re : [Résolu] Liaison ssh vers Rasberry pi

Merci des réponses complémentaires.

J'ai réussi à obtenir un câble croisé. En vérité j'ai modifié celui que j'avais afin de le rendre complètement croisé ;o)

Ça ne fonctionne toujours pas mais il y a du nouveau.

Je ne peux pas permettre l'attribution automatique de l'IP au niveau de la raspberry car j'ai besoin de connaitre son IP quand je veux y accéder en ssh.

J'ai attribué un IP fixe à mon PC. 192.168.0.5 pour tout vous dire. Pour le faire, je suis obligé d'utiliser une "Méthode" 'Manuelle'. Je ne peux donc plus utiliser la "Méthode" 'Partagé.'

Quand j'envoie la commande:
sudo ssh pi@192.168.0.6 -p666
maintenant il me répond:
ssh: connect to host 192.168.0.6 port 666: No route to host

???
Aidez moi, please, en plus je n'arrive pas à maitriser ce qui devrait se passer.
Si mon PC exécute la commande ssh pi@192.168.0.6 -p666. Celui ci demande bien au truc qui porte l'adresse 192.168.0.6 en passant par la porte 666 de bien vouloir recevoir les commandes du requérant ?
Le RPi ayant l'adresse 192.168.0.6 avec la porte 666 ouverte devrait recevoir la requête ?
Hors, si je comprend bien, le système dit qu'il n'y a pas de chemin qui mène à l'adresse spécifiée.
Est ce que j'ai bon là ?
Si oui il faut que j'oriente la requête dans la bonne direction. Comment ? Et est ce que je comprend bien ?

A+
Ferdinand

Hors ligne

#10 Le 11/07/2013, à 18:48

nesthib

Re : [Résolu] Liaison ssh vers Rasberry pi

Si ta machine fait office de DCHP, tu peux retrouver l'IP attribuée, au pire tu peux faire un ping sur toute la plage d'IP (broadcast)

En ce qui concerne le port, par défaut ssh écoute sur le port 22, à moins que tu aies changé cela (ce qui à mon avis est une mauvais pratique), tu devrais rester sur le port 22.
Si le service ssh n'écoute pas sur le port 666, alors ça ne fonctionnera pas.

Que te donne :

nmap 192.168.0.6

GUL Bordeaux : GirollServices libres : TdCT.org
Hide in your shell, scripts & astuces :  applications dans un tunnelsmart wgettrouver des pdfinstall. auto de paquetssauvegarde auto♥ awk
  ⃛ɹǝsn xnuᴉꞁ uʍop-ǝpᴉsdn

Hors ligne

#11 Le 11/07/2013, à 18:58

Shanx

Re : [Résolu] Liaison ssh vers Rasberry pi

Juste une petite remarque en passant : pourquoi utiliser ssh avec sudo ? A priori ce n’est pas nécessaire, et ne peut qu’apporter (dans le pire des cas, je l’accorde) des problèmes de sécurité.

Dernière modification par Shanx (Le 11/07/2013, à 19:12)


« En vérité, je ne voyage pas, moi, pour atteindre un endroit précis, mais pour marcher : simple plaisir de voyager. » R. L. Stevenson
--
Blog et randos

Hors ligne

#12 Le 11/07/2013, à 19:06

nesthib

Re : [Résolu] Liaison ssh vers Rasberry pi

Je n'avais pas relevé le sudo et je rejoins totalement Shanx : le sudo est inutile et potentiellement problématique.


GUL Bordeaux : GirollServices libres : TdCT.org
Hide in your shell, scripts & astuces :  applications dans un tunnelsmart wgettrouver des pdfinstall. auto de paquetssauvegarde auto♥ awk
  ⃛ɹǝsn xnuᴉꞁ uʍop-ǝpᴉsdn

Hors ligne

#13 Le 11/07/2013, à 19:10

mydjey

Re : [Résolu] Liaison ssh vers Rasberry pi

nesthib a écrit :

En ce qui concerne le port, par défaut ssh écoute sur le port 22, à moins que tu aies changé cela (ce qui à mon avis est une mauvais pratique), tu devrais rester sur le port 22.

Pourquoi est-ce une mauvaise pratique ?
Dans le cas d'un serveur exposé au grand InterWeb ça évite les tentatives de connexion via ce port archi connu, nan ?


Mon site : http://mydjey.eu/

Hors ligne

#14 Le 11/07/2013, à 19:35

Ferdinand75

Re : [Résolu] Liaison ssh vers Rasberry pi

@nesthib
Oui je sais que le port par défaut est 22 je l'ai changé car plusieurs site le préconisent par mesure de sécurité. Bon ce n'ai pas que je craigne grand chose, je l'ai fais sans trop réfléchir. Je vais remettre 22 mais je crois pas que c'est ça qui va débloquer la situation.
Moi je veux bien faire ce que tu veux du moment que ça solutionne mon problème mais je ne sais pas vraiment comment faire alors, s'il te plait, explique moi comment dois je faire pour que ma machine gère le DHCP et comment retrouver ne numéro d'IP attribué à mon RPi.

Et je ne comprend toujours pas pourquoi le fait de mettre le RPi en IP fixe peut poser problème vu que je le connais.

à la suite de nmap 192.168.0.6
Il me dit que je n'ai pas de dns. Ça je le savais j'ai rien mis dans le champ dns. que mettre, vu que je n'ai qu'un PC relié au RPi.
puis:
Host seems down. If it is really up, but blocking our ping probes, try -Pn
et
Nmap done: 1 IP address '0 host up) scanned in 3.08 seconds

J'ai donc envoyé la commande:
nmap 192.168.0.6 -Pn

ce qui donne même remarque pour le dns
et
Nmap scan report for 192.168.0.6
Host is up (0.10s latency).
All 1000 scanned ports on 192.168.0.6 are filtered

Alors docteur, c'est grave ?

@Shanx
Je suis une bille en linux. J'ai remarqué que devant plein de commande il fallait ajouter sudo. De plus, pour avoir utilisé souvent des commandes sans sudo dans un premier temps qui ne répondaient pas puis, dans un deuxième temps, avoir ajouter sudo et les voir fonctionner, je met sudo à toutes les sauces.

A+
Ferdinand

Hors ligne

#15 Le 12/07/2013, à 00:17

sosmayo

Re : [Résolu] Liaison ssh vers Rasberry pi

Que tu sois en IP fixe au niveau de ta RBpi ne doit normalement pas posé de problème si ton PC à une adresse IP dans la même gamme.
Sur ta RBpi, peux tu avoir le contenu du ficher /etc/network/interfaces ? Peut être faire un ifconfig ?
Sur ton PC, que donne

ifconfig

et

nmap -sP 192.168.0.0/24

Hors ligne

#16 Le 12/07/2013, à 04:00

nesthib

Re : [Résolu] Liaison ssh vers Rasberry pi

mydjey a écrit :

Pourquoi est-ce une mauvaise pratique ?
Dans le cas d'un serveur exposé au grand InterWeb ça évite les tentatives de connexion via ce port archi connu, nan ?

Car ça n'apporte aucune sécurité (c'est assimilable à de la sécurité par l'obscurité) et parce qu'il est excessivement facile de trouver le port ssh (le protocole ssh fait que le serveur doit explicitement dire qu'il sert du ssh sur le port d'écoute). La seule chose que ça peut faire c'est engendrer tout un tas de problème le jour où tu seras sur un réseau qui filtre certains ports. Le seul intérêt de modifier le port est d'ajouter la prise en charge du port 443 pour contourner un filtrage du 22 chez le client. Si tu veux de la sécurité, mets en place fail2ban ou assimilé.

@Ferdinand75 : pour le port 22, voir ci-dessus.
Pour sudo, je confirme que ça ne sert à rien.
En ce qui concerne ton problème, si tu arrives à avoir une connexion (un ping qui fonctionne), tu peux garder ton IP fixe, pas de soucis. Le nmap ne donne aucune information pertinente. Sois sûr de mettre ssh sur le port 22 et recommence l'opération.
As-tu essayé de mettre des règles sur le pare-feu ?


GUL Bordeaux : GirollServices libres : TdCT.org
Hide in your shell, scripts & astuces :  applications dans un tunnelsmart wgettrouver des pdfinstall. auto de paquetssauvegarde auto♥ awk
  ⃛ɹǝsn xnuᴉꞁ uʍop-ǝpᴉsdn

Hors ligne

#17 Le 12/07/2013, à 13:43

lolomalin

Re : [Résolu] Liaison ssh vers Rasberry pi

Bonjour à tous,

je suis tombé sur ce fil par hasard, et il se trouve que je souhaite tester la même chose (c'est à dire une connexion directe par ethernet entre le Pi et mon portable sans passer par un routeur).
Il se trouve que je suis tombé sur ce lien : https://pihw.wordpress.com/guides/direc … onnection/  lequel semble répondre à la question. Je ne l'ai pas encore testé, mais ça m'a paru clair.

Il est effectivement question d'attribuer une adresse IP fixe au Pi pour le portable puisse y accéder facilement.

En espérant que ça aide !

Hors ligne

#18 Le 12/07/2013, à 14:20

sosmayo

Re : [Résolu] Liaison ssh vers Rasberry pi

L'IP fixe n'est pas une obligation.
Perso j'ai activé le DHCP sur ma raspberry pi, puis configurer le réseau sur mon PC en choisissant l'option "Partagé avec d'autres ordinateurs". De cette manière rien à configurer (enfin de manière manuel) et j'utilise mon pc comme passerelle pour connecter ma RBpi à internet.
Pour activé le DHCP sur la RBpi :
il faut éditer le fichier /etc/network/interfaces
puis rajouter :

auto lo
iface lo inet loopback
auto eth0
iface eth0 inet dhcp

Plus d'info avec un

man interfaces

Hors ligne

#19 Le 12/07/2013, à 15:42

Ferdinand75

Re : [Résolu] Liaison ssh vers Rasberry pi

Bon alors, gros changement. Mon Raspberry Pi a planté et je ne sais pas pourquoi impossible de rebooter. Le système ne reconnaissait plus l'espace mémoire (carte SD).
J'ai donc tout réinstallé sans toucher à la configuration de l'IP. Au niveau du réseau j'ai laissé la config par défaut et donc le numéro du port est de nouveau 22.

Au niveau du PC, je l'ai configuré en 'Manuelle' IP:192.168.0.5, masque de sous réseau 255.255.255.0, champs 'Passerelle' vide, champs 'serveur DNS' vide.

Donc nous sommes sur ces nouvelles bases.

Dans ce cas je ne sais pas comment faire pour accéder à mon RPi en ssh. Je compte sur vous pour me l'expliquer.

Pour information:
Voici le contenu de /etc/network/interfaces du RPi

auto lo

iface lo inet loopback
iface eth0 inet dhcp

allow-hotplug wlan0
iface wlan0 inet manual
wpa-roam /etc/wpa_supplicant/wpa_supplicant.conf
iface default inet dhcp

La réponse à ifconfig du PC:

eth0      Link encap:Ethernet  HWaddr 00:21:70:dc:e6:4d  
          inet adr:192.168.0.5  Bcast:192.168.0.255  Masque:255.255.255.0
          adr inet6: fe80::221:70ff:fedc:e64d/64 Scope:Lien
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          Packets reçus:159 erreurs:0 :0 overruns:0 frame:0
          TX packets:827 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 lg file transmission:1000 
          Octets reçus:10176 (10.1 KB) Octets transmis:59824 (59.8 KB)
          Interruption:18 

lo        Link encap:Boucle locale  
          inet adr:127.0.0.1  Masque:255.0.0.0
          adr inet6: ::1/128 Scope:Hôte
          UP LOOPBACK RUNNING  MTU:65536  Metric:1
          Packets reçus:1089 erreurs:0 :0 overruns:0 frame:0
          TX packets:1089 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 lg file transmission:0 
          Octets reçus:95864 (95.8 KB) Octets transmis:95864 (95.8 KB)

         
Et le résultat à la commande nmap -sP 192.168.0.0/24 du PC:

Starting Nmap 6.00 ( http://nmap.org ) at 2013-07-12 15:26 CEST
mass_dns: warning: Unable to determine any DNS servers. Reverse DNS is disabled. Try using --system-dns or specify valid servers with --dns-servers
Nmap scan report for 192.168.0.5
Host is up (0.00033s latency).
Nmap done: 256 IP addresses (1 host up) scanned in 2.72 seconds

A+
Ferdinand

Dernière modification par Ferdinand75 (Le 12/07/2013, à 15:48)

Hors ligne

#20 Le 12/07/2013, à 16:07

Ferdinand75

Re : [Résolu] Liaison ssh vers Rasberry pi

@ sosmayo
J'ai essayé ce que tu préconises. J'ai configuré le réseau de mon PC en 'Méthode' "Partagé" et dans ce cas la réponse à la commande

nmap -sP 192.168.0.0/24

est

Starting Nmap 6.00 ( http://nmap.org ) at 2013-07-12 16:55 CEST
mass_dns: warning: Unable to determine any DNS servers. Reverse DNS is disabled. Try using --system-dns or specify valid servers with --dns-servers
Nmap done: 256 IP addresses (0 hosts up) scanned in 0.03 seconds

autrement dit, je crois comprendre qu'il ne voit personne sur la ligne.

@ lolomalin
Merci de ta réponse mais j'ai un mal fou avec l'anglais surtout quand c'est dans un domaine que je ne maitrise pas du tout

A+
Ferdinand

Hors ligne

#21 Le 12/07/2013, à 17:19

nesthib

Re : [Résolu] Liaison ssh vers Rasberry pi

@Ferdinand75 : je confirme que tu ne ping personne, la connexion ne passe donc pas.

Je ne suis pas sûr que dnsmasq (le programme qui attribue l'adresse IP à ton RPi en DHCP) utilise des adresses en 192.168.0.x.
Essaie de regarder si tu as des messages dans /var/log/messages.log lorsque tu connectes ton câble ethernet.

tail -f /var/log/messages.log

puis branche le câble.


GUL Bordeaux : GirollServices libres : TdCT.org
Hide in your shell, scripts & astuces :  applications dans un tunnelsmart wgettrouver des pdfinstall. auto de paquetssauvegarde auto♥ awk
  ⃛ɹǝsn xnuᴉꞁ uʍop-ǝpᴉsdn

Hors ligne

#22 Le 12/07/2013, à 17:22

sosmayo

Re : [Résolu] Liaison ssh vers Rasberry pi

La commande nmap -sP permet de connaître les machines connecté au réseau.
Dans le cas où tu es en IP fixe sur ton PC, il y a seulement ton PC qui est vu (192.168.0.5) mais pas la RBpi. Il semblerait donc que l'IP de la RBpi ne soit pas dans cette gamme d'IP.
Cependant, le DHCP semble être activé sur ta RBpi (iface eth0 inet dhcp dans /etc/network/interfaces).
Quand tu es en méthode partagé au niveau du PC, il est normal qu'un scan sur 192.168.0.0/24 ne renvoie rien, car dans ce cas là le PC s'attribue une IP du type 10.0.0.0/8.
Ce que tu peux essayer de faire :
- Au niveau du PC, rester en configuration "méthode partagée"
- Au niveau de la RBpi, faire un ifconfig pour vérifier si elle obtient une adresse IP automatiquement.

Si tu obtiens une adresse IP au niveau du PC du type 10.X.X.X et la même au niveau de la RBpi, tu devrais pouvoir pinger ta RBpi depuis ton PC et y accéder en ssh.

Au fait juste par curiosité, quelle distrib as tu sur ta raspberry pi ?

Hors ligne

#23 Le 12/07/2013, à 18:02

Ferdinand75

Re : [Résolu] Liaison ssh vers Rasberry pi

Alors il y a du nouveau et du progrès.

Je suis désolé mais je n'ai pas suivi vos conseils. En fait je viens de les lire.

J'ai suivi le tut que nous a envoyé lolomalin: https://pihw.wordpress.com/guides/direc … onnection/

C'est en anglais, j'ai du batailler pour comprendre mais j'étais trop pressé pour attendre vos réponses.
Alors voilà où j'en suis:

Le RPi a une IP fixe: 192.168.0.6
Le PC a une IP fixe: 192.168.0.5 masque 255.255.255.0

Quand je fait un ping 192.168.0.6 du PC il y a un réponse et quand je fait un ping 192.168.0.5 du RPi il y a une réponse aussi.

malheureusement quand je fais du PC

ssh pi@192.168.0.6

j'ai droit à:

ssh: connect to host 192.168.0.5 port 22: Connection refused

Qu'est ce que je dois débloquer pour que ça ne soit plus "refused" ?

A+
Ferdinand

Hors ligne

#24 Le 12/07/2013, à 18:06

Ferdinand75

Re : [Résolu] Liaison ssh vers Rasberry pi

Effectivement, maintenant quand j'utilise la commande nmap -sP je vois l'IP de la RPi.

J'ai Raspbian comme distrib.

A+
Ferdinand

Dernière modification par Ferdinand75 (Le 12/07/2013, à 18:08)

Hors ligne

#25 Le 12/07/2013, à 19:42

nesthib

Re : [Résolu] Liaison ssh vers Rasberry pi

Que te donne :

ssh -vvv pi@192.168.0.6

GUL Bordeaux : GirollServices libres : TdCT.org
Hide in your shell, scripts & astuces :  applications dans un tunnelsmart wgettrouver des pdfinstall. auto de paquetssauvegarde auto♥ awk
  ⃛ɹǝsn xnuᴉꞁ uʍop-ǝpᴉsdn

Hors ligne

Haut de page ↑