Contenu | Rechercher | Menus

Annonce

Si vous rencontrez des soucis à rester connecté sur le forum (ou si vous avez perdu votre mot de passe) déconnectez-vous et reconnectez-vous depuis cette page, en cochant la case "Me connecter automatiquement lors de mes prochaines visites". Attention, le forum rencontre actuellement quelques difficultés. En cas d'erreur 502, il ne faut pas re-valider l'envoi d'un message ou l'ouverture d'une discussion, au risque de créer un doublon.

La section divers se réorganise ! De nouvelles sous-sections à venir. (plus d'infos + donner son avis)

#1 Le 12/07/2013, à 22:07

pistache

Problème de connexion à haut parleur bluetooth

Bonjour.

Je n'arrive pas à me connecter à des haut-parleur bluetooth.

Matériel :
clef bluetooth trendnet tbw-170ub  : fonctionne : j'arrive par exemple à naviguer dans le système de fichier de mon téléphone portable, et la clef autodétecte bien le haut parleur bluetooth.

le haut parleur bluetooth fonctionne bien : par exemple j'arrive à m'y connecter avec mon téléphone gsm et y faire jouer des mp3.

au niveau logiciel, je lance l'autodétection du matériel, le haut parleur est détecté, j'indique à l'utilitaire graphique comme type de choix d'utilisation : "A2DP sink (send audio)"

j'ai pour erreur :

"périphérique ajouté, mais échec de la connexion" /  stream setup failed.

Je suis usager "basique" , je ne sais pas aller au delà pour le diagnostic et la résolution du problème.

Merci d'avance pour votre aide.

Hors ligne

#2 Le 13/07/2013, à 02:18

MicP

Re : Problème de connexion à haut parleur bluetooth

Bonjour

pistache a écrit :

... le haut parleur est détecté, j'indique à l'utilitaire graphique comme type de choix d'utilisation : "A2DP sink (send audio)" ...

Je me demande s'il ne faudrait pas choisir "A2DP Source" plutôt que "Sink", étant donné qu'il s'agit d'envoyer un flux audio vers un récepteur.
Ce devrait être facile à tester

Dernière modification par MicP (Le 13/07/2013, à 02:21)

Hors ligne

#3 Le 13/07/2013, à 08:07

pistache

Re : Problème de connexion à haut parleur bluetooth

Merci, mais je n'ai que cette option (sink), ou bien "ne pas connecter".

Hors ligne

#4 Le 07/12/2013, à 15:37

manup31

Re : Problème de connexion à haut parleur bluetooth

C'est à peu de chose près le même problème que celui que j'exposais récemment.
On parvient à appairer les hauts-parleurs avec le PC, mais pas à les connecter par a2dp.

De mon côté j'ai deux configurations, l'une avec un dongle BT qui ne fonctionne pas, l'autre avec un BT intégré dans un portable HP qui fonctionne : oui, le son sort sur les HP via BT et sans devoir modifier quelque fichier que ce soit, ni créer de .asoundrc ! Exactement comme à partir d'un GSM (android ou pas).

J'ai déjà passé quelques heures à tenter de diagnostiquer le dysfonctionnement avec 2 dongle BT différents, notamment avec hcidump qui permet de tracer le dialogue entre le PC et les hauts-parleurs, mais c'est assez touffu et sans l'appui d'un "expert" qui pointerait où il faut regarder ça va prendre du temps, pour pas forcément trouver... hmm
Car il y a plusieurs niveau de BT, par exemple, et peut-être que les dongles utilisés ne sont simplement pas compatibles avec les hauts-parleurs...

Or il ne semble pas qu'il y ait de poilus bluetooth ici, ou ils ne lisent pas ces posts...

Côté AskUbuntu, on trouve les mêmes questions mais guère de réponse fonctionnelle, je n'y ai rien trouvé d'efficace, à part les outils. Idem sur les forums d'autres distros (fedora, ...).

Il doit plutôt falloir ouvrir un bug sur launchpad et/ou voir du côté de forums logitech (les hauts-parleurs que j'essaie de faire fonctionner sont de cette marque) ou autres.

Ces problèmes ne sont pas spécifiques à Linux, beaucoup ont les mêmes sous windows.


manu'

Hors ligne

#5 Le 07/12/2013, à 16:13

pistache

Re : Problème de connexion à haut parleur bluetooth

Bonjour

Merci pour ce complément d'information. Pour ma part, je n'ai aussi toujours pas trouvé de solution, ce qui est fort dommage, malgré des tests avec divers dongles BT.

Hors ligne

#6 Le 19/01/2014, à 16:37

Tiachofe

Re : Problème de connexion à haut parleur bluetooth

Bonjour,

je connais le même problème que celui décrit dans le premier post. Je fouille sur internet en vain. Avez-vous pu trouver une solution?

Merci

Hors ligne

#7 Le 19/01/2014, à 17:32

manup31

Re : Problème de connexion à haut parleur bluetooth

Pas de mon côté...


manu'

Hors ligne

#8 Le 19/01/2014, à 17:58

ft84-19

Re : Problème de connexion à haut parleur bluetooth

Bonjour,

J'ai eu les mêmes problèmes que j'ai résolus en désinstallant blueman et en n'utilisant que l'outil de base. J'utilise un dongle belkin et un adaptateur Logitech sur mon ampli, et j'avais réussi à apairer, mais avec toujours le message que la connexion échouait.

J'espère que ça pourra être aussi simple pour vous.

François

Hors ligne

#9 Le 19/01/2014, à 19:16

pistache

Re : Problème de connexion à haut parleur bluetooth

Bonsoir,

et en n'utilisant que l'outil de base

Quel est le nom de cet outil? Merci !

Hors ligne

#10 Le 19/01/2014, à 22:31

Tiachofe

Re : Problème de connexion à haut parleur bluetooth

ça a un peu évolué de mon côté. Je parviens maintenant à connecter l'adaptateur logitech bluetooth avec le gestionnaire de périphérique blueman. Par contre, si la communication entre le pc et l'équipement bluetooth semble OK, le son continue de sortir sur les haut parleur du pc et ne switche pas sur l'appareil bluetooth...

pour connecter l'appareil et ne plus avoir le "stream setup failed":

- ouvrir en écriture le fichier suivant avec la commande:
sudo leafpad /etc/bluetooth/audio.conf

- modifier et sauvegarder le fichier avec:
[General]
Enable=Socket

- redémarrer le pc ou lancer la commande suivante:
sudo service bluetooth restart

- après appairage, le matériel audio bluetooth se connecte au PC.


Maintenant, il ne reste plus qu'à envoyer le son par le bluetooth!

P.S: pour info, je suis sur lubuntu

Hors ligne

#11 Le 05/02/2014, à 21:26

Tiachofe

Re : Problème de connexion à haut parleur bluetooth

bonjour,

quelqu'un peut-il m'aider à balancer le son?

merci

Hors ligne

#12 Le 09/02/2014, à 20:42

berserk_14

Re : Problème de connexion à haut parleur bluetooth

bonjour j'en suis au meme point!!! j'ai retourné internet et j'ai pas trouvé de solution!!

A l'aide

Hors ligne

#13 Le 10/02/2014, à 10:35

agensbur

Re : Problème de connexion à haut parleur bluetooth

Pour ma part, je n'ai aussi toujours pas trouvé de solution, ce qui est fort dommage, malgré des tests avec divers dongles BT.

Même constat de mon coté.
Sur une machine avec bluetooth intégré cela  fonctionne, par contre les essais de dongle bluetooth sur plusieurs machines, je n'ai jusqu'ici pas trouver de solutions pour l'audio même via des dongle claironnant une compatibilité linux.
Pour moi l'audio et bluetooth sous linux c'est encore la loterie et la jungle.

Dernière modification par agensbur (Le 10/02/2014, à 10:36)


Dell Inspirion 620 - Intel(R) Core(TM) i5- 3.00GHz - 6 Go mémoire - Xubuntu 14.04-64 bits
NetBook Samsung NC -10 - Lubuntu 14.04-32 bits

Hors ligne

#14 Le 12/02/2014, à 22:27

berserk_14

Re : Problème de connexion à haut parleur bluetooth

bonsoir
alors moi j'essai sur un netbook avec bluetooth integré et ya rien a faire, j'arrive a appairer mais dans le controleur de volume je ne vois rien concernant le bluetooth.

bon courage

Hors ligne

#15 Le 14/02/2014, à 17:07

berserk_14

Re : Problème de connexion à haut parleur bluetooth

bonjour, alors pour moi "c'est bon". J'avais essayé en long en large en travers avec ma xfce fraichement installé sur mon netboot et sa ne fonctionnais pas. Donc la avec une ubuntu du premier coup sans rien faire, sans editer le fichier audio.conf sa fonctionne!!!

Bon courage

@++

Hors ligne

#16 Le 15/02/2014, à 11:08

berserk_14

Re : Problème de connexion à haut parleur bluetooth

bonjour j'ai refait l'essai sur xfce: pour appairer sur xfce j'ai viré blueman je n'ai rien modifié dans /etc/bluetooth/audio.conf. Par contre j'ai appairé avec sudo gnome-control-center .  et la sa apparait dans les gestionnaire de son

bon courage

Hors ligne

#17 Le 16/02/2014, à 20:23

gaboum

Re : Problème de connexion à haut parleur bluetooth

Bonjour,
J'ai le même problème...
Le fait de mettre Enable=Socket dans /etc/bluetooth/audio.conf permet la connexion avec mon enceinte. (bien que sur certains forum, ils conseillent de mettre Disable=Socket, chez moi ca ne marche pas). C'est déjà un grand pas. Blueman connecte le stream a2dp sink sans problèmes.

Maintenant, il semble que PulseAudio n'est pas informé de l'existence de l'enceinte. C'est rageant et pour l'instant je ne trouve pas de solutions.
Voici le syslog lorsque je connecte mon enceinte:

$
Feb 16 20:21:08 mamachine pulseaudio[5121]: [pulseaudio] module-bluetooth-device.c: 00:0C:8A:A3:5E:34 is not known.

Feb 16 20:21:08 mamachine pulseaudio[5121]: [pulseaudio] module.c: Failed to load module "module-bluetooth-device" (argument: "address=00:0C:8A:A3:5E:34 profile=a2dp"): initialization failed.

Des idées?

Hors ligne

#18 Le 03/04/2014, à 21:30

Dr Strangelove

Re : Problème de connexion à haut parleur bluetooth

Bonsoir,
J'ai le même problème: pas de son avec mes enceintes! Quelqu'un a t-il la solution sous XFCE avant de migrer sous Gnome qui semble mieux gérer le bluetooth?


XFCE 12.04LTS

Hors ligne

#19 Le 03/04/2014, à 21:57

agensbur

Re : Problème de connexion à haut parleur bluetooth

Par contre j'ai appairé avec sudo gnome-control-center .

Je reteste donc avec ma clef. Mais idem. Pas de pb pour appairé, mais j'ai toujours pu appairé.
Par contre à faire du coté du gestionnaire de son : pas communique par avec pulse audio malgré la librairie censée faire cela.


Dell Inspirion 620 - Intel(R) Core(TM) i5- 3.00GHz - 6 Go mémoire - Xubuntu 14.04-64 bits
NetBook Samsung NC -10 - Lubuntu 14.04-32 bits

Hors ligne

#20 Le 03/04/2014, à 22:02

Dr Strangelove

Re : Problème de connexion à haut parleur bluetooth

agensbur a écrit :

Par contre à faire du coté du gestionnaire de son : pas communique par avec pulse audio malgré la librairie censée faire cela.

Quelle librairie pour avoir le son?

Dernière modification par Dr Strangelove (Le 03/04/2014, à 22:02)


XFCE 12.04LTS

Hors ligne

#21 Le 03/04/2014, à 22:49

agensbur

Re : Problème de connexion à haut parleur bluetooth

Quelle librairie pour avoir le son?

En théorie celle-ci pulseaudio-module-bluetooth, mais c'est ce qui ne fonctionne pas, du moins chez moi.

Ci-après un long rapport de ce bug donc apparemment confirmé sous ubuntu (pas vraiment sûr qu'xfce soit le fautif)
https://bugs.launchpad.net/ubuntu/+sour … ug/1181106

La médecine préconisée (corrections sur le fichier audio.conf référencées dans le rapport) ne fonctionne pas chez moi (situation aussi référencé en 13.10). Donc pour moi toujours rien coté des gestionnaires de son, ni pavucontrol - ni via controleur de son de gnome ).

Cela semble contradictoire avec ce qu'ont expérimenté certains et demeure confus.

Dernière modification par agensbur (Le 04/04/2014, à 08:20)


Dell Inspirion 620 - Intel(R) Core(TM) i5- 3.00GHz - 6 Go mémoire - Xubuntu 14.04-64 bits
NetBook Samsung NC -10 - Lubuntu 14.04-32 bits

Hors ligne

#22 Le 04/04/2014, à 00:01

Dr Strangelove

Re : Problème de connexion à haut parleur bluetooth

agensbur a écrit :

Ci-après un long rapport de ce bug donc apparemment confirmé sous ubuntu (pas vraiment sûr qu'xfce soit le fautif)
https://bugs.launchpad.net/ubuntu/+sour … ug/1181106

J'ai réussi à avoir le son de mes enceintes en installant le paquet gnome-bluetooth (car le transfert de fichier du pc vers mon smartphone n'était pas possible avec blueman) en utilisant ce rapport de bug puis en déclarant le bon périphérique de sortie dans pavucontrol.

Mais il manque encore le son du navigateur (youtube ou autre)! Quelqu'un a t-il une solution?


XFCE 12.04LTS

Hors ligne

#23 Le 04/04/2014, à 08:24

agensbur

Re : Problème de connexion à haut parleur bluetooth

J'ai réussi à avoir le son de mes enceintes

A lire le rapport je pense que tu auras intérêt à ne pas quitter trop tôt ta 12.04.


Dell Inspirion 620 - Intel(R) Core(TM) i5- 3.00GHz - 6 Go mémoire - Xubuntu 14.04-64 bits
NetBook Samsung NC -10 - Lubuntu 14.04-32 bits

Hors ligne

#24 Le 04/04/2014, à 23:50

Dr Strangelove

Re : Problème de connexion à haut parleur bluetooth

Pour avoir le son avec mon firefox, il m'a fallu rediriger vers mes enceintes la sortie audio de gnome mplayer qui gère le son du navigateur. Il faut aussi le faire pour d'autres applications comme vlc. Tout est ok pour mon bluetooth.

Dernière modification par Dr Strangelove (Le 04/04/2014, à 23:51)


XFCE 12.04LTS

Hors ligne

#25 Le 01/05/2014, à 19:12

aquassarim

Re : Problème de connexion à haut parleur bluetooth

Bonjour à tous,

j'ai rencontré des problèmes similaires aux vôtres pour connecter un récepteur audio bluetooth à ma Xubuntu 14.04. Après avoir beaucoup galéré et lu beaucoup de post, j'ai finalement trouvé une solution qui j'espère, pourra vous aider. Je précise que je ne sais absolument pas pourquoi ça marche !

Voici les différentes étapes :
1. sudo nano /etc/bluetooth/audio.conf
    vérifier que les lignes suivantes sont présentes et non commentées (pour le reste, laisser tel quel) :
        [General]
        Enable=Socket
        [Headset]
        HFP=true
        [A2DP]
        SBCSources=1
        MPEG12Sources=0
     sauvegarder et quitter : Ctrl O puis Ctrl X

2. sudo nano ~/.asoundrc
     y écrire les lignes suivantes :
pcm.btheadset {
    type bluetooth
    device XX:XX:XX:XX:XX:XX
    profile "auto"
}
    sauvegarder et quitter : Ctrl O puis Ctrl X
    (XX:XX:XX:XX:XX:XX est l'adresse MAC du périphérique bluetooth que vous voulez connecter et qui peut être obtenue en lançant une recherche avec blueman-applet)

3. sudo service bluetooth restart (en ayant désactivé le bluetooth préalablement : clique droit sur blueman-applet dans la zone de notification et Désactiver Bluetooth)

4. utiliser blueman-applet pour connecter le périphérique bluetooth (le même dans la zone de notification)
    ajouter, appairer, connecter à Audio Sink

5. dans un terminal, taper :
    pulseaudio -k
    (dans mon cas, c'est cette ligne qui a débloqué la situation en permettant d'exécuter avec succès les deux lignes suivantes)
6. pactl load-module module-alsa-sink device=btheadset
7. pactl load-module module-alsa-source device=btheadset (pas indispensable)
    (vous devriez obtenir des nombres après chacune de ces deux dernières commandes)

8. Ouvrir le contrôle du volume (pavucontrol) :
  - dans l'onglet Configuration : éteindre toutes les sorties audio « classiques »
  - dans l'onglet Périphériques de sortie, vous devriez voir apparaître : btheadset

Il ne reste plus qu'à essayer avec votre logiciel préféré.

Par contre, j'ai peur qu'il ne faille faire les manips 5, 6, 7 et 8 à chaque fois...

Dernière modification par aquassarim (Le 01/05/2014, à 19:13)

Hors ligne

Haut de page ↑