Contenu | Rechercher | Menus

Annonce

Ubuntu 16.04 LTS
Commandez vos DVD et clés USB Ubuntu-fr !

Appel à contributeurs. Réunion pour la refonte du wiki lundi 26 juin

Si vous avez des soucis pour rester connecté, déconnectez-vous puis reconnectez-vous depuis ce lien en cochant la case
Me connecter automatiquement lors de mes prochaines visites.

#1 Le 12/07/2013, à 23:07

pistache

[resolu] Problème de connexion à haut parleur bluetooth

Bonjour.

Je n'arrive pas à me connecter à des haut-parleur bluetooth.

Matériel :
clef bluetooth trendnet tbw-170ub  : fonctionne : j'arrive par exemple à naviguer dans le système de fichier de mon téléphone portable, et la clef autodétecte bien le haut parleur bluetooth.

le haut parleur bluetooth fonctionne bien : par exemple j'arrive à m'y connecter avec mon téléphone gsm et y faire jouer des mp3.

au niveau logiciel, je lance l'autodétection du matériel, le haut parleur est détecté, j'indique à l'utilitaire graphique comme type de choix d'utilisation : "A2DP sink (send audio)"

j'ai pour erreur :

"périphérique ajouté, mais échec de la connexion" /  stream setup failed.

Je suis usager "basique" , je ne sais pas aller au delà pour le diagnostic et la résolution du problème.

Merci d'avance pour votre aide.

Dernière modification par pistache (Le 05/03/2015, à 17:09)

Hors ligne

#2 Le 13/07/2013, à 03:18

MicP

Re : [resolu] Problème de connexion à haut parleur bluetooth

Bonjour

pistache a écrit :

... le haut parleur est détecté, j'indique à l'utilitaire graphique comme type de choix d'utilisation : "A2DP sink (send audio)" ...

Je me demande s'il ne faudrait pas choisir "A2DP Source" plutôt que "Sink", étant donné qu'il s'agit d'envoyer un flux audio vers un récepteur.
Ce devrait être facile à tester

Dernière modification par MicP (Le 13/07/2013, à 03:21)

Hors ligne

#3 Le 13/07/2013, à 09:07

pistache

Re : [resolu] Problème de connexion à haut parleur bluetooth

Merci, mais je n'ai que cette option (sink), ou bien "ne pas connecter".

Hors ligne

#4 Le 07/12/2013, à 16:37

manup31

Re : [resolu] Problème de connexion à haut parleur bluetooth

C'est à peu de chose près le même problème que celui que j'exposais récemment.
On parvient à appairer les hauts-parleurs avec le PC, mais pas à les connecter par a2dp.

De mon côté j'ai deux configurations, l'une avec un dongle BT qui ne fonctionne pas, l'autre avec un BT intégré dans un portable HP qui fonctionne : oui, le son sort sur les HP via BT et sans devoir modifier quelque fichier que ce soit, ni créer de .asoundrc ! Exactement comme à partir d'un GSM (android ou pas).

J'ai déjà passé quelques heures à tenter de diagnostiquer le dysfonctionnement avec 2 dongle BT différents, notamment avec hcidump qui permet de tracer le dialogue entre le PC et les hauts-parleurs, mais c'est assez touffu et sans l'appui d'un "expert" qui pointerait où il faut regarder ça va prendre du temps, pour pas forcément trouver... hmm
Car il y a plusieurs niveau de BT, par exemple, et peut-être que les dongles utilisés ne sont simplement pas compatibles avec les hauts-parleurs...

Or il ne semble pas qu'il y ait de poilus bluetooth ici, ou ils ne lisent pas ces posts...

Côté AskUbuntu, on trouve les mêmes questions mais guère de réponse fonctionnelle, je n'y ai rien trouvé d'efficace, à part les outils. Idem sur les forums d'autres distros (fedora, ...).

Il doit plutôt falloir ouvrir un bug sur launchpad et/ou voir du côté de forums logitech (les hauts-parleurs que j'essaie de faire fonctionner sont de cette marque) ou autres.

Ces problèmes ne sont pas spécifiques à Linux, beaucoup ont les mêmes sous windows.


manu'

Hors ligne

#5 Le 07/12/2013, à 17:13

pistache

Re : [resolu] Problème de connexion à haut parleur bluetooth

Bonjour

Merci pour ce complément d'information. Pour ma part, je n'ai aussi toujours pas trouvé de solution, ce qui est fort dommage, malgré des tests avec divers dongles BT.

Hors ligne

#6 Le 19/01/2014, à 17:37

Tiachofe

Re : [resolu] Problème de connexion à haut parleur bluetooth

Bonjour,

je connais le même problème que celui décrit dans le premier post. Je fouille sur internet en vain. Avez-vous pu trouver une solution?

Merci

Hors ligne

#7 Le 19/01/2014, à 18:32

manup31

Re : [resolu] Problème de connexion à haut parleur bluetooth

Pas de mon côté...


manu'

Hors ligne

#8 Le 19/01/2014, à 18:58

ft84-19

Re : [resolu] Problème de connexion à haut parleur bluetooth

Bonjour,

J'ai eu les mêmes problèmes que j'ai résolus en désinstallant blueman et en n'utilisant que l'outil de base. J'utilise un dongle belkin et un adaptateur Logitech sur mon ampli, et j'avais réussi à apairer, mais avec toujours le message que la connexion échouait.

J'espère que ça pourra être aussi simple pour vous.

François

Hors ligne

#9 Le 19/01/2014, à 20:16

pistache

Re : [resolu] Problème de connexion à haut parleur bluetooth

Bonsoir,

et en n'utilisant que l'outil de base

Quel est le nom de cet outil? Merci !

Hors ligne

#10 Le 19/01/2014, à 23:31

Tiachofe

Re : [resolu] Problème de connexion à haut parleur bluetooth

ça a un peu évolué de mon côté. Je parviens maintenant à connecter l'adaptateur logitech bluetooth avec le gestionnaire de périphérique blueman. Par contre, si la communication entre le pc et l'équipement bluetooth semble OK, le son continue de sortir sur les haut parleur du pc et ne switche pas sur l'appareil bluetooth...

pour connecter l'appareil et ne plus avoir le "stream setup failed":

- ouvrir en écriture le fichier suivant avec la commande:
sudo leafpad /etc/bluetooth/audio.conf

- modifier et sauvegarder le fichier avec:
[General]
Enable=Socket

- redémarrer le pc ou lancer la commande suivante:
sudo service bluetooth restart

- après appairage, le matériel audio bluetooth se connecte au PC.


Maintenant, il ne reste plus qu'à envoyer le son par le bluetooth!

P.S: pour info, je suis sur lubuntu

Hors ligne

#11 Le 05/02/2014, à 22:26

Tiachofe

Re : [resolu] Problème de connexion à haut parleur bluetooth

bonjour,

quelqu'un peut-il m'aider à balancer le son?

merci

Hors ligne

#12 Le 09/02/2014, à 21:42

berserk_14

Re : [resolu] Problème de connexion à haut parleur bluetooth

bonjour j'en suis au meme point!!! j'ai retourné internet et j'ai pas trouvé de solution!!

A l'aide

Hors ligne

#13 Le 10/02/2014, à 11:35

agensbur

Re : [resolu] Problème de connexion à haut parleur bluetooth

Pour ma part, je n'ai aussi toujours pas trouvé de solution, ce qui est fort dommage, malgré des tests avec divers dongles BT.

Même constat de mon coté.
Sur une machine avec bluetooth intégré cela  fonctionne, par contre les essais de dongle bluetooth sur plusieurs machines, je n'ai jusqu'ici pas trouver de solutions pour l'audio même via des dongle claironnant une compatibilité linux.
Pour moi l'audio et bluetooth sous linux c'est encore la loterie et la jungle.

Dernière modification par agensbur (Le 10/02/2014, à 11:36)


Dell Inspirion 620 - Intel(R) Core(TM) i5- 3.00GHz - 6 Go mémoire - Xubuntu 14.04-64 bits
NetBook Samsung NC -10 - Lubuntu 14.04-32 bits

Hors ligne

#14 Le 12/02/2014, à 23:27

berserk_14

Re : [resolu] Problème de connexion à haut parleur bluetooth

bonsoir
alors moi j'essai sur un netbook avec bluetooth integré et ya rien a faire, j'arrive a appairer mais dans le controleur de volume je ne vois rien concernant le bluetooth.

bon courage

Hors ligne

#15 Le 14/02/2014, à 18:07

berserk_14

Re : [resolu] Problème de connexion à haut parleur bluetooth

bonjour, alors pour moi "c'est bon". J'avais essayé en long en large en travers avec ma xfce fraichement installé sur mon netboot et sa ne fonctionnais pas. Donc la avec une ubuntu du premier coup sans rien faire, sans editer le fichier audio.conf sa fonctionne!!!

Bon courage

@++

Hors ligne

#16 Le 15/02/2014, à 12:08

berserk_14

Re : [resolu] Problème de connexion à haut parleur bluetooth

bonjour j'ai refait l'essai sur xfce: pour appairer sur xfce j'ai viré blueman je n'ai rien modifié dans /etc/bluetooth/audio.conf. Par contre j'ai appairé avec sudo gnome-control-center .  et la sa apparait dans les gestionnaire de son

bon courage

Hors ligne

#17 Le 16/02/2014, à 21:23

gaboum

Re : [resolu] Problème de connexion à haut parleur bluetooth

Bonjour,
J'ai le même problème...
Le fait de mettre Enable=Socket dans /etc/bluetooth/audio.conf permet la connexion avec mon enceinte. (bien que sur certains forum, ils conseillent de mettre Disable=Socket, chez moi ca ne marche pas). C'est déjà un grand pas. Blueman connecte le stream a2dp sink sans problèmes.

Maintenant, il semble que PulseAudio n'est pas informé de l'existence de l'enceinte. C'est rageant et pour l'instant je ne trouve pas de solutions.
Voici le syslog lorsque je connecte mon enceinte:

$
Feb 16 20:21:08 mamachine pulseaudio[5121]: [pulseaudio] module-bluetooth-device.c: 00:0C:8A:A3:5E:34 is not known.

Feb 16 20:21:08 mamachine pulseaudio[5121]: [pulseaudio] module.c: Failed to load module "module-bluetooth-device" (argument: "address=00:0C:8A:A3:5E:34 profile=a2dp"): initialization failed.

Des idées?

Hors ligne

#18 Le 03/04/2014, à 22:57

agensbur

Re : [resolu] Problème de connexion à haut parleur bluetooth

Par contre j'ai appairé avec sudo gnome-control-center .

Je reteste donc avec ma clef. Mais idem. Pas de pb pour appairé, mais j'ai toujours pu appairé.
Par contre à faire du coté du gestionnaire de son : pas communique par avec pulse audio malgré la librairie censée faire cela.


Dell Inspirion 620 - Intel(R) Core(TM) i5- 3.00GHz - 6 Go mémoire - Xubuntu 14.04-64 bits
NetBook Samsung NC -10 - Lubuntu 14.04-32 bits

Hors ligne

#19 Le 03/04/2014, à 23:49

agensbur

Re : [resolu] Problème de connexion à haut parleur bluetooth

Quelle librairie pour avoir le son?

En théorie celle-ci pulseaudio-module-bluetooth, mais c'est ce qui ne fonctionne pas, du moins chez moi.

Ci-après un long rapport de ce bug donc apparemment confirmé sous ubuntu (pas vraiment sûr qu'xfce soit le fautif)
https://bugs.launchpad.net/ubuntu/+sour … ug/1181106

La médecine préconisée (corrections sur le fichier audio.conf référencées dans le rapport) ne fonctionne pas chez moi (situation aussi référencé en 13.10). Donc pour moi toujours rien coté des gestionnaires de son, ni pavucontrol - ni via controleur de son de gnome ).

Cela semble contradictoire avec ce qu'ont expérimenté certains et demeure confus.

Dernière modification par agensbur (Le 04/04/2014, à 09:20)


Dell Inspirion 620 - Intel(R) Core(TM) i5- 3.00GHz - 6 Go mémoire - Xubuntu 14.04-64 bits
NetBook Samsung NC -10 - Lubuntu 14.04-32 bits

Hors ligne

#20 Le 04/04/2014, à 09:24

agensbur

Re : [resolu] Problème de connexion à haut parleur bluetooth

J'ai réussi à avoir le son de mes enceintes

A lire le rapport je pense que tu auras intérêt à ne pas quitter trop tôt ta 12.04.


Dell Inspirion 620 - Intel(R) Core(TM) i5- 3.00GHz - 6 Go mémoire - Xubuntu 14.04-64 bits
NetBook Samsung NC -10 - Lubuntu 14.04-32 bits

Hors ligne

#21 Le 01/05/2014, à 20:12

aquassarim

Re : [resolu] Problème de connexion à haut parleur bluetooth

Bonjour à tous,

j'ai rencontré des problèmes similaires aux vôtres pour connecter un récepteur audio bluetooth à ma Xubuntu 14.04. Après avoir beaucoup galéré et lu beaucoup de post, j'ai finalement trouvé une solution qui j'espère, pourra vous aider. Je précise que je ne sais absolument pas pourquoi ça marche !

Voici les différentes étapes :
1. sudo nano /etc/bluetooth/audio.conf
    vérifier que les lignes suivantes sont présentes et non commentées (pour le reste, laisser tel quel) :
        [General]
        Enable=Socket
        [Headset]
        HFP=true
        [A2DP]
        SBCSources=1
        MPEG12Sources=0
     sauvegarder et quitter : Ctrl O puis Ctrl X

2. sudo nano ~/.asoundrc
     y écrire les lignes suivantes :
pcm.btheadset {
    type bluetooth
    device XX:XX:XX:XX:XX:XX
    profile "auto"
}
    sauvegarder et quitter : Ctrl O puis Ctrl X
    (XX:XX:XX:XX:XX:XX est l'adresse MAC du périphérique bluetooth que vous voulez connecter et qui peut être obtenue en lançant une recherche avec blueman-applet)

3. sudo service bluetooth restart (en ayant désactivé le bluetooth préalablement : clique droit sur blueman-applet dans la zone de notification et Désactiver Bluetooth)

4. utiliser blueman-applet pour connecter le périphérique bluetooth (le même dans la zone de notification)
    ajouter, appairer, connecter à Audio Sink

5. dans un terminal, taper :
    pulseaudio -k
    (dans mon cas, c'est cette ligne qui a débloqué la situation en permettant d'exécuter avec succès les deux lignes suivantes)
6. pactl load-module module-alsa-sink device=btheadset
7. pactl load-module module-alsa-source device=btheadset (pas indispensable)
    (vous devriez obtenir des nombres après chacune de ces deux dernières commandes)

8. Ouvrir le contrôle du volume (pavucontrol) :
  - dans l'onglet Configuration : éteindre toutes les sorties audio « classiques »
  - dans l'onglet Périphériques de sortie, vous devriez voir apparaître : btheadset

Il ne reste plus qu'à essayer avec votre logiciel préféré.

Par contre, j'ai peur qu'il ne faille faire les manips 5, 6, 7 et 8 à chaque fois...

Dernière modification par aquassarim (Le 01/05/2014, à 20:13)

Hors ligne

#22 Le 01/05/2014, à 20:37

agensbur

Re : [resolu] Problème de connexion à haut parleur bluetooth

j'ai rencontré des problèmes similaires aux vôtres pour connecter un récepteur audio bluetooth à ma Xubuntu 14.04. Après avoir beaucoup galéré et lu beaucoup de post, j'ai finalement trouvé une solution qui j'espère, pourra vous aider. Je précise que je ne sais absolument pas pourquoi ça marche !

Je suis arrivé à quelque chose de semblable en 14.04 alors que je coinçais sur les distirb précédentes.
Même solution sur audio conf. Puis relancer après coup pluseaudio.
La réserve est que je trouve la solution fragile (obligation de reset sur pulse-audio à chaque changement de sortie sur pavu control - parfois redémarage sans pulse-audio)
A vous de voir si un tel fonctionnement est acceptable : de mon coté ça eut marché mais ce n'est pas ça

Dernière modification par agensbur (Le 01/05/2014, à 22:40)


Dell Inspirion 620 - Intel(R) Core(TM) i5- 3.00GHz - 6 Go mémoire - Xubuntu 14.04-64 bits
NetBook Samsung NC -10 - Lubuntu 14.04-32 bits

Hors ligne

#23 Le 02/05/2014, à 14:49

aquassarim

Re : [resolu] Problème de connexion à haut parleur bluetooth

Bonjour agensbur,

je suis bien d'accord avec toi, c'est vraiment du bricolage. Après je t'avoue que quand j'ai entendu le son sortir des enceintes j'étais quand même bien content !

Depuis j'ai installé le paquet : padevchooser (je pense que pour que cela fonctionne il faut le fichier .asoundrc).
Avec ça, une fois lancée ton application, tu peux ouvrir pavucontrol et choisir ton périphérique de sortie.
Ça t'évite d'avoir à faire :
    pulseaudio -k
    pactl load-module module-alse-sink device=btheadset

Voili

Hors ligne

#24 Le 31/08/2014, à 14:17

agensbur

Re : [resolu] Problème de connexion à haut parleur bluetooth

Mon problème de communication bluetooth - pulseaudio s'est réglé au fil des mise à jour de noyaux
(j'en suis au 3.13.0-35, mais cela fait deux ou trois mises à jour de noyau que tout fonctionne correctement et sans bidouille particulière)

Dernière modification par agensbur (Le 31/08/2014, à 14:19)


Dell Inspirion 620 - Intel(R) Core(TM) i5- 3.00GHz - 6 Go mémoire - Xubuntu 14.04-64 bits
NetBook Samsung NC -10 - Lubuntu 14.04-32 bits

Hors ligne

#25 Le 24/10/2014, à 20:59

MKlown

Re : [resolu] Problème de connexion à haut parleur bluetooth

Si ça peut aider, et puisque je me suis appuyé sur ce post :
Sur une Trusty server à jour en date du post, paquets minimum au départ (pas de son, pas de GUI, le moins possible (en fait je partirais bien sur Arch si les dépots étaient aussi cools que sur Ubuntu, et je suis du genre à vouloir tout tout de suite sans rien faire...)), en ayant installé blueman et pulseaudio j'ai suivi ceci :

Activation du bluetooth dans /etc/init #NDR j'avais désactivé pour gratter 1sec au boot avant d'avoir l'enceinte

/etc/init/rc.local

rfkill ublock all #NDR ajout en fin de fichier, connecteurs soft bloqués par défaut ou pas, là je suis sûr que pas

/etc/bluetooth/audio.conf

[General]
        Enable=Source,Sink,Headset,Gateway,Control,Socket,Media #NDR socket semble suffisant
[Headset]
        HFP=true
        AutoConnect=true #NDR J'avais envie que ça démarre tout seul sans que je fasse des manips à chaque fois
[A2DP]
        SBCSources=1
        MPEG12Sources=0

/etc/asound.conf #NDR mieux que ~/.asoundrc à mon sens puisque je veux utiliser l'enceinte quelque soit la session

pcm.btheadset {
    type bluetooth
    device XX:XX:XX:XX:XX:XX #NDR l'adresse MAC de l'enceinte
    profile "auto"
}
   
/etc/pulse/default.pa

#NDR Je voulais que ça démarre auto donc... la jolie ligne piqué un post plus haut, je l'ai rajoutée ici, et je ne redémarre pas pulseaudio, pas besoin

#set-default-sink output
load-module module-alsa-sink device=btheadset

#################################################################

Et maintenant tout marche en auto
Truc magique ça marche aussi sans plus de config dans XBMC sur session session utilisateur (compte applicatif) dédiée. En fait le BT est managé en session non root pour tous les utilisateurs (je savais pas, c'est la première fois que j'utilise) (Et ça veut dire quoi, qu'il y a une conf partagée en lecture écriture pour tout le monde ou que bluemen tourne en root quoi qu'il arrive  ??? Si quelqu'un sait répondre je prend, sinon je vais creuser...). J'ai lu que pas mal galéraient avec le BT et XBMC...
Enfin, et pour la frime, je viens de récup un Brix i5 + un ssd 500Go et 8go de ram. Le tout tient dans la main. il est connecté en wifi au routeur, en wifi à la petite enceinte soundlink mini, presque plus de fils, encombrement extrêmement réduit... Et le tout piloté par le téléphone (XBMC Remote) Ca a un MAF (Myself Acceptance Factor) de dingue smile

Bon, en espérant que ce post fera plaisir à quelqu'un.
(pour répondre à quelqu'un plus haut, je comprends pourquoi des gens utilisent Windows, Linux, ou encore les produits Apple, c'est parce qu'ils sont cools).

Dernière modification par MKlown (Le 24/10/2014, à 21:29)

Hors ligne