Contenu | Rechercher | Menus

Annonce

Si vous rencontrez des soucis à rester connecté sur le forum (ou si vous avez perdu votre mot de passe) déconnectez-vous et reconnectez-vous depuis cette page, en cochant la case "Me connecter automatiquement lors de mes prochaines visites". Attention, le forum rencontre actuellement quelques difficultés. En cas d'erreur 502, il ne faut pas re-valider l'envoi d'un message ou l'ouverture d'une discussion, au risque de créer un doublon.

La section divers se réorganise ! De nouvelles sous-sections à venir. (plus d'infos + donner son avis)

#1 Le 22/07/2013, à 16:50

RoKN

Wake on lan / conserver paramétrage.

Bonjour !

Voilà, j'ai un soucis avec mon serveur sous Debian.

J'ai bien suivi la doc Wake on Lan, mais lorsque je veux conserver le paramétrage en éditant le fichier /etc/rc.local, au redémarrage rien à faire, j'obtiens toujours :

Wake-on: d

Mon fichier /etc/rc.local :

#!/bin/sh -e
#
# rc.local
#
# This script is executed at the end of each multiuser runlevel.
# Make sure that the script will "exit 0" on success or any other
# value on error.
#
# In order to enable or disable this script just change the execution
# bits.
#
# By default this script does nothing.

ethtool -s eth1 wol g
exit 0

J'ai même écrit un script dans le /etc/init.d, la même chose mais nommé "wakeonlan.sh", mais rien à faire non plus, à chaque redémarrage le Wol est toujours "d", et je ne comprends pas pourquoi.
Ah oui, et j'ai bien autorisé l'exécution des scripts.

Comment cela se fait-il ?

Merci d'avance ! big_smile

Dernière modification par RoKN (Le 23/07/2013, à 14:32)

Hors ligne

Haut de page ↑