Contenu | Rechercher | Menus

Annonce

Si vous rencontrez des soucis à rester connecté sur le forum (ou si vous avez perdu votre mot de passe) déconnectez-vous et reconnectez-vous depuis cette page, en cochant la case "Me connecter automatiquement lors de mes prochaines visites".

#1 Le 21/12/2004, à 23:32

w0arz

[Resolu]xmms et gdesklets

xmms refuse de marcher depuis que je suis passé en hoary de plus gdesklets fait des siennes maintenant en refusant de faire tourner son daemon, à en devenir chèvre.

Hors ligne

#2 Le 22/12/2004, à 09:43

EricDele

Re : [Resolu]xmms et gdesklets

Oui, pareil.

Xmms me sort une segmentation fault

Gdesklets nous gratifie d'un problème qui à mon avis est du au fait que le python a changé de version entre warty et hoary, il me sort un truc du genre gnome.vfs depreacated et que je ferai mieux d'utiliser gnomevfs à la place.
Il semble que ça vienne de python-gtk2 ou un truc comme ça qui reste désespérément dans les packages qui ne seront pas mis à jour lorsque je fais un apt-get upgrade.

Hors ligne

#3 Le 22/12/2004, à 21:50

EricDele

Re : [Resolu]xmms et gdesklets

Bno et bien je viens de remettre à jour et là, les gdesklets-data ont carrément été désinstallées, car le python est le 2.4 et il faut une version < 2.4 pour que ça fonctionne, sniff j'aimais bien mes desklets, visiblement il y a d'autres personnes dans le même cas :

http://gnomesupport.org/forums/viewtopic.php?t=7900

il va surrement falloir attendre la nouvelle version du gdesklets-data, c'est un sacré boulot, il faut que les dèv se retappent tous les display à reconfigurer...

Hors ligne

#4 Le 23/12/2004, à 19:41

EricDele

Re : [Resolu]xmms et gdesklets

Il semblerai que ça se passe mieux ce soir après mise à jour de python2.4 et gdesklets 0.32.

Mais, car il y a un mais, les display ne fonctionnent toujours pas, ils réclament gtkhtml2, qui n'est pas fournit sur ubuntu !!!

gdesklets-data est bien installé ce soir, par rapport à hier où il refusait de s'installer à cause de python qui était en 2.4.

Hors ligne

#5 Le 23/12/2004, à 19:49

EricDele

Re : [Resolu]xmms et gdesklets

Bno je viens de trouver, il faut installer python2.4-gnome2-extras qui est maintenu par notre Sebastien Bacher national, un grand merci à lui wink

Mais il y a toujours un truc qui marche pas, pour le starter bar Gnome il me manque ce module là : GConfWatcher

Il est visiblement dans gnome-python2-gconf que je ne trouve pas sur ubuntu....

Voici le message :

raceback (most recent call last):
  File "/usr/share/gdesklets/factory/SensorFactory.py", line 60, in create_sensor
    module = __import__(name)
  File "/usr/share/gdesklets/Sensors/StarterBar/__init__.py", line 2, in ?
    from IconSet import IconSet
  File "/usr/share/gdesklets/Sensors/StarterBar/IconSet.py", line 9, in ?
    from utils import GConfWatcher
ImportError: cannot import name GConfWatcher

Dernière modification par EricDele (Le 23/12/2004, à 21:56)

Hors ligne

#6 Le 25/12/2004, à 10:04

thx1138

Re : [Resolu]xmms et gdesklets

J'ai le même problème avec d'autres "displays" : il ne peut pas importer les modules, ce qui est bizarre puisque les modules sont là et sont corrects. Je ne pense cependant pas que ce soit dû à Python 2.4 car j'ai aussi le problème avec ma Debian/Sid où Python en est toujours à la version 2.3

Edit : j'investigue.

Dernière modification par thx1138 (Le 25/12/2004, à 10:04)


They did not know it was impossible, so they did it - Mark Twain

Hors ligne

#7 Le 25/12/2004, à 21:20

EricDele

Re : [Resolu]xmms et gdesklets

Bon, en fait la starterbar je suis allé la downloader dans une version plus récente directement sur gdesklets.gnomedesktop.org et après installation, elle fonctionne.

il me semble que la version 31 ou 32 de gdesklets a apporté de grosses modifications sur la gestion des sensors/display, ce qui donne que certains displays qui sont dans la gdesklets-data, ne sont pas encore mis à jour ou plus supporté ( comme Good Weather forecast ) et donc ne peuvent fonctionner correctement :'(

investiguons, investiguons ... smile

Hors ligne

Haut de page ↑