Contenu | Rechercher | Menus

Annonce

Ubuntu 16.04 LTS
Commandez vos DVD et clés USB Ubuntu-fr !

Pour en savoir un peu plus sur l'équipe du forum.

Si vous avez des soucis pour rester connecté, déconnectez-vous puis reconnectez-vous depuis ce lien en cochant la case
Me connecter automatiquement lors de mes prochaines visites.

#1 Le 09/01/2008, à 10:46

korekorp

Gusty et ZendCore ...

Bonjour,
J'ai récemment installé ubuntu gusty en version desktop. J'ai ensuite rajouté apache, php5 et rajouté l'extension oci8. Tout fonctionnait très bien mis à  part que je ne pouvais pas executer un fichier php depuis la console car il ne pouvait pas charger dynamiquement la librairie oci8.
Je n'ai pas insisté, désinstallé proprement apache, php et oci puis tenté une installation de la ZendCore.
Le tout étant regroupé, je pensais que c'était la meilleure des solutions. Que néni ! Le serveur apache se lance sans aucune erreure apparente mais impossible d'y accéder depuis l'extérieur. J'ai pourtant bien modifié le fichier de configuration d'apache.
J'ai regardé les forums de Zend et j'ai trouvé http://www.zend.com/forums/index.php?t= … b77c0461a4 cette erreure.

Je cite :

/usr/local/Zend/apache2/bin/httpd: symbol lookup error: /lib/libnss_compat.so.2: undefined symbol: sysconf, version GLIBC_2.0.

About this error in the last weeks (i can't find a solution) I install ZEND complete new.

ZEND told me im using a non compatible Vesion of GLIBC.
I use now Gutsy Gibbon Ubuntu 7.10.
Bevor with Ubuntu 7.04 (Feisty Fawn) it works fine over month.

ainsi que :

n my experience, the libdb2.so is very strict with the version of the glibc it is compatible with.
I can suggest two things that might solve your problem:
1. Go back to the previous Ubuntu version.
or
2. Search IBM site for fix pack for ubuntu for their DB2 run-time client.

Que faire pour faire fonctionner le tout ? Est-il possible de downgrader ma version d'ubuntu ou juste de glibc (même si je ne pense pas que celà  puisse être possible).

Des infos ? Des solutions ?
Merci de m'aider smile


korekorp on Feisty Fawn with Sony VAIO FE31M
blog : http://www.bumble.fr

Hors ligne

#2 Le 09/01/2008, à 11:23

korekorp

Re : Gusty et ZendCore ...

Voulant en finir avec cette histoire, je suis entrain de compiler apache, php avec oci. En espérant que ça fonctionnera ...
Je pourrai fournir un paquet .deb si certaine personne sont dans le besoin.
Je vous tiens au courant !

Dernière modification par korekorp (Le 09/01/2008, à 11:24)


korekorp on Feisty Fawn with Sony VAIO FE31M
blog : http://www.bumble.fr

Hors ligne

#3 Le 09/01/2008, à 12:51

korekorp

Re : Gusty et ZendCore ...

Le serveur se lance ... c'est plutôt sympa. Maintenant il réagit vraiment bizarrement. Un simple session_start()  et il ne veut plus afficher une page php, et pour la connexion au serveur oracle, c'est vraiment pas gagné. Entendre par là ça ne fonctionne pas, mais il reconnait bien les fonctions oci c'est déjà ça.

J'ai essayé de réinstaller un serveur apache de base avec les paquets apt. Résultat ? Il ne me re-cré plus le dossier /etc/apache2 avec tous les fichiers de configuration. Il n'y a donc aucun moyen de l'executer. De mieux en mieux !

Si vous avez des remarques, suggestions, n'hésitez pas ...


korekorp on Feisty Fawn with Sony VAIO FE31M
blog : http://www.bumble.fr

Hors ligne