Contenu | Rechercher | Menus

Annonce

Si vous rencontrez des soucis à rester connecté sur le forum (ou si vous avez perdu votre mot de passe) déconnectez-vous et reconnectez-vous depuis cette page, en cochant la case "Me connecter automatiquement lors de mes prochaines visites". Attention, le forum rencontre actuellement quelques difficultés. En cas d'erreur 502, il ne faut pas re-valider l'envoi d'un message ou l'ouverture d'une discussion, au risque de créer un doublon.

La section divers se réorganise ! De nouvelles sous-sections à venir. (plus d'infos + donner son avis)

#76 Le 18/07/2013, à 13:01

Silvio66

Re : [QGis 1.8] Lire ECW sous Ubuntu 12.10

kikislater a écrit :

Autant pour moi !

sudo apt-get install libgdal-dev

Ça donne:

Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances       
Lecture des informations d'état... Fait
libgdal-dev est déjà la plus récente version disponible.
Les paquets suivants ont été installés automatiquement et ne sont plus nécessaires :
  qgis-plugin-grass-common libvncserver0 qgis-plugin-globe-common libgsoap1
Veuillez utiliser « apt-get autoremove » pour les supprimer.
0 mis à jour, 0 nouvellement installés, 0 à enlever et 0 non mis à jour.

Silvio
Xubuntu 14.04 sur TERRA mobile 1562P Pro (qui marche encore à pétrole...) 32 bit et avec la RAM qui rame.

Hors ligne

#77 Le 18/07/2013, à 16:08

kikislater

Re : [QGis 1.8] Lire ECW sous Ubuntu 12.10

ok ok faut passer à la suite :

sudo rm -rf /usr/lib/gdalplugins/1.8

Si tu n'as pas déjà fait puis :

sudo gdal-ecw-build /usr

Dernière modification par kikislater (Le 18/07/2013, à 16:09)

Hors ligne

#78 Le 19/07/2013, à 09:26

Silvio66

Re : [QGis 1.8] Lire ECW sous Ubuntu 12.10

kikislater a écrit :

ok ok faut passer à la suite :

sudo rm -rf /usr/lib/gdalplugins/1.8

Si tu n'as pas déjà fait puis :

sudo gdal-ecw-build /usr

Avec

sudo rm -rf /usr/lib/gdalplugins/1.8

Ça ne donne rien...

Et avec:

sudo gdal-ecw-build /usr

ça donne:

missing source /usr/src/libgdal-ecw-1.9.0.tar.gz

Silvio
Xubuntu 14.04 sur TERRA mobile 1562P Pro (qui marche encore à pétrole...) 32 bit et avec la RAM qui rame.

Hors ligne

#79 Le 19/07/2013, à 09:49

kikislater

Re : [QGis 1.8] Lire ECW sous Ubuntu 12.10

Silvio66 a écrit :
kikislater a écrit :

ok ok faut passer à la suite :

sudo rm -rf /usr/lib/gdalplugins/1.8

Si tu n'as pas déjà fait puis :

sudo gdal-ecw-build /usr

Avec

sudo rm -rf /usr/lib/gdalplugins/1.8

Ça ne donne rien...

Et avec:

sudo gdal-ecw-build /usr

ça donne:

missing source /usr/src/libgdal-ecw-1.9.0.tar.gz

On patine là mais bon j'ai une petite idée !
Redonne moi le résultat de ça :

ls /usr/lib/gdalplugins

puis de

ls /usr/src/

En attendant cette réponse on va faire la procédure à la main :

export VERSION=1.10.0
export PLUGINDIR=/usr/lib/gdalplugins/1.10
export TARBALL=/usr/src/libgdal-ecw-$VERSION.tar.gz
export BUILDDIR=`mktemp -d /tmp/gdal-ecw-build.temp`
tar xzf $TARBALL -C $BUILDDIR
cd $BUILDDIR/libgdal-ecw-$VERSION
sh ./configure --with-ecw=/usr --with-autoload=$PLUGINDIR
make
sudo make install
sudo chown root:root $PLUGINDIR/gdal_ECW_JP2ECW.so
sudo chmod 0644 $PLUGINDIR/gdal_ECW_JP2ECW.so
sudo rm -rf $BUILDDIR

Hors ligne

#80 Le 19/07/2013, à 10:01

Silvio66

Re : [QGis 1.8] Lire ECW sous Ubuntu 12.10

ls /usr/lib/gdalplugins

ça ne donne rien.

ls /usr/src/

ça donne:

libgdal-ecw-1.10.0.tar.gz           linux-headers-3.2.0-39-generic
linux-headers-2.6.32-33             linux-headers-3.2.0-39-generic-pae
linux-headers-2.6.32-33-generic     linux-headers-3.2.0-40
linux-headers-3.2.0-24              linux-headers-3.2.0-40-generic
linux-headers-3.2.0-24-generic      linux-headers-3.2.0-40-generic-pae
linux-headers-3.2.0-24-generic-pae  linux-headers-3.2.0-41
linux-headers-3.2.0-25              linux-headers-3.2.0-41-generic
linux-headers-3.2.0-25-generic      linux-headers-3.2.0-41-generic-pae
linux-headers-3.2.0-26              linux-headers-3.2.0-42
linux-headers-3.2.0-26-generic      linux-headers-3.2.0-42-generic
linux-headers-3.2.0-29              linux-headers-3.2.0-42-generic-pae
linux-headers-3.2.0-29-generic      linux-headers-3.2.0-43
linux-headers-3.2.0-30              linux-headers-3.2.0-43-generic
linux-headers-3.2.0-30-generic      linux-headers-3.2.0-43-generic-pae
linux-headers-3.2.0-31              linux-headers-3.2.0-44
linux-headers-3.2.0-31-generic      linux-headers-3.2.0-44-generic
linux-headers-3.2.0-32              linux-headers-3.2.0-44-generic-pae
linux-headers-3.2.0-32-generic      linux-headers-3.2.0-45
linux-headers-3.2.0-33              linux-headers-3.2.0-45-generic
linux-headers-3.2.0-33-generic      linux-headers-3.2.0-45-generic-pae
linux-headers-3.2.0-34              linux-headers-3.2.0-47
linux-headers-3.2.0-34-generic      linux-headers-3.2.0-47-generic
linux-headers-3.2.0-35              linux-headers-3.2.0-47-generic-pae
linux-headers-3.2.0-35-generic      linux-headers-3.2.0-48
linux-headers-3.2.0-36              linux-headers-3.2.0-48-generic
linux-headers-3.2.0-36-generic      linux-headers-3.2.0-48-generic-pae
linux-headers-3.2.0-36-generic-pae  linux-headers-3.2.0-49
linux-headers-3.2.0-37              linux-headers-3.2.0-49-generic
linux-headers-3.2.0-37-generic      linux-headers-3.2.0-49-generic-pae
linux-headers-3.2.0-37-generic-pae  linux-headers-3.2.0-50
linux-headers-3.2.0-38              linux-headers-3.2.0-50-generic
linux-headers-3.2.0-38-generic      linux-headers-3.2.0-50-generic-pae
linux-headers-3.2.0-38-generic-pae  vhba-20120422
linux-headers-3.2.0-39

Au sujet de la procédure à la main tout se passe bien jusqu'à:

export BUILDDIR=`mktemp -d /tmp/gdal-ecw-build.temp`

Qu'il renvoi:

mktemp: trop peu de X dans le modèle «/tmp/gdal-ecw-build.temp»

Silvio
Xubuntu 14.04 sur TERRA mobile 1562P Pro (qui marche encore à pétrole...) 32 bit et avec la RAM qui rame.

Hors ligne

#81 Le 19/07/2013, à 10:07

kikislater

Re : [QGis 1.8] Lire ECW sous Ubuntu 12.10

Ok pardon !


export VERSION=1.10.0
export PLUGINDIR=/usr/lib/gdalplugins/1.10
export TARBALL=/usr/src/libgdal-ecw-$VERSION.tar.gz
export BUILDDIR=`mktemp -d /tmp/gdal-ecw-build.XXXXXX`
tar xzf $TARBALL -C $BUILDDIR
cd $BUILDDIR/libgdal-ecw-$VERSION
sh ./configure --with-ecw=/usr --with-autoload=$PLUGINDIR
make
sudo make install
sudo chown root:root $PLUGINDIR/gdal_ECW_JP2ECW.so
sudo chmod 0644 $PLUGINDIR/gdal_ECW_JP2ECW.so
sudo rm -rf $BUILDDIR

Dernière modification par kikislater (Le 19/07/2013, à 10:08)

Hors ligne

#82 Le 19/07/2013, à 10:19

Silvio66

Re : [QGis 1.8] Lire ECW sous Ubuntu 12.10

kikislater a écrit :

Ok pardon !


export VERSION=1.10.0
export PLUGINDIR=/usr/lib/gdalplugins/1.10
export TARBALL=/usr/src/libgdal-ecw-$VERSION.tar.gz
export BUILDDIR=`mktemp -d /tmp/gdal-ecw-build.XXXXXX`
tar xzf $TARBALL -C $BUILDDIR
cd $BUILDDIR/libgdal-ecw-$VERSION
sh ./configure --with-ecw=/usr --with-autoload=$PLUGINDIR
make
sudo make install
sudo chown root:root $PLUGINDIR/gdal_ECW_JP2ECW.so
sudo chmod 0644 $PLUGINDIR/gdal_ECW_JP2ECW.so
sudo rm -rf $BUILDDIR

Voilà le résultats:

silvio@silvio-TWH:~$ export VERSION=1.10.0
silvio@silvio-TWH:~$ export PLUGINDIR=/usr/lib/gdalplugins/1.10
silvio@silvio-TWH:~$ export TARBALL=/usr/src/libgdal-ecw-$VERSION.tar.gz
silvio@silvio-TWH:~$ export BUILDDIR=`mktemp -d /tmp/gdal-ecw-build.XXXXXX`
silvio@silvio-TWH:~$ tar xzf $TARBALL -C $BUILDDIR
silvio@silvio-TWH:~$ cd $BUILDDIR/libgdal-ecw-$VERSION
silvio@silvio-TWH:/tmp/gdal-ecw-build.sUfF3S/libgdal-ecw-1.10.0$ 
silvio@silvio-TWH:/tmp/gdal-ecw-build.sUfF3S/libgdal-ecw-1.10.0$ sh ./configure --with-ecw=/usr --with-autoload=$PLUGINDIR
checking for gcc... gcc
checking for C compiler default output file name... a.out
checking whether the C compiler works... yes
checking whether we are cross compiling... no
checking for suffix of executables... 
checking for suffix of object files... o
checking whether we are using the GNU C compiler... yes
checking whether gcc accepts -g... yes
checking for gcc option to accept ISO C89... none needed
checking for g++... g++
checking whether we are using the GNU C++ compiler... yes
checking whether g++ accepts -g... yes
checking for ranlib... ranlib
checking for g++ -shared ... yes
checking for gdal-config... /usr/bin/gdal-config
using /usr/lib/gdalplugins/1.10 as GDAL shared library autoload directory
checking for libNCSEcw.so or libecwj2... found in /usr/lib.
checking for NCSECWClient.h in /usr/include... found.
configure: creating ./config.status
config.status: creating Makefile
silvio@silvio-TWH:/tmp/gdal-ecw-build.sUfF3S/libgdal-ecw-1.10.0$ make
g++ -DFRMT_ecw -Wall -I/usr/include -fPIC  -DFRMT_ecw -I/usr/include/gdal -I/usr/include   -c -o ecwcreatecopy.o ecwcreatecopy.cpp
ecwcreatecopy.cpp: In member function ‘virtual CNCSError GDALECWCompressor::WriteReadLine(UINT32, void**)’:
ecwcreatecopy.cpp:222:16: attention : deprecated conversion from string constant to ‘char*’ [-Wwrite-strings]
ecwcreatecopy.cpp:224:16: attention : deprecated conversion from string constant to ‘char*’ [-Wwrite-strings]
ecwcreatecopy.cpp: In member function ‘CPLErr GDALECWCompressor::Initialize(const char*, char**, int, int, int, const char* const*, int, GDALDataType, const char*, double*, int, const GDAL_GCP*, int)’:
ecwcreatecopy.cpp:1012:15: attention : deprecated conversion from string constant to ‘char*’ [-Wwrite-strings]
ecwcreatecopy.cpp:1019:62: attention : deprecated conversion from string constant to ‘char*’ [-Wwrite-strings]
ecwcreatecopy.cpp: In function ‘GDALDataset* ECWCreateCopy(const char*, GDALDataset*, int, char**, GDALProgressFunc, void*, int)’:
ecwcreatecopy.cpp:1168:15: attention : deprecated conversion from string constant to ‘char*’ [-Wwrite-strings]
ecwcreatecopy.cpp: In member function ‘CPLErr ECWWriteDataset::Crystalize()’:
ecwcreatecopy.cpp:1706:15: attention : deprecated conversion from string constant to ‘char*’ [-Wwrite-strings]
g++ -DFRMT_ecw -Wall -I/usr/include -fPIC  -DFRMT_ecw -I/usr/include/gdal -I/usr/include   -c -o ecwdataset.o ecwdataset.cpp
ecwdataset.cpp: In member function ‘CPLErr ECWRasterBand::OldIRasterIO(GDALRWFlag, int, int, int, int, void*, int, int, GDALDataType, int, int)’:
ecwdataset.cpp:715:15: attention : deprecated conversion from string constant to ‘char*’ [-Wwrite-strings]
ecwdataset.cpp: In member function ‘virtual CPLErr ECWDataset::AdviseRead(int, int, int, int, int, int, GDALDataType, int, int*, char**)’:
ecwdataset.cpp:1501:15: attention : deprecated conversion from string constant to ‘char*’ [-Wwrite-strings]
ecwdataset.cpp: In member function ‘virtual CPLErr ECWDataset::IRasterIO(GDALRWFlag, int, int, int, int, void*, int, int, GDALDataType, int, int*, int, int, int)’:
ecwdataset.cpp:1894:18: attention : deprecated conversion from string constant to ‘char*’ [-Wwrite-strings]
ecwdataset.cpp: In static member function ‘static CNCSJP2FileView* ECWDataset::OpenFileView(const char*, bool, int&, bool)’:
ecwdataset.cpp:2221:22: attention : deprecated conversion from string constant to ‘char*’ [-Wwrite-strings]
ecwdataset.cpp: In function ‘int ECWTranslateFromWKT(const char*, char*, int, char*, int, char*)’:
ecwdataset.cpp:2860:19: attention : deprecated conversion from string constant to ‘char*’ [-Wwrite-strings]
g++ -DFRMT_ecw -Wall -I/usr/include -fPIC  -DFRMT_ecw -I/usr/include/gdal -I/usr/include   -c -o jp2userbox.o jp2userbox.cpp
jp2userbox.cpp: In member function ‘virtual CNCSError JP2UserBox::Parse(CNCSJP2File&, CNCSJPCIOStream&)’:
jp2userbox.cpp:104:23: attention : deprecated conversion from string constant to ‘char*’ [-Wwrite-strings]
jp2userbox.cpp: In member function ‘virtual CNCSError JP2UserBox::UnParse(CNCSJP2File&, CNCSJPCIOStream&)’:
jp2userbox.cpp:123:23: attention : deprecated conversion from string constant to ‘char*’ [-Wwrite-strings]
jp2userbox.cpp:127:17: attention : deprecated conversion from string constant to ‘char*’ [-Wwrite-strings]
g++ -shared  ecwcreatecopy.o ecwdataset.o jp2userbox.o -L/usr/lib -lNCSEcw -lNCSCnet -lNCSUtil -L/usr/lib -lgdal  -o gdal_ECW_JP2ECW.so
silvio@silvio-TWH:/tmp/gdal-ecw-build.sUfF3S/libgdal-ecw-1.10.0$ sudo make install
[sudo] password for silvio: 
install -d /usr/lib/gdalplugins/1.10
cp gdal_ECW_JP2ECW.so /usr/lib/gdalplugins/1.10
silvio@silvio-TWH:/tmp/gdal-ecw-build.sUfF3S/libgdal-ecw-1.10.0$ sudo chown root:root $PLUGINDIR/gdal_ECW_JP2ECW.so
silvio@silvio-TWH:/tmp/gdal-ecw-build.sUfF3S/libgdal-ecw-1.10.0$ sudo chmod 0644 $PLUGINDIR/gdal_ECW_JP2ECW.so
silvio@silvio-TWH:/tmp/gdal-ecw-build.sUfF3S/libgdal-ecw-1.10.0$ sudo rm -rf $BUILDDIR

Après j'ouvre QGIS et... ça marche!!!!

UN GRAND ENORME MERCI!!!

[EDIT]

Mon gestionnaire de MAJ me propose:

Modifications pour les versions :
Version installée : 1.10.0-1~precise2
Version disponible : 1.10.0-1~precise3

sur le paquet:

http://ppa.launchpad.net/ubuntugis/ubuntugis-unstable/ubuntu

C'est le même qu'il m'as fait tout deconner la semaine dernière... donc je me garde bien de le mettre à jour...

Dernière modification par Silvio66 (Le 19/07/2013, à 10:24)


Silvio
Xubuntu 14.04 sur TERRA mobile 1562P Pro (qui marche encore à pétrole...) 32 bit et avec la RAM qui rame.

Hors ligne

#83 Le 19/07/2013, à 10:29

kikislater

Re : [QGis 1.8] Lire ECW sous Ubuntu 12.10

Silvio66 a écrit :
kikislater a écrit :

Ok pardon !


export VERSION=1.10.0
export PLUGINDIR=/usr/lib/gdalplugins/1.10
export TARBALL=/usr/src/libgdal-ecw-$VERSION.tar.gz
export BUILDDIR=`mktemp -d /tmp/gdal-ecw-build.XXXXXX`
tar xzf $TARBALL -C $BUILDDIR
cd $BUILDDIR/libgdal-ecw-$VERSION
sh ./configure --with-ecw=/usr --with-autoload=$PLUGINDIR
make
sudo make install
sudo chown root:root $PLUGINDIR/gdal_ECW_JP2ECW.so
sudo chmod 0644 $PLUGINDIR/gdal_ECW_JP2ECW.so
sudo rm -rf $BUILDDIR

Voilà le résultats:

silvio@silvio-TWH:~$ export VERSION=1.10.0
silvio@silvio-TWH:~$ export PLUGINDIR=/usr/lib/gdalplugins/1.10
silvio@silvio-TWH:~$ export TARBALL=/usr/src/libgdal-ecw-$VERSION.tar.gz
silvio@silvio-TWH:~$ export BUILDDIR=`mktemp -d /tmp/gdal-ecw-build.XXXXXX`
silvio@silvio-TWH:~$ tar xzf $TARBALL -C $BUILDDIR
silvio@silvio-TWH:~$ cd $BUILDDIR/libgdal-ecw-$VERSION
silvio@silvio-TWH:/tmp/gdal-ecw-build.sUfF3S/libgdal-ecw-1.10.0$ 
silvio@silvio-TWH:/tmp/gdal-ecw-build.sUfF3S/libgdal-ecw-1.10.0$ sh ./configure --with-ecw=/usr --with-autoload=$PLUGINDIR
checking for gcc... gcc
checking for C compiler default output file name... a.out
checking whether the C compiler works... yes
checking whether we are cross compiling... no
checking for suffix of executables... 
checking for suffix of object files... o
checking whether we are using the GNU C compiler... yes
checking whether gcc accepts -g... yes
checking for gcc option to accept ISO C89... none needed
checking for g++... g++
checking whether we are using the GNU C++ compiler... yes
checking whether g++ accepts -g... yes
checking for ranlib... ranlib
checking for g++ -shared ... yes
checking for gdal-config... /usr/bin/gdal-config
using /usr/lib/gdalplugins/1.10 as GDAL shared library autoload directory
checking for libNCSEcw.so or libecwj2... found in /usr/lib.
checking for NCSECWClient.h in /usr/include... found.
configure: creating ./config.status
config.status: creating Makefile
silvio@silvio-TWH:/tmp/gdal-ecw-build.sUfF3S/libgdal-ecw-1.10.0$ make
g++ -DFRMT_ecw -Wall -I/usr/include -fPIC  -DFRMT_ecw -I/usr/include/gdal -I/usr/include   -c -o ecwcreatecopy.o ecwcreatecopy.cpp
ecwcreatecopy.cpp: In member function ‘virtual CNCSError GDALECWCompressor::WriteReadLine(UINT32, void**)’:
ecwcreatecopy.cpp:222:16: attention : deprecated conversion from string constant to ‘char*’ [-Wwrite-strings]
ecwcreatecopy.cpp:224:16: attention : deprecated conversion from string constant to ‘char*’ [-Wwrite-strings]
ecwcreatecopy.cpp: In member function ‘CPLErr GDALECWCompressor::Initialize(const char*, char**, int, int, int, const char* const*, int, GDALDataType, const char*, double*, int, const GDAL_GCP*, int)’:
ecwcreatecopy.cpp:1012:15: attention : deprecated conversion from string constant to ‘char*’ [-Wwrite-strings]
ecwcreatecopy.cpp:1019:62: attention : deprecated conversion from string constant to ‘char*’ [-Wwrite-strings]
ecwcreatecopy.cpp: In function ‘GDALDataset* ECWCreateCopy(const char*, GDALDataset*, int, char**, GDALProgressFunc, void*, int)’:
ecwcreatecopy.cpp:1168:15: attention : deprecated conversion from string constant to ‘char*’ [-Wwrite-strings]
ecwcreatecopy.cpp: In member function ‘CPLErr ECWWriteDataset::Crystalize()’:
ecwcreatecopy.cpp:1706:15: attention : deprecated conversion from string constant to ‘char*’ [-Wwrite-strings]
g++ -DFRMT_ecw -Wall -I/usr/include -fPIC  -DFRMT_ecw -I/usr/include/gdal -I/usr/include   -c -o ecwdataset.o ecwdataset.cpp
ecwdataset.cpp: In member function ‘CPLErr ECWRasterBand::OldIRasterIO(GDALRWFlag, int, int, int, int, void*, int, int, GDALDataType, int, int)’:
ecwdataset.cpp:715:15: attention : deprecated conversion from string constant to ‘char*’ [-Wwrite-strings]
ecwdataset.cpp: In member function ‘virtual CPLErr ECWDataset::AdviseRead(int, int, int, int, int, int, GDALDataType, int, int*, char**)’:
ecwdataset.cpp:1501:15: attention : deprecated conversion from string constant to ‘char*’ [-Wwrite-strings]
ecwdataset.cpp: In member function ‘virtual CPLErr ECWDataset::IRasterIO(GDALRWFlag, int, int, int, int, void*, int, int, GDALDataType, int, int*, int, int, int)’:
ecwdataset.cpp:1894:18: attention : deprecated conversion from string constant to ‘char*’ [-Wwrite-strings]
ecwdataset.cpp: In static member function ‘static CNCSJP2FileView* ECWDataset::OpenFileView(const char*, bool, int&, bool)’:
ecwdataset.cpp:2221:22: attention : deprecated conversion from string constant to ‘char*’ [-Wwrite-strings]
ecwdataset.cpp: In function ‘int ECWTranslateFromWKT(const char*, char*, int, char*, int, char*)’:
ecwdataset.cpp:2860:19: attention : deprecated conversion from string constant to ‘char*’ [-Wwrite-strings]
g++ -DFRMT_ecw -Wall -I/usr/include -fPIC  -DFRMT_ecw -I/usr/include/gdal -I/usr/include   -c -o jp2userbox.o jp2userbox.cpp
jp2userbox.cpp: In member function ‘virtual CNCSError JP2UserBox::Parse(CNCSJP2File&, CNCSJPCIOStream&)’:
jp2userbox.cpp:104:23: attention : deprecated conversion from string constant to ‘char*’ [-Wwrite-strings]
jp2userbox.cpp: In member function ‘virtual CNCSError JP2UserBox::UnParse(CNCSJP2File&, CNCSJPCIOStream&)’:
jp2userbox.cpp:123:23: attention : deprecated conversion from string constant to ‘char*’ [-Wwrite-strings]
jp2userbox.cpp:127:17: attention : deprecated conversion from string constant to ‘char*’ [-Wwrite-strings]
g++ -shared  ecwcreatecopy.o ecwdataset.o jp2userbox.o -L/usr/lib -lNCSEcw -lNCSCnet -lNCSUtil -L/usr/lib -lgdal  -o gdal_ECW_JP2ECW.so
silvio@silvio-TWH:/tmp/gdal-ecw-build.sUfF3S/libgdal-ecw-1.10.0$ sudo make install
[sudo] password for silvio: 
install -d /usr/lib/gdalplugins/1.10
cp gdal_ECW_JP2ECW.so /usr/lib/gdalplugins/1.10
silvio@silvio-TWH:/tmp/gdal-ecw-build.sUfF3S/libgdal-ecw-1.10.0$ sudo chown root:root $PLUGINDIR/gdal_ECW_JP2ECW.so
silvio@silvio-TWH:/tmp/gdal-ecw-build.sUfF3S/libgdal-ecw-1.10.0$ sudo chmod 0644 $PLUGINDIR/gdal_ECW_JP2ECW.so
silvio@silvio-TWH:/tmp/gdal-ecw-build.sUfF3S/libgdal-ecw-1.10.0$ sudo rm -rf $BUILDDIR

Après j'ouvre QGIS et... ça marche!!!!

UN GRAND ENORME MERCI!!!

[EDIT]

Mon gestionnaire de MAJ me propose:

Modifications pour les versions :
Version installée : 1.10.0-1~precise2
Version disponible : 1.10.0-1~precise3

sur le paquet:

http://ppa.launchpad.net/ubuntugis/ubuntugis-unstable/ubuntu

C'est le même qu'il m'as fait tout deconner la semaine dernière... donc je me garde bien de le mettre à jour...

Non vas y mets à jour c'est ok. La lib est compilé pour la version de gdal. Tu avais la 1.9 et c'est lors du passage à la 1.10 que ça a foiré ... Là tu restes en 1.10 donc c'est ok pas de soucis !

Hors ligne

#84 Le 23/07/2013, à 09:25

Yomgui_LS

Re : [QGis 1.8] Lire ECW sous Ubuntu 12.10

Bonjour,
j'ai bien tout suivi, mais j'ai un problème probablement tout con.
A l'étape
sh ./configure --with-ecw=/usr --with-autoload=$PLUGINDIR
il y a tout une liste qui me semble pas trop mal, mais à un moment il y a

...
checking for ECWJP2BuildNumber.h in /usr/include... not found.
configure: creating ./config.status
config.status: creating GDALmake.opt
config.status: WARNING:  'GDALmake.opt.in' seems to ignore the --datarootdir setting
config.status: executing libtool commands
sed: can't read ./ltmain.sh: No such file or directory
sed: can't read libtoolT: No such file or directory
....

Je suis en ubuntu 12.04
j'ai essayé la methode classique, j'ai les mêmes 2 dernières lignes à un moment, lors du make install il me semble alors que le ltmain.sh est bien dans le répertoire courant.
Ca me semble plus être un problème de compilateur que de ecw, mais si vous avez des avis.

kikislater a écrit :

Ok pardon !


export VERSION=1.10.0
export PLUGINDIR=/usr/lib/gdalplugins/1.10
export TARBALL=/usr/src/libgdal-ecw-$VERSION.tar.gz
export BUILDDIR=`mktemp -d /tmp/gdal-ecw-build.XXXXXX`
tar xzf $TARBALL -C $BUILDDIR
cd $BUILDDIR/libgdal-ecw-$VERSION
sh ./configure --with-ecw=/usr --with-autoload=$PLUGINDIR
make
sudo make install
sudo chown root:root $PLUGINDIR/gdal_ECW_JP2ECW.so
sudo chmod 0644 $PLUGINDIR/gdal_ECW_JP2ECW.so
sudo rm -rf $BUILDDIR

Hors ligne

#85 Le 23/07/2013, à 14:32

kikislater

Re : [QGis 1.8] Lire ECW sous Ubuntu 12.10

Yomgui_LS a écrit :

Bonjour,
j'ai bien tout suivi, mais j'ai un problème probablement tout con.
A l'étape
sh ./configure --with-ecw=/usr --with-autoload=$PLUGINDIR
il y a tout une liste qui me semble pas trop mal, mais à un moment il y a

...
checking for ECWJP2BuildNumber.h in /usr/include... not found.
configure: creating ./config.status
config.status: creating GDALmake.opt
config.status: WARNING:  'GDALmake.opt.in' seems to ignore the --datarootdir setting
config.status: executing libtool commands
sed: can't read ./ltmain.sh: No such file or directory
sed: can't read libtoolT: No such file or directory
....

Je suis en ubuntu 12.04
j'ai essayé la methode classique, j'ai les mêmes 2 dernières lignes à un moment, lors du make install il me semble alors que le ltmain.sh est bien dans le répertoire courant.
Ca me semble plus être un problème de compilateur que de ecw, mais si vous avez des avis.

kikislater a écrit :

Ok pardon !


export VERSION=1.10.0
export PLUGINDIR=/usr/lib/gdalplugins/1.10
export TARBALL=/usr/src/libgdal-ecw-$VERSION.tar.gz
export BUILDDIR=`mktemp -d /tmp/gdal-ecw-build.XXXXXX`
tar xzf $TARBALL -C $BUILDDIR
cd $BUILDDIR/libgdal-ecw-$VERSION
sh ./configure --with-ecw=/usr --with-autoload=$PLUGINDIR
make
sudo make install
sudo chown root:root $PLUGINDIR/gdal_ECW_JP2ECW.so
sudo chmod 0644 $PLUGINDIR/gdal_ECW_JP2ECW.so
sudo rm -rf $BUILDDIR

Bonjour,

Que donne ?

sudo gdal-ecw-build /usr

Comment as-tu installé ou compilé la lib ecw ?

Hors ligne

#86 Le 24/07/2013, à 09:36

Yomgui_LS

Re : [QGis 1.8] Lire ECW sous Ubuntu 12.10

kikislater a écrit :

Bonjour,

Que donne ?

sudo gdal-ecw-build /usr

Bonjour,

c'est pas beau:

guillaume@guillaume-TECRA-A11:~$ sudo gdal-ecw-build /usr
Extracting GDAL/ECW tarball
Building GDAL/ECW plugin
checking build system type... i686-pc-linux-gnu
checking host system type... i686-pc-linux-gnu
checking for gcc... gcc
checking whether the C compiler works... yes
checking for C compiler default output file name... a.out
checking for suffix of executables... 
checking whether we are cross compiling... no
checking for suffix of object files... o
checking whether we are using the GNU C compiler... yes
checking whether gcc accepts -g... yes
checking for gcc option to accept ISO C89... none needed
checking C_WFLAGS for maximum warnings... -Wall -Wdeclaration-after-statement
checking for g++... g++
checking whether we are using the GNU C++ compiler... yes
checking whether g++ accepts -g... yes
checking CXX_WFLAGS for maximum warnings... -Wall
checking for gcc... (cached) gcc
checking whether we are using the GNU C compiler... (cached) yes
checking whether gcc accepts -g... (cached) yes
checking for gcc option to accept ISO C89... (cached) none needed
checking whether we are using the GNU C++ compiler... (cached) yes
checking whether g++ accepts -g... (cached) yes
checking how to print strings... printf
checking for a sed that does not truncate output... /bin/sed
checking for grep that handles long lines and -e... /bin/grep
checking for egrep... /bin/grep -E
checking for fgrep... /bin/grep -F
checking for ld used by gcc... /usr/bin/ld
checking if the linker (/usr/bin/ld) is GNU ld... yes
checking for BSD- or MS-compatible name lister (nm)... /usr/bin/nm -B
checking the name lister (/usr/bin/nm -B) interface... BSD nm
checking whether ln -s works... yes
checking the maximum length of command line arguments... 1572864
checking whether the shell understands some XSI constructs... yes
checking whether the shell understands "+="... yes
checking how to convert i686-pc-linux-gnu file names to i686-pc-linux-gnu format... func_convert_file_noop
checking how to convert i686-pc-linux-gnu file names to toolchain format... func_convert_file_noop
checking for /usr/bin/ld option to reload object files... -r
checking for objdump... objdump
checking how to recognize dependent libraries... pass_all
checking for dlltool... dlltool
checking how to associate runtime and link libraries... printf %s\n
checking for ar... ar
checking for archiver @FILE support... @
checking for strip... strip
checking for ranlib... ranlib
checking for gawk... gawk
checking command to parse /usr/bin/nm -B output from gcc object... ok
checking for sysroot... no
checking for mt... mt
checking if mt is a manifest tool... no
checking how to run the C preprocessor... gcc -E
checking for ANSI C header files... yes
checking for sys/types.h... yes
checking for sys/stat.h... yes
checking for stdlib.h... yes
checking for string.h... yes
checking for memory.h... yes
checking for strings.h... yes
checking for inttypes.h... yes
checking for stdint.h... yes
checking for unistd.h... yes
checking for dlfcn.h... yes
checking for objdir... .libs
checking if gcc supports -fno-rtti -fno-exceptions... no
checking for gcc option to produce PIC... -fPIC -DPIC
checking if gcc PIC flag -fPIC -DPIC works... yes
checking if gcc static flag -static works... yes
checking if gcc supports -c -o file.o... yes
checking if gcc supports -c -o file.o... (cached) yes
checking whether the gcc linker (/usr/bin/ld) supports shared libraries... yes
checking whether -lc should be explicitly linked in... no
checking dynamic linker characteristics... GNU/Linux ld.so
checking how to hardcode library paths into programs... immediate
checking whether stripping libraries is possible... yes
checking if libtool supports shared libraries... yes
checking whether to build shared libraries... yes
checking whether to build static libraries... yes
checking how to run the C++ preprocessor... g++ -E
checking for ld used by g++... /usr/bin/ld
checking if the linker (/usr/bin/ld) is GNU ld... yes
checking whether the g++ linker (/usr/bin/ld) supports shared libraries... yes
checking for g++ option to produce PIC... -fPIC -DPIC
checking if g++ PIC flag -fPIC -DPIC works... yes
checking if g++ static flag -static works... yes
checking if g++ supports -c -o file.o... yes
checking if g++ supports -c -o file.o... (cached) yes
checking whether the g++ linker (/usr/bin/ld) supports shared libraries... yes
checking dynamic linker characteristics... (cached) GNU/Linux ld.so
checking how to hardcode library paths into programs... immediate
checking for ranlib... (cached) ranlib
checking for g++ -shared ... yes
checking for dlopen in -ldl... yes
checking for nanosleep in -lrt... yes
checking for sin in -lm... yes
checking for ANSI C header files... (cached) yes
checking assert.h usability... yes
checking assert.h presence... yes
checking for assert.h... yes
checking fcntl.h usability... yes
checking fcntl.h presence... yes
checking for fcntl.h... yes
checking for unistd.h... (cached) yes
checking dbmalloc.h usability... no
checking dbmalloc.h presence... no
checking for dbmalloc.h... no
checking for dlfcn.h... (cached) yes
checking for stdint.h... (cached) yes
checking limits.h usability... yes
checking limits.h presence... yes
checking for limits.h... yes
checking locale.h usability... yes
checking locale.h presence... yes
checking for locale.h... yes
checking values.h usability... yes
checking values.h presence... yes
checking for values.h... yes
checking float.h usability... yes
checking float.h presence... yes
checking for float.h... yes
checking errno.h usability... yes
checking errno.h presence... yes
checking for errno.h... yes
checking direct.h usability... no
checking direct.h presence... no
checking for direct.h... no
checking whether byte ordering is bigendian... no
checking for 64bit integer type... long long
checking for 64bit file io... yes
checking for stat64... yes
checking for fopen64... yes
checking for ftruncate64... yes
checking size of int... 4
checking size of unsigned long... 4
checking size of void*... 4
checking for int8... no
checking for int16... no
checking for int32... no
checking native cpu bit order... lsb2msb
checking for vprintf... yes
checking for _doprnt... no
checking for snprintf... yes
checking for vsnprintf... yes
checking for atoll... yes
checking for strtof... yes
checking for getcwd... yes
checking whether strtof is declared... yes
checking for readlink... yes
checking for lstat... yes
checking for posix_spawnp... yes
checking for vfork... yes
checking for gmtime_r... yes
checking for localtime_r... yes
checking for setlocale... yes
checking whether GCC 4.1 atomic builtins are available... yes
checking for gdal-config... /usr/bin/gdal-config
using /usr/lib/gdalplugins/1.10 as GDAL shared library autoload directory
checking for libNCSEcw.so or libecwj2... found in /usr/lib.
checking for NCSECWClient.h in /usr/include... found.
checking for ECWJP2BuildNumber.h in /usr/include... not found.
configure: creating ./config.status
config.status: creating GDALmake.opt
config.status: WARNING:  'GDALmake.opt.in' seems to ignore the --datarootdir setting
config.status: executing libtool commands
sed: can't read ./ltmain.sh: No such file or directory
sed: can't read libtoolT: No such file or directory
g++ -g -O2 -fPIC  -Wall  -I/usr/include/gdal -DFRMT_ecw -I-I/usr/include/gdal  -I/usr/include  -c -o ecwdataset.o ecwdataset.cpp
ecwdataset.cpp: In member function ‘CPLErr ECWRasterBand::OldIRasterIO(GDALRWFlag, int, int, int, int, void*, int, int, GDALDataType, int, int)’:
ecwdataset.cpp:715:15: attention : deprecated conversion from string constant to ‘char*’ [-Wwrite-strings]
ecwdataset.cpp: In member function ‘virtual CPLErr ECWDataset::AdviseRead(int, int, int, int, int, int, GDALDataType, int, int*, char**)’:
ecwdataset.cpp:1501:15: attention : deprecated conversion from string constant to ‘char*’ [-Wwrite-strings]
ecwdataset.cpp: In member function ‘virtual CPLErr ECWDataset::IRasterIO(GDALRWFlag, int, int, int, int, void*, int, int, GDALDataType, int, int*, int, int, int)’:
ecwdataset.cpp:1894:18: attention : deprecated conversion from string constant to ‘char*’ [-Wwrite-strings]
ecwdataset.cpp: In static member function ‘static CNCSJP2FileView* ECWDataset::OpenFileView(const char*, bool, int&, bool)’:
ecwdataset.cpp:2221:22: attention : deprecated conversion from string constant to ‘char*’ [-Wwrite-strings]
ecwdataset.cpp: In function ‘int ECWTranslateFromWKT(const char*, char*, int, char*, int, char*)’:
ecwdataset.cpp:2860:19: attention : deprecated conversion from string constant to ‘char*’ [-Wwrite-strings]
g++ -g -O2 -fPIC  -Wall  -I/usr/include/gdal -DFRMT_ecw -I-I/usr/include/gdal  -I/usr/include  -c -o ecwcreatecopy.o ecwcreatecopy.cpp
ecwcreatecopy.cpp: In member function ‘virtual CNCSError GDALECWCompressor::WriteReadLine(UINT32, void**)’:
ecwcreatecopy.cpp:222:16: attention : deprecated conversion from string constant to ‘char*’ [-Wwrite-strings]
ecwcreatecopy.cpp:224:16: attention : deprecated conversion from string constant to ‘char*’ [-Wwrite-strings]
ecwcreatecopy.cpp: In member function ‘CPLErr GDALECWCompressor::Initialize(const char*, char**, int, int, int, const char* const*, int, GDALDataType, const char*, double*, int, const GDAL_GCP*, int)’:
ecwcreatecopy.cpp:1012:15: attention : deprecated conversion from string constant to ‘char*’ [-Wwrite-strings]
ecwcreatecopy.cpp:1019:62: attention : deprecated conversion from string constant to ‘char*’ [-Wwrite-strings]
ecwcreatecopy.cpp: In function ‘GDALDataset* ECWCreateCopy(const char*, GDALDataset*, int, char**, GDALProgressFunc, void*, int)’:
ecwcreatecopy.cpp:1168:15: attention : deprecated conversion from string constant to ‘char*’ [-Wwrite-strings]
ecwcreatecopy.cpp: In member function ‘CPLErr ECWWriteDataset::Crystalize()’:
ecwcreatecopy.cpp:1706:15: attention : deprecated conversion from string constant to ‘char*’ [-Wwrite-strings]
g++ -g -O2 -fPIC  -Wall  -I/usr/include/gdal -DFRMT_ecw -I-I/usr/include/gdal  -I/usr/include  -c -o jp2userbox.o jp2userbox.cpp
jp2userbox.cpp: In member function ‘virtual CNCSError JP2UserBox::Parse(CNCSJP2File&, CNCSJPCIOStream&)’:
jp2userbox.cpp:104:23: attention : deprecated conversion from string constant to ‘char*’ [-Wwrite-strings]
jp2userbox.cpp: In member function ‘virtual CNCSError JP2UserBox::UnParse(CNCSJP2File&, CNCSJPCIOStream&)’:
jp2userbox.cpp:123:23: attention : deprecated conversion from string constant to ‘char*’ [-Wwrite-strings]
jp2userbox.cpp:127:17: attention : deprecated conversion from string constant to ‘char*’ [-Wwrite-strings]
g++ -g -O2 -fPIC  -Wall  -I/usr/include/gdal -DFRMT_ecw -I-I/usr/include/gdal  -I/usr/include  -c -o ecwasyncreader.o ecwasyncreader.cpp
install -d /usr/lib/gdalplugins/1.10
cp gdal_ECW_JP2ECW.so /usr/lib/gdalplugins/1.10
cp: impossible d'évaluer «gdal_ECW_JP2ECW.so»: Aucun fichier ou dossier de ce type
make: *** [install] Erreur 1
kikislater a écrit :

Bonjour,
Comment as-tu installé ou compilé la lib ecw ?

??? je ne sais pas trop ce qu'il y a comme trace.
J'ai essayé la méthode cité là http://doc.ubuntu-fr.org/qgis
puis toutes celles de cette discussion,
J'ai même essayé http://gis.stackexchange.com/questions/ … untu-12-04
y compris avec le 5.0, mais avec x86 et non x64 comme cité.

Le tout toujours avec les compilations, jamais avec les .deb

J'ai bien le répertoire /usr/lib/gdalplugins/1.10, mais vide et libgdal-ecw-1.10.0.tar.gz  est dans le répertoire /usr/src

Par avance merci,

Hors ligne

#87 Le 24/07/2013, à 16:52

kikislater

Re : [QGis 1.8] Lire ECW sous Ubuntu 12.10

Yomgui_LS a écrit :

[

??? je ne sais pas trop ce qu'il y a comme trace.
J'ai essayé la méthode cité là http://doc.ubuntu-fr.org/qgis
puis toutes celles de cette discussion,
J'ai même essayé http://gis.stackexchange.com/questions/ … untu-12-04
y compris avec le 5.0, mais avec x86 et non x64 comme cité.

Le tout toujours avec les compilations, jamais avec les .deb

J'ai bien le répertoire /usr/lib/gdalplugins/1.10, mais vide et libgdal-ecw-1.10.0.tar.gz  est dans le répertoire /usr/src

Par avance merci,

Les deb ne sont plus fonctionnels, je les avais créé mais ils ne sont pas patchés ! Je les ai donc refait et patchés pour les plateforme x86 et amd64 et sont dispo ailleurs ... 
Si tu veux donc la version patchée, il faudrait que tu désinstalles ta précédente version via make uninstall si tu as compilé à la main.
Ensuite,
- soit tu peux ensuite recompiler à la main en t'aidant tu script dispo ici :
https://aur.archlinux.org/packages/libecwj2/?setlang=fr
https://aur.archlinux.org/packages/li/libecwj2/PKGBUILD
- soit tu utilises mon deb déjà compilé ici :
libecwj2-3.3-3_i386.deb

Une fois ces étapes réalisées, tu peux refaire
sudo gdal-ecw-build /usr

Hors ligne

#88 Le 24/07/2013, à 19:08

Yomgui_LS

Re : [QGis 1.8] Lire ECW sous Ubuntu 12.10

kikislater a écrit :

Les deb ne sont plus fonctionnels, je les avais créé mais ils ne sont pas patchés ! Je les ai donc refait et patchés pour les plateforme x86 et amd64 et sont dispo ailleurs ... 
Si tu veux donc la version patchée, il faudrait que tu désinstalles ta précédente version via make uninstall si tu as compilé à la main.
Ensuite,
- soit tu peux ensuite recompiler à la main en t'aidant tu script dispo ici :
https://aur.archlinux.org/packages/libecwj2/?setlang=fr
https://aur.archlinux.org/packages/li/libecwj2/PKGBUILD
- soit tu utilises mon deb déjà compilé ici :
libecwj2-3.3-3_i386.deb

Une fois ces étapes réalisées, tu peux refaire
sudo gdal-ecw-build /usr

Bonsoir,

Désolé, je bloque sur le make uninstall. J'ai du effacer un peu trop de répertoires temporaires hier et je vois que je ne maîtrise pas tellement ce genre de manips.

Je crois que je vais attendre que mon collègue me passe mon Ubuntu en 64b et repartir à neuf pour utiliser mes vielles cartes ecw.
Pour l'instant QGIS fonctionne suffisamment pour moi...
Je repasserai par là...

Hors ligne

#89 Le 18/08/2013, à 13:40

pichel

Re : [QGis 1.8] Lire ECW sous Ubuntu 12.10

Bonjour,
petit update du sujet pour mémoire.

Je viens d'installer qgis sur une Mint 15 (basée sur ubuntu 13.04 raring) en suivant les étapes suivantes :
ppa:ubuntugis/ubuntugis-unstable
le dépôt de rider du coin (release = precise !)
installé le paquet libgal-ecw-src depuis le ppa
installé les paquets ecw depuis le dépôt du riderducoin
suivi les instructions du post #37 :
     sudo gdal-ecw-build /usr
     sudo ldconfig
=> et tout remarche comme sous quantal !


Lorsque l'actualité vous entraîne à penser quelque chose, il faut résister à l'actualité.
Jean Prévost

Hors ligne

#90 Le 20/08/2013, à 09:14

kikislater

Re : [QGis 1.8] Lire ECW sous Ubuntu 12.10

pichel a écrit :

Bonjour,
petit update du sujet pour mémoire.

Je viens d'installer qgis sur une Mint 15 (basée sur ubuntu 13.04 raring) en suivant les étapes suivantes :
ppa:ubuntugis/ubuntugis-unstable
le dépôt de rider du coin (release = precise !)
installé le paquet libgal-ecw-src depuis le ppa
installé les paquets ecw depuis le dépôt du riderducoin
suivi les instructions du post #37 :
     sudo gdal-ecw-build /usr
     sudo ldconfig
=> et tout remarche comme sous quantal !

Merci du retour

Hors ligne

#91 Le 04/09/2013, à 16:43

symba

Re : [QGis 1.8] Lire ECW sous Ubuntu 12.10

Bonjour,
je me permets de remonter ce sujet car j'ai de nouveau un problème avec qgis.
Il n'est plus installé sur mon PC suite à une recharge/actualisation avec synaptic.
J'ai voulu le réinstallé mais j'ai un message m'indiquant que le paquet est cassé. Lorsque je fais "réparer le paquet cassé", j'ai un nouveau message d'erreur m'indiquant:

E: Impossible de corriger les problèmes, des paquets défectueux sont en mode « garder en l'état ».
E: Erreur, pkgProblem::Resolve a généré des ruptures, ce qui a pu être causé par les paquets devant être gardés en l'état.
E: Impossible de corriger les dépendances
E: Erreur, pkgProblem::Resolve a généré des ruptures, ce qui a pu être causé par les paquets devant être gardés en l'état.
E: Impossible de corriger les dépendances

J'ai essayé les méthodes précédentes sans succès sad

Hors ligne

#92 Le 04/09/2013, à 16:48

kikislater

Re : [QGis 1.8] Lire ECW sous Ubuntu 12.10

Que donne
sudo apt-get -f install

Hors ligne

#93 Le 05/09/2013, à 13:54

symba

Re : [QGis 1.8] Lire ECW sous Ubuntu 12.10

voilà le résultat:

Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances       
Lecture des informations d'état... Fait
0 mis à jour, 0 nouvellement installés, 0 à enlever et 4 non mis à jour.

Hors ligne

#94 Le 05/09/2013, à 15:12

kikislater

Re : [QGis 1.8] Lire ECW sous Ubuntu 12.10

Le résultat de ça stp

apt-cache policy gdal-bin
apt-cache policy gdal
apt-cache policy libgdal-ecw
apt-cache policy libgdal-ecw-src
ls /usr/lib/gdalplugins
ls /usr/src/

Hors ligne

#95 Le 05/09/2013, à 15:52

symba

Re : [QGis 1.8] Lire ECW sous Ubuntu 12.10

Voilà ce que ça donne:

symba@symbaPC:~$ apt-cache policy gdal-bin
gdal-bin:
  Installé : 1.10.0-1~raring1
  Candidat : 1.10.0-1~raring1
Table de version :
*** 1.10.0-1~raring1 0
        500 http://ppa.launchpad.net/ubuntugis/ubun … le/ubuntu/ raring/main amd64 Packages
        100 /var/lib/dpkg/status
     1.9.0-3.1ubuntu1 0
        500 http://fr.archive.ubuntu.com/ubuntu/ raring/universe amd64 Packages
symba@symbaPC:~$ apt-cache policy gdal
N: Impossible de trouver le paquet gdal
symba@symbaPC:~$ apt-cache policy libgdal-ecw
N: Impossible de trouver le paquet libgdal-ecw
symba@symbaPC:~$ apt-cache policy libgdal-ecw-src

Hors ligne

#96 Le 05/09/2013, à 15:55

symba

Re : [QGis 1.8] Lire ECW sous Ubuntu 12.10

Oups je viens de m'apercevoir que le dépôt riderducoin était décoché dans synaptic,
voilà ce que ça donne une fois rétabli:

symba@symbaPC:~$ symba@symbaPC:~$ apt-cache policy gdal-bin
symba@symbaPC:~$ : commande introuvable
symba@symbaPC:~$ gdal-bin:
gdal-bin: : commande introuvable
symba@symbaPC:~$   Installé : 1.10.0-1~raring1
Installé : : commande introuvable
symba@symbaPC:~$   Candidat : 1.10.0-1~raring1
Candidat : : commande introuvable
symba@symbaPC:~$  Table de version :
Table : commande introuvable
symba@symbaPC:~$  *** 1.10.0-1~raring1 0
Bureau : commande introuvable
symba@symbaPC:~$         500 http://ppa.launchpad.net/ubuntugis/ubun … le/ubuntu/ raring/main amd64 Packages
500 : commande introuvable
symba@symbaPC:~$         100 /var/lib/dpkg/status
100 : commande introuvable
symba@symbaPC:~$      1.9.0-3.1ubuntu1 0
1.9.0-3.1ubuntu1 : commande introuvable
symba@symbaPC:~$         500 http://fr.archive.ubuntu.com/ubuntu/ raring/universe amd64 Packages
500 : commande introuvable
symba@symbaPC:~$ symba@symbaPC:~$ apt-cache policy gdal
symba@symbaPC:~$ : commande introuvable
symba@symbaPC:~$ N: Impossible de trouver le paquet gdal
N: : commande introuvable
symba@symbaPC:~$ symba@symbaPC:~$ apt-cache policy libgdal-ecw
symba@symbaPC:~$ : commande introuvable
symba@symbaPC:~$ N: Impossible de trouver le paquet libgdal-ecw
N: : commande introuvable
symba@symbaPC:~$ symba@symbaPC:~$ apt-cache policy libgdal-ecw-src
symba@symbaPC:~$ : commande introuvable

Hors ligne

#97 Le 05/09/2013, à 16:22

kikislater

Re : [QGis 1.8] Lire ECW sous Ubuntu 12.10

symba a écrit :

Oups je viens de m'apercevoir que le dépôt riderducoin était décoché dans synaptic,
voilà ce que ça donne une fois rétabli:

symba@symbaPC:~$ symba@symbaPC:~$ apt-cache policy gdal-bin
symba@symbaPC:~$ : commande introuvable
symba@symbaPC:~$ gdal-bin:
gdal-bin: : commande introuvable
symba@symbaPC:~$   Installé : 1.10.0-1~raring1
Installé : : commande introuvable
symba@symbaPC:~$   Candidat : 1.10.0-1~raring1
Candidat : : commande introuvable
symba@symbaPC:~$  Table de version :
Table : commande introuvable
symba@symbaPC:~$  *** 1.10.0-1~raring1 0
Bureau : commande introuvable
symba@symbaPC:~$         500 http://ppa.launchpad.net/ubuntugis/ubun … le/ubuntu/ raring/main amd64 Packages
500 : commande introuvable
symba@symbaPC:~$         100 /var/lib/dpkg/status
100 : commande introuvable
symba@symbaPC:~$      1.9.0-3.1ubuntu1 0
1.9.0-3.1ubuntu1 : commande introuvable
symba@symbaPC:~$         500 http://fr.archive.ubuntu.com/ubuntu/ raring/universe amd64 Packages
500 : commande introuvable
symba@symbaPC:~$ symba@symbaPC:~$ apt-cache policy gdal
symba@symbaPC:~$ : commande introuvable
symba@symbaPC:~$ N: Impossible de trouver le paquet gdal
N: : commande introuvable
symba@symbaPC:~$ symba@symbaPC:~$ apt-cache policy libgdal-ecw
symba@symbaPC:~$ : commande introuvable
symba@symbaPC:~$ N: Impossible de trouver le paquet libgdal-ecw
N: : commande introuvable
symba@symbaPC:~$ symba@symbaPC:~$ apt-cache policy libgdal-ecw-src
symba@symbaPC:~$ : commande introuvable

Euh tu peut refaire parce que là visiblement tu ne tapes pas les bonnes commandes

Hors ligne

#98 Le 05/09/2013, à 16:59

symba

Re : [QGis 1.8] Lire ECW sous Ubuntu 12.10

ah en effet je mettais toutes les commandes en même temps...

Pour apt-cache policy gdal-bin:

gdal-bin:
  Installé : 1.10.0-1~raring1
  Candidat : 1.10.0-1~raring1
Table de version :
*** 1.10.0-1~raring1 0
        500 http://ppa.launchpad.net/ubuntugis/ubun … le/ubuntu/ raring/main amd64 Packages
        100 /var/lib/dpkg/status
     1.9.0-3.1ubuntu1 0
        500 http://fr.archive.ubuntu.com/ubuntu/ raring/universe amd64 Packages

Pour apt-cache policy gdal:

N: Impossible de trouver le paquet gdal

Pour apt-cache policy libgdal-ecw:

apt-cache policy libgdal-ecw

Pour apt-cache policy libgdal-ecw-src:

libgdal-ecw-src:
  Installé : 1.10.0-1~raring4
  Candidat : 1.10.0-1~raring4
Table de version :
*** 1.10.0-1~raring4 0
        500 http://ppa.launchpad.net/ubuntugis/ubun … le/ubuntu/ raring/main amd64 Packages
        100 /var/lib/dpkg/status

Pour ls /usr/lib/gdalplugins:

1.10

Enfin pour ls /usr/src/:

libgdal-ecw-1.10.0.tar.gz       linux-headers-3.8.0-27-generic
linux-headers-3.8.0-26          linux-headers-3.8.0-29
linux-headers-3.8.0-26-generic  linux-headers-3.8.0-29-generic
linux-headers-3.8.0-27

Avec tout en bleu sauf le premier "libgdal-ecw-1.10.0.tar.gz" qui est en rouge

Hors ligne

#99 Le 05/09/2013, à 17:02

kikislater

Re : [QGis 1.8] Lire ECW sous Ubuntu 12.10

symba a écrit :

ah en effet je mettais toutes les commandes en même temps...

Pour apt-cache policy gdal-bin:

gdal-bin:
  Installé : 1.10.0-1~raring1
  Candidat : 1.10.0-1~raring1
Table de version :
*** 1.10.0-1~raring1 0
        500 http://ppa.launchpad.net/ubuntugis/ubun … le/ubuntu/ raring/main amd64 Packages
        100 /var/lib/dpkg/status
     1.9.0-3.1ubuntu1 0
        500 http://fr.archive.ubuntu.com/ubuntu/ raring/universe amd64 Packages

Pour apt-cache policy gdal:

N: Impossible de trouver le paquet gdal

Pour apt-cache policy libgdal-ecw:

apt-cache policy libgdal-ecw

Pour apt-cache policy libgdal-ecw-src:

libgdal-ecw-src:
  Installé : 1.10.0-1~raring4
  Candidat : 1.10.0-1~raring4
Table de version :
*** 1.10.0-1~raring4 0
        500 http://ppa.launchpad.net/ubuntugis/ubun … le/ubuntu/ raring/main amd64 Packages
        100 /var/lib/dpkg/status

Pour ls /usr/lib/gdalplugins:

1.10

Enfin pour ls /usr/src/:

libgdal-ecw-1.10.0.tar.gz       linux-headers-3.8.0-27-generic
linux-headers-3.8.0-26          linux-headers-3.8.0-29
linux-headers-3.8.0-26-generic  linux-headers-3.8.0-29-generic
linux-headers-3.8.0-27

Avec tout en bleu sauf le premier "libgdal-ecw-1.10.0.tar.gz" qui est en rouge

ok c'est mieux, j'en ai oublié un :

apt-cache policy libecwj2

Hors ligne

#100 Le 06/09/2013, à 08:20

symba

Re : [QGis 1.8] Lire ECW sous Ubuntu 12.10

Voilà pour le dernier:

libecwj2:
  Installé : 3.3-3
  Candidat : 3.3-3
Table de version :
*** 3.3-3 0
        500 http://riderducoin.com/ubuntu1/ precise/main amd64 Packages
        100 /var/lib/dpkg/status

Hors ligne

Haut de page ↑