Contenu | Rechercher | Menus

Annonce

Si vous rencontrez des soucis à rester connecté sur le forum (ou si vous avez perdu votre mot de passe) déconnectez-vous et reconnectez-vous depuis cette page, en cochant la case "Me connecter automatiquement lors de mes prochaines visites".
Test de l'ISO d'Ubuntu francophone : nous avons besoin de testeurs pour la version francophone d'Ubuntu 14.04. Liens et informations ici.

#1 Le 29/08/2013, à 09:32

Clhiver

[RESOLU] Impossible d'activer wicd

Salut, J'ai installé l'environnement xfce4 avec ubuntu-server. J'ai choisi  d'essayer wicd au lieu de netmork-manager, notamment en raison du plus faible nombre de dépendances.
J'ai donc installé wicd, wicd-gtk et wicd-daemon.
Quand j'ai installé la distrib, je me suis contenté de remplir les champs essid et wpa.
Quand j'essaie d'activer wicd, j'obtiens successivement les messages d'erreur suivants :

Impossible de se connecter à l'interface D-Bus de wicd. Inspecter le journal pour obtenir les messages d'erreur.
Le démon wicd s'est éteint. L'interface graphique ne marchera pas tant que le démon n'est pas redémarré

Le problème est que, pour l'intant, je ne peux me connecter que sur le réseau crée lors de l'installation !

Si quelqu'un a une idee, je suis bien sû preneuse !

Dernière modification par Clhiver (Le 19/01/2014, à 20:36)


L'informatique ça marche, sauf quand ça ne marche pas !

Hors ligne

#2 Le 30/08/2013, à 11:28

ljere

Re : [RESOLU] Impossible d'activer wicd

vu que tu es dans le but d'avoir un systeme leger pourquoi tu passes par wicd configure simplement ton fichier

/etc/network/interfaces

Modérateur d'ubuntu-fr.org
athlon 2800+, nvidia FX5200 et 2 Go de ram et sempron 3000+, ati radeon et 1 Go de ram sur voyager 12.04 32 bit
Toshiba satellite_c670d-11l sur openbox/xubuntu 14.04 64 bit
Mon Blog et Une découverte

En ligne

#3 Le 01/09/2013, à 10:51

Clhiver

Re : [RESOLU] Impossible d'activer wicd

Salut,
J'y ai pensé un moment. Sauf que, par exepmle, j'aimerai bien visualiser les différents réseaux disponibles. Et j'aime bien les interfaces graphiques, même si j'utilise de plus en plus souvent la console.


L'informatique ça marche, sauf quand ça ne marche pas !

Hors ligne

#4 Le 03/09/2013, à 13:12

ljere

Re : [RESOLU] Impossible d'activer wicd

tu peux essayer cela j'ai mis ton pseudo pour l'exemple:

sudo adduser Clhiver netdev
sudo  /etc/init.d/dbus reload
sudo service wicd restart

attention pas de sudo pour cette commande

wicd-client -n

n'hésite pas à donner les retours si ça ne fonctionne pas


Modérateur d'ubuntu-fr.org
athlon 2800+, nvidia FX5200 et 2 Go de ram et sempron 3000+, ati radeon et 1 Go de ram sur voyager 12.04 32 bit
Toshiba satellite_c670d-11l sur openbox/xubuntu 14.04 64 bit
Mon Blog et Une découverte

En ligne

#5 Le 03/09/2013, à 14:13

Clhiver

Re : [RESOLU] Impossible d'activer wicd

Salut,
Ça bloque à la deuxième étape :

Rather than invoking initi script through /etc/init.d use the service utility...

J'ai donc tapé la commande suivante :

sudo service dbus reload

Et tout s'est bien passé
Par contre, blocage avec le retour suivznt pour la troisième étape :

wicd : unrecognized service

L'informatique ça marche, sauf quand ça ne marche pas !

Hors ligne

#6 Le 03/09/2013, à 14:53

ljere

Re : [RESOLU] Impossible d'activer wicd

tu as bien installé wicd?


Modérateur d'ubuntu-fr.org
athlon 2800+, nvidia FX5200 et 2 Go de ram et sempron 3000+, ati radeon et 1 Go de ram sur voyager 12.04 32 bit
Toshiba satellite_c670d-11l sur openbox/xubuntu 14.04 64 bit
Mon Blog et Une découverte

En ligne

#7 Le 05/09/2013, à 13:55

Clhiver

Re : [RESOLU] Impossible d'activer wicd

roll Fatigue du soir...j'utilisais virtualbox...
Sinon, je te donne le retour de la commande

sudo service wicd restart
* Restarting Network connection manager wicd                    [fail]

Dernière modification par Clhiver (Le 05/09/2013, à 13:56)


L'informatique ça marche, sauf quand ça ne marche pas !

Hors ligne

#8 Le 05/09/2013, à 14:40

Clhiver

Re : [RESOLU] Impossible d'activer wicd

Salut,
Pour l'instant, quand je démarre, voici ce qui se passe (ubuntu-server+xfce+slim) successivement :
1) l'ordi peut se connecter automatiquement au réseau dont je me suis servi lors de l'installation de la distrib,
2) les messages suivants (waiting for network configuration, waiting up to 60 more seconds for network configuration...) s'affichent dans le tty
3) J'attends...
4) Puis, une fenêtre s'ouvre me demandant mon mot de passe pour activer la carte réseau.
5) Je tape le mot de passe.
6) Le message d'erreur suivant s'affiche :

Impossible de se connecter à l'interface D-Bus de wicd. Inspecter le journal pour obtenir les messages d'erreur.

7) Apparaît le message de notification "Non-connecté", alors que je suis connectée ! La preuve...
8) Enfin, j'obtiens ce deuxième message d'erreur s'affiche :

Le démon wicd s'est étient. l'interface graphique ne marchera pas correctement tant que le démon n'est pas redémarré.

Voilà. J'espère que je n'ai rien oublié...

Dernière modification par Clhiver (Le 05/09/2013, à 15:25)


L'informatique ça marche, sauf quand ça ne marche pas !

Hors ligne

#9 Le 05/09/2013, à 16:23

ljere

Re : [RESOLU] Impossible d'activer wicd

tu peux être plus clair sur virtualbox?
tu as lancé les commandes sur ton systèmes?
si oui quel sont les retours?


Modérateur d'ubuntu-fr.org
athlon 2800+, nvidia FX5200 et 2 Go de ram et sempron 3000+, ati radeon et 1 Go de ram sur voyager 12.04 32 bit
Toshiba satellite_c670d-11l sur openbox/xubuntu 14.04 64 bit
Mon Blog et Une découverte

En ligne

#10 Le 06/09/2013, à 14:51

Clhiver

Re : [RESOLU] Impossible d'activer wicd

Salut,
Retour des commandes sur la machine-hôte :
sudo adduser moi netdev : RAS
sudo service dbus reload : RAS
sudo service wicd restart : message d'erreur

* Restarting Network connection manager wicd                    [fail]

Sinon, en ce qui concerne virtualbox : j'utilise tor version TorMiddleBox (Tor + virtualbox +réseau avec accès par pont vnet0).
Bien sûr, tu n'hésites pas si tu as besoin d'autres infos.


L'informatique ça marche, sauf quand ça ne marche pas !

Hors ligne

#11 Le 07/09/2013, à 14:00

Clhiver

Re : [RESOLU] Impossible d'activer wicd

Salut, je te donne le contenu du fichier /etc/network/interfaces :

# This file describes the network interfaces available on your system
# and how to activate them. For more information, see interfaces(5).

# The loopback network interface
auto lo
iface lo inet loopback

# The primary network interface
auto wlan0
iface wlan0 inet dhcp
	wpa-ssid Nom_du_réseau
	wpa-psk  Nom_de_la_clé
	

# Creation d'un pont
auto vnet0
iface vnet0 inet static
 address 172.16.0.1
 netmask 255.255.255.0
 bridge_ports none
 bridge_maxwait 0
 bridge_fd 1
 up iptables -t nat -I POSTROUTING -s 172.16.0.0/24 -j MASQUERADE
 down iptables -t nat -D POSTROUTING -s 172.16.0.0/24 -j MASQUERADE

Tu en penses quoi ?


L'informatique ça marche, sauf quand ça ne marche pas !

Hors ligne

#12 Le 07/09/2013, à 14:06

ljere

Re : [RESOLU] Impossible d'activer wicd

j'en pense que le mien ne contient que

# The loopback network interface
auto lo
iface lo inet loopback

maintenant si tu es sur de tes réglages je ne vois pas de souci


Modérateur d'ubuntu-fr.org
athlon 2800+, nvidia FX5200 et 2 Go de ram et sempron 3000+, ati radeon et 1 Go de ram sur voyager 12.04 32 bit
Toshiba satellite_c670d-11l sur openbox/xubuntu 14.04 64 bit
Mon Blog et Une découverte

En ligne

#13 Le 07/09/2013, à 14:11

Clhiver

Re : [RESOLU] Impossible d'activer wicd

Je te  remercie. Je ne ssuis sûre de rien. C'est les réglages que j'utilise depuis longtemps et qui ne posaient aucun problèmes avec network-manager...
Penses-tu que ça vaudrait le coup d'essayer de ne garder que les deux premières lignes ?


L'informatique ça marche, sauf quand ça ne marche pas !

Hors ligne

#14 Le 07/09/2013, à 14:20

ljere

Re : [RESOLU] Impossible d'activer wicd

tu peux toujours essayer de tout façon tu as maintenant l'original sur le forum ou tu en fais une copie avant


Modérateur d'ubuntu-fr.org
athlon 2800+, nvidia FX5200 et 2 Go de ram et sempron 3000+, ati radeon et 1 Go de ram sur voyager 12.04 32 bit
Toshiba satellite_c670d-11l sur openbox/xubuntu 14.04 64 bit
Mon Blog et Une découverte

En ligne

#15 Le 07/09/2013, à 14:23

Clhiver

Re : [RESOLU] Impossible d'activer wicd

Je viens d'essayer : ça change rien. C'est rageant. Merci pour ton aide et passes un bon week-end.


L'informatique ça marche, sauf quand ça ne marche pas !

Hors ligne

#16 Le 08/09/2013, à 19:10

Clhiver

Re : [RESOLU] Impossible d'activer wicd

Salut,
Finallement, j'ai profité du week-end pour tout virer et installer ubuntu_mini+xfce4+slim.
Lors de l'installation, je dois préciser le nom du réseau et la clé wpa. C'est pourquoi, j'obtiens le fichier /etc/network/interfaces suivant :

# This file describes the network interfaces available on your system
# and how to activate them. For more information, see interfaces(5).

# The loopback network interface
auto lo
iface lo inet loopback

# The primary network interface
auto wlan0
iface wlan0 inet dhcp
	wpa-ssid Nom_du_réseau
	wpa-psk  Nom_de_la_clé
	

J'ai bien sûr toujours les mêmes messages d'erreur mad
Presque envie de repasser à network-manager !


L'informatique ça marche, sauf quand ça ne marche pas !

Hors ligne

#17 Le 08/09/2013, à 21:39

ljere

Re : [RESOLU] Impossible d'activer wicd

c'est vrai qu'en passant à network manager tu devrais avoir moins de souci


Modérateur d'ubuntu-fr.org
athlon 2800+, nvidia FX5200 et 2 Go de ram et sempron 3000+, ati radeon et 1 Go de ram sur voyager 12.04 32 bit
Toshiba satellite_c670d-11l sur openbox/xubuntu 14.04 64 bit
Mon Blog et Une découverte

En ligne

#18 Le 09/09/2013, à 18:03

Clhiver

Re : [RESOLU] Impossible d'activer wicd

Mois qui pensais bien faire en passant à wicd, pour changer de NM. Merci pour ton aide et je te tiens au courant.
Pourvu que les problèmes proviennent de wicd et pas de ubuntu_mini !!!

Dernière modification par Clhiver (Le 09/09/2013, à 18:05)


L'informatique ça marche, sauf quand ça ne marche pas !

Hors ligne

#19 Le 13/09/2013, à 19:10

Clhiver

Re : [RESOLU] Impossible d'activer wicd

Salut,
À tout hasard, voici le retour de la commande ifconfig :

lo        Link encap:Boucle locale  
          inet adr:127.0.0.1  Masque:255.0.0.0
          adr inet6: ::1/128 Scope:Hôte
          UP LOOPBACK RUNNING  MTU:65536  Metric:1
          Packets reçus:12 erreurs:0 :0 overruns:0 frame:0
          TX packets:12 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 lg file transmission:0 
          Octets reçus:1029 (1.0 KB) Octets transmis:1029 (1.0 KB)

wlan0     Link encap:Ethernet  HWaddr 0c:60:76:2b:fd:a1  
          inet adr:192.168.1.111  Bcast:192.168.1.255  Masque:255.255.255.0
          adr inet6: fe80::e60:76ff:fe2b:fda1/64 Scope:Lien
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          Packets reçus:3428 erreurs:0 :0 overruns:0 frame:0
          TX packets:75 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 lg file transmission:1000 
          Octets reçus:677729 (677.7 KB) Octets transmis:7539 (7.5 KB)

Sinon, je me connecte sans problèmes quand je suis à l'endroit où j'ai installé ubuntu-mini +xfce4.


L'informatique ça marche, sauf quand ça ne marche pas !

Hors ligne

#20 Le 20/09/2013, à 16:15

Clhiver

Re : [RESOLU] Impossible d'activer wicd

Salut à tous,
Toujours le même problème : j'otiens les mêmes messages du #1 au démarrage avec l'impossibilité de me connecter à un réseau wifi, sauf quand je me trouve à proximité du réseau qui a servi à l'installation... Pas très pratique.
J'ai bien sûr tapé les commandes indiquées :
sudo adduser identifiant netdev
sudo service dbus reload

Quand je tape la 3ème commande
sudo service wicd restart
j'obtiens le reotur suivant :

* Restarting Network connection manager wicd [fail]

Quelqu'un a une petite idée ?

Dernière modification par Clhiver (Le 20/09/2013, à 16:21)


L'informatique ça marche, sauf quand ça ne marche pas !

Hors ligne

#21 Le 20/09/2013, à 17:50

ljere

Re : [RESOLU] Impossible d'activer wicd

oui une petite alors wink

sudo mv /etc/resolv.conf /etc/resolv.conf.backup
sudo ln -s /run/resolvconf/resolv.conf /etc/resolv.conf

Modérateur d'ubuntu-fr.org
athlon 2800+, nvidia FX5200 et 2 Go de ram et sempron 3000+, ati radeon et 1 Go de ram sur voyager 12.04 32 bit
Toshiba satellite_c670d-11l sur openbox/xubuntu 14.04 64 bit
Mon Blog et Une découverte

En ligne

#22 Le 20/09/2013, à 18:05

navtex

Re : [RESOLU] Impossible d'activer wicd

wicd ne marche pas pais as tu installé

sudo apt-get download python-wicd wicd-daemon wicd-gtk wicd

Voyager 14.04  sur Dell vostro 1720  2.66GHz × 2  - Ram 4Gio
Voyager- 14.04  sur  Asus X56V   2.16GHz × 2  - Ram 3,9 Gio
Xubuntu 14.04  sur  Panasonic CF-M34  PIII 0,93Ghz   500Mo
(Keep the wind in your back)               mon ébauche blog- http://voiliershy.wordpress.com/

Hors ligne

#23 Le 21/09/2013, à 14:31

Clhiver

Re : [RESOLU] Impossible d'activer wicd

Salut et merci pour votre aide !
@ navtex : j'ai vérifié ; les 4 paquets indiquéssont bel et bien installés
@ ljere: j'essaie  tes commandes et je te tiens au courant.

Même motif, même punition... En fait, nm ne fonctionne pas non plus... Je n'ai jamais eu de problèmes avec les réseaux (sous ubuntu ou xubuntu), mais plus rien de fonctionne depuis que j'installe ubuntu-server (ou ubuntu-mini) + xfce4. Du reste, j'ai également des soucis avec xarchiver et d'autres applis.

Dernière modification par Clhiver (Le 21/09/2013, à 14:35)


L'informatique ça marche, sauf quand ça ne marche pas !

Hors ligne

Haut de page ↑