Contenu | Rechercher | Menus

Annonce

Si vous rencontrez des soucis à rester connecté sur le forum (ou si vous avez perdu votre mot de passe) déconnectez-vous et reconnectez-vous depuis cette page, en cochant la case "Me connecter automatiquement lors de mes prochaines visites".
Test de l'ISO d'Ubuntu francophone : nous avons besoin de testeurs pour la version francophone d'Ubuntu 14.04. Liens et informations ici.

Attention, une faille de sécurité dans bash a récemment été rapportée, il est recommandé de mettre à jour son système (plus de détails) *** mise à jour 12/10/2014 ***

#1 Le 14/09/2013, à 08:43

Snamiac

Installer Gnome shell sous quelle version d'Ubuntu ?

Bonjour à tous, smile

Jusque-là, j'utilisais Gnome shell avec la version 12.10 mais à la suite d'un changement d'ordinateur, j'ai dû réinstaller la version 12.04.3.
Hier, j'ai installé Gnome shell selon la procédure idoine mais les extensions ne sont pas toutes opérantes et j'ai l'impression que ce n'est pas comme avant ?!
N'ayant pas suivi l'évolution de Gnome 3 depuis près d'un an, je ne m'y retrouve pas. hmm

Par conséquent, je préfère vous poser la question principale :
- Est-il préférable d'installer Gnome shell sur une version d'Ubuntu postérieure à la 12.04 ?

La question accessoire :
- Si oui, puis-je alors choisir la 13.04 qui est la plus récente ?

Par avance, je vous remercie vivement pour vos conseils.

Dernière modification par Snamiac (Le 14/09/2013, à 08:43)


Je suis un fidèle débutant non informaticien sur Ubuntu (64 bits).
Merci pour votre patience.

Etes-vous déja allés ici ?

Hors ligne

#2 Le 14/09/2013, à 09:38

ljere

Re : Installer Gnome shell sous quelle version d'Ubuntu ?

il y a cet article http://www.le-libriste.fr/2013/07/ubunt … ome-shell/
et biensur la doc gnome-shell
donc je dirai oui c'est faisable


athlon 2800+, nvidia FX5200 et 2 Go de ram et sempron 3000+, ati radeon et 1 Go de ram sur voyager 12.04 32 bit
Toshiba satellite_c670d-11l sur openboxubuntu 14.10 64 bit
Mon Blog
administrateur du forum ubuntu-fr.org

Hors ligne

#3 Le 14/09/2013, à 13:48

remjg

Re : Installer Gnome shell sous quelle version d'Ubuntu ?

GNOME Shell 3.4 fourni avec Ubuntu 12.04 (LTS) fonctionne très bien.

Les versions suivantes fournies avec Ubuntu 12.10 et 13.04 m'ont posé de nombreux problèmes. Les fonctionnalités ajoutées sont très bien, mais l'intégration dans Ubuntu est incomplète (Ubuntu 13.04 ne propose pas toutes les briques de la version 3.8 même avec les PPA) et le support de mauvaise qualité (plus de support officiel, de nombreux plantages chez moi). Ce n'est pas le cas sur d'autres distributions, ce qui me fait dire que c'est un problème spécifique à Ubuntu.

Reste à voir le problème des extensions, elles doivent être réécrites à chaque version de GNOME Shell. Donc des extensions sous GNOME Shell 3.6 (Ubuntu 12.10) ne peuvent pas fonctionner sur GNOME Shell 3.4 (Ubuntu 12.04) et vice-versa sauf exception.

Hors ligne

#4 Le 14/09/2013, à 14:09

Snamiac

Re : Installer Gnome shell sous quelle version d'Ubuntu ?

Bonjour ljere,

Merci pour ta réponse.

ljere a écrit :

il y a cet article http://www.le-libriste.fr/2013/07/ubunt … ome-shell/

Je consulte régulièrement mais là j'ai complètement oublié.
Je vais donc y retourner pour actualiser mes connaissances.
wink

Bonjour remjg,

Merci pour ta réponse.

remjg a écrit :

GNOME Shell 3.4 fourni avec Ubuntu 12.04 (LTS) fonctionne très bien

Dans ce cas, je vais conserver la 12.04.3. d'autant que c'est effectivement une LTS.

remjg a écrit :

Donc des extensions sous GNOME Shell 3.6 (Ubuntu 12.10) ne peuvent pas fonctionner sur GNOME Shell 3.4 (Ubuntu 12.04) et vice-versa sauf exception.

Merci pour l'information. Cela ne fait que m'inciter à conserver la  version 12.04.3. d'Ubuntu.

Mais alors j'ai peut-être tout simplement installé la mauvaise version de Gnome shell et des extensions pas tout à fait compatibles avec la 12.04.3 ?
Que me conseilles-tu de faire ?

Dernière modification par Snamiac (Le 15/09/2013, à 04:21)


Je suis un fidèle débutant non informaticien sur Ubuntu (64 bits).
Merci pour votre patience.

Etes-vous déja allés ici ?

Hors ligne

#5 Le 15/09/2013, à 04:52

Snamiac

Re : Installer Gnome shell sous quelle version d'Ubuntu ?

Bonjour à tous,

J'ai vérifié quelle est version de Gnome shell dont je je bénéficie :  il s'agit de la 3.4.1.
Probablement l'installation par défaut au regard de la version d'Ubuntu dont je dispose actuellement ...

Je vais retourner voir de plus près les extensions que j'ai installées car peut-être ne sont-elles pas adaptées à la 12.04.


Je suis un fidèle débutant non informaticien sur Ubuntu (64 bits).
Merci pour votre patience.

Etes-vous déja allés ici ?

Hors ligne

#6 Le 15/09/2013, à 06:41

willcoyote

Re : Installer Gnome shell sous quelle version d'Ubuntu ?

Salut
Dans chaque extension, il y a un fichier: metadata.json qui indique la version de gnome-shell pour lequel elle est prévue
gnome-shell 3.4 étant assez ancien, tu risques d'avoir pas mal de problème pour trouver des extensions valide

Je pense que ubuntu reste a la traîne pour l'utilisation de gnome-shell


archlinux+kde

Hors ligne

#7 Le 15/09/2013, à 11:52

Snamiac

Re : Installer Gnome shell sous quelle version d'Ubuntu ?

Bonjour willcoyote,

Ah bon ?  sad

C'est vraiment dommage.

En tous les cas, je te remercie de m'avoir indiqué de quelle manière vérifier la version de chaque extension.

Si je résume :

- Avec la version 12.04 => Gnome shell 3.4 => mais probablement des difficultés à trouver des extensions.
- Avec une version > 12.04  => Gnome shell plus récent => mais apparemment des soucis de fonctionnement.

Ben, j'vous l'dis, on a pas une vie facile !

wink

Dernière modification par Snamiac (Le 15/09/2013, à 12:46)


Je suis un fidèle débutant non informaticien sur Ubuntu (64 bits).
Merci pour votre patience.

Etes-vous déja allés ici ?

Hors ligne

Haut de page ↑