Contenu | Rechercher | Menus

Annonce

Si vous rencontrez des soucis à rester connecté sur le forum (ou si vous avez perdu votre mot de passe) déconnectez-vous et reconnectez-vous depuis cette page, en cochant la case "Me connecter automatiquement lors de mes prochaines visites".
Test de l'ISO d'Ubuntu francophone : nous avons besoin de testeurs pour la version francophone d'Ubuntu 14.04. Liens et informations ici.

#1 Le 13/09/2013, à 23:58

Ktapulte

Pannes chroniques de l'auto-complétion sous Konsole

Bonjour à tous.

Sous Konsole, mon auto-complétion tombe parfois "en panne" sans raison apparente alors qu'elle fonctionne très bien 20 secondes avant.

Le message d'erreur qui s'affiche est:

bash: impossible de créer un fichier temporaire pour le « here-document » : Aucun espace disponible sur le périphérique

Il me reste pourtant beaucoup de place sur mon USB-Kubuntu (13.04 installé sur une USB de 8 Go).

Le fichier .bashrc est bien dans mon dossier /home/$myUserName et il contient bien:

if ! shopt -oq posix; then
  if [ -f /usr/share/bash-completion/bash_completion ]; then
    . /usr/share/bash-completion/bash_completion
  elif [ -f /etc/bash_completion ]; then
    . /etc/bash_completion
  fi
fi

J'ai regardé ce topic

J'ai fait un

sudo apt-get install bash-completion

qui semble s'être bien déroulé.

Ainsi qu'un

sudo apt-get update

Enfin j'ai essayé d'éditer le .bashrc sous Kate, mais même en sudo chmod777 je n'arrive pas à enregistrer les modifs.

Quelqu'un saurait-il règler ce problème ?

Merci beaucoup.

A+


Kubuntu 13.04 - KDE 4.10.3

Hors ligne

#2 Le 14/09/2013, à 08:28

pingouinux

Re : Pannes chroniques de l'auto-complétion sous Konsole

Bonjour,
Que donne cette commande ?

df -h

En ligne

#3 Le 18/09/2013, à 00:23

Ktapulte

Re : Pannes chroniques de l'auto-complétion sous Konsole

Bonjour, merci de l'intérêt porté à ma question.

J'ai eu un crash sur ma clef USB (boot sans problème mais 'acpid exiting' avant le lancement de ma session), j'ai donc réinstallé Kubuntu.

Voici ce que donne df -h:

Sys. de fichiers Taille Utilisé Dispo Uti% Monté sur
/dev/sda1          3,6G    3,3G   92M  98% /
none               4,0K       0  4,0K   0% /sys/fs/cgroup
udev               1,9G    4,0K  1,9G   1% /dev
tmpfs              391M    796K  390M   1% /run
none               5,0M       0  5,0M   0% /run/lock
none               2,0G     80K  2,0G   1% /run/shm
none               100M     12K  100M   1% /run/user

Kubuntu 13.04 - KDE 4.10.3

Hors ligne

#4 Le 18/09/2013, à 08:18

tiramiseb

Re : Pannes chroniques de l'auto-complétion sous Konsole

Salut,

On voit que ton /dev/sda1 est quasiment plein.
C'est d'ailleurs l'objet du message d'erreur que tu as cité : « Aucun espace disponible sur le périphérique »...

N'as-tu pas la possibilité d'avoir plus d'espace disque ? Là c'est vraiment limite... Surtout si tu veux utiliser Kubuntu.
Avec 4 Go d'espace de stockage, je conseillerais plutôt de partir vers des distributions qui proposent des environnements légers et non pas un poids lourd comme KDE...


Ce n'est pas une panne, c'est juste que tu atteins les limites de ton matériel.
C'est quoi précisément, ton matériel ?

Dernière modification par tiramiseb (Le 18/09/2013, à 08:19)


Sébastien Maccagnoni-Munch - administrateur Linux depuis le XXème siècle
Consultant informatique indépendant - http://www.smm-informatique.fr
Geek et tout plein d'autres choses - http://www.tiramiseb.fr

Hors ligne

#5 Le 18/09/2013, à 22:28

Ktapulte

Re : Pannes chroniques de l'auto-complétion sous Konsole

Clef USB de 8 Go sous-marque pas chère pour l'installation de Kubuntu.

Comme j'ai opté pour la partition automatique swap/ext4 à l'installation, il a alloué 3 Go et des brouettes au swap.

Mon PC c'est Toshiba Satellite C650 de base dont le disque dur a méchamment crashé plusieurs fois (là il n'est plus reconnu par fdisk -l, j'y connais pas grand chose mais je pense qu'il est mort).

Là je vais sortir du sujet intial ...

Quand j'essaie de le faire booté sur HDD, il me mets un écran type console:

Intel UNDI, PXE-2.0 (build 083)
Copyright (C) 1997-2000 Intel Corporation
For Atheros PCIE Ethernet Controller V2.0.1.9 (12/15/09)
Check cable connection!
PXE-M0F: Exiting Intel PXE ROM.
No bootable device - - insert boot disk and press any key.

Ma carte réseaux est bien l'Atheros et elle fonctionne très bien sous Kubuntu.

Je n'ai jamais branché aucun cable ethernet, toujours fait en WiFi.

Quand je lui mets un liveCD et que je press une key, ça me raffiche la même chose.

Quand j'ai eu accès au grub rescue après mon dernier super crash, un ls donnait

 (hd0) (hd, msdos5) (hd, msdos6)

mais rien du genre (hdX,Y) comme décrit dans ce topic

avec le grub 2 de Kubuntu sur ma clef USB, je pense avoir réussi à réparer le grub.cfg mais pas sûr (comment s'en rendre compte ?).

Bref, je suis un peu perdu et je pense que plusieurs problèmes se superposent.


Kubuntu 13.04 - KDE 4.10.3

Hors ligne

Haut de page ↑