Contenu | Rechercher | Menus

Annonce

Si vous rencontrez des soucis à rester connecté sur le forum (ou si vous avez perdu votre mot de passe) déconnectez-vous et reconnectez-vous depuis cette page, en cochant la case "Me connecter automatiquement lors de mes prochaines visites".

#1 Le 20/11/2011, à 15:01

g4llic4

Impossible de changer les permissions d'accès

Bonjour à tous,

Ce n'est pas la première fois que je remarque ce problème mais impossible de le régler. J'espère que vous pourrez m'aider !

Le problème est relativement simple : je possède un répertoire (partitions de mon disque dur intitulée "data_local") dont j'ai les accès rwx. Les composantes groupe et autre n'ont aucun accès et impossible de les changer (malgré les sudo chmod & co.). Voici un screen plutôt explicite :
capturedu20111120135632.th.png

Une suggestion ?

Hors ligne

#2 Le 20/11/2011, à 15:06

Haleth

Re : Impossible de changer les permissions d'accès

Ne met pas le / final


Ubuntu is an ancien African word which means "I can't configure Debian"

Because accessor & mutator are against encapsulation (one of OOP principles), good OOP-programmers do not use them. Obviously, procedural-devs do not. In fact, only ugly-devs are still using them.

Hors ligne

#3 Le 21/11/2011, à 04:06

AlexandreP

Re : Impossible de changer les permissions d'accès

Salut,

Si le volume en question est formaté en NTFS ou en FAT32, tu ne peux pas modifier les permissions à l'aide de chmod. Ces systèmes de fichiers ne prennent pas en charge les droits d'accès.


«La capacité d'apprendre est un don; La faculté d'apprendre est un talent; La volonté d'apprendre est un choix.» -Frank Herbert
93,8% des gens sont capables d'inventer des statistiques sans fournir d'études à l'appui.

Hors ligne

#4 Le 21/11/2011, à 14:10

Postmortem

Re : Impossible de changer les permissions d'accès

Salut,
Il faut changer les droits par défaut au montage de la partition. Ceci se fait dans le fichier /etc/fstab.
Dans ce fichier, tu dois avoir une ligne où apparaît data_local
Sur cette ligne, il faut modifier la valeur umask
Commence par faire une sauvegarde du fichier :

sudo cp -p /etc/fstab /etc/fstab.$(date '+%Y%m%d-%H%M%S')

Cela sauvegarde le fichier avec en extension la date et l'heure.

Puis tu édites le fichier /etc/fstab avec la commande :

gksu gedit /etc/fstab

Tu modifies le umask de 077 (ou autre) en 000 :

/etc/fstab a écrit :

UUID=xxxxxxxxxxxxxxxxxx /media/data_local        ntfs    defaults,umask=000,gid=46 0       0

Ensuite, tu sauvegardes et tu quittes gedit.
Au redémarrage, les droits de ta partition seront tous en 777.
Fais attention de pas faire de conneries dans ce fichier ! Ne modifie que le umask.
Si tu en fais, tu pourras remplacer par le fichier sauvegardé à la première étape.


Raring Ringtail (64 bits), Athlon64 3800+, ATI Radeon HD4870

Mot' a dit : « Un Hellfest sans Slayer, c'est comme une galette-saucisse sans saucisse ! »

Hors ligne

#5 Le 23/11/2011, à 17:05

g4llic4

Re : Impossible de changer les permissions d'accès

Merci à vous, je n'étais pas au courant de la contrainte pour le NTFS, c'est bien noté. J'essaierai ces manipulations dès que possible.

Hors ligne

#6 Le 06/12/2011, à 19:04

bowmore

Re : Impossible de changer les permissions d'accès

Salut à tous.

J'ai exactement le même soucis que g4llic4.
Une partition NTFS montée sous /media/Data dont les droits d'accès sont verrouillés en lecture et exécution pour le proprio (root) et le groupe (plugdev).
J'ai suivi la manip de Postmortem, et changé mon fstab. Le umask était =007, je l'ai changé en =000.
Enregistrement fstab, redémarrage du PC, et ... pareil qu'avant...
J'ai loupé quoi??? neutral

Dernière modification par bowmore (Le 06/12/2011, à 19:05)


"Bon bah, je vais essayer de ne pas claquer la porte en sortant"
Buzz Aldrin, le 21 juillet 1969 sur la Mer de la Tranquillité

Hors ligne

#7 Le 07/12/2011, à 05:10

AlexandreP

Re : Impossible de changer les permissions d'accès

Salut,

Montre-nous ton fstab:

cat /etc/fstab

Il s'agit peut-être simplement d'une typo dans ton fichier.


«La capacité d'apprendre est un don; La faculté d'apprendre est un talent; La volonté d'apprendre est un choix.» -Frank Herbert
93,8% des gens sont capables d'inventer des statistiques sans fournir d'études à l'appui.

Hors ligne

#8 Le 07/12/2011, à 18:01

bowmore

Re : Impossible de changer les permissions d'accès

Salut AlexandreP.
Et merci de t'intéresser à mon problème...
Voici mon fstab

# /etc/fstab: static file system information.
#
# Use 'blkid -o value -s UUID' to print the universally unique identifier
# for a device; this may be used with UUID= as a more robust way to name
# devices that works even if disks are added and removed. See fstab(5).
#
# <file system> <mount point>   <type>  <options>       <dump>  <pass>
proc            /proc           proc    nodev,noexec,nosuid 0       0
# / was on /dev/sda5 during installation
UUID=15cb78bd-abda-4ef0-8bbd-23371a9f8269 /               ext4    errors=remount-ro 0       1
# /home was on /dev/sda6 during installation
UUID=f45b2406-2175-4f46-98d3-6f5a3317d66a /home           ext4    defaults        0       2
# /media/Data was on /dev/sda3 during installation
UUID=30C9E8F340E0F525 /media/Data     ntfs    defaults,umask=000,gid=46 0       0

J'ai bien umask=000.
neutral


"Bon bah, je vais essayer de ne pas claquer la porte en sortant"
Buzz Aldrin, le 21 juillet 1969 sur la Mer de la Tranquillité

Hors ligne

#9 Le 09/12/2011, à 06:05

AlexandreP

Re : Impossible de changer les permissions d'accès

Re!

Vérifie aussi que le pilote ntfs-3g, qui est celui permettant l'écriture dans les volumes NTFS, est bien installé. Il semblerait que ce ne soit pas toujours le cas dans les installations neuves d'Ubuntu 11.10. Dans un terminal, exécute la commande suivante:

sudo apt-get install ntfs-3g

(Quoique ntfs-3g est probablement accessible depuis la Logithèque Ubuntu.) Après l'installation de ntfs-3g, s'il y a eu lieu, démonte puis remonte ton volume. (Ou redémarre ton système.)



Au besoin, tu auras peut-être aussi à ouvrir le fichier /etc/fsab en mode administrateur et à modifier la ligne

# /media/Data was on /dev/sda3 during installation
UUID=30C9E8F340E0F525 /media/Data     ntfs    defaults,umask=000,gid=46 0       0

par

# /media/Data was on /dev/sda3 during installation
UUID=30C9E8F340E0F525 /media/Data     ntfs-3g    defaults,umask=000,gid=46 0       0

pour forcer l'utilisation du pilote ntfs-3g.


«La capacité d'apprendre est un don; La faculté d'apprendre est un talent; La volonté d'apprendre est un choix.» -Frank Herbert
93,8% des gens sont capables d'inventer des statistiques sans fournir d'études à l'appui.

Hors ligne

#10 Le 09/12/2011, à 18:32

bowmore

Re : Impossible de changer les permissions d'accès

Alors...

Le pilote ntfs-3g était installé.
Mais, j'ai suivi ton conseil en changeant de nouveau le fstab comme tu me le suggérais, et ... ça marche!!! smile

A présent, j'arrive à lire, écrire et exécuter des fichiers sur ma partition qui était bloquée en lecture seule.
Merci pour cette info, que je n'aurais pas devinée tout seul. wink


"Bon bah, je vais essayer de ne pas claquer la porte en sortant"
Buzz Aldrin, le 21 juillet 1969 sur la Mer de la Tranquillité

Hors ligne

#11 Le 14/06/2013, à 00:33

fly_in_the_sky

Re : Impossible de changer les permissions d'accès

Salut,
j'ai un disque dure externe en NTFS, je suis sous KDE 12.04
Je sais lire les fichier sur la partition NTFS, mais impossible de modifié les fichiers.
J'ai voulut suivre les instructions donnée dans ce sujet, mais le problème est que ma partition externe, n'apparait pas dans le fstab.
Du  coup je suis bloqué. pouvez vous m'aider ?

Il s'agit de la partition sdb7 "stockage"
j'ai éssayer un sudo chmod -R 777 sans succes.

Voici quelque commande :

# /etc/fstab: static file system information.
#nsuel

# Use 'blkid' to print the universally unique identifier for a
# device; this may be used with UUID= as a more robust way to name devices
# that works even if disks are added and removed. See fstab(5).
#
# <file system> <mount point>   <type>  <options>       <dump>  <pass>
proc            /proc           proc    nodev,noexec,nosuid 0       0
# / was on /dev/sda7 during installation
UUID=43a55771-f65c-48a4-a3be-a9dcdf29cb2d /               ext4    errors=remount-ro 0       1
# /home was on /dev/sda8 during installation
UUID=e066d81c-78f2-4247-a5e6-06629dcdbaba /home           ext4    defaults        0       2
# swap was on /dev/sda5 during installation
UUID=83dce766-961d-437f-afe0-087e8a86e48f none            swap    sw              0       0
UUID=c0493a15-a772-46b9-8363-bcc5c0028ebc  none		  ext4 	  defaults 	  0	   2

Disk /dev/sdb: 160.0 GB, 160041885696 bytes
255 têtes, 63 secteurs/piste, 19457 cylindres, total 312581808 secteurs
Unités = secteurs de 1 * 512 = 512 octets
Taille de secteur (logique / physique) : 512 octets / 512 octets
taille d'E/S (minimale / optimale) : 512 octets / 512 octets
Identifiant de disque : 0xf98d6e74

Périphérique Amorce  Début        Fin      Blocs     Id  Système
/dev/sdb1            2048    14338047     7168000   1c  W95 FAT32 masquée (LBA)
/dev/sdb2   *    14338048   136820735    61241344   83  Linux
/dev/sdb3       136825605   157212089    10193242+  83  Linux
/dev/sdb4       157212151   312576704    77682277    5  Étendue
/dev/sdb5       157212153   159380864     1084356   82  partition d'échange Linux / Solaris
/dev/sdb6       159380928   179911934    10265503+  83  Linux
/dev/sdb7       179911998   312576704    66332353+   7  HPFS/NTFS/exFAT
fly@fly:~$ ^C

et 

fly@fly:/media$ ll
total 16
drwxr-xr-x  4 root root 4096 jun 14 00:27 ./
drwxr-xr-x 25 root root 4096 mai 15 22:03 ../
drwxr-xr-x  2 root root 4096 fév 25 00:38 cdrom/
lrwxrwxrwx  1 root root   45 fév 25 00:56 .directory -> /etc/kubuntu-default-settings/directory-media
lrwxrwxrwx  1 root root   42 fév 25 00:56 .hidden -> /etc/kubuntu-default-settings/hidden-media
drwxr-xr-x  2 root root 4096 mar  1 14:53 Stockage/
fly@fly:/media$ 

merci de me donner un petit coup de pouce.
Nico

Hors ligne

#12 Le 14/06/2013, à 05:01

AlexandreP

Re : Impossible de changer les permissions d'accès

Re,

Exécute la commande suivante dans un terminal -- ceci ajoutera la bonne instruction à la fin de ton fichier /etc/fstab:

echo "/dev/sdb7   /media/Stockage   ntfs   defaults,umask=000,gid=46   0   0" | sudo tee -a /etc/fstab

«La capacité d'apprendre est un don; La faculté d'apprendre est un talent; La volonté d'apprendre est un choix.» -Frank Herbert
93,8% des gens sont capables d'inventer des statistiques sans fournir d'études à l'appui.

Hors ligne

#13 Le 20/09/2013, à 20:06

paspro

Re : Impossible de changer les permissions d'accès

bonjour tout le monde,
Comme mon nom l'indique, je débute sous ubuntu 14 lts.
Je cherche à donner une permission pour mon disk monté sur /media/MP3
Seulement quand j'essaye de changer les paramètres, le slide revient dans sa position initial.
Lisant ce forum, je m’aperçois qu'il s'agit d'une partition ntfs,
bon. Je test alors la ligne de commande de postmortem pour changer le umask et


# /etc/fstab: static file system information.
#
# Use 'blkid' to print the universally unique identifier for a
# device; this may be used with UUID= as a more robust way to name devices
# that works even if disks are added and removed. See fstab(5).
#
# <file system> <mount point>   <type>  <options>       <dump>  <pass>
proc            /proc           proc    nodev,noexec,nosuid 0       0
# / was on /dev/sdc1 during installation
UUID=aca5cfa7-68d8-4173-8fa9-f8bec0aa346a /               ext4    errors=remount-ro 0       1
# swap was on /dev/sdc5 during installation
UUID=cd4accdb-14c7-4c82-ab57-3146b59dd0f0 none            swap    sw              0       0


Je ne comprends pas bien se qui se passe... pourriez vous m'aider svp?

Merci

Hors ligne

#14 Le 21/09/2013, à 04:49

AlexandreP

Re : Impossible de changer les permissions d'accès

Salut,

paspro a écrit :

Je ne comprends pas bien se qui se passe... pourriez vous m'aider svp?

Il s'est passé qu'il ne s'est rien passé tongue
En regardant ton fichier /etc/fstab, qui liste les instructions de montage des divers volumes fixes de ton ordinateur, je ne constate aucune instruction présente pour monter un volume NTFS.

Les commandes que propose Postmortem sont expliquées dans son message:
- la première effectue une copie de sauvegarde du fichier /etc/fstab sous un autre nom. Ainsi, si tu fais une boulette, il sera possible de revenir en arrière pour corriger la situation. Elle n'applique pas de changement;
- la seconde exécute un éditeur de texte (Gedit) en mode administrateur, puisque seul un administrateur peut modifier les règles de montage des volumes. Encore là, elle ne fait pas elle-même de changement;
- la troisième est une instruction de montage. C'est ça qui doit être copié-collé dans le fichier /etc/fstab et qui doit être adapté à ta situation.


«La capacité d'apprendre est un don; La faculté d'apprendre est un talent; La volonté d'apprendre est un choix.» -Frank Herbert
93,8% des gens sont capables d'inventer des statistiques sans fournir d'études à l'appui.

Hors ligne

Haut de page ↑