Contenu | Rechercher | Menus

Annonce

Si vous rencontrez des soucis à rester connecté sur le forum (ou si vous avez perdu votre mot de passe) déconnectez-vous et reconnectez-vous depuis cette page, en cochant la case "Me connecter automatiquement lors de mes prochaines visites".
Test de l'ISO d'Ubuntu francophone : nous avons besoin de testeurs pour la version francophone d'Ubuntu 14.04. Liens et informations ici.

#1 Le 23/09/2013, à 23:23

Pierrot84

[Résolu] Ouverture systématique non voulue d'une fenêtre "home" au dém

Bonsoir,

Je suis sous Kubuntu 12.04.
Au démarrage, un fenêtre Dolphin s'ouvre automatiquement et fait apparaître mon répertoire home. J'ai beau la fermer, elle réapparaît à chaque démarrage.
Quelqu'un saurait-il où cela se configure-t-il, ou bien quel est le problème ?
Merci d'avance.

Dernière modification par Pierrot84 (Le 26/09/2013, à 22:10)

Hors ligne

#2 Le 24/09/2013, à 12:14

louis94

Re : [Résolu] Ouverture systématique non voulue d'une fenêtre "home" au dém

Bonjour,

Ça se configure dans
Menu > Configuration du système > Administration du système > Démarrage et arrêt > Démarrage automatique
Il faut décocher la case correspondant au programme qui démarre ou bien le sélectionner et cliquer sur « Enlever ».

Si le problème persiste, vérifier le dossier /home/TOI/.config/autostart

Louis

Hors ligne

#3 Le 24/09/2013, à 20:02

Pierrot84

Re : [Résolu] Ouverture systématique non voulue d'une fenêtre "home" au dém

Merci de votre réponse.
En fait, j'avais déjà jeté un oeil dans "Menu > Configuration du système > Administration du système > Démarrage et arrêt > Démarrage automatique" mais il n'apparaît que le script "gtk2-default-theme.rc.sh". Je ne sais pas si c'est lui qui est en cause...
Par ailleurs, le répertoire "TOI" dont vous parlez n'existe pas chez moi.

Petite précision, les menus de la fenêtre Dolphin qui me pose problème sont en anglais alors que d'habitude ils sont en français...

Hors ligne

#4 Le 24/09/2013, à 23:58

louis94

Re : [Résolu] Ouverture systématique non voulue d'une fenêtre "home" au dém

Le répertoire "TOI", c'était pour dire qu'il faudrait le remplacer par ton nom d'utilisateur.
Le fait que Dolphin soit en Anglais est étrange. Est-ce que tu pourrais lancer dans un terminal la commande

ps -Af | grep dolphin

qui donne des informations sur comment et par qui le processus a été lancé ?

Louis

Hors ligne

#5 Le 25/09/2013, à 10:39

Pierrot84

Re : [Résolu] Ouverture systématique non voulue d'une fenêtre "home" au dém

louis94 a écrit :

Le répertoire "TOI", c'était pour dire qu'il faudrait le remplacer par ton nom d'utilisateur.

Oui, bien sûr ! je devais être bien fatigué hier soir smile Je contribue à un futur bêtisier...
Dans autostart, j'ai un fichier nommé KNetworkManager.desktop mais je n'y vois rien de suspect, pour ce que j'en comprends.

Le fait que Dolphin soit en Anglais est étrange. Est-ce que tu pourrais lancer dans un terminal la commande

ps -Af | grep dolphin

qui donne des informations sur comment et par qui le processus a été lancé ?

Voici (j'ai actuellement deux fenêtres Dolphin ouvertes, ainsi que la fenêtre intempestive) :

pierre    1905  1617  0 10:30 ?        00:00:00 /usr/bin/dolphin -session 101931ac16b123000137918003800000018250041_1380063421_118710
pierre    1928  1617  1 10:30 ?        00:00:04 /usr/bin/dolphin -session 101931ac16b123000137997102000000018310050_1380063421_120393
pierre    1947  1617  0 10:30 ?        00:00:00 kdeinit4: kio_file [kdeinit] file local:/tmp/ksocket-pierre/klauncherMT1618.slave-socket local:/tmp/ksocket-pierre/dolphinQH1928.slave-socket
pierre    1963  1617  0 10:30 ?        00:00:00 kdeinit4: kio_file [kdeinit] file local:/tmp/ksocket-pierre/klauncherMT1618.slave-socket local:/tmp/ksocket-pierre/dolphinAx1905.slave-socket
pierre    2512  1617  0 10:32 ?        00:00:00 kdeinit4: kio_filenamesearch [kdeinit] filenamesearch local:/tmp/ksocket-pierre/klauncherMT1618.slave-socket local:/tmp/ksocket-pierre/dolphinyU1928.slave-socket
pierre    2513  1617  0 10:32 ?        00:00:00 kdeinit4: kio_filenamesearch [kdeinit] filenamesearch local:/tmp/ksocket-pierre/klauncherMT1618.slave-socket local:/tmp/ksocket-pierre/dolphinLg1928.slave-socket
pierre    2515  1617  0 10:32 ?        00:00:00 kdeinit4: kio_filenamesearch [kdeinit] filenamesearch local:/tmp/ksocket-pierre/klauncherMT1618.slave-socket local:/tmp/ksocket-pierre/dolphinlN1928.slave-socket
pierre    2518  1617  0 10:33 ?        00:00:00 kdeinit4: kio_thumbnail [kdeinit] thumbnail local:/tmp/ksocket-pierre/klauncherMT1618.slave-socket local:/tmp/ksocket-pierre/dolphinXM1928.slave-socket
pierre    2581  1934  0 10:35 pts/1    00:00:00 grep dolphin

Hors ligne

#6 Le 25/09/2013, à 11:24

erresse

Re : [Résolu] Ouverture systématique non voulue d'une fenêtre "home" au dém

Mis à part le fait que la fenêtre est en Anglais au lieu du Français, n'y aurait-il pas pour Kubuntu comme pour Ubuntu (Gnome) une option de mémorisation de la session pour réouvrir les applications lors du redémarrage ?


Plus de 40 ans d'informatique, ça en fait des lignes de commandes en console, mais on n'avait pas le choix...
Excellente raison pour, aujourd'hui qu'on le peut, utiliser au maximum les INTERFACES GRAPHIQUES !

En ligne

#7 Le 25/09/2013, à 11:30

Pierrot84

Re : [Résolu] Ouverture systématique non voulue d'une fenêtre "home" au dém

Si. Et cette fonction marche très bien. Le problème est que cette fenêtre réapparaît au prochain démarrage même si je la ferme.

Hors ligne

#8 Le 25/09/2013, à 18:24

louis94

Re : [Résolu] Ouverture systématique non voulue d'une fenêtre "home" au dém

Ça a l'air d'être

pierre    1905  1617  0 10:30 ?        00:00:00 /usr/bin/dolphin -session 101931ac16b123000137918003800000018250041_1380063421_118710

Le paramètre "-session" m'interpelle, c'est comme si Dolphin était restauré depuis un état antérieur.

Essaye de tuer le processus avant de fermer ta session  :

xkill

Puis clique sur la fenêtre du "méchant" dolphin.

Voici une liste d'autre dossiers pouvant être en cause (rechercher un fichier de type "dolphin.desktop") :
/usr/share/autostart/
~/.kde/Autostart
~/.kde/share/autostart/

Louis

Hors ligne

#9 Le 25/09/2013, à 20:49

Pierrot84

Re : [Résolu] Ouverture systématique non voulue d'une fenêtre "home" au dém

J'avais effectivement deux fenêtres Dolphin ouvertes depuis une session antérieure donc rien d'anormal. Je les ai fermées puis j'ai redémarré et là, aucun processus Dolphin. Je regardé le menu "About" de ma fenêtre qui s'ouvre toute seule et là, surprise, il s'agit en fait de Nautilus. C'était difficile de faire la différence par l'aspect graphique.
J'ai donc pris l'initiative de lancer :

ps -Af | grep nautilus

qui a retourné

pierre    2059  1614  1 20:28 ?        00:00:01 nautilus
pierre    2557  2130  0 20:31 pts/1    00:00:00 grep nautilus

Qu'en penser ?

Hors ligne

#10 Le 25/09/2013, à 23:33

louis94

Re : [Résolu] Ouverture systématique non voulue d'une fenêtre "home" au dém

Ah c'était Nautilus cool
Alors, je pense que ce qui se passe est ceci :
Nautilus gère également le bureau de Gnome. Pour ce faire, il reste allumé quand toutes ses fenêtres sont fermées. (Ou alors pour pouvoir démarrer plus vite la fois suivante.)
J'imagine que tu utilises la restauration automatique de session, voir Configuration du système > Démarrage et arrêt > Gestion de sessions > À la connexion.
Du coup, quand Kde se ferme, il enregistre que Nautilus est lancé et le rouvre au démarrage suivant.
Il y a plusieurs solutions possibles :

  1. Ajouter « nautilus » dans la liste Applications à ne pas restaurer ;

  2. Tuer Nautilus à chaque fois que tu n'en veux plus :

    killall nautilus
  3. Cocher « Démarrer avec une session vide » ;

  4. Désinstaller Nautilus et utiliser Dolphin tout le temps tongue

Louis

Hors ligne

#11 Le 26/09/2013, à 22:07

Pierrot84

Re : [Résolu] Ouverture systématique non voulue d'une fenêtre "home" au dém

J'ai finalement tué le processus nautilus et tout semble être rentré dans l'ordre. Ouf !
Merci beaucoup pour ton aide.

Hors ligne

Haut de page ↑