Contenu | Rechercher | Menus

Annonce

Si vous rencontrez des soucis à rester connecté sur le forum (ou si vous avez perdu votre mot de passe) déconnectez-vous et reconnectez-vous depuis cette page, en cochant la case "Me connecter automatiquement lors de mes prochaines visites".

#1 Le 22/01/2008, à 02:48

vega_dagraeyt-wuon

Un problème à  priori tout bête...

J'aimerais pouvoir ajouter une directive à  mon fichier /etc/fstab pour monter (bind) un repertoire de ma partition xp dans un des dossiers de l'arborescence linux (/home/ftp/bidule en l'occurence)
la ligne ressemble donc à  celle çi

/windows/Documents\ and\ Settings/User\ name/Mes\ documents/Mon\ dossier/home/ftp/bidule    none    bind,defaults,auto 0       0

j'ai ce message d'erreur

[mntent]: ligne 17 dans /etc/fstab est erroné

Je crois que c'est le fait qu'il y ait des espaces dans le chemin de mon repertoire windows qui pose problème malgré le fait que je les déspécialise. Quelqu'un a déjà  eu pareil problème ? Existe-il une solution ?

Hors ligne

#2 Le 22/01/2008, à 02:55

HymnToLife

Re : Un problème à  priori tout bête...

/windows/Documents\ and\ Settings/User\ name/Mes\ documents/Mon\ dossier /home/ftp/bidule    none    bind,defaults,auto 0       0

La seule solution que je connaisse contre ce genre d'erreurs est de faire attention à  ce qu'on tape...

Dernière modification par HymnToLife (Le 22/01/2008, à 02:57)


- Rodrigue, as-tu du cœur ?
- Non, mais j'ai du pique !

Hors ligne

#3 Le 22/01/2008, à 03:05

vega_dagraeyt-wuon

Re : Un problème à  priori tout bête...

HymnToLife a écrit :
/windows/Documents\ and\ Settings/User\ name/Mes\ documents/Mon\ dossier /home/ftp/bidule    none    bind,defaults,auto 0       0

La seule solution que je connaisse contre ce genre d'erreurs est de faire attention à  ce qu'on tape...

nonobstant la possibilité que j'aie fait une erreur (ce qui n'est pas le cas puisque j'ai quand même vérifié) est-il possible d'avoir un chemin avec des espaces dans son /etc/fstab si oui comment ?

Hors ligne

#4 Le 22/01/2008, à 03:19

vega_dagraeyt-wuon

Re : Un problème à  priori tout bête...

j'ai essayé de mettre des guillemets autour du chemin avec des espaces avec et sans les \ devant et pareil j'ai la même erreur...

Hors ligne

#5 Le 22/01/2008, à 03:23

vega_dagraeyt-wuon

Re : Un problème à  priori tout bête...

J'ai trouvé la soluce.:D
Alors celle-là  il faut la connaà®tre hein...:cool:

Hors ligne

#6 Le 22/01/2008, à 04:11

GentooUser

Re : Un problème à  priori tout bête...

Fait péter, je suis curieux.

Hors ligne

#7 Le 22/01/2008, à 05:42

vega_dagraeyt-wuon

Re : Un problème à  priori tout bête...

GentooUser a écrit :

Fait péter, je suis curieux.

il faut mettre \040 à la place du caractère espace wink
la soluce ressemble donc à ceci

/windows/Documents\040and\040Settings/User\040name/Mes\040documents/My\040directory      /home/ftp/bidule    none    bind,defaults,auto 0       0

source

Hors ligne

#8 Le 22/01/2008, à 07:12

sonal

Re : Un problème à  priori tout bête...

/windows/Documents\ and\ Settings/User\ name/Mes\ documents/Mon\ dossier/home/ftp/bidule    none    bind,defaults,auto 0       0

il ne manque pas aussi un espace dans le fichier original (comme le suggérait HymnToLife ?)

Dernière modification par sonal (Le 22/01/2008, à 07:12)


Sonal

Patience et longueur de temps, font plus que force, ni que rage

Hors ligne

#9 Le 22/01/2008, à 23:47

vega_dagraeyt-wuon

Re : Un problème à  priori tout bête...

sonal a écrit :

/windows/Documents\ and\ Settings/User\ name/Mes\ documents/Mon\ dossier/home/ftp/bidule    none    bind,defaults,auto 0       0

il ne manque pas aussi un espace dans le fichier original (comme le suggérait HymnToLife ?)

ça se voit que vous avez lu le premier post du thread... roll
anyway comme je l'ai déjà  dit j'ai trouvé la soluce tout seul comme un grand.

Hors ligne

#10 Le 23/01/2008, à 11:09

sonal

Re : Un problème à  priori tout bête...

nolacm a écrit :

ça se voit que vous avez lu le premier post du thread... roll

si mais il pouvait s'agir d'une eventuelle erreur supplémentaire (ça arrive)

anyway comme je l'ai déjà  dit j'ai trouvé la soluce tout seul comme un grand.

d'ailleurs merci. ça peut être utile de se souvenir de ça


Sonal

Patience et longueur de temps, font plus que force, ni que rage

Hors ligne

#11 Le 13/06/2013, à 15:34

vega_dagraeyt-wuon

Re : Un problème à  priori tout bête...

saperlipopette

Hors ligne

Haut de page ↑