Contenu | Rechercher | Menus

Annonce

Si vous rencontrez des soucis à rester connecté sur le forum (ou si vous avez perdu votre mot de passe) déconnectez-vous et reconnectez-vous depuis cette page, en cochant la case "Me connecter automatiquement lors de mes prochaines visites". Attention, le forum rencontre actuellement quelques difficultés. En cas d'erreur 502, il ne faut pas re-valider l'envoi d'un message ou l'ouverture d'une discussion, au risque de créer un doublon.

La section divers se réorganise ! De nouvelles sous-sections à venir. (plus d'infos + donner son avis)

#1 Le 07/10/2013, à 17:25

eonshao

[Résolu] Postfix, Invalid Sender

Bonsoir,

Suite à un gros plantage la semaine dernière, j'ai réinstallé Ubuntu 12.04 complètement, donc tout propre. Je rencontre cependant un souci avec Postfix. Je n'arrive plus à envoyer d'e-mails (je dis "plus" car avant ça fonctionnait sans problème). Je suis chez Orange, seuls eux me fournissait la fibre, donc pas le choix... N'ayant pas pu récupérer une copie de mon ancien main.cf, je ne me souviens plus si je l'avais paramétré ainsi. Et comme cela fait maintenant plus de deux heures que j'essaie de le faire fonctionner, je m'en remets à vous !

n750jv est le nom de ma machine (etc/hostname).

main.cf

# See /usr/share/postfix/main.cf.dist for a commented, more complete version

# Debian specific:  Specifying a file name will cause the first
# line of that file to be used as the name.  The Debian default
# is /etc/mailname.
#myorigin = /etc/mailname

smtpd_banner = $myhostname ESMTP $mail_name (Ubuntu)
biff = no

# appending .domain is the MUA's job.
append_dot_mydomain = no

# Uncomment the next line to generate "delayed mail" warnings
#delay_warning_time = 4h

readme_directory = no

# TLS parameters
smtpd_tls_cert_file=/etc/ssl/certs/ssl-cert-snakeoil.pem
smtpd_tls_key_file=/etc/ssl/private/ssl-cert-snakeoil.key
smtpd_use_tls=yes
smtpd_tls_session_cache_database = btree:${data_directory}/smtpd_scache
smtp_tls_session_cache_database = btree:${data_directory}/smtp_scache

# See /usr/share/doc/postfix/TLS_README.gz in the postfix-doc package for
# information on enabling SSL in the smtp client.

myhostname = n750jv
alias_maps = hash:/etc/aliases
alias_database = hash:/etc/aliases
mydestination = n750jv, localhost.localdomain, localhost
relayhost = smtp.orange.fr
mynetworks = 127.0.0.0/8 [::ffff:127.0.0.0]/104 [::1]/128
mailbox_size_limit = 0
recipient_delimiter = +
inet_interfaces = all

mail.log

Oct  7 18:05:30 n750jv postfix/master[1490]: daemon started -- version 2.9.6, configuration /etc/postfix
Oct  7 18:05:31 n750jv postfix/master[1490]: reload -- version 2.9.6, configuration /etc/postfix
Oct  7 18:05:41 n750jv postfix/master[1490]: reload -- version 2.9.6, configuration /etc/postfix
Oct  7 18:07:42 n750jv postfix/pickup[2505]: 8D414981E5D: uid=33 from=<www-data>
Oct  7 18:07:42 n750jv postfix/cleanup[4188]: 8D414981E5D: message-id=<20131007160742.8D414981E5D@n750jv>
Oct  7 18:07:42 n750jv postfix/qmgr[2506]: 8D414981E5D: from=<www-data@n750jv>, size=2573, nrcpt=1 (queue active)
Oct  7 18:07:43 n750jv postfix/smtp[4190]: 8D414981E5D: to=<mon@mail>, relay=smtp.orange.fr[193.252.22.64]:25, delay=1.4, delays=0.01/0/0.36/0.99, dsn=5.1.0, status=bounced (host smtp.orange.fr[193.252.22.64] said: 501 5.1.0 Emetteur invalide. Invalid Sender. OFR204_405 [405] (in reply to MAIL FROM command))
Oct  7 18:07:43 n750jv postfix/cleanup[4188]: E7DA3981E5F: message-id=<20131007160743.E7DA3981E5F@n750jv>
Oct  7 18:07:43 n750jv postfix/bounce[4193]: 8D414981E5D: sender non-delivery notification: E7DA3981E5F
Oct  7 18:07:43 n750jv postfix/qmgr[2506]: E7DA3981E5F: from=<>, size=4392, nrcpt=1 (queue active)
Oct  7 18:07:43 n750jv postfix/qmgr[2506]: 8D414981E5D: removed
Oct  7 18:07:43 n750jv postfix/local[4194]: E7DA3981E5F: to=<www-data@n750jv>, relay=local, delay=0.01, delays=0/0.01/0/0, dsn=2.0.0, status=sent (delivered to mailbox)
Oct  7 18:07:43 n750jv postfix/qmgr[2506]: E7DA3981E5F: removed

Merci d'avance.

Sébastien.

Dernière modification par eonshao (Le 07/10/2013, à 19:13)

Hors ligne

#2 Le 07/10/2013, à 19:13

eonshao

Re : [Résolu] Postfix, Invalid Sender

Voilà mon problème résolu...

Il semble qu'il faille ajouter la ligne...

myorigin = ici un domaine existant

... afin de régler ce problème de Invalid Sender

Je ne me souviens pas avoir ajouté ça lors de l'ancienne installation, mais bon, en tout cas, ça fonctionne maintenant...

Hors ligne

Haut de page ↑