Contenu | Rechercher | Menus

Annonce

Ubuntu-fr.org recrute toujours de nouveaux modérateurs, avec de l'expérience.

Ubuntu 16.04 LTS
Commandez vos DVD et clés USB Ubuntu-fr !

Si vous avez des soucis pour rester connecté, déconnectez vous et reconnectez vous depuis ce lien en cochant le case
Me connecter automatiquement lors de mes prochaines visites.

#1 Le 09/12/2005, à 23:42

Creusois

Installer les bonne librairy

Bonjour à tous,

Je debute sur Ubuntu, avant j'avais une debian et à l'installation tout était installer, du coup j'ai un peu de mal (car je suis un peu un novice tout de meme sous linux)

Donc voila, avec synaptic j'ai installé gcc et emacs comme editeur.
Seulement je n'arrive pas à compiler quand j'utilise des fonctions de la libc (et autre) ca merde. (en l'occurence juste un printf)
les includes n'ont pas l'air d'etre accepté.
Ca m'a donc tout l'air d'etre du au manque des bonnes libraries, mais je n'arrive pas, du moins je ne sais pas comment les installer.
quand je tape stdlib dans le module de recherche de synaptic ca n etrouve rien, et si je tape libc il y a bcp de chose, je ne sais quoi prendre (sachant que libc6 je l'ai apparament)

Les man aussi tel que man printf ne fonctionne pas...

C'est suremetn une question bateau mais si on pouvait me donner un coup de main, cela me permettrai d'adopter definitivement ubuntu

Merci
Alexandre

#2 Le 17/12/2005, à 18:42

thx1138

Re : Installer les bonne librairy

Il faut installer un minimum de paquets, effectivement.
Installe le paquet libc6-dev, il devrait contenir ce que tu désires, à savoir les fichiers d'en-tête pour la programmation C.

En ce qui concerne les pages de manuel, les paquets manpages-dev et manpages-fr feront l'affaire.
Le premier paquet contient les pages de manuel pour développeur (manuel des fonctions C, appels systèmes, etc ...) et le deuxième contient des pages de manuel non-développeur, mais en français.


They did not know it was impossible, so they did it - Mark Twain

Hors ligne