Contenu | Rechercher | Menus

Annonce

Si vous rencontrez des soucis à rester connecté sur le forum (ou si vous avez perdu votre mot de passe) déconnectez-vous et reconnectez-vous depuis cette page, en cochant la case "Me connecter automatiquement lors de mes prochaines visites".

#1 Le 15/10/2013, à 14:59

pti-jean

[Résolu] Pb pas de tableau de bord ni de floritures aux fenêtres

Bonjour,

J'ai un problème, sur mon Kde, je n'ai plus de tableau de bord ni de floritures aux fenêtres...
Je ne sais pas trop comment vérifier la version de Kde... il semble que cela soit la 4
J'ai commencé par créer un fil ici:
http://forum.kubuntu-fr.org/viewtopic.php?id=1392031
en pensant qu'il s'agissait peut-être d'un problème lié au driver graphique... en réalité je sais pas... mais ce que je sais c'est qu'avec l'interface vnc4server le problème est toujours présent... il semble donc que cela ne soit pas lié à la gestion du matériel.

Donc si mon pronostic est bon, c'est un problème purement lié à kde...
Je m'en remet donc à vous pour essayer de me sortir de cette problématique.

JM

Dernière modification par pti-jean (Le 20/10/2013, à 17:04)


Chalet à vendre Vosges Le Menil 88 Cadre très joli au bord d'un étang:
http://chalet-du-ruisseau.over-blog.fr/
http://youtu.be/clNc4pXWXsI

Hors ligne

#2 Le 15/10/2013, à 15:40

line

Re : [Résolu] Pb pas de tableau de bord ni de floritures aux fenêtres

Salut,

Un cp -R .kde .kde_bak && rm -R .kde depuis un tty sans etre connecté a ta session kde devrait te remettre les parmatres d'aorigine wink si ce n'est pas le cas ou que tu veux en recuperer certains (ou les icones par exemples) tout sera present dans le rep .kde_bak wink

Hors ligne

#3 Le 15/10/2013, à 16:22

pti-jean

Re : [Résolu] Pb pas de tableau de bord ni de floritures aux fenêtres

Bonjour line,

Cela me semble plus compliqué que ça, car j'ai créé un nouvel utilisateur:

sudo adduser test

et le problème est présent aussi dans ce nouvel utilisateur!

JM


Chalet à vendre Vosges Le Menil 88 Cadre très joli au bord d'un étang:
http://chalet-du-ruisseau.over-blog.fr/
http://youtu.be/clNc4pXWXsI

Hors ligne

#4 Le 15/10/2013, à 21:03

line

Re : [Résolu] Pb pas de tableau de bord ni de floritures aux fenêtres

Alors le probleme viendrait du driver graphique apparement vu ce que j'ai lu la: http://www.kubuntuforums.net/archive/in … 60649.html et la: http://dragly.org/2012/05/04/installing … ntu-12-04/

je cite un post de la derniere page:

"As a side note, I resolved mine merely by using apt to install nvidia-current-updates (or nvidia current) as the packages include the kernel source for compiling the modules. Why Jockey is pulling down a package without the ability is beyond me, but I'll leave it at that."

Hors ligne

#5 Le 16/10/2013, à 16:14

pti-jean

Re : [Résolu] Pb pas de tableau de bord ni de floritures aux fenêtres

Re,

Voila les commandes que j'ai exécutées en suivant cette page:
http://dragly.org/2012/05/04/installing … ntu-12-04/

$ jockey-text -l
ERROR:root:Could not find any typelib for AppIndicator3
kmod:nvidia_304 - NVIDIA binary Xorg driver, kernel module and VDPAU library (Propriétaire, Désactivé, Non utilisé)
kmod:nvidia_304_updates - nvidia_304_updates (Propriétaire, Activé, Non utilisé)
kmod:nvidia_319 - NVIDIA binary Xorg driver, kernel module and VDPAU library (Propriétaire, Désactivé, Non utilisé)
kmod:nvidia_319_updates - NVIDIA binary Xorg driver, kernel module and VDPAU library (Propriétaire, Désactivé, Non utilisé)
$ sudo jockey-text -d kmod:nvidia_304_updates
[sudo] password for jean-marc: 
ERROR:root:Could not find any typelib for AppIndicator3
$ jockey-text -l
ERROR:root:Could not find any typelib for AppIndicator3
kmod:nvidia_304 - NVIDIA binary Xorg driver, kernel module and VDPAU library (Propriétaire, Désactivé, Non utilisé)
kmod:nvidia_304_updates - nvidia_304_updates (Propriétaire, Désactivé, Non utilisé)
kmod:nvidia_319 - NVIDIA binary Xorg driver, kernel module and VDPAU library (Propriétaire, Désactivé, Non utilisé)
kmod:nvidia_319_updates - NVIDIA binary Xorg driver, kernel module and VDPAU library (Propriétaire, Désactivé, Non utilisé)

Puis:

$ sudo apt-get update
...
$ dpkg -al | grep nvidia
rc  nvidia-304-updates                                          304.88-0ubuntu0.0.3                                 NVIDIA binary Xorg driver, kernel module and VDPAU library
ii  nvidia-settings-304-updates                                 304.88-0ubuntu0.0.3                                 Tool for configuring the NVIDIA graphics driver
$
$ sudo apt-get purge `dpkg -al | grep nvidia | cut -f3 -d" "`
[sudo] password for jean-marc: 
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances       
Lecture des informations d'état... Fait
Les paquets suivants ont été installés automatiquement et ne sont plus nécessaires :
  screen-resolution-extra libkwineffects1abi3 kmenuedit kde-window-manager-common dkms
  kinfocenter libkwinglutils1
Veuillez utiliser « apt-get autoremove » pour les supprimer.
Les paquets suivants seront ENLEVÉS :
  nvidia-304-updates* nvidia-settings-304-updates*
0 mis à jour, 0 nouvellement installés, 2 à enlever et 62 non mis à jour.
Après cette opération, 4 150 ko d'espace disque seront libérés.
Souhaitez-vous continuer [O/n] ? o
(Lecture de la base de données... 295719 fichiers et répertoires déjà installés.)
Suppression de nvidia-304-updates ...
Purge des fichiers de configuration de nvidia-304-updates ...
update-initramfs: deferring update (trigger activated)
Suppression de nvidia-settings-304-updates ...
Purge des fichiers de configuration de nvidia-settings-304-updates ...
Traitement des actions différées (« triggers ») pour « initramfs-tools »...
update-initramfs: Generating /boot/initrd.img-3.2.0-55-generic
Traitement des actions différées (« triggers ») pour « libc-bin »...
ldconfig deferred processing now taking place
$
$ dpkg -al | grep nvidia
$
$ sudo reboot

Est-il normal qu’après le redémarrage, sans driver nvidia sur la machine je constate toujours le même problème (cad pas de tableau de bord ni de floritures aux fenêtres) ?

$ xrandr
Screen 0: minimum 320 x 200, current 640 x 480, maximum 8192 x 8192
LVDS-1 connected 640x480+0+0 (normal left inverted right x axis y axis) 382mm x 215mm
   640x480        59.4*
DVI-D-1 disconnected (normal left inverted right x axis y axis)
VGA-1 disconnected (normal left inverted right x axis y axis)

Puis:

$ sudo apt-get install linux-source
[sudo] password for jean-marc: 
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances       
Lecture des informations d'état... Fait
linux-source est déjà la plus récente version disponible.
Les paquets suivants ont été installés automatiquement et ne sont plus nécessaires :
  screen-resolution-extra libkwineffects1abi3 kmenuedit kde-window-manager-common dkms
  kinfocenter libkwinglutils1
Veuillez utiliser « apt-get autoremove » pour les supprimer.
0 mis à jour, 0 nouvellement installés, 0 à enlever et 62 non mis à jour.
$
$ sudo apt-get install linux-headers-generic
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances       
Lecture des informations d'état... Fait
linux-headers-generic est déjà la plus récente version disponible.
Les paquets suivants ont été installés automatiquement et ne sont plus nécessaires :
  screen-resolution-extra libkwineffects1abi3 kmenuedit kde-window-manager-common dkms
  kinfocenter libkwinglutils1
Veuillez utiliser « apt-get autoremove » pour les supprimer.
0 mis à jour, 0 nouvellement installés, 0 à enlever et 62 non mis à jour.
$
$ sudo apt-get install linux-image
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances       
Lecture des informations d'état... Fait
linux-image est déjà la plus récente version disponible.
Les paquets suivants ont été installés automatiquement et ne sont plus nécessaires :
  screen-resolution-extra libkwineffects1abi3 kmenuedit kde-window-manager-common dkms
  kinfocenter libkwinglutils1
Veuillez utiliser « apt-get autoremove » pour les supprimer.
0 mis à jour, 0 nouvellement installés, 0 à enlever et 62 non mis à jour.

Puis:

$ sudo apt-get install nvidia-current-updates
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances       
Lecture des informations d'état... Fait
Les paquets suivants ont été installés automatiquement et ne sont plus nécessaires :
  libkwineffects1abi3 kmenuedit kde-window-manager-common kinfocenter libkwinglutils1
Veuillez utiliser « apt-get autoremove » pour les supprimer.
Les paquets supplémentaires suivants seront installés : 
  nvidia-304-updates nvidia-settings-304-updates
Les NOUVEAUX paquets suivants seront installés :
  nvidia-304-updates nvidia-current-updates nvidia-settings-304-updates
0 mis à jour, 3 nouvellement installés, 0 à enlever et 62 non mis à jour.
Il est nécessaire de prendre 0 o/70,2 Mo dans les archives.
Après cette opération, 210 Mo d'espace disque supplémentaires seront utilisés.
Souhaitez-vous continuer [O/n] ? o
Sélection du paquet nvidia-304-updates précédemment désélectionné.
(Lecture de la base de données... 295651 fichiers et répertoires déjà installés.)
Dépaquetage de nvidia-304-updates (à partir de .../nvidia-304-updates_304.88-0ubuntu0.0.3_amd64.deb) ...
Sélection du paquet nvidia-current-updates précédemment désélectionné.
Dépaquetage de nvidia-current-updates (à partir de .../nvidia-current-updates_304.88-0ubuntu0.0.3_amd64.deb) ...
Sélection du paquet nvidia-settings-304-updates précédemment désélectionné.
Dépaquetage de nvidia-settings-304-updates (à partir de .../nvidia-settings-304-updates_304.88-0ubuntu0.0.3_amd64.deb) ...
Traitement des actions différées (« triggers ») pour « man-db »...
Traitement des actions différées (« triggers ») pour « desktop-file-utils »...
Paramétrage de nvidia-304-updates (304.88-0ubuntu0.0.3) ...
update-alternatives: utilisation de « /usr/lib/nvidia-304-updates/ld.so.conf » pour fournir « /etc/ld.so.conf.d/x86_64-linux-gnu_GL.conf » (x86_64-linux-gnu_gl_conf) en mode automatique.
update-alternatives: utilisation de « /usr/lib/nvidia-304-updates/alt_ld.so.conf » pour fournir « /etc/ld.so.conf.d/i386-linux-gnu_GL.conf » (i386-linux-gnu_gl_conf) en mode automatique.
update-initramfs: deferring update (trigger activated)
Loading new nvidia-304-updates-304.88 DKMS files...
First Installation: checking all kernels...
Building only for 3.2.0-55-generic
Building for architecture x86_64
Building initial module for 3.2.0-55-generic
Done.

nvidia_304_updates:
Running module version sanity check.
 - Original module
   - No original module exists within this kernel
 - Installation
   - Installing to /lib/modules/3.2.0-55-generic/updates/dkms/

depmod....

DKMS: install completed.
Paramétrage de nvidia-current-updates (304.88-0ubuntu0.0.3) ...
Paramétrage de nvidia-settings-304-updates (304.88-0ubuntu0.0.3) ...
update-alternatives: avertissement: l'alternative /usr/lib/nvidia-settings-304/ld.so.conf (qui fait partie du groupe de liens nvidia_settings_conf) n'a pas été trouvée. Suppression de la liste des alternatives.
update-alternatives: avertissement: /etc/alternatives/nvidia_settings_conf pointe dans le vide et sera mis à jour avec le choix le plus adapté.
update-alternatives: utilisation de « /usr/lib/nvidia-settings-304-updates/ld.so.conf » pour fournir « /etc/ld.so.conf.d/nvidia_settings.conf » (nvidia_settings_conf) en mode automatique.
Traitement des actions différées (« triggers ») pour « initramfs-tools »...
update-initramfs: Generating /boot/initrd.img-3.2.0-55-generic

Puis:

$ sudo jockey-text -e xorg:nvidia_current-updates
ERROR:root:Could not find any typelib for AppIndicator3
Pilotes additionnels
Recherche des pilotes disponibles...
Pilote inconnu: xorg:nvidia_current-updates
Utilisez --list pour voir les pilotes disponibles
$
$ sudo jockey-text -e xorg:nvidia_current_updates
ERROR:root:Could not find any typelib for AppIndicator3
Pilote inconnu: xorg:nvidia_current_updates
Utilisez --list pour voir les pilotes disponibles
$
$ sudo jockey-text -l
ERROR:root:Could not find any typelib for AppIndicator3
kmod:nvidia_304 - NVIDIA binary Xorg driver, kernel module and VDPAU library (Propriétaire, Désactivé, Non utilisé)
kmod:nvidia_304_updates - nvidia_304_updates (Propriétaire, Désactivé, Non utilisé)
kmod:nvidia_319 - NVIDIA binary Xorg driver, kernel module and VDPAU library (Propriétaire, Désactivé, Non utilisé)
kmod:nvidia_319_updates - NVIDIA binary Xorg driver, kernel module and VDPAU library (Propriétaire, Désactivé, Non utilisé)
$
$ dpkg -al | grep nvidia
ii  nvidia-304-updates                                          304.88-0ubuntu0.0.3                                 NVIDIA binary Xorg driver, kernel module and VDPAU library
ii  nvidia-current-updates                                      304.88-0ubuntu0.0.3                                 Transitional package for nvidia-current-updates
ii  nvidia-settings-304-updates                                 304.88-0ubuntu0.0.3                                 Tool for configuring the NVIDIA graphics driver
$
$ sudo jockey-text -e kmod:nvidia_304_updates
ERROR:root:Could not find any typelib for AppIndicator3
$
$ sudo jockey-text -l
ERROR:root:Could not find any typelib for AppIndicator3
kmod:nvidia_304 - NVIDIA binary Xorg driver, kernel module and VDPAU library (Propriétaire, Désactivé, Non utilisé)
kmod:nvidia_304_updates - nvidia_304_updates (Propriétaire, Activé, Non utilisé)
kmod:nvidia_319 - NVIDIA binary Xorg driver, kernel module and VDPAU library (Propriétaire, Désactivé, Non utilisé)
kmod:nvidia_319_updates - NVIDIA binary Xorg driver, kernel module and VDPAU library (Propriétaire, Désactivé, Non utilisé)
$
$ sudo reboot

Au redémarrage le problème est toujours présent!

Et:

$ xrandr
Screen 0: minimum 8 x 8, current 1600 x 900, maximum 8192 x 8192
VGA-0 disconnected (normal left inverted right x axis y axis)
LVDS-0 connected 1600x900+0+0 (normal left inverted right x axis y axis) 382mm x 215mm
   1600x900       60.1*+
DVI-D-0 disconnected (normal left inverted right x axis y axis)
$
$ glxinfo | grep "direct rendering"
direct rendering: Yes

Un info... je sais pas si elle a un rapport, mais quand j'ai fait la maintenance des paquets... le paquet dkms c'est montré très réticent... impossible d'en faire quoi que ce soit... impossible à réinstaller... impossible à désinstaller... il semble maintenant que ce soit rentré dans l'ordre, mais cela n'est-il qu'une impression ???

Pour le moment je sèche... rien ne résous mon problème!

JM


Chalet à vendre Vosges Le Menil 88 Cadre très joli au bord d'un étang:
http://chalet-du-ruisseau.over-blog.fr/
http://youtu.be/clNc4pXWXsI

Hors ligne

#6 Le 17/10/2013, à 14:55

TNZ

Re : [Résolu] Pb pas de tableau de bord ni de floritures aux fenêtres

Je sais pas si ça peut t'aider  : la dernière fois que j'ai eu à gérer un pilote nVidia sous Ubuntu, il fallait le faire à la console (Ctrl-Alt-F1) après avoir shooté le serveur X avec un "sudo gdm stop". Cette procédure de compilation / installation des pilotes était clairement mise en avant dans le README. Ça s'était au taf.
hmm

Pour chez moi, je tourne avec des Radeon/Catalyst et le DKMS ne m'a jamais posé de problème. Les mises à jour en mode graphique passent comme papa dans maman.
smile


L'engin : Msi 990FXA-GD65 , FX8350, 8 Go ddr3-1866, Radeon HD7970
Les softs : Ubuntu64 13.10, KDE SC 4.12.0

Hors ligne

#7 Le 18/10/2013, à 21:07

pti-jean

Re : [Résolu] Pb pas de tableau de bord ni de floritures aux fenêtres

Bonjour TNZ,

C'était avant... quand on avait à télécharger le driver manuellement!
Aujourd'hui les drivers sont intégrés directement sous forme de paquets... du coup ta méthode est obsolète... non ?

JM


Chalet à vendre Vosges Le Menil 88 Cadre très joli au bord d'un étang:
http://chalet-du-ruisseau.over-blog.fr/
http://youtu.be/clNc4pXWXsI

Hors ligne

#8 Le 18/10/2013, à 21:22

pti-jean

Re : [Résolu] Pb pas de tableau de bord ni de floritures aux fenêtres

La où cela m’inquiète c'est cette partie:

Les paquets suivants ont été installés automatiquement et ne sont plus nécessaires :
  screen-resolution-extra libkwineffects1abi3 kmenuedit kde-window-manager-common dkms
  kinfocenter libkwinglutils1
Veuillez utiliser « apt-get autoremove » pour les supprimer.

quand j'utilise apt-get...

Que me conseillez-vous ?
appliquer "apt-get autoremove"...
ou y-aurait-il des paquets importants de Kde qui auraient sautés ?

JM

Dernière modification par pti-jean (Le 18/10/2013, à 21:23)


Chalet à vendre Vosges Le Menil 88 Cadre très joli au bord d'un étang:
http://chalet-du-ruisseau.over-blog.fr/
http://youtu.be/clNc4pXWXsI

Hors ligne

#9 Le 19/10/2013, à 09:54

bruno

Re : [Résolu] Pb pas de tableau de bord ni de floritures aux fenêtres

Tu devrais recommencer :
- purger les paquets nvidia*
- installer le paquet kubuntu-desktop

Si cela fonctionne, tu pourras installer le pilote propriétaire nvidia avec jockey ou avec apt-get :

sudo apt-get install nvidia-current

Dernière modification par bruno (Le 19/10/2013, à 16:16)

Hors ligne

#10 Le 19/10/2013, à 16:05

pti-jean

Re : [Résolu] Pb pas de tableau de bord ni de floritures aux fenêtres

Bien vu Bruno... un bon progrès!

Donc maintenant j'ai la floreiture aux fenêtres sans drivers et avec le driver privateur... et avec l'accélération 3D activé!

Donc de ce côté là c'est bon.



Un problème reste à résoudre... il semble qu'il n'est rien à voir avec l'accélération graphique... il s'agit du tableau de bord qui reste absent...

Pour cela j'ai une piste:

$ sudo apt-get -f install
[sudo] password for jean-marc: 
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances       
Lecture des informations d'état... Fait
Les paquets suivants ont été installés automatiquement et ne sont plus nécessaires :
  kmenuedit kinfocenter
Veuillez utiliser « apt-get autoremove » pour les supprimer.
0 mis à jour, 0 nouvellement installés, 0 à enlever et 84 non mis à jour.

Je pense qui si je trouve pourquoi ces paquets (kmenuedit, kinfocenter) ne sont plus nécessaires, alors je croie que je vais résoudre mon problème de tableau de bord!
Qu'en pensez-vous ?

JM


Chalet à vendre Vosges Le Menil 88 Cadre très joli au bord d'un étang:
http://chalet-du-ruisseau.over-blog.fr/
http://youtu.be/clNc4pXWXsI

Hors ligne

#11 Le 19/10/2013, à 16:15

bruno

Re : [Résolu] Pb pas de tableau de bord ni de floritures aux fenêtres

Clic droit sur le bureau -> Ajouter un tableau de bord -> tableau de bord par défaut (déverrouiller au préalable les composants graphiques si nécessaire).

Est-ce que cela fonctionne ?

Hors ligne

#12 Le 19/10/2013, à 16:33

pti-jean

Re : [Résolu] Pb pas de tableau de bord ni de floritures aux fenêtres

Non Bruno... ça fonctionne pas!

Indice: après avoir redémarrer après la crach disque, j'ai eu des messages d'erreurs qui ne volaient pas exécuter les scripts contenus dans  ~/.kde/Autostart/ ... puis j'ai démarré sur un vieux kernel 2.6, parce que c'était le seul à ce moment là à gérer l'interface réseau...
C'est après avoir démarré avec le noyau 2.6 que le tableau de bord avait disparu.

Une idée ?

JM


Chalet à vendre Vosges Le Menil 88 Cadre très joli au bord d'un étang:
http://chalet-du-ruisseau.over-blog.fr/
http://youtu.be/clNc4pXWXsI

Hors ligne

#13 Le 19/10/2013, à 16:46

bruno

Re : [Résolu] Pb pas de tableau de bord ni de floritures aux fenêtres

Tu as vérifié ton disque après le crash ? Parce que normalement avec kubuntu-desktop tous les paquets essentiels au bon fonctionnement de KDE sont présents. La manip que j'ai indiqué aurait dû fonctionner !
Vérifie quand même que le paquet kubuntu-default-settings est bien installé.

Hors ligne

#14 Le 19/10/2013, à 16:55

pti-jean

Re : [Résolu] Pb pas de tableau de bord ni de floritures aux fenêtres

Oui, après le crach j'ai formaté le disque bas niveau... mais effectivement peut-être qu'il faut le changer... pourtant cela me semblé maintenant stable ??
Le paquet kubuntu-default-settings est bien présent!

Bruno, une autre suggestion... ou je vais direct acheter un disque ?

JM


Chalet à vendre Vosges Le Menil 88 Cadre très joli au bord d'un étang:
http://chalet-du-ruisseau.over-blog.fr/
http://youtu.be/clNc4pXWXsI

Hors ligne

#15 Le 19/10/2013, à 18:01

line

Re : [Résolu] Pb pas de tableau de bord ni de floritures aux fenêtres

Alors pour le disque il pourrait etre interessant de le tester avec un programme fait pour (gnome-disk-utility par exemple) afin d'eviter des frais inutiles wink Apres effectivement ca pourrait etre des secteurs defectueux qui empecheraient d'acceder a certains blocs ^^

Pour ce qui est de dkms est ce que les depots necessaires sont actifs? je sais que sous debian stable il faut activer contrib et non-free afin d'avoir acces a tout les paquets necessaires a l'installation... Apres sous ubuntu je ne sais pas et perso sous kubuntu avec ma nvidia (pc d'ou j'ecris) je n'ai eu qu'a installer via jockey-gtk (pilotes supplementaires sous KDE)

[EDIT] et pour le disque pourquoi ne pas faire une install sur une cle usb (ou autre) afin de verifier que le probleme vient bien de la?

Dernière modification par line (Le 19/10/2013, à 18:02)

Hors ligne

#16 Le 19/10/2013, à 18:22

pti-jean

Re : [Résolu] Pb pas de tableau de bord ni de floritures aux fenêtres

Ok line... pas de soucis, j'ai un nouveau disque dur... j'ai été contraint de faire vite... le magasin d'accoté de chez moi fermant à 18h et demain c'est dimanche!

Dans tout les cas, je commençais à douter du disque dur!

Je vais donc tester avec le nouveau disque, et je reviens vers vous.

JM


Chalet à vendre Vosges Le Menil 88 Cadre très joli au bord d'un étang:
http://chalet-du-ruisseau.over-blog.fr/
http://youtu.be/clNc4pXWXsI

Hors ligne

#17 Le 20/10/2013, à 17:00

pti-jean

Re : [Résolu] Pb pas de tableau de bord ni de floritures aux fenêtres

Bonjour,

Bonne nouvelle... j'y suis arrivé à bout!

Depuis le début de mon histoire, je me suis référé à cette page:
http://arthurdejong.org/recovery.html
pour réparer ma distribution après mon crach!
Plus particulièrement au chapitre 4.

En résumé, je fais:

$ sudo apt-get clean
sudo apt-get --reinstall install debsums

Puis:

cd /var/cache/apt/archives
sudo apt-get --download-only --reinstall install `debsums -l | grep -v dbgsym`
sudo debsums --generate=keep,nocheck *.deb
sudo debsums -s -a 2> /tmp/broken.log

puis:

sed -n 's/^.*\(checksum mismatch\|changed file\) \([^ ]*\) file.*$/\1/p;s/^.*t open \([^ ]*\) file.*$/\1/p' < /tmp/broken.log | sort -u > /tmp/broken.pkgs

Seulement le fichier "broken.pkgs" qui vient d'être créé ne tien pas compte des fichiers manquants ("missing file")...

Ce qui fait que la commande:

sudo apt-get --reinstall install `cat /tmp/broken.pkgs`

répare bien la distribution... mais dans mon cas comme j'ai un ta de "missing file", ils sont pas réparé!

J'ai donc exécuté une commande de mon crue pour dresser la liste des paquets contenants des fichiers manquants:

$ cat /tmp/broken.log | grep "missing file" | cut -f6 -d" " | sort -u > /tmp/broken.missing.pkg

Et du coup j'ai exécuté cette commande pour réparer:

$ sudo apt-get --reinstall install `cat /tmp/broken.pkgs /tmp/broken.missing.pkg`

Ça bien fonctionné... j'ai bien retrouvé mon bureau!

Et le disque dur d'origine, je sais pas s'il est encore fiable!!!

Merci à tous,

JM


Chalet à vendre Vosges Le Menil 88 Cadre très joli au bord d'un étang:
http://chalet-du-ruisseau.over-blog.fr/
http://youtu.be/clNc4pXWXsI

Hors ligne

#18 Le 20/10/2013, à 17:39

line

Re : [Résolu] Pb pas de tableau de bord ni de floritures aux fenêtres

re

Alors merci du retour et des explications detaillées ainsi que des commandes ca pourrait servir a d'autres wink
Pour l'ancien hdd il suffit de le tester avec un logiciel qui analyse les données SMART afin d'avoir un apercu assez fiable de son etat wink

Hors ligne

#19 Le 20/10/2013, à 17:56

pti-jean

Re : [Résolu] Pb pas de tableau de bord ni de floritures aux fenêtres

Salut line,

Je croie que mon disque dur a un cluster défectueux au niveau de la définition de la table des partions... c'est certainement pour cette raison que j'ai perdu autan de fichiers!

Quand j'ai fait la sauvegarde de ma partition racine avec la commande dd, j'ai aussi sauvé le mbr... et une fois le formatage bas niveau du disque dur... impossible de rétablir la table des partitions à partir de sauvegarde du mbr! ce qui me fait penser qu'il doit y avoir un cluster défectueux directement au niveau de la définition de la table des partitions!

Maintenant un truc magique... avec un des outils xParted, j'ai pu recréer une table des partitions valide... maintenant je ne sais pas quel en est la fiabilité ???

JM


Chalet à vendre Vosges Le Menil 88 Cadre très joli au bord d'un étang:
http://chalet-du-ruisseau.over-blog.fr/
http://youtu.be/clNc4pXWXsI

Hors ligne

  • Accueil
  • » Forum
  • » KDE
  • » [Résolu] Pb pas de tableau de bord ni de floritures aux fenêtres

Haut de page ↑