Contenu | Rechercher | Menus

Annonce

Si vous rencontrez des soucis à rester connecté sur le forum (ou si vous avez perdu votre mot de passe) déconnectez-vous et reconnectez-vous depuis cette page, en cochant la case "Me connecter automatiquement lors de mes prochaines visites".

#1 Le 21/10/2013, à 19:31

chicard

Virtualbox et Debian

Bonjour,

Je souhaite installer une Debian (la dernière version stable) en virtuel sur Virtualbox.

Je suis sous Saucy (13.10) et j'utilise l'ISO de la net install (debian-7.2.0-i386-netinst;iso). Jusqu'à avant l'installation des paquets APT tout va bien à partir de APT les fichiers montent jusqu'à 5 sur 17 puis s'arrêtent. J'ai beau changé de miroir en http ça n'avance pas. Enn ftp il me propose juste mirror puis /debian/ et ça avance pas plus. Je n'ai pas de serveur mandataire pour le http ni pour le ftp.

A l'install je choisi l'environnement graphique, le serveur de fichiers, les serveur ssh mis par défaut) et le système standard.

J'aurais bien besoin d'un coup de main s'il vous plait.

Merci.

Dernière modification par chicard (Le 21/10/2013, à 19:38)

Hors ligne

#2 Le 21/10/2013, à 21:18

src

Re : Virtualbox et Debian

Utilises-tu un reseau en pont ou en NAT ?


Actuellement sur Xubuntu 14.04 (amd64)
Serveur sur FreeBSD 9.2 (i386)
http://maniatux.fr

En ligne

#3 Le 22/10/2013, à 09:48

chicard

Re : Virtualbox et Debian

J'utilise le réseau en NAT

Hors ligne

#4 Le 22/10/2013, à 11:14

mazarini

Re : Virtualbox et Debian

As tu activé masquerade pour que ta vm puisse communiquer avec l'extérieur ?

Dernière modification par mazarini (Le 22/10/2013, à 11:14)


Je suis désolé de t'avoir blessé en te traitant de con. Je croyais que tu le savais déjà...

Hors ligne

#5 Le 22/10/2013, à 11:37

chicard

Re : Virtualbox et Debian

C'est le nom en français? Je ne sais pas. Je sais que sur la config de la VM j'ai pas mis le glisser déposer, ni les I/O APCI. Il y a un autre composant que j'ai pas activé mais là je suis pas devant et le nom m'échappe. Je modifierais le message ce soir avec le nom du manquant.

Hors ligne

#6 Le 22/10/2013, à 11:50

mazarini

Re : Virtualbox et Debian

A priori, je te conseille de mettre le réseau de ta machine virtuelle en mode pont (bridge). Ca permet à ta machine virtuelle d'avoir accès à internet directement sans complication.

En mode routage ou nat, il faut faire quelque chose sur la machine hote pour que la vm communique à l'extérieur. En particulier, il faut modifier les paquets envoyer pour remplacer l'adresse de la VM par celle de l'hote (c'est ce que l'on appelle le masquerading)

C'est un peu comme pour la poste quand on met Mr X chez Mr Y alors que pour le bridge on met 2 étiquettes sur la boite aux lettres.


Je suis désolé de t'avoir blessé en te traitant de con. Je croyais que tu le savais déjà...

Hors ligne

#7 Le 22/10/2013, à 12:01

chicard

Re : Virtualbox et Debian

D'accord. C'est "bizarre" (le mot n'est pas le bon mais faute de mieux) mais je comprends pourtant l'autre daube (windows pour ne pas le nommer) qui si ma mémoire est bonne est configurer pareil lui ce connecte bien au web. Mais bon je changerais ça en rentrant.

Hors ligne

#8 Le 22/10/2013, à 12:21

maxire

Re : Virtualbox et Debian

Bonjour,

Pont ou Nat normalement pas de problème de connexion. C'était le cas voici quelques années et c'était, je crois, la connexion par pont qu'il fallait paramétrer de manière spécifique pour accéder au réseau externe.
J'utilise les deux sans paramétrage particulier. J'utilise la connexion par pont lorsque je veux que ma machine virtuelle soit visible du réseau local (de l'ordinateur hôte par exemple) et la connexion Nat dans le cas contraire.

Je pense à 4 possibilités d'explication à ton problème :

1 - Les serveurs Debian sont surchargés, ce qui ne semblerait pas être le cas puisque tu as testé plusieurs miroirs
2 - Ubuntu 13.10 lui-même, c'est une version récente et certainement encore instable
3- La version de VirtualBox, généralement il est conseillé d'utiliser la dernière version stable (4.3 ou 4.2.18) mise à disposition par Oracle à cette adresse VirtualBox, mais il n'existe pas encore de version disponible pour Ubuntu 13.10 Saucy à ce jour ce qui nous renvoie au point 2.
4- Un problème avec le disque d'installation lui-même, peut-être qu'en essayant un autre type d'installation cela marcherait mieux  ...


Maxire
Archlinux/Mate sur portable -- Mint 13/Mate sur poste de travail + Multiboot Archlinux/Mate, Wheezy/Gnome, Trusty/Xubuntu, Trusty/Unity

Hors ligne

#9 Le 22/10/2013, à 12:30

chicard

Re : Virtualbox et Debian

La première install de debian j'avais gravé l'iso du mini cd puis graver celui de l'a net (problème de vitesse de gravure du cd en plus du reste). Puis sur un topic su forum j'ai vu que je pouvais utilisé directement l'image iso ( et oui je suis un peu con). Je verrais si avec le pont ça ne marche pas mieux je referais un test avec l'iso du mini cd.

La version de virtualbox étant celle de la 13.04, il s'agit de la 4.2.18 qui fonctionnait plutot bien sur la 13.04.

Hors ligne

#10 Le 22/10/2013, à 13:32

mazarini

Re : Virtualbox et Debian

Pour utiliser masquerade :

$> echo 1 > /proc/sys/net/ipv4/ip_forward
$> iptables -t nat -A POSTROUTING -o eth0 -j SNAT --to 123.345.567.789

123.345.567.789 : adresse de la machine hote.


Je suis désolé de t'avoir blessé en te traitant de con. Je croyais que tu le savais déjà...

Hors ligne

#11 Le 22/10/2013, à 18:48

chicard

Re : Virtualbox et Debian

Les lignes de masquerade ne fonctionnent pas

:~$ echo 1 > /proc/sys/net/ipv4/ip_forwardbash: /proc/sys/net/ipv4/ip_forward: Permission non accordée

:~$ sudo echo 1 > /proc/sys/net/ipv4/ip_forwardbash: /proc/sys/net/ipv4/ip_forward: Permission non accordée

:~$ iptables -t nat -A POSTROUTING -o eth0 -j SNAT --to 192.xxx.xxx.xxx
ERROR: could not insert 'ip_tables': Operation not permitted
iptables v1.4.18: can't initialize iptables table `nat': Table does not exist (do you need to insmod?)
Perhaps iptables or your kernel needs to be upgraded.
 

De plus en passant par le pont il faut que je configure mon réseau à la main car la config automatique ne fonctionne paset je pense que je dois peut-etre me planter quelque par.

Hors ligne

#12 Le 23/10/2013, à 19:34

chicard

Re : Virtualbox et Debian

bon j'ai toujours pas réussi.

j'ai suivi un tuto et modifié mon fichirer /etc/network/interfaces comme ceci:

#Virtualbox
auto tap0
iface tap0 inet manual
up ifconfig $IFACE 0.0.0.0 up
down ifconfig $IFACE down
tuncl_user sylvain

#Bridge
auto br0
iface br0 inet dhcp
bridge_ports all tap0

Après avoir redémarré br0 est reconnu. Au niveau de la carte réseau que cela soit br0 ou eth0 que cela soit 192.168.0.5 ou les valeurs du serveur de virtualbox en 192.168.56.x c'est pareil ça plante au niveau du ftp.

Je suis repassé en nat et là ça passe jusqu'à la configuration des fichiers (il a pris les 1280) mais après au moment le la décompression initialisation et installation il plante.

Je sais plus comment faire. Dire que si j'installe ubuntu ça passe tout seul (mais bon si je mets debian c'est que je veux pas ubuntu).

Hors ligne

#13 Le 23/10/2013, à 21:14

mazarini

Re : Virtualbox et Debian

Moi j'aurai bridgé eth0
Grace au bridge sur eth0, la VM a un accès à l'extérieur avec une adresse de même type que l'hote (192.168.0.X).


Je suis désolé de t'avoir blessé en te traitant de con. Je croyais que tu le savais déjà...

Hors ligne

#14 Le 24/10/2013, à 08:24

chicard

Re : Virtualbox et Debian

Sans la modification du /etc/network/interfaces je n'ai même pas ma config du eth0. Je pense que c'est du au fait que je suis en baut dhcp auto pour avoir un adresse fixe dans mon réseau local.

Quand je monte mon bridge en général la liaison utilisé est eth0 mais le problème reste entier.

Bon j'ai fait un pont et eth0 était la liaison pont et br0 ma liaison internet du coup ma connexion était pas terrible t en mettant br0 comme réseau hote ça change rien.

J'ai essayé sur kvm et le problème est le même.

Dernière modification par chicard (Le 25/10/2013, à 08:39)

Hors ligne

#15 Le 28/10/2013, à 11:40

chicard

Re : Virtualbox et Debian

bon mon problème avance, maintenant je passe le cap du ftp et l'install "plante" au niveau du choix des logiciels. Il commence à en télécharger (j'en suis pas sur mais dans le doute) puis extraction installation  et vers 20% problème. Je lui demande pas la lune, juste l'environnement graphique, le serveur de fichier, le serveur SSH est par défaut (mais le problème est le même quand je l'enlève) et le systèmes de base qui est un peu obligatoire.

Bon. Mon pont fonctionne (pas en DHCP aller comprendre ) et mon install c'est faite (utilisation du mini cd).

Pour ceux qui en aurait besoin : pour faire un pont suivait la méthode de la doc sur virualbox qui est sur ici et pour info voici mon fichier /etc/network/interface:

 # interfaces(5) file used by ifup(8) and ifdown(8)
auto lo
iface lo inet loopback

auto eth0
iface eth0 inet manual


auto tap0
iface tap0 inet manual
	up ifconfig $IFACE up
	down ifconfig $IFACE down
	tunctl_user $user

#Bridge
auto br0
iface br0 inet dhcp
	bridge_ports eth0 tap0

Si jamais le dhcp est pas découvert lors de l'intall rentré un adresse qui est couverte par le dhcp.

Merci à tous pour votre aide.

Dernière modification par chicard (Le 02/11/2013, à 17:36)

Hors ligne

Haut de page ↑