Contenu | Rechercher | Menus

Annonce

Si vous rencontrez des soucis à rester connecté sur le forum (ou si vous avez perdu votre mot de passe) déconnectez-vous et reconnectez-vous depuis cette page, en cochant la case "Me connecter automatiquement lors de mes prochaines visites".
Test de l'ISO d'Ubuntu francophone : nous avons besoin de testeurs pour la version francophone d'Ubuntu 14.04. Liens et informations ici.

#1 Le 22/10/2013, à 10:21

DJ Raging-Bull

[Résolu] 13.10 Ecran noir après écran de choix de session

Bonjour,

J'ai installé au propre la dernière version d'Ubuntu 13.10 sans aucun soucis.
J'ai réinstallé tout les logiciels que j'avais sur la 13.04, tout bien reconfiguré, nickel.

Mais voilà, j'ai un SSD et j'ai voulu l'optimiser comme expliqué sur cette page: diminuer les écritures sur SSD

Et alors là, je ne comprend pas bien. Ça démarre super vite jusqu'à l'écran de choix de session et une fois le mot de passe tapé, je me retrouve sur un écran tout noir avec juste le curseur de la souris. Et strictement rien d'autre.

Alors bien sur j'ai essayé de réédité les fichiers que j'avais édité pour l'optimisation SSD en ouvrant une console de récupération en mode de dépannage, en mettant un # devant chaque ligne de modification mais après redémarrage ça ne change strictement rien.

Alors en gros, voilà ce que j'ai modifié dans le /etc/fstab:

UUID=57480a3f-e7db-4a5e-9fca-7df45f5a7d9d  /               ext4    defaults,noatime,errors=remount-ro 0       1
tmpfs      /tmp            tmpfs        defaults,size=1g           0    0
tmpfs /var/log tmpfs defaults,nosuid,nodev,noatime,mode=0755,size=5% 0 0
tmpfs    /var/cache/apt/archives    tmpfs    defaults,size=4g    0    0
tmpfs    /home/djragingbull/.cache    tmpfs    defaults,size=1g    0    0
data=writeback

Et voilà ce que j'ai modifié dans /etc/init/ureadahead.conf: j'ai commenté cette ligne

# exec /sbin/ureadahead –daemon

J'ai pas touché au SWAP parce que je n'en ai pas configuré à l'installation (avec 16 Go de ram je me suis dis que c'était pas nécessaire), j'ai pas touché au TRIM, à la journalisation, ni à rien d'autre à part ce que j'ai noté ici.

Dernière modification par DJ Raging-Bull (Le 27/10/2013, à 18:35)


Desktop: Intel Core i7 2600K - 16 Go DDR3 - GeForce GTX 590 - Asus P8P67 - Sound Blaster X-Fi Titanium 7.1 - SSD 64 Go
Laptop: Lenovo ThinkPad X201 - Intel Core i5 520M - 4 Go DDR3 - Kingstone SSD 60 Go
HTPC: Intel Core i5 4570S - 4 Go DDR3 - Asus H81M - Asus Xonar DX - Kingstone SSD 60 Go - 2 x WD Caviar Green 4To
OS: GNU/Linux Ubuntu 14.04 LTS Trusty Tahr & Microsoft Windows 7 Édition Intégrale

Hors ligne

#2 Le 22/10/2013, à 12:18

michel_04

Re : [Résolu] 13.10 Ecran noir après écran de choix de session

Bonjour,

DJ Raging-Bull a écrit :

Alors en gros, voilà ce que j'ai modifié dans le /etc/fstab:

UUID=57480a3f-e7db-4a5e-9fca-7df45f5a7d9d  /               ext4    defaults,noatime,errors=remount-ro 0       1
tmpfs      /tmp            tmpfs        defaults,size=1g           0    0
tmpfs /var/log tmpfs defaults,nosuid,nodev,noatime,mode=0755,size=5% 0 0
tmpfs    /var/cache/apt/archives    tmpfs    defaults,size=4g    0    0
tmpfs    /home/djragingbull/.cache    tmpfs    defaults,size=1g    0    0
data=writeback

Tu peux essayer :

UUID=57480a3f-e7db-4a5e-9fca-7df45f5a7d9d  /               ext4    noatime,errors=remount-ro  0       1

et :

tmpfs      /tmp            tmpfs        defaults           0    0

Et enlever les :

tmpfs /var/log tmpfs defaults,nosuid,nodev,noatime,mode=0755,size=5% 0 0
tmpfs    /var/cache/apt/archives    tmpfs    defaults,size=4g    0    0
tmpfs    /home/djragingbull/.cache    tmpfs    defaults,size=1g    0    0
data=writeback

Mon /etc/fstab sur ce portable (sous 12.04) avec SSD :

# <file system> <mount point>   <type>  <options>       <dump>  <pass>
proc            /proc           proc    nodev,noexec,nosuid 0       0
# / was on /dev/sda1 during installation
UUID=b3ffbc0f-5e70-4ee2-91fa-ee050196a503 /               ext4    noatime,discard,commit=60,errors=remount-ro 0       1
# /home was on /dev/sda3 during installation
UUID=5e733759-2667-437b-9fc2-a75ae8fecca3 /home           ext4    noatime,discard,commit=60       0       2
# swap was on /dev/sda2 during installation
UUID=7619d8e3-8318-4b68-8b6f-6361b122e842 none            swap    sw              0       0
tmpfs	/tmp            tmpfs		defaults	0	0
## tmpfs	/tmp            tmpfs		tmpfs defaults,size=1g    0     0

Détails de sudo lshw :

*-disk:0
                description: ATA Disk
                produit: Samsung SSD 840
                identifiant matériel: 0
                information bus: scsi@0:0.0.0
                nom logique: /dev/sda
                version: DXM0
                numéro de série: S12RNEACC04067N
                taille: 238GiB (256GB)
                fonctionnalités: partitioned partitioned:dos
                configuration: ansiversion=5 signature=000e9c29
              *-volume:0
                   description: Volume EXT4
                   fabriquant: Linux
                   identifiant matériel: 1
                   information bus: scsi@0:0.0.0,1
                   nom logique: /dev/sda1
                   nom logique: /
                   version: 1.0
                   numéro de série: b3ffbc0f-5e70-4ee2-91fa-ee050196a503
                   taille: 17GiB
                   capacité: 17GiB
                   fonctionnalités: primary bootable journaled extended_attributes large_files huge_files dir_nlink recover extents ext4 ext2 initialized
                   configuration: created=2013-04-21 17:42:41 filesystem=ext4 lastmountpoint=/ modified=2013-08-25 21:11:17 mount.fstype=ext4 mount.options=rw,noatime,errors=remount-ro,user_xattr,commit=60,barrier=1,data=ordered,discard mounted=2013-10-22 11:03:02 state=mounted
              *-volume:1
                   description: Linux swap volume
                   identifiant matériel: 2
                   information bus: scsi@0:0.0.0,2
                   nom logique: /dev/sda2
                   version: 1
                   numéro de série: 7619d8e3-8318-4b68-8b6f-6361b122e842
                   taille: 8131MiB
                   capacité: 8131MiB
                   fonctionnalités: primary nofs swap initialized
                   configuration: filesystem=swap pagesize=4096
              *-volume:2
                   description: Volume EXT4
                   fabriquant: Linux
                   identifiant matériel: 3
                   information bus: scsi@0:0.0.0,3
                   nom logique: /dev/sda3
                   nom logique: /home
                   version: 1.0
                   numéro de série: 5e733759-2667-437b-9fc2-a75ae8fecca3
                   taille: 213GiB
                   capacité: 213GiB
                   fonctionnalités: primary journaled extended_attributes large_files huge_files dir_nlink recover extents ext4 ext2 initialized
                   configuration: created=2013-01-09 18:30:17 filesystem=ext4 lastmountpoint=/home modified=2013-10-22 11:03:03 mount.fstype=ext4 mount.options=rw,noatime,user_xattr,commit=60,barrier=1,data=ordered,discard mounted=2013-10-22 11:03:03 state=mounted

A+

Dernière modification par michel_04 (Le 23/10/2013, à 19:56)

Hors ligne

#3 Le 22/10/2013, à 17:51

DJ Raging-Bull

Re : [Résolu] 13.10 Ecran noir après écran de choix de session

J'ai essayé mais sans plus de résultat malheureusement.
Par contre j'ai découvert qu'en lançant la session invité plutôt que la mienne, ça m'emmène jusqu'au bureau sans aucun soucis.

En résumé depuis les changements décris plus haut, je ne peux plus ouvrir MA session, mais la session invité ça ne pose aucun soucis.

C'est déjà plus confortable que la console root de récupération en mode dépannage. Mais je ne comprends pas pourquoi ça ne revient pas à la normal en commentant toute les lignes rajoutées.

J'arrive à me connecter sur ma session avec "su" et mon mot de passe, ce qui me permet de modifier les fichiers beaucoup plus facilement au besoin.

Par contre ce que je comprend pas c'est comment ces modifications, que j'avais déjà faite sur la 12.04 puis sur la 12.10 puis sur la 13.04, sur la 13.10 empêche l'ouverture de ma session. A moins que ça ne vienne d'autre chose, mais pitié qu'on ne me demande pas de m'en recréer une, j'ai passé la journée d'hier à tout configurer aux petits oignons.

Dernière modification par DJ Raging-Bull (Le 22/10/2013, à 18:18)


Desktop: Intel Core i7 2600K - 16 Go DDR3 - GeForce GTX 590 - Asus P8P67 - Sound Blaster X-Fi Titanium 7.1 - SSD 64 Go
Laptop: Lenovo ThinkPad X201 - Intel Core i5 520M - 4 Go DDR3 - Kingstone SSD 60 Go
HTPC: Intel Core i5 4570S - 4 Go DDR3 - Asus H81M - Asus Xonar DX - Kingstone SSD 60 Go - 2 x WD Caviar Green 4To
OS: GNU/Linux Ubuntu 14.04 LTS Trusty Tahr & Microsoft Windows 7 Édition Intégrale

Hors ligne

#4 Le 22/10/2013, à 18:23

DJ Raging-Bull

Re : [Résolu] 13.10 Ecran noir après écran de choix de session

Voilà la réponse à la commande "lshw" si ça peut aider à résoudre le problème.

     *-scsi:1
          identifiant matériel: 2
          nom logique: scsi1
          fonctionnalités: emulated
        *-disk
             description: ATA Disk
             produit: SAMSUNG SSD 830
             identifiant matériel: 0.0.0
             information bus: scsi@1:0.0.0
             nom logique: /dev/sdb
             version: CXM0
             numéro de série: S0XXNEAC701041
             taille: 59GiB (64GB)
             fonctionnalités: partitioned partitioned:dos
             configuration: ansiversion=5 sectorsize=512 signature=00055a33
           *-volume
                description: Volume EXT4
                fabriquant: Linux
                identifiant matériel: 1
                information bus: scsi@1:0.0.0,1
                nom logique: /dev/sdb1
                nom logique: /
                version: 1.0
                numéro de série: bd4f961b-f339-4b49-8b06-eeb485ba57ef
                taille: 59GiB
                capacité: 59GiB
                fonctionnalités: primary journaled extended_attributes large_files huge_files dir_nlink recover extents ext4 ext2 initialized
                configuration: created=2013-10-20 18:17:06 filesystem=ext4 lastmountpoint=/ modified=2013-10-22 18:04:18 mount.fstype=ext4 mount.options=rw,noatime,errors=remount-ro mounted=2013-10-22 18:04:18 state=mounted

Je tiens aussi à préciser qu'en plus de ma session invité, ma session principale s'ouvre si je modifie le gestionnaire de bureau "Ubuntu (default)" en "XBMC" mais bon je ne peux qu'utiliser XBMC donc ça ne m'est pas très utile.

Je ne comprend pas ce qui empêche ma session de s'ouvrir, et encore elle s'ouvre mais je n'ai qu'un écran noir et un curseur de souris. C'est vraiment très bizarre.

Dernière modification par DJ Raging-Bull (Le 22/10/2013, à 19:08)


Desktop: Intel Core i7 2600K - 16 Go DDR3 - GeForce GTX 590 - Asus P8P67 - Sound Blaster X-Fi Titanium 7.1 - SSD 64 Go
Laptop: Lenovo ThinkPad X201 - Intel Core i5 520M - 4 Go DDR3 - Kingstone SSD 60 Go
HTPC: Intel Core i5 4570S - 4 Go DDR3 - Asus H81M - Asus Xonar DX - Kingstone SSD 60 Go - 2 x WD Caviar Green 4To
OS: GNU/Linux Ubuntu 14.04 LTS Trusty Tahr & Microsoft Windows 7 Édition Intégrale

Hors ligne

#5 Le 23/10/2013, à 17:05

DJ Raging-Bull

Re : [Résolu] 13.10 Ecran noir après écran de choix de session

Un petit up avant que je ne craque et que je fasse une réinstallation qui va me prendre la tête en configuration ?


Desktop: Intel Core i7 2600K - 16 Go DDR3 - GeForce GTX 590 - Asus P8P67 - Sound Blaster X-Fi Titanium 7.1 - SSD 64 Go
Laptop: Lenovo ThinkPad X201 - Intel Core i5 520M - 4 Go DDR3 - Kingstone SSD 60 Go
HTPC: Intel Core i5 4570S - 4 Go DDR3 - Asus H81M - Asus Xonar DX - Kingstone SSD 60 Go - 2 x WD Caviar Green 4To
OS: GNU/Linux Ubuntu 14.04 LTS Trusty Tahr & Microsoft Windows 7 Édition Intégrale

Hors ligne

#6 Le 23/10/2013, à 17:28

michel_04

Re : [Résolu] 13.10 Ecran noir après écran de choix de session

Re,

DJ Raging-Bull a écrit :

Un petit up avant que je ne craque et que je fasse une réinstallation qui va me prendre la tête en configuration ?

Est ce que ça ne pêut pas venir du pilote (proprio ?) de ta CG ?
Sinon, je ne vois pas...

A+

Hors ligne

#7 Le 23/10/2013, à 18:05

DJ Raging-Bull

Re : [Résolu] 13.10 Ecran noir après écran de choix de session

J'ai tenté de remettre "nouveau" mais ça me plante même en session invité.
T'inquiètes, c'est pas grave, je viens de tout réinstaller.

Par contre du coup je sais pas quoi faire pour le SSD, je ne voulais pas le laisser comme ça mais en même temps je ne sais pas quelle ligne l'a fait planté donc du coup je sais pas trop.
J'ai pas envie non plus qu'il s'use à mort ni qu'il soit moins rapide qu'il en devrait.


Desktop: Intel Core i7 2600K - 16 Go DDR3 - GeForce GTX 590 - Asus P8P67 - Sound Blaster X-Fi Titanium 7.1 - SSD 64 Go
Laptop: Lenovo ThinkPad X201 - Intel Core i5 520M - 4 Go DDR3 - Kingstone SSD 60 Go
HTPC: Intel Core i5 4570S - 4 Go DDR3 - Asus H81M - Asus Xonar DX - Kingstone SSD 60 Go - 2 x WD Caviar Green 4To
OS: GNU/Linux Ubuntu 14.04 LTS Trusty Tahr & Microsoft Windows 7 Édition Intégrale

Hors ligne

#8 Le 23/10/2013, à 18:33

michel_04

Re : [Résolu] 13.10 Ecran noir après écran de choix de session

Re,

DJ Raging-Bull a écrit :

J'ai pas envie non plus qu'il s'use à mort ni qu'il soit moins rapide qu'il en devrait.

Regarde mon /etc/fstab ci dessus.

A+

Hors ligne

#9 Le 23/10/2013, à 19:17

DJ Raging-Bull

Re : [Résolu] 13.10 Ecran noir après écran de choix de session

Oui, mais tu es sur la 12.04, pas sur la 13.10, ça fait une sacré différence


Desktop: Intel Core i7 2600K - 16 Go DDR3 - GeForce GTX 590 - Asus P8P67 - Sound Blaster X-Fi Titanium 7.1 - SSD 64 Go
Laptop: Lenovo ThinkPad X201 - Intel Core i5 520M - 4 Go DDR3 - Kingstone SSD 60 Go
HTPC: Intel Core i5 4570S - 4 Go DDR3 - Asus H81M - Asus Xonar DX - Kingstone SSD 60 Go - 2 x WD Caviar Green 4To
OS: GNU/Linux Ubuntu 14.04 LTS Trusty Tahr & Microsoft Windows 7 Édition Intégrale

Hors ligne

#10 Le 23/10/2013, à 19:35

fcn50

Re : [Résolu] 13.10 Ecran noir après écran de choix de session

Salut Raging,

Quelles options exactement as-tu rajouté pour le SSD car je n'en vois aucune à part noatime? Ah je vois un truck! Qu'est-ce que ce data=writeback fait au milieu de nul part?

tmpfs    /home/djragingbull/.cache    tmpfs    defaults,size=1g    0    0
data=writeback <<<<<<<<<<!!!!!!!!!

Voici mon fstab:

proc                                       /proc         proc   nodev,noexec,nosuid                          0  0  
# / was on /dev/sda1 during installation
UUID=15b357e1-fc18-4c73-a061-af704c2357f5  /             ext4   noatime,discard,commit=60,errors=remount-ro  0  1  
# /data was on /dev/sda2 during installation
UUID=6e788234-a8cc-4584-a595-8c8205a1f210  /data         ext4   noatime,discard,commit=60                    0  2  
# /home was on /dev/sdb2 during installation
UUID=8617193a-7c05-439c-856a-1aca65b55508  /home         ext4   noatime                                      0  2  
# /var was on /dev/sdb1 during installation
UUID=fc5d4388-f299-463e-b1ea-8d2c80d7874b  /var          ext4   noatime                                      0  2  
tmpfs                                      /tmp          tmpfs  noatime,mode=1777                            0  0  
tmpfs                                      /media/tmpfs  tmpfs  defaults,size=10%                            0  0

Dernière modification par fcn50 (Le 23/10/2013, à 23:12)


12.04.4 LTS, Xfce 4.10, Phenom II x6 1090T BE, SSD Patriot Inferno 60 Go, WD Black 1 To, Sapphire HD 7750 ULTIMATE, RME HDSP 9632, Dell U2713HM.
    Un site qui vaut le détour: http://blog.syti.net  Une radio hors du commun: http://solenopole.org  You like the american dream? Wellcome to Guantànamo!

Hors ligne

#11 Le 24/10/2013, à 07:49

DJ Raging-Bull

Re : [Résolu] 13.10 Ecran noir après écran de choix de session

La configuration de mon fstab était exactement celle décrite plus haut, et une copie conforme de celle de la doc finalement.
Tout en bas de la page on voit le "data=writeback" c'est censé accélérer certain SSD, dans le doute je l'ai mise parce que je ne savais pas si j'étais concerné.

Et comme je l'ai dis plus haut j'ai aussi modifié le "/etc/init/ureadahead.conf" toujours conformément à la doc et comme décrit ci-dessus.

Je ne sais pas quelle est l'option exacte qui aurait mis en péril ma session. Au pire je les ferais une par une ...


Desktop: Intel Core i7 2600K - 16 Go DDR3 - GeForce GTX 590 - Asus P8P67 - Sound Blaster X-Fi Titanium 7.1 - SSD 64 Go
Laptop: Lenovo ThinkPad X201 - Intel Core i5 520M - 4 Go DDR3 - Kingstone SSD 60 Go
HTPC: Intel Core i5 4570S - 4 Go DDR3 - Asus H81M - Asus Xonar DX - Kingstone SSD 60 Go - 2 x WD Caviar Green 4To
OS: GNU/Linux Ubuntu 14.04 LTS Trusty Tahr & Microsoft Windows 7 Édition Intégrale

Hors ligne

#12 Le 24/10/2013, à 09:46

fcn50

Re : [Résolu] 13.10 Ecran noir après écran de choix de session

C'est pas la question de l'option mais elle ne se trouve pas à la bonne place:

UUID=57480a3f-e7db-4a5e-9fca-7df45f5a7d9d  /               ext4    defaults,noatime,errors=remount-ro 0       1
tmpfs      /tmp            tmpfs        defaults,size=1g           0    0
tmpfs /var/log tmpfs defaults,nosuid,nodev,noatime,mode=0755,size=5% 0 0
tmpfs    /var/cache/apt/archives    tmpfs    defaults,size=4g    0    0
tmpfs    /home/djragingbull/.cache    tmpfs    defaults,size=1g    0    0
data=writeback

vs

UUID=57480a3f-e7db-4a5e-9fca-7df45f5a7d9d  /               ext4    data=writeback,noatime,errors=remount-ro 0       1
tmpfs      /tmp            tmpfs        defaults,size=1g           0    0
tmpfs /var/log tmpfs defaults,nosuid,nodev,noatime,mode=0755,size=5% 0 0
tmpfs    /var/cache/apt/archives    tmpfs    defaults,size=4g    0    0
tmpfs    /home/djragingbull/.cache    tmpfs    defaults,size=1g    0    0

Une autre chose, defaults ne sert à rien, c'est même contradictoire car tu as noatime qui n'est justement pas defaults, il manque aussi l'option discard pour le trim des SSD.


12.04.4 LTS, Xfce 4.10, Phenom II x6 1090T BE, SSD Patriot Inferno 60 Go, WD Black 1 To, Sapphire HD 7750 ULTIMATE, RME HDSP 9632, Dell U2713HM.
    Un site qui vaut le détour: http://blog.syti.net  Une radio hors du commun: http://solenopole.org  You like the american dream? Wellcome to Guantànamo!

Hors ligne

#13 Le 24/10/2013, à 15:18

DJ Raging-Bull

Re : [Résolu] 13.10 Ecran noir après écran de choix de session

Aaah oui d'accord ça y est j'ai compris ...
Je vais tester dès que je rentre chez moi, je te remercie ! big_smile


Desktop: Intel Core i7 2600K - 16 Go DDR3 - GeForce GTX 590 - Asus P8P67 - Sound Blaster X-Fi Titanium 7.1 - SSD 64 Go
Laptop: Lenovo ThinkPad X201 - Intel Core i5 520M - 4 Go DDR3 - Kingstone SSD 60 Go
HTPC: Intel Core i5 4570S - 4 Go DDR3 - Asus H81M - Asus Xonar DX - Kingstone SSD 60 Go - 2 x WD Caviar Green 4To
OS: GNU/Linux Ubuntu 14.04 LTS Trusty Tahr & Microsoft Windows 7 Édition Intégrale

Hors ligne

#14 Le 24/10/2013, à 18:16

DJ Raging-Bull

Re : [Résolu] 13.10 Ecran noir après écran de choix de session

Bon ben verdict: je viens de foiré de nouveau ma session alors que je m'étais amusé à tout réinstallé.
Ça commence un tout petit peu à me saouler, j'espère que ce coup-ci je vais la récupérer.

J'hésite entre le data_writeback précédé de la commande:

sudo tune2fs -o journal_data_writeback /dev/sdb1

Si quelqu'un connait la commande inverse d'ailleurs je suis preneur du coup.
ou
La modification du fichier "/etc/init/ureadahead.conf"
En commentant la ligne:

exec /sbin/ureadahead –daemon

J'ai un peu de mal à imaginer que ça soit les répertoires mis en mémoire vive qui fasse foirer la session, mais dans tout les cas ça me dérange pas de virer une ligne pour tester.

Là je suis sur la session invité et je n'ai aucun soucis, il n'y a que la session principale qui est touchée et comme la dernière fois c'est un écran noir avec juste le curseur de la souris.
Je ne comprend pas ce qui a pu causer ça ni comment faire machine arrière.

Dernière modification par DJ Raging-Bull (Le 24/10/2013, à 18:20)


Desktop: Intel Core i7 2600K - 16 Go DDR3 - GeForce GTX 590 - Asus P8P67 - Sound Blaster X-Fi Titanium 7.1 - SSD 64 Go
Laptop: Lenovo ThinkPad X201 - Intel Core i5 520M - 4 Go DDR3 - Kingstone SSD 60 Go
HTPC: Intel Core i5 4570S - 4 Go DDR3 - Asus H81M - Asus Xonar DX - Kingstone SSD 60 Go - 2 x WD Caviar Green 4To
OS: GNU/Linux Ubuntu 14.04 LTS Trusty Tahr & Microsoft Windows 7 Édition Intégrale

Hors ligne

#15 Le 24/10/2013, à 18:53

fcn50

Re : [Résolu] 13.10 Ecran noir après écran de choix de session

DJ Raging-Bull a écrit :

Bon ben verdict: je viens de foiré de nouveau ma session alors que je m'étais amusé à tout réinstallé.

Qu'as-tu changé pour que ça "foire" ? Perso je n'utilise pas l'option data=writeback. Mon fstab au #10 pour un SSD.


12.04.4 LTS, Xfce 4.10, Phenom II x6 1090T BE, SSD Patriot Inferno 60 Go, WD Black 1 To, Sapphire HD 7750 ULTIMATE, RME HDSP 9632, Dell U2713HM.
    Un site qui vaut le détour: http://blog.syti.net  Une radio hors du commun: http://solenopole.org  You like the american dream? Wellcome to Guantànamo!

Hors ligne

#16 Le 25/10/2013, à 10:50

DJ Raging-Bull

Re : [Résolu] 13.10 Ecran noir après écran de choix de session

Le soucis avec l'option data=writeback c'est qu'il y a une commande comme écrit plus haut pour l'activer, et je ne connais pas la commande inverse.


Desktop: Intel Core i7 2600K - 16 Go DDR3 - GeForce GTX 590 - Asus P8P67 - Sound Blaster X-Fi Titanium 7.1 - SSD 64 Go
Laptop: Lenovo ThinkPad X201 - Intel Core i5 520M - 4 Go DDR3 - Kingstone SSD 60 Go
HTPC: Intel Core i5 4570S - 4 Go DDR3 - Asus H81M - Asus Xonar DX - Kingstone SSD 60 Go - 2 x WD Caviar Green 4To
OS: GNU/Linux Ubuntu 14.04 LTS Trusty Tahr & Microsoft Windows 7 Édition Intégrale

Hors ligne

#17 Le 25/10/2013, à 12:09

fcn50

Re : [Résolu] 13.10 Ecran noir après écran de choix de session

Tu devrais trouver la commande inverse dans tune2fs manpage. Perso je préfère de loin: commit=60 qui ne désactive pas complètement la journalisation mais elle s'exécute toute les 60 secondes, ce qui est bien plus sûr tout en épargnant le SSD.


12.04.4 LTS, Xfce 4.10, Phenom II x6 1090T BE, SSD Patriot Inferno 60 Go, WD Black 1 To, Sapphire HD 7750 ULTIMATE, RME HDSP 9632, Dell U2713HM.
    Un site qui vaut le détour: http://blog.syti.net  Une radio hors du commun: http://solenopole.org  You like the american dream? Wellcome to Guantànamo!

Hors ligne

#18 Le 25/10/2013, à 12:59

DJ Raging-Bull

Re : [Résolu] 13.10 Ecran noir après écran de choix de session

Apparemment ça serait une commande qui désactive l'archivage, pour désactiver la journalisation c'est encore une autre commande plus haut et celle là je ne l'avais pas encore faite par contre.

J'irais voir quand je rentre du boulot si je trouve la commande inverse, j'espère que ça fonctionnera parce que j'ai pas envie de réinstaller à nouveau ...


Desktop: Intel Core i7 2600K - 16 Go DDR3 - GeForce GTX 590 - Asus P8P67 - Sound Blaster X-Fi Titanium 7.1 - SSD 64 Go
Laptop: Lenovo ThinkPad X201 - Intel Core i5 520M - 4 Go DDR3 - Kingstone SSD 60 Go
HTPC: Intel Core i5 4570S - 4 Go DDR3 - Asus H81M - Asus Xonar DX - Kingstone SSD 60 Go - 2 x WD Caviar Green 4To
OS: GNU/Linux Ubuntu 14.04 LTS Trusty Tahr & Microsoft Windows 7 Édition Intégrale

Hors ligne

#19 Le 25/10/2013, à 17:18

DJ Raging-Bull

Re : [Résolu] 13.10 Ecran noir après écran de choix de session

Alors, je suis pas forcément une buse en informatique, mais là j'ai du mal à interpréter tune2fs manpage.
J'ai bien compris qu'il s'agit d'un manuel expliquant en gros la logique et la syntaxe des commandes, mais je ne parviens pas à construire la commande inverse.

Si quelqu'un la connait surtout qu'il n'hésite pas. Je viens de lire sur des forums de support Ubuntu anglophone que cette option pourrait éventuellement poser problème lors d'un redémarrage ... (tiens tiens...).

Edit: en cherchant bien, la commande inverse de:

sudo tune2fs -o journal_data_writeback /dev/sdb1

est

sudo tune2fs -o journal_data /dev/sdb1

tout simplement ou même:

sudo tune2fs -o journal_data_ordered /dev/sdb1

Malheureusement même en virant l'option et en tapant cette commande qui a eut l'air d'être validée, ma session réagit toujours de la même manière.

Ce qui est vraiment étonnant c'est qu'au moment ou je valide mon mot de passe à l'écran de connexion on dirait vraiment qu'il ne charge rien du tout ... il passe à l'écran noir directement, le curseur de la souris et puis plus moyen de rien faire à part appuyer sur "reset".

Dernière modification par DJ Raging-Bull (Le 25/10/2013, à 17:30)


Desktop: Intel Core i7 2600K - 16 Go DDR3 - GeForce GTX 590 - Asus P8P67 - Sound Blaster X-Fi Titanium 7.1 - SSD 64 Go
Laptop: Lenovo ThinkPad X201 - Intel Core i5 520M - 4 Go DDR3 - Kingstone SSD 60 Go
HTPC: Intel Core i5 4570S - 4 Go DDR3 - Asus H81M - Asus Xonar DX - Kingstone SSD 60 Go - 2 x WD Caviar Green 4To
OS: GNU/Linux Ubuntu 14.04 LTS Trusty Tahr & Microsoft Windows 7 Édition Intégrale

Hors ligne

#20 Le 25/10/2013, à 19:38

Geoffrey Frogeye

Re : [Résolu] 13.10 Ecran noir après écran de choix de session

Salut !
Je vais essayer d'aborder le problème autrement, ne voyant pas trop le rapport entre l'"écran noir" et les SSD.
Est-ce que tu peux lancer la console avec Ctrl + Alt + T depuis cet écran ?
Si oui (ta console ne devrait pas avoir de bords), essaye de lancer unity.
Si ça ne change rien, annule (Ctrl + C), essaye sudo apt-get install compizconfig-settings-manager, puis ccsm. Si ccsm s'affiche, essaye d'activer Ubuntu Unity Plugin, et vois ce qui se passe.
Après je peux être complètement hors de la plaque, mais dans certains cas ça peut marcher.


Tu as perdu 2 secondes de ta vie à lire cette signature. Mais ne t'inquiète pas, j'en ai perdu plus à l'écrire.

Hors ligne

#21 Le 25/10/2013, à 20:11

DJ Raging-Bull

Re : [Résolu] 13.10 Ecran noir après écran de choix de session

Malheureusement j'ai déjà tenté ce raccourcis clavier et ça ne donne absolument rien.
Et comme je l'ai déjà dis, bizarrement la session invité fonctionne à merveille de manière fluide et agréable.

Ma session s'est retrouvé dans cette état juste après un redémarrage de prise en compte des nouvelles options pour le SSD.
Comme si une option avait mis en péril le processus de démarrage de la session.

Malheureusement je ne peux pas vérifier ce qui se charge et ce qui ne se charge pas, peut être qu'un log nous en apprendrait plus, mais je ne saurais même pas lequel regarder ni quel défaut chercher pour comprendre.

D'autant que du coup là les log sont dans le /var/log qui se monte dans les RAM vu les options de mon fstab, m'enfin ça à la limite je peux le désactiver et le remettre par défaut le temps d'un démarrage ou deux si ça peut aider à comprendre.

Edit: j'ai ajouté une petite note sur la page de documentation histoire de prévenir que ça peut faire foirer la session.

Edit 2: apparemment il n'y a que la session Unity touchée, j'ai installé Cinnamon pour voir et j'arrive à me connecter sans aucun soucis ... c'est vraiment bizarre. Il y aurait une option qui serait contraire à Unity dans les modifications.

Dernière modification par DJ Raging-Bull (Le 26/10/2013, à 18:00)


Desktop: Intel Core i7 2600K - 16 Go DDR3 - GeForce GTX 590 - Asus P8P67 - Sound Blaster X-Fi Titanium 7.1 - SSD 64 Go
Laptop: Lenovo ThinkPad X201 - Intel Core i5 520M - 4 Go DDR3 - Kingstone SSD 60 Go
HTPC: Intel Core i5 4570S - 4 Go DDR3 - Asus H81M - Asus Xonar DX - Kingstone SSD 60 Go - 2 x WD Caviar Green 4To
OS: GNU/Linux Ubuntu 14.04 LTS Trusty Tahr & Microsoft Windows 7 Édition Intégrale

Hors ligne

#22 Le 27/10/2013, à 10:21

DJ Raging-Bull

Re : [Résolu] 13.10 Ecran noir après écran de choix de session

J'ai tenté de faire une désinstallation de Cinnamon et Unity puis une réinstallation de Unity, rien à faire toujours la même réaction.
Je sais pas ce qui a fait foiré Unity, mais impossible de la récupérer... j'ai pas vraiment envie de me taper un bureau Cinnamon, je fais partie des rares à préférer Unity.

C'est vraiment dingue, impossible de faire fonctionner Unity, il n'y a que Cinnamon qui fonctionne. Par contre après le passage sur Cinnamon j'ai perdu la Logithèque Ubuntu.

Dernière modification par DJ Raging-Bull (Le 27/10/2013, à 12:14)


Desktop: Intel Core i7 2600K - 16 Go DDR3 - GeForce GTX 590 - Asus P8P67 - Sound Blaster X-Fi Titanium 7.1 - SSD 64 Go
Laptop: Lenovo ThinkPad X201 - Intel Core i5 520M - 4 Go DDR3 - Kingstone SSD 60 Go
HTPC: Intel Core i5 4570S - 4 Go DDR3 - Asus H81M - Asus Xonar DX - Kingstone SSD 60 Go - 2 x WD Caviar Green 4To
OS: GNU/Linux Ubuntu 14.04 LTS Trusty Tahr & Microsoft Windows 7 Édition Intégrale

Hors ligne

#23 Le 27/10/2013, à 14:21

Geoffrey Frogeye

Re : [Résolu] 13.10 Ecran noir après écran de choix de session

Cinnamon 2.0 et Unity 7.1 en même temps ce n'est pas la meilleure chose à faire mais le problème était là avant donc bon.
Tu peux démarrer avec Gnome par hasard ?
Si tu peux accéder au terminal avec ta session (Ctrl + Alt + F1 depuis l'écran de sélection des utilisateurs), essaye :

sudo apt-get purge unity cinnamon compiz; sudo apt-get update; sudo apt-get install ubuntu_desktop; dpkg --configure -a

Puis rebascule en mode graphique (Ctrl + Alt + F7) et lance ta session sous Unity.


Tu as perdu 2 secondes de ta vie à lire cette signature. Mais ne t'inquiète pas, j'en ai perdu plus à l'écrire.

Hors ligne

#24 Le 27/10/2013, à 15:21

DJ Raging-Bull

Re : [Résolu] 13.10 Ecran noir après écran de choix de session

Je ne peux pas démarrer en "Gnome Flashback" ni en "Unity", j'ai essayé de virer Cinnnamon, mais aucun éffet, finalement j'ai de nouveau réinstaller et je vais tester option par options pour voir ce qui foire.

Dernière modification par DJ Raging-Bull (Le 27/10/2013, à 18:32)


Desktop: Intel Core i7 2600K - 16 Go DDR3 - GeForce GTX 590 - Asus P8P67 - Sound Blaster X-Fi Titanium 7.1 - SSD 64 Go
Laptop: Lenovo ThinkPad X201 - Intel Core i5 520M - 4 Go DDR3 - Kingstone SSD 60 Go
HTPC: Intel Core i5 4570S - 4 Go DDR3 - Asus H81M - Asus Xonar DX - Kingstone SSD 60 Go - 2 x WD Caviar Green 4To
OS: GNU/Linux Ubuntu 14.04 LTS Trusty Tahr & Microsoft Windows 7 Édition Intégrale

Hors ligne

#25 Le 27/10/2013, à 18:34

DJ Raging-Bull

Re : [Résolu] 13.10 Ecran noir après écran de choix de session

Après réinstallation et test de chaque option une par une, Unity n'a pas l'air d'apprécier qu'on touche au dossier /home/nom d'utilisateur/.cache sous Ubuntu 13.10, j'ai donc ajouté un avertissement sur la page de la documentation sur les SSD histoire que ça n'arrive pas à d'autre.
D'autant que l'avantage n'était pas spécialement énorme à mettre ce dossier en mémoire vive en y regardant bien.


Desktop: Intel Core i7 2600K - 16 Go DDR3 - GeForce GTX 590 - Asus P8P67 - Sound Blaster X-Fi Titanium 7.1 - SSD 64 Go
Laptop: Lenovo ThinkPad X201 - Intel Core i5 520M - 4 Go DDR3 - Kingstone SSD 60 Go
HTPC: Intel Core i5 4570S - 4 Go DDR3 - Asus H81M - Asus Xonar DX - Kingstone SSD 60 Go - 2 x WD Caviar Green 4To
OS: GNU/Linux Ubuntu 14.04 LTS Trusty Tahr & Microsoft Windows 7 Édition Intégrale

Hors ligne

Haut de page ↑