Contenu | Rechercher | Menus

Annonce

Si vous rencontrez des soucis à rester connecté sur le forum (ou si vous avez perdu votre mot de passe) déconnectez-vous et reconnectez-vous depuis cette page, en cochant la case "Me connecter automatiquement lors de mes prochaines visites".
Test de l'ISO d'Ubuntu francophone : nous avons besoin de testeurs pour la version francophone d'Ubuntu 14.04. Liens et informations ici.

#1 Le 24/10/2013, à 10:43

Strone

Problème d'installation de pilote AMD (fglrx)

Bonjour.

Comme indiqué dans le titre, j'ai un problème d'installation des pilotes de ma carte graphique AMD Radon HD.
En effet, c'est quand je suivais les tuto's d'installation des pilotes que je me suis rendu compte du problème.

À chaque fois, en arrivant à l'installation des paquets .deb, le terminal me retournait qu'il n'y avait pas de paquet fglrx installé.
J'ai donc décidé d'installer le paquet, cependant, celui-ci ne s'installe pas correctement et pose problème.

En effet, on me dit que le paquet est cassé. Lorsque je réessaie d'installer les paquets .deb, le terminal que retourne un code d'erreur (1) en disant que les paquets ont des dépendances non satisfaites ou non configurées.
Après ça, j'essaie de désinstaller le paquet maintes fois, avec plusieurs méthode, sans succès.
J'arrive finalement à le retirer.

Mais si je le réinstalle, le problème revient, et je ne sais pas comment faire pour avoir de pilote pour ma carte sans avoir de problème avec fglrx.
Comment faire pour que ma carte soit opérationnelle ? ( Pour une utilisation du côté des jeux vidéo, principalement ).

Version d'Ubuntu : 13.10
Retour de la commande "lscpi | grep VGA" :

00:02.0 VGA compatible controller: Intel Corporation 3rd Gen Core processor Graphics Controller (rev 09)
01:00.0 VGA compatible controller: Advanced Micro Devices, Inc. [AMD/ATI] Thames [Radeon HD 7500M/7600M Series]

En effet, vous pouvez remarquer qu'il y a deux cartes, et que c'est la carte intégrée qui fonctionne.

Merci d'avance à vous.

Dernière modification par Strone (Le 24/10/2013, à 10:44)


"Hello ! My name is mine turtle !"

Hors ligne

#2 Le 24/10/2013, à 10:46

ljere

Re : Problème d'installation de pilote AMD (fglrx)

tu peux essayer cette méthode http://ljeremie.legtux.org/?p=125


Modérateur d'ubuntu-fr.org
athlon 2800+, nvidia FX5200 et 2 Go de ram et sempron 3000+, ati radeon et 1 Go de ram sur voyager 12.04 32 bit
Toshiba satellite_c670d-11l sur openbox/xubuntu 14.04 64 bit
Mon Blog et Une découverte

Hors ligne

#3 Le 24/10/2013, à 16:22

Strone

Re : Problème d'installation de pilote AMD (fglrx)

J'ai essayé ta méthode, cependant ça bloque toujours au niveau des paquets .deb.
Dans tous les tuto's que je suivais je mettes Ubuntu/raring ou Ubuntu/precise sans savoir à quoi cela servait... je pense que le mien est saucy car lors des mises à jour, il est écrit plein de fois saucy.

Voici ce que me retourne le terminal :

bob@bob-HP-Pavilion-g6-Notebook-PC:~/catalyst13.10$ sudo dpkg -i fglrx*.deb
[sudo] password for bob: 
(Lecture de la base de données... 283759 fichiers et répertoires déjà installés.)
Dépaquetage de fglrx (à partir de fglrx_13.200-0ubuntu1_i386.deb) ...
/usr/share/ati/fglrx-uninstall.sh: 32: /usr/share/ati/fglrx-uninstall.sh: cannot create /etc/ati/fglrx-uninstall.log: Directory nonexistent

[Warning] Uninstall : inst_path_default or inst_path_override
 does not exist in /etc/ati.  This suggests that the AMD driver
 is not installed, the AMD driver is only partially installed,
 or the current AMD driver installed is an older version than the
 one this script was designed for.  Both files listed above are
 required for determining where installed files are located.
 To force uninstallation of the driver by guessing where the
 uninstallation files are located, set the force option
 re-run /usr/share/ati/fglrx-uninstall.sh (this is not recommended).

dpkg: erreur de traitement de fglrx_13.200-0ubuntu1_i386.deb (--install) :
 le sous-processus nouveau script pre-installation a retourné une erreur de sortie d'état 1
Préparation du remplacement de fglrx-amdcccle 2:13.200-0ubuntu1 (en utilisant fglrx-amdcccle_13.200-0ubuntu1_i386.deb) ...
Dépaquetage de la mise à jour de fglrx-amdcccle ...
Préparation du remplacement de fglrx-dev 2:13.200-0ubuntu1 (en utilisant fglrx-dev_13.200-0ubuntu1_i386.deb) ...
Dépaquetage de la mise à jour de fglrx-dev ...
dpkg: des problèmes de dépendances empêchent la configuration de fglrx-amdcccle :
 fglrx-amdcccle dépend de fglrx ; cependant :
  Le paquet fglrx n'est pas installé.

dpkg: erreur de traitement de fglrx-amdcccle (--install) :
 problèmes de dépendances - laissé non configuré
dpkg: des problèmes de dépendances empêchent la configuration de fglrx-dev :
 fglrx-dev dépend de fglrx ; cependant :
  Le paquet fglrx n'est pas installé.

dpkg: erreur de traitement de fglrx-dev (--install) :
 problèmes de dépendances - laissé non configuré
Des erreurs ont été rencontrées pendant l'exécution :
 fglrx_13.200-0ubuntu1_i386.deb
 fglrx-amdcccle
 fglrx-dev

Comme je l'ai dit précédemment, l'erreur est due au paquet fglrx qui est inexistant, et même installé il ne sert à rien puisqu'il n'est même pas détecté car il s'installe mal, et ne cause que des problèmes.
Les commandes lancées dans le terminal que tu as en bloc ci-dessus :

sudo dpkg -i fglrx*.deb
sudo amdconfig --initial -f
fglrxinfo
glxinfo | egrep render
glxgears

( À savoir que l'animation de "glxgears" était fluide ).

Tu vois, le problème est lié au paquet fglrx, mais il pose problème dans les deux sens.


"Hello ! My name is mine turtle !"

Hors ligne

#4 Le 24/10/2013, à 17:31

Horigo

Re : Problème d'installation de pilote AMD (fglrx)

Pourquoi tu fais tout cela ?
Il suffit d'aller dans les options du gestionnaire de mise à jour et dans l'onglet'pilotes propriétaire s' il suffit de cocher le pilote 'fglxr updates'

Maintenant que tu as fait plein de manips je ne sais pas du tout si ça va encore marcher.

Quelle est ta carte graphique exactement ?

Au passage pour les cartes un peu ancienne s il vaut mieux garder le pilote libre.

Pourquoi as tu besoin du propriétaire ?

Hors ligne

#5 Le 24/10/2013, à 19:48

Strone

Re : Problème d'installation de pilote AMD (fglrx)

J'avais déjà essayé en passant par le gestionnaire de pilotes, ça ne fonctionnait pas, il se remettait par défaut sur le premier pilote à chaque fois.
Ma carte graphique : une Radeon HD 7500/7600 ( ce qui est affiché lors de la commande ).

Je ne crois pas que ma carte soit ancienne, mon ordinateur date de l'année dernière.
Je cherche juste un pilote qui fonctionne, libre ou propriétaire, peu importe, tant qu'il me permet de faire fonctionner ma carte graphique et d'avoir accès à un panneau de réglage des graphismes.
( La plupart des jeux auxquels j'ai essayé de jouer avaient des graphismes très sombres, dus à la carte graphique trop faible ou aux pilotes trop anciens, qu'ils disaient sur le net ).

En fait le vrai problème c'est que l'installation des paquets fglrx et fglrx-dev ne se déroule pas correctement, et je voudrais palier à ce problème, soit en réglant le problème de fglrx, soit en passant par une autre méthode pour pouvoir utiliser ma carte graphique.

Dernière modification par Strone (Le 24/10/2013, à 20:06)


"Hello ! My name is mine turtle !"

Hors ligne

#6 Le 24/10/2013, à 20:43

ljere

Re : Problème d'installation de pilote AMD (fglrx)

essaye de virer ton ancienne installation

sudo sh /usr/share/ati/fglrx-uninstall.sh
sudo apt-get remove --purge fglrx fglrx_* fglrx-amdcccle* fglrx-dev* xserver-xorg-video-ati xserver-xorg-video-radeon

puis au choix tu pourras installer un pilote libre ou retenter mon tuto


Modérateur d'ubuntu-fr.org
athlon 2800+, nvidia FX5200 et 2 Go de ram et sempron 3000+, ati radeon et 1 Go de ram sur voyager 12.04 32 bit
Toshiba satellite_c670d-11l sur openbox/xubuntu 14.04 64 bit
Mon Blog et Une découverte

Hors ligne

#7 Le 25/10/2013, à 15:37

Strone

Re : Problème d'installation de pilote AMD (fglrx)

Tu pourrais me donner des exemples de pilotes libres correspondant à mon système et à ma carte s'il te plaît ?
Je ne sais pas où en trouver.

Et je vais essayer de désinstaller l'ancienne installation ce soir, quand j'en aurais le temps. smile


"Hello ! My name is mine turtle !"

Hors ligne

#8 Le 25/10/2013, à 16:27

ljere

Re : Problème d'installation de pilote AMD (fglrx)


Modérateur d'ubuntu-fr.org
athlon 2800+, nvidia FX5200 et 2 Go de ram et sempron 3000+, ati radeon et 1 Go de ram sur voyager 12.04 32 bit
Toshiba satellite_c670d-11l sur openbox/xubuntu 14.04 64 bit
Mon Blog et Une découverte

Hors ligne

#9 Le 25/10/2013, à 20:53

Alexubuntu87

Re : Problème d'installation de pilote AMD (fglrx)

Ce ne fonctionne toujours pas.

Existe t il une alternative linux pour éviter ce problème. J'ai fait presque tous les topics où ils traitent de problèmes avec ati hd radeon mais toujours rien.

La j'ai les fichiers installé de fglrx legacy mais les températures sont toujours trés fortes;
Adapter: Virtual device
temp1:        +63.0°C  (crit = +100.0°C)
temp2:        +57.0°C  (crit = +100.0°C)
temp3:        +61.0°C  (crit = +100.0°C)

coretemp-isa-0000
Adapter: ISA adapter
Core 0:       +58.0°C  (high = +100.0°C, crit = +100.0°C)
Core 1:       +59.0°C  (high = +100.0°C, crit = +100.0°C)

Hors ligne

#10 Le 26/10/2013, à 08:37

Strone

Re : Problème d'installation de pilote AMD (fglrx)

J'ai purgé mon ancienne installation, sauf que ça m'a répété la même erreur. Alors là je me rends compte que depuis sa première installation, je n'avais jamais supprimé le dossier "ati", donc je l'ai fait là, et apparemment l'installation des paquets .deb fonctionne, les commandes aticonfig et amdcccle existent, cependant il reste des erreurs.

Voici ce que me retourne le terminal à partir de la commande de l'installation des paquets .deb :

bob@bob-HP-Pavilion-g6-Notebook-PC:~/catalyst13.10$ sudo dpkg -i fglrx*.deb
(Lecture de la base de données... 283950 fichiers et répertoires déjà installés.)
Préparation du remplacement de fglrx 2:13.200-0ubuntu1 (en utilisant fglrx_13.200-0ubuntu1_i386.deb) ...
Removing all DKMS Modules
Done.
Dépaquetage de la mise à jour de fglrx ...
Préparation du remplacement de fglrx-amdcccle 2:13.200-0ubuntu1 (en utilisant fglrx-amdcccle_13.200-0ubuntu1_i386.deb) ...
Dépaquetage de la mise à jour de fglrx-amdcccle ...
Préparation du remplacement de fglrx-dev 2:13.200-0ubuntu1 (en utilisant fglrx-dev_13.200-0ubuntu1_i386.deb) ...
Dépaquetage de la mise à jour de fglrx-dev ...
Paramétrage de fglrx (2:13.200-0ubuntu1) ...
update-initramfs: deferring update (trigger activated)
Loading new fglrx-13.200 DKMS files...
Building only for 3.11.0-13-generic
Building for architecture i686
Building initial module for 3.11.0-13-generic
Done.

fglrx:
Running module version sanity check.
 - Original module
   - No original module exists within this kernel
 - Installation
   - Installing to /lib/modules/3.11.0-13-generic/updates/dkms/

depmod....

DKMS: install completed.
update-initramfs: deferring update (trigger activated)
Traitement des actions différées (« triggers ») pour « ureadahead »...
Traitement des actions différées (« triggers ») pour « bamfdaemon »...
Rebuilding /usr/share/applications/bamf-2.index...
Paramétrage de fglrx-amdcccle (2:13.200-0ubuntu1) ...
Paramétrage de fglrx-dev (2:13.200-0ubuntu1) ...
Traitement des actions différées (« triggers ») pour « initramfs-tools »...
update-initramfs: Generating /boot/initrd.img-3.11.0-13-generic
Traitement des actions différées (« triggers ») pour « libc-bin »...
bob@bob-HP-Pavilion-g6-Notebook-PC:~/catalyst13.10$ sudo amdconfig --initial -f
Uninitialised file found, configuring.
Using /etc/X11/xorg.conf
Saving back-up to /etc/X11/xorg.conf.fglrx-2

Donc là dedans j'ai lancé l'installation des paquets .deb ( la réinstallation parce que je ne pouvais plus voir l'installation originale dans le terminal, une commande avait bouffé toute la fenêtre, mais il est écrit la même chose à part qu'il y a des fichiers existants ), puis la commande avec aticonfig.
En lançant la commande amdcccle, une fenêtre AMD s'ouvre et me dit :

"Il y avait un problème d'initialisation dans l'édition Catalyst Conrol Center Linux. Il peut provenir du suivant :

Aucun pilote AMD n'est installé, ou bien le pilote AMD ne fonctionne pas correctement. Veuillez installer le pilote AMD adapté à votre matériel AMD, ou configurez avec aticonfig."

Le problème vient-il du fait que le pilote 13.10 est une bêta ? Je devrais faire une recherche manuelle du pilote pour ma carte ?
Le problème devient de moins en moins grave ou de plus en plus grave ?

Par contre maintenant, si je lance les vérifications :

fglrxinfo
glxinfo | egrep render
glxgears

Une fenêtre s'ouvre pour chaque commande, disant que l'application s'est arrêtée de façon inattendue. La commande "glxgears" lance toujours une fenêtre mais elle se ferme au bout d'une seconde et il n'y a rien à l'intérieur.

EDIT [4 heures après]
J'ai réessayé ton tuto' avec une version d'AMD différente ( 13.4 ) et voici le résultat :

bob@bob-HP-Pavilion-g6-Notebook-PC:~/catalyst13.4$ sudo sh ./amd-driver-installer-catalyst-13-4-x86.x86_64.run --buildpkg Ubuntu/saucy
Created directory fglrx-install.369Ifu
Verifying archive integrity... All good.
Uncompressing AMD Catalyst(TM) Proprietary Driver-12.104....................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................
=====================================================================
 AMD Catalyst(TM) Proprietary Driver Installer/Packager 
=====================================================================
Generating package: Ubuntu/saucy
Package /home/bob/catalyst13.4/fglrx_12.104-0ubuntu1_i386.deb has been successfully generated
Package /home/bob/catalyst13.4/fglrx-dev_12.104-0ubuntu1_i386.deb has been successfully generated
Package /home/bob/catalyst13.4/fglrx-amdcccle_12.104-0ubuntu1_i386.deb has been successfully generated
Removing temporary directory: fglrx-install.369Ifu
bob@bob-HP-Pavilion-g6-Notebook-PC:~/catalyst13.4$ sudo dpkg -i fglrx*.deb
Sélection du paquet fglrx précédemment désélectionné.
(Lecture de la base de données... 283684 fichiers et répertoires déjà installés.)
Dépaquetage de fglrx (à partir de fglrx_12.104-0ubuntu1_i386.deb) ...
Sélection du paquet fglrx-amdcccle précédemment désélectionné.
Dépaquetage de fglrx-amdcccle (à partir de fglrx-amdcccle_12.104-0ubuntu1_i386.deb) ...
Sélection du paquet fglrx-dev précédemment désélectionné.
Dépaquetage de fglrx-dev (à partir de fglrx-dev_12.104-0ubuntu1_i386.deb) ...
Paramétrage de fglrx (2:12.104-0ubuntu1) ...
update-alternatives: utilisation de « /usr/lib/fglrx/ld.so.conf » pour fournir « /etc/ld.so.conf.d/i386-linux-gnu_GL.conf » (i386-linux-gnu_gl_conf) en mode automatique
update-alternatives: avertissement: création de /usr/lib32/libaticalcl.so abandonnée car le fichier associé /usr/lib32/fglrx/libaticalcl.so (du groupe de liens i386-linux-gnu_gl_conf) n'existe pas
update-alternatives: avertissement: création de /usr/lib32/libaticalrt.so abandonnée car le fichier associé /usr/lib32/fglrx/libaticalrt.so (du groupe de liens i386-linux-gnu_gl_conf) n'existe pas
update-alternatives: avertissement: forçage de la réinstallation de l'alternative /usr/lib/fglrx/ld.so.conf car le groupe de liens i386-linux-gnu_gl_conf est cassé
update-alternatives: avertissement: création de /usr/lib32/libaticalcl.so abandonnée car le fichier associé /usr/lib32/fglrx/libaticalcl.so (du groupe de liens i386-linux-gnu_gl_conf) n'existe pas
update-alternatives: avertissement: création de /usr/lib32/libaticalrt.so abandonnée car le fichier associé /usr/lib32/fglrx/libaticalrt.so (du groupe de liens i386-linux-gnu_gl_conf) n'existe pas
update-alternatives: utilisation de « /usr/lib/fglrx/alt_ld.so.conf » pour fournir « /etc/ld.so.conf.d/x86_64-linux-gnu_GL.conf » (x86_64-linux-gnu_gl_conf) en mode automatique
update-initramfs: deferring update (trigger activated)
Loading new fglrx-12.104 DKMS files...
First Installation: checking all kernels...
Building only for 3.11.0-13-generic
Building for architecture i686
Building initial module for 3.11.0-13-generic
Error! Bad return status for module build on kernel: 3.11.0-13-generic (i686)
Consult /var/lib/dkms/fglrx/12.104/build/make.log for more information.
update-initramfs: deferring update (trigger activated)
Traitement des actions différées (« triggers ») pour « ureadahead »...
Traitement des actions différées (« triggers ») pour « bamfdaemon »...
Rebuilding /usr/share/applications/bamf-2.index...
Paramétrage de fglrx-amdcccle (2:12.104-0ubuntu1) ...
Paramétrage de fglrx-dev (2:12.104-0ubuntu1) ...
Traitement des actions différées (« triggers ») pour « initramfs-tools »...
update-initramfs: Generating /boot/initrd.img-3.11.0-13-generic
Traitement des actions différées (« triggers ») pour « libc-bin »...
bob@bob-HP-Pavilion-g6-Notebook-PC:~/catalyst13.4$ 

bob@bob-HP-Pavilion-g6-Notebook-PC:~/catalyst13.4$ sudo amdconfig --initial -f
Uninitialised file found, configuring.
PowerXpress info: Diagnostic output from /usr/lib/fglrx/switchlibglx:
update-alternatives: avertissement: forçage de la réinstallation de l'alternative /usr/lib/fglrx/ld.so.conf car le groupe de liens i386-linux-gnu_gl_conf est cassé
update-alternatives: avertissement: création de /usr/lib32/libaticalcl.so abandonnée car le fichier associé /usr/lib32/fglrx/libaticalcl.so (du groupe de liens i386-linux-gnu_gl_conf) n'existe pas
update-alternatives: avertissement: création de /usr/lib32/libaticalrt.so abandonnée car le fichier associé /usr/lib32/fglrx/libaticalrt.so (du groupe de liens i386-linux-gnu_gl_conf) n'existe pas
update-alternatives: avertissement: /usr/lib/i386-linux-gnu/xorg/extra-modules ne sera pas remplacé par un lien

Using /etc/X11/xorg.conf
Saving back-up to /etc/X11/xorg.conf.fglrx-7

Pas de grand changement, à ce que je vois. Apparemment il y a beaucoup de choses qui ne coïncident pas, les erreurs doivent provenir de cela...

Dernière modification par Strone (Le 26/10/2013, à 12:11)


"Hello ! My name is mine turtle !"

Hors ligne

#11 Le 26/10/2013, à 20:29

ljere

Re : Problème d'installation de pilote AMD (fglrx)

je pense que tu dois pas être loin, est ce que ta carte chauffe toujours? ou est ce que ça c'est stabilisé


Modérateur d'ubuntu-fr.org
athlon 2800+, nvidia FX5200 et 2 Go de ram et sempron 3000+, ati radeon et 1 Go de ram sur voyager 12.04 32 bit
Toshiba satellite_c670d-11l sur openbox/xubuntu 14.04 64 bit
Mon Blog et Une découverte

Hors ligne

#12 Le 27/10/2013, à 11:59

Strone

Re : Problème d'installation de pilote AMD (fglrx)

Hé bien moi ma carte ne chauffe pas, vu qu'elle n'est même pas opérationnelle...

D'ailleurs, j'ai encore rencontré un problème dernièrement. En effet, lorsque j'ai redémarré mon ordinateur, la carte a posé problème et ubuntu ne s'est pas lancé correctement, il m'a affiché un problème comme quoi la carte ne fonctionnait pas bien, et me proposait 4 solutions : "Run in low-graphic mode", "Reconfigure graphics", ...

Enfin tu vois de quoi je veux parler quoi. Du coup j'ai été obligé de désinstaller fglrx pour que tout rentre dans l'ordre.
Je vois pas comment faire pour utiliser ma carte.
Tu vois une solution ?


"Hello ! My name is mine turtle !"

Hors ligne

#13 Le 28/10/2013, à 16:27

Strone

Re : Problème d'installation de pilote AMD (fglrx)

Un petit up pour que quelqu'un daigne jeter un oeil sur mon problème ? roll


"Hello ! My name is mine turtle !"

Hors ligne

#14 Le 28/10/2013, à 16:47

Gaara

Re : Problème d'installation de pilote AMD (fglrx)

salut,

moi aussi j'ai des problèmes avec les pilotes AMD et ubuntu 13.10. Malheureusement les drivers que tu télécharges sur le sites ne sont pas compatibles, même la version bêta 13.11. Le support s'arrête à Ubuntu 13.04, c'est noté sur la page.
De mon côté, j'ai installé fglrx-updates, qui fonctionne à peu près. (malgré quelques ralentissements des animations des fenêtres sur KDE)
Essaye de les installer, mais avant fait un:

sudo apt-get remove --purge fglrx*
sudo reboot

puis

sudo apt-get install fglrx-updates
sudo aticonfig --initial

et enfin un second reboot.

Dernière modification par gaara92 (Le 30/10/2013, à 16:53)


Kubuntu!!
Notification de mises à jour automatiques
Téléchargement des vidéos Pluzz
                                              <code>zenity  --question --title "Alert"  --text "Microsoft Windows has been found! Would you like to remove it?"</code>

Hors ligne

#15 Le 29/10/2013, à 05:37

ratafia

Re : Problème d'installation de pilote AMD (fglrx)

Vous prenez pas le choux les gars. fglrx s'installe via la logithèque, AMD catalyst aussi. Lorsque c'est fait allez sélectionner votre nouveau pilote dans le dépôt si nécessaire. C'est ce que j'ai fait et ça marche au poil. cool

Dernière modification par ratafia (Le 29/10/2013, à 05:40)

Hors ligne

#16 Le 30/10/2013, à 15:27

Strone

Re : Problème d'installation de pilote AMD (fglrx)

@gaara : On a un panneau de configuration de la carte graphique ensuite ? Comment savoir si elle est opérationnelle ?

@ratafia : Non justement, le problème est bien là, l'installation de ce paquet pose problème et n'est pas fonctionnel.


"Hello ! My name is mine turtle !"

Hors ligne

#17 Le 30/10/2013, à 15:54

ljere

Re : Problème d'installation de pilote AMD (fglrx)

pour savoir si tout est fonctionnel ce sont ces commandes

fglrxinfo
glxinfo | egrep render
glxgears

Modérateur d'ubuntu-fr.org
athlon 2800+, nvidia FX5200 et 2 Go de ram et sempron 3000+, ati radeon et 1 Go de ram sur voyager 12.04 32 bit
Toshiba satellite_c670d-11l sur openbox/xubuntu 14.04 64 bit
Mon Blog et Une découverte

Hors ligne

#18 Le 30/10/2013, à 16:47

Gaara

Re : Problème d'installation de pilote AMD (fglrx)

Oui, le paquet fglrx-amdcccle-updates s'installe avec. On peut le lancer en faisant

sudo amdcccle

Pour vérifier, éventuellement un

fgl_glxgears

Dernière modification par gaara92 (Le 30/10/2013, à 16:51)


Kubuntu!!
Notification de mises à jour automatiques
Téléchargement des vidéos Pluzz
                                              <code>zenity  --question --title "Alert"  --text "Microsoft Windows has been found! Would you like to remove it?"</code>

Hors ligne

#19 Le 31/10/2013, à 10:23

Strone

Re : Problème d'installation de pilote AMD (fglrx)

Dans toutes les installations de fglrx que je fais, on me dit que certains dossiers et fichiers n'ont pas pu être créés car le répertoire n'existe pas, et entre parenthèses il me précise "groupe de lien...".

Le problème peut également survenir de là. Mon ordinateur a eu beaucoup de problèmes, réglés maintenant, mais le premier d'entre eux était le pilote wi-fi non fonctionnel, j'ai réussi à le régler mais avec beaucoup de difficultés...
D'où peuvent provenir tous ces problèmes ? Sachant que j'ai déjà fait une réinstallation il y a environ 6 mois, je ne pense pas que cela vienne d'un problème d'installation, à moins que mon ordinateur n'aime pas Ubuntu ?

Et la commande aticonfig --initial ne fonctionne toujours pas. Par précaution je préfère retirer fglrx-updates le temps de trouver une autre solution.


"Hello ! My name is mine turtle !"

Hors ligne

#20 Le 31/10/2013, à 10:56

fcn50

Re : Problème d'installation de pilote AMD (fglrx)

Salut,

Vire tout ce qui concerne fglrx puis reboot, je vais essayer de te guider dans l'installation de catalyst 13.11 beta 6. Fait signe dès que tu es prêts.


12.04.4 LTS, Xfce 4.10, Phenom II x6 1090T BE, SSD Patriot Inferno 60 Go, WD Black 1 To, Sapphire HD 7750 ULTIMATE, RME HDSP 9632, Dell U2713HM.
    Un site qui vaut le détour: http://blog.syti.net  Une radio hors du commun: http://solenopole.org  You like the american dream? Wellcome to Guantànamo!

Hors ligne

#21 Le 02/11/2013, à 09:20

Strone

Re : Problème d'installation de pilote AMD (fglrx)

Désolé de ne pas avoir répondu, ces derniers temps je suis débordé de travail et en plus mon ordinateur déconne...
Bon, à présent, il ne veut plus démarrer.

J'ai donc supprimé "fglrx" dans le terminal, rien, il ne veut toujours pas redémarrer...
Ensuite ( et là grosse boulette je pense ) j'ai supprimé "xorg"...

Donc, comment je peux faire maintenant ?


"Hello ! My name is mine turtle !"

Hors ligne

#22 Le 02/11/2013, à 10:14

ljere

Re : Problème d'installation de pilote AMD (fglrx)

supprimé xorg n'est pas une boulette, sinon un simple

sudo dpkg-reconfigure xserver-xorg

devrait suffire à en recréer un


Modérateur d'ubuntu-fr.org
athlon 2800+, nvidia FX5200 et 2 Go de ram et sempron 3000+, ati radeon et 1 Go de ram sur voyager 12.04 32 bit
Toshiba satellite_c670d-11l sur openbox/xubuntu 14.04 64 bit
Mon Blog et Une découverte

Hors ligne

#23 Le 02/11/2013, à 10:18

fcn50

Re : Problème d'installation de pilote AMD (fglrx)

Tu boot en mode dépannage puis tu choisis console root et tu tapes: sudo rm /etc/X11/xorg.conf ensuite: sudo apt-get install xorg xserver-xorg-video-radeon, une fois fait tu tapes: sudo reboot et ça devrait marcher.


12.04.4 LTS, Xfce 4.10, Phenom II x6 1090T BE, SSD Patriot Inferno 60 Go, WD Black 1 To, Sapphire HD 7750 ULTIMATE, RME HDSP 9632, Dell U2713HM.
    Un site qui vaut le détour: http://blog.syti.net  Une radio hors du commun: http://solenopole.org  You like the american dream? Wellcome to Guantànamo!

Hors ligne

#24 Le 02/11/2013, à 18:11

Strone

Re : Problème d'installation de pilote AMD (fglrx)

D'accord, merci, j'essaierais dès que j'en aurais l'occasion.

[EDIT] Il me fait le même problème que fglrx : quand je veux le supprimer on me dit qu'il n'existe pas et quand je veux l'installer on me dit qu'il est partiellement installé ou cassé.

Le problème c'est que je ne connais plus la commande que j'ai utilisé pour forcer la désinstallation de fglrx, vous en avez une idée ?
Et il me dit aussi que /etc/X11/xorg.conf ne peut être supprimé en lecture seule.

Comment faire ?

Dernière modification par Strone (Le 03/11/2013, à 17:14)


"Hello ! My name is mine turtle !"

Hors ligne

#25 Le 05/11/2013, à 15:49

Strone

Re : Problème d'installation de pilote AMD (fglrx)

Un gentil petit up pour quelqu'un dans le besoin ? roll


"Hello ! My name is mine turtle !"

Hors ligne

Haut de page ↑