Contenu | Rechercher | Menus

Annonce

Si vous rencontrez des soucis à rester connecté sur le forum (ou si vous avez perdu votre mot de passe) déconnectez-vous et reconnectez-vous depuis cette page, en cochant la case "Me connecter automatiquement lors de mes prochaines visites". Attention, le forum rencontre actuellement quelques difficultés. En cas d'erreur 502, il ne faut pas re-valider l'envoi d'un message ou l'ouverture d'une discussion, au risque de créer un doublon.

La section divers se réorganise ! De nouvelles sous-sections à venir. (plus d'infos + donner son avis)

#1 Le 10/11/2013, à 18:30

Le Goss

Handbrake a le hoquet en encodant des fichiers *.m2ts

Bonsoir à tous

Je teste l'encodage des videos m2ts de ma freebox avec HandBrake, en lignes de commande.
C'est simple à mettre en œuvre, mais je n'arrive pas à m'expliquer que le fichier obtenu comporte des sauts, en simultané, du son et d'image, alors que je ne décèle rien sur la vidéo originale.
La console me renvoie très fréquemment les lignes suivantes, au millième de seconde près (216 et 239):

Encoding: task 1 of 1, 89.18 % (119.34 fps, avg 117.96 fps, ETA 00h00m48s)[18:13:14] sync: video time didn't advance - dropped 6 frames (delta 216 ms, current 168857812, next 168859971, dur 2159)
Encoding: task 1 of 1, 97.70 % (106.65 fps, avg 117.61 fps, ETA 00h00m11s)[18:13:53] sync: audio 0x45 time went backwards 239 ms, dropped 6 frames (start 184962763, next 184984320)

Quelqu'un a-t-il déjà rencontré le problème? en a-t-il trouvé la raison... et la solution? d'autant qu'avec ffmpeg et mencoder, aucune anomalie de ce genre n'est à signaler dans mon cas.

Je pressens que ceci a un rapport avec la nature des fichier m2ts...
Merci pour votre aide!
Cordialement


i7-3630QM CPU @ 2.40GHz × 8 - 64 bits - RAM 7,7 Gio - DD 976,0 Go
Ubuntu Studio 14.04
Allergique au wysiwyg; traitement à vie: Lilypond LaTeX txt2tags

Hors ligne

#2 Le 11/11/2013, à 10:09

vikin712

Re : Handbrake a le hoquet en encodant des fichiers *.m2ts

Bonjour.

On ne lit pas dans tes pensées donc pourrais-tu préciser la version d'ubuntu et de Handbrake que tu utilises. Merci.

Dernière modification par vikin712 (Le 11/11/2013, à 10:10)

#3 Le 11/11/2013, à 17:32

Le Goss

Re : Handbrake a le hoquet en encodant des fichiers *.m2ts

Désolé... Ubuntu Studio 13.04 et HandBrake 0.9.9

Dernière modification par Le Goss (Le 11/11/2013, à 17:33)


i7-3630QM CPU @ 2.40GHz × 8 - 64 bits - RAM 7,7 Gio - DD 976,0 Go
Ubuntu Studio 14.04
Allergique au wysiwyg; traitement à vie: Lilypond LaTeX txt2tags

Hors ligne

#4 Le 12/11/2013, à 08:14

Le Goss

Re : Handbrake a le hoquet en encodant des fichiers *.m2ts

J'ai trouvé par hasard une (la?) solution.
J'avais besoin de découper mes fichiers. Je suis tombé sur Tsmuxer.
Quand j'encode le fichier obtenu, plus de saute d'image, ni de son.
Par contre, j'ai un décalage son progressif...


i7-3630QM CPU @ 2.40GHz × 8 - 64 bits - RAM 7,7 Gio - DD 976,0 Go
Ubuntu Studio 14.04
Allergique au wysiwyg; traitement à vie: Lilypond LaTeX txt2tags

Hors ligne

#5 Le 12/11/2013, à 18:41

vikin712

Re : Handbrake a le hoquet en encodant des fichiers *.m2ts

Bonsoir.

Tu peux aussi essayer avec ProjectX.

#6 Le 12/11/2013, à 21:15

Le Goss

Re : Handbrake a le hoquet en encodant des fichiers *.m2ts

Je m'en sers déjà pour encoder les fichiers enregistrés à partir de ma clé tnt.
Mais ProjectX ne me prend aucun des fichiers m2ts de ma freebox.
Au chargement des fichiers le message suivant apparaît:

error while decoding frame not enough data in buffer


i7-3630QM CPU @ 2.40GHz × 8 - 64 bits - RAM 7,7 Gio - DD 976,0 Go
Ubuntu Studio 14.04
Allergique au wysiwyg; traitement à vie: Lilypond LaTeX txt2tags

Hors ligne

#7 Le 19/08/2014, à 23:40

tugdualenligne

Re : Handbrake a le hoquet en encodant des fichiers *.m2ts

Hello Le Goss,
As-tu trouvé la réponse à ta question d'origine ? J'ai le même problème que toi sur mon Mac, après avoir encodé des centaines de vidéo m2ts avec mon Ubuntu server... sans aucun problème.
Merci d'avance

Hors ligne

#8 Le 20/08/2014, à 09:17

Le Goss

Re : Handbrake a le hoquet en encodant des fichiers *.m2ts

Tu poses la question pile poil!
Pas plus tard qu'avant hier, je pense avoir trouvé la solution:
Lorsque je faisais mon mux avec tsmuxer, je laissais l'output réglé sur "m2ts muxing" coché.
En choisissant "ts", la compression d'handbrake qui suit ne comporte ni saut ni décalage son, sauf au début de la vidéo obtenue. Mais au bout de quelques secondes, tout est en phase avec seulement un éventuel décalage son constant (+/- 2-3 dixièmes).
Donc:
1. Avec tsmuxer, charger le fichier *.m2ts ,virer les pistes audio inutiles, sélectionner "ts muxing" et muxer
2. Ta ligne de commande hanbrake pour la compression
3. Possible décalage son constant à estimer avec mplayer et à corriger, et début fin et pubs à couper (avec avidemux pour ce qui me concerne)
Je referai quelques test avant de mettre de sujet en résolu.

Merci pour les retours!


i7-3630QM CPU @ 2.40GHz × 8 - 64 bits - RAM 7,7 Gio - DD 976,0 Go
Ubuntu Studio 14.04
Allergique au wysiwyg; traitement à vie: Lilypond LaTeX txt2tags

Hors ligne

#9 Le 20/08/2014, à 16:53

Le Goss

Re : Handbrake a le hoquet en encodant des fichiers *.m2ts

Il semble que ça fonctionne...
Je me suis fait un script que j'ai mis dans le dossier Vidéos. A vous d'adapter...

Comment je m'y prends:
1. Accès à ma page freebox et ouverture du dossier Téléchargements où Firefox télécharge mes fichiers *.m2ts
2. Dans mon dossier Téléchargements, se trouve déjà le dossier extrait de l'archive de tsmuxer; je l'ouvre et double-clic sur tsMuxerGUI
3. Chargement de chaque vidéo *.m2ts et muxage en *ts dans mon dossier Vidéos (nommage des fichiers sans espace)
4. Lancement de HandBrakeCLI qui traitera TOUS les fichiers *.ts présents dans le dossier Vidéos
5. Un petit chocolat chaud et... tiens, c'est fini!
6. Un petit coup de mplayer pour estimer le décalage son/vidéo (touches + et - du clavier)
7. Avidemux pour le corriger, supprimer les pubs etc.

#!/bin/bash

clear
firefox "http://mafreebox.freebox.fr/"
clear
xdg-open /home/${USER}/Téléchargements
read -p 'Une fois le(s) fichier(s) *.ts obtenus, appuyer pour lancer HandBrakeCLI : '

for i in *.ts; do
HandBrakeCLI -i $i --start-at duration:00:00:01 --x264-tune film -o $i.mkv -e x264 -q 25 -E copy && mencoder $i.mkv -ovc copy -oac mp3lame -lameopts cbr:br=80 -o $i.mp4 && rm $i.mkv
done

Remarque 1: les options et réglages sont arbitraires; à vous d'y mettre les vôtres
Remarque 2: pourquoi un "--start-at duration:00:00:01"?
Après plusieurs essais, je me suis aperçu que handbrake est sensible au problème de désynchronisation présent dans les fichiers ts issus de la freebox. Pour une raison que j'ignore, cette anomalie "disparaît" au bout de quelques secondes à quelques minutes de conversion. l'ajout de "--start-at duration:00:00:01" amène handbrake à ne commencer la conversion qu'à partir du moment où la synchro est la moins importante possible. Pensez donc, lors de vos programmations d'enregistrements, à prendre une marge minimale de 5mn.
Remarque 3: pourquoi une commande mencoder pour faire la compression son, alors que handbrake pourrait la faire avec -B 80?
Parce que quand je supprime les pubs avec avidemux, le son de la nouvelle vidéo est complètement HS. Ça me faisait la même chose lorsque ma vidéo initiale était obtenu par ffmpeg puis avconv. Sans pouvoir l'expliquer, seule une vidéo traitée par encoder peut être correctement traité au niveau du son par avidemux.
Remarque 4: pourquoi sauver la vidéo obtenu par handbrake en mkv? simplement parce que pour l'instant (???), je ne peut rien mettre d'autre!!!

Si quelqu'un à des infos...

@+


i7-3630QM CPU @ 2.40GHz × 8 - 64 bits - RAM 7,7 Gio - DD 976,0 Go
Ubuntu Studio 14.04
Allergique au wysiwyg; traitement à vie: Lilypond LaTeX txt2tags

Hors ligne

Haut de page ↑