Contenu | Rechercher | Menus

Annonce

Si vous rencontrez des soucis à rester connecté sur le forum (ou si vous avez perdu votre mot de passe) déconnectez-vous et reconnectez-vous depuis cette page, en cochant la case "Me connecter automatiquement lors de mes prochaines visites".
Test de l'ISO d'Ubuntu francophone : nous avons besoin de testeurs pour la version francophone d'Ubuntu 14.04. Liens et informations ici.

Attention, une faille de sécurité dans bash a récemment été rapportée, il est recommandé de mettre à jour son système (plus de détails) *** mise à jour 12/10/2014 ***

#1 Le 25/06/2012, à 18:56

tutoux

POI-loader sous wine

Bonjour,

j'essaye de faire marcher POILoaderforWindows_271.exe via Wine 1.4 sous Ubuntu 12.04 sur machine 64 bits.

Voilà l'erreur :

$ cd /home/mlbg/GPS/POI-loader
mlbg@UL30A:~/GPS/POI-loader$ wine POILoaderforWindows_271.exe
p11-kit: couldn't load module: /usr/lib/i386-linux-gnu/pkcs11/gnome-keyring-pkcs11.so: /usr/lib/i386-linux-gnu/pkcs11/gnome-keyring-pkcs11.so: Ne peut ouvrir le fichier d'objet partagé: Aucun fichier ou dossier de ce type
fixme:storage:create_storagefile Storage share mode not implemented.
mlbg@UL30A:~/GPS/POI-loader$ p11-kit: couldn't load module: /usr/lib/i386-linux-gnu/pkcs11/gnome-keyring-pkcs11.so: /usr/lib/i386-linux-gnu/pkcs11/gnome-keyring-pkcs11.so: Ne peut ouvrir le fichier d'objet partagé: Aucun fichier ou dossier de ce type
fixme:dbghelp:EnumerateLoadedModulesW64 If this happens, bump the number in mod
fixme:dbghelp:EnumerateLoadedModulesW64 If this happens, bump the number in mod
fixme:wininet:CommitUrlCacheEntryInternal entry already in cache - don't know what to do!
fixme:dbghelp:EnumerateLoadedModulesW64 If this happens, bump the number in mod
err:wininet:open_http_connection create_netconn failed: 10004
fixme:wininet:CommitUrlCacheEntryInternal entry already in cache - don't know what to do!
fixme:wininet:InternetCanonicalizeUrlA Unhandled flags 0x00001000


ici je lis :

http://askubuntu.com/questions/127848/w … -pkcs11-so
This solution works for Ubuntu 12.04 64bit
I originally had this error:
/usr/lib/i386-linux-gnu/pkcs11/gnome-keyring-pkcs11.so: /usr/lib/i386-linux-gnu/pkcs11/gnome-keyring-pkcs11.so: cannot open shared object file: No such file or directory
Then I did a ln -s link to the 64-bit lib and got this error: /usr/lib/i386-linux-gnu/pkcs11/gnome-keyring-pkcs11.so: wrong ELF class: ELFCLASS64
note: before you start remove the link to the 64bit lib if you created it.
Solution:
Here is how to fix it. Note I am using Crossover 11.3, which uses wine 1.4 so it should also work for wine users.
Further related information to getlibs can be found here.
1) Install getlibs:
wget https://launchpad.net/~jcollins/+archiv … a2_all.deb
sudo dpkg -i getlibs_2.06-0ubuntu1~ppa2_all.deb
2) Install the 32bit library:
getlibs -p gnome-keyring:i386
3) Make the symbolic link:
sudo ln -s /usr/lib32/i386-linux-gnu/pkcs11/gnome-keyring-pkcs11.so /usr/lib/i386-linux-gnu/pkcs11/gnome-keyring-pkcs11.so
Now run your Crossover/Wine app and the error is gone.

Le premier message d'erreur :
p11-kit: couldn't load module: /usr/lib/i386-linux-gnu/pkcs11/gnome-keyring-pkcs11.so

Mes gnome-keyring-pkcs11.so :
/usr/lib32/i386-linux-gnu/pkcs11
et
/usr/lib/x86_64-linux-gnu/pkcs11

je tente le lien symbolique indiqué :

:~$ sudo ln -s /usr/lib32/i386-linux-gnu/pkcs11/gnome-keyring-pkcs11.so /usr/lib/i386-linux-gnu/pkcs11/gnome-keyring-pkcs11.so
[sudo] password for mlbg:
ln: impossible de créer le lien symbolique «/usr/lib/i386-linux-gnu/pkcs11/gnome-keyring-pkcs11.so»: Aucun fichier ou dossier de ce type

effectivement il n'y a pas de  pkcs11 dans /usr/lib/i386-linux-gnu
donc je n'ai pas compris grand chose:-)

une idée ?
Merci d'avance.
Cordialement.
Tutoux

Hors ligne

#2 Le 18/11/2013, à 17:38

Georges VINCENTS

Re : POI-loader sous wine

Bonjour,
Même problème : j'essaye d'utiliser poi-loader de Garmin via wine et rien ne marche.
Mon installation arrive à faire fonctionner l'outil de capture "faststone capture" donc elle n'est pas totalement bancale mais à chaque fois que je lance le programme d'installation de poi-loader j'obtiens :
"you must be a local administrator to run this application"...
J'ai donc retenté avec un sudo, et même avec root... rien n'y fait !
Si quelqu'un a des lumières, merci !
GV


2014 : PC serveur "maison" (carte MSI 64 bits, Mem 8Go, HD 1To, 2 cartes réseau) Edubuntu 13.10 avec ltsp
2013 : LDLC-W240EU Ubuntu 14.04, CPU Intel Core i5-3230M@2.6GHz*4/Mem 8Go/HD 500Go
2007 : ASUS F5VL, Xubuntu 14.04 / Windows XP, CPU duo T5250/Mem 2Go/HD 160 Go
2005 : PC monté "maison" et mis à jour de temps en temps... Ubuntu 12.04/Windows XP/Mem 2Go/HD120Go+320Go,

Hors ligne

#3 Le 18/11/2013, à 17:48

Georges VINCENTS

Re : POI-loader sous wine

suite :
Voici les messages obtenus dans le terminal :

georges@georges-F5VL:~$ wine /home/georges/Bureau/POILoaderforWindows_272.exe
fixme:appbar:handle_appbarmessage SHAppBarMessage(ABM_GETAUTOHIDEBAR, hwnd=(nil), edge=3): stub
fixme:appbar:handle_appbarmessage SHAppBarMessage(ABM_GETAUTOHIDEBAR, hwnd=(nil), edge=1): stub
fixme:appbar:handle_appbarmessage SHAppBarMessage(ABM_GETAUTOHIDEBAR, hwnd=(nil), edge=0): stub
fixme:appbar:handle_appbarmessage SHAppBarMessage(ABM_GETAUTOHIDEBAR, hwnd=(nil), edge=2): stub
.NET 3.5 found.
Launching client...

... et là plus rien, wine s'arrête... est-ce un problème d'affichage ?


2014 : PC serveur "maison" (carte MSI 64 bits, Mem 8Go, HD 1To, 2 cartes réseau) Edubuntu 13.10 avec ltsp
2013 : LDLC-W240EU Ubuntu 14.04, CPU Intel Core i5-3230M@2.6GHz*4/Mem 8Go/HD 500Go
2007 : ASUS F5VL, Xubuntu 14.04 / Windows XP, CPU duo T5250/Mem 2Go/HD 160 Go
2005 : PC monté "maison" et mis à jour de temps en temps... Ubuntu 12.04/Windows XP/Mem 2Go/HD120Go+320Go,

Hors ligne

#4 Le 21/11/2013, à 10:40

Georges VINCENTS

Re : POI-loader sous wine

Pour préciser voici ce que donnent plusieurs essais...

Lancement de wine via sudo :
georges@georges-F5VL:~$ sudo wine /home/georges/Bureau/POILoaderforWindows_272.exe
... il parait que "sudo" n'est pas propriétaire de .wine (et c'est vrai puisque c'est georges) et donc blocage immédiat

Lancement de wine via sudo su pour être root :
root@georges-F5VL:/home/georges# wine /home/georges/Bureau/POILoaderforWindows_272.exe
fixme:iphlpapi:NotifyAddrChange (Handle 0xdce880, overlapped 0xdce88c): stub
wine: configuration in '/root/.wine' has been updated.
fixme:appbar:handle_appbarmessage SHAppBarMessage(ABM_GETAUTOHIDEBAR, hwnd=(nil), edge=3): stub
fixme:appbar:handle_appbarmessage SHAppBarMessage(ABM_GETAUTOHIDEBAR, hwnd=(nil), edge=1): stub
fixme:appbar:handle_appbarmessage SHAppBarMessage(ABM_GETAUTOHIDEBAR, hwnd=(nil), edge=0): stub
fixme:appbar:handle_appbarmessage SHAppBarMessage(ABM_GETAUTOHIDEBAR, hwnd=(nil), edge=2): stub
.NET 3.5 found.
Launching client...
... et à nouveau le setup s'arrête sur le message "you must be a local administrator to run this program", et comme je suis root je suis plus que surpris.

Help ?


2014 : PC serveur "maison" (carte MSI 64 bits, Mem 8Go, HD 1To, 2 cartes réseau) Edubuntu 13.10 avec ltsp
2013 : LDLC-W240EU Ubuntu 14.04, CPU Intel Core i5-3230M@2.6GHz*4/Mem 8Go/HD 500Go
2007 : ASUS F5VL, Xubuntu 14.04 / Windows XP, CPU duo T5250/Mem 2Go/HD 160 Go
2005 : PC monté "maison" et mis à jour de temps en temps... Ubuntu 12.04/Windows XP/Mem 2Go/HD120Go+320Go,

Hors ligne

#5 Le 05/04/2014, à 19:06

Kedoc

Re : POI-loader sous wine

Bonjour,

Cette exécutable est en réalité une archive auto-extractible.
Avez-vous essayé cette manip : http://appdb.winehq.org/objectManager.p … &iId=11101

Pour ma part l'installation se fait. C'est ensuite que je suis bloqué…


Kedoc

Hors ligne

Haut de page ↑