Contenu | Rechercher | Menus

Annonce

Si vous rencontrez des soucis à rester connecté sur le forum (ou si vous avez perdu votre mot de passe) déconnectez-vous et reconnectez-vous depuis cette page, en cochant la case "Me connecter automatiquement lors de mes prochaines visites".
Test de l'ISO d'Ubuntu francophone : nous avons besoin de testeurs pour la version francophone d'Ubuntu 14.04. Liens et informations ici.

Attention, une faille de sécurité dans bash a récemment été rapportée, il est recommandé de mettre à jour son système (plus de détails) *** mise à jour 12/10/2014 ***

#1 Le 21/11/2013, à 19:01

demeter44

Probleme MAIL

Bonjour,

j'ai configuré un petit serveur mail via postfix dovecot amavis spamassin

j'ai néanmoins un petit souci de réception de mes email.

Exemple d'une adresse mail gmail vers mon domaine xxxxx@freeprog.fr

Nov 21 17:47:10 server1 postfix/smtpd[13229]: connect from mail-bk0-f53.google.com[209.85.214.53]
Nov 21 17:47:10 server1 postfix/smtpd[13229]: Anonymous TLS connection established from mail-bk0-f53.google.com[209.85.214.53]: TLSv1 with cipher ECDHE-RSA-RC4-SHA (128/128 bits)
Nov 21 17:47:25 server1 postfix/smtpd[13229]: warning: 53.214.85.209.dnsbl.njabl.org: RBL lookup error: Host or domain name not found. Name service error for name=53.214.85.209.dnsbl.njabl.org type=A: Host not found, try again
Nov 21 17:47:26 server1 postfix/smtpd[13274]: lost connection after UNKNOWN from localhost.localdomain[127.0.0.1]
Nov 21 17:47:26 server1 postfix/smtpd[13274]: disconnect from localhost.localdomain[127.0.0.1]

j'ai suivi le tuto a cette adresse : http://doc.ubuntu-fr.org/utilisateurs/m … stfixadmin

J'ai neamoins quelque probleme concernant mon domaine. En l'occurance mon mail qui est soit disant pas accepté mais qui est bien créer tout de même... ( l'envoie de mail du dedier a mon domicile fonctionne )

http://dnslookup.fr/freeprog.fr

Si une personne peut m’éclairer sur ce problème je le remercie d'avance.

Hors ligne

#2 Le 23/11/2013, à 22:59

Titouan

Re : Probleme MAIL

Salut,

quelques pistes pour ton problème de réception;

1/ Les *_restrictions s'affinent une fois que tu es arrivé  à envoyer et recevoir des mails.  Au début, tu les laisses presque par défaut.

sudo postconf -d | grep restrictions
smtpd_client_restrictions = 
smtpd_data_restrictions = 
smtpd_end_of_data_restrictions = 
smtpd_etrn_restrictions = 
smtpd_helo_restrictions = 
smtpd_recipient_restrictions = permit_mynetworks, reject_unauth_destination
smtpd_sender_restrictions = 

#sauf
smtpd_recipient_restrictions = permit_mynetworks, permit_sasl_authenticated, reject_unauth_destination

2/ transport; postfix ne sait pas où livrer le mail venant de gmail?

méthode virtual

mydestination = 
mydestination = localhost    # n'est pas gênant aussi 

renseigner transport_maps pour être explicite; 3 cas possibles; il y a forcément un cas qui va valider.

sudo nano /etc/postfix/transport
#domaines de messagerie à livrer sur la machine
mydomain.tld    :
#2ème cas mydomain.tld    virtual:
#3ème cas mydomain.tld    local:

sudo postmap hash:/etc/postfix/transport


une option sup. mais pas obligatoire, est de renseigner virtual_alias_domains = mydomain.tld
Tu regarderas la doc postfix & virtual pour voir les subtilités qu'il y a entre virtual unix et virtual non unix

3/ enfin vérifier les permissions de la BAL ( READ/WRITE)

a1 telnet mail.target.tld 143
#a1 openssl s_client -connect mail.target.tld:143 -starttls imap -ign_eof
a15 capability
a2 login toto mot_de_passe
#a2 login toto@mydomain.tld mot_de_passe
a3 list "" *
a4 select "inbox"
#et voir READ/WRITE
a5 create "dossier-test"
a6 delete "dossier-test"
a7 logout

Hors ligne

Haut de page ↑