Contenu | Rechercher | Menus

Annonce

Si vous rencontrez des soucis à rester connecté sur le forum (ou si vous avez perdu votre mot de passe) déconnectez-vous et reconnectez-vous depuis cette page, en cochant la case "Me connecter automatiquement lors de mes prochaines visites".
Test de l'ISO d'Ubuntu francophone : nous avons besoin de testeurs pour la version francophone d'Ubuntu 14.04. Liens et informations ici.

#1 Le 11/02/2008, à 11:07

tomtom

kde4 : paquet cassé :'(

Coucou tout le monde !

Hier soir, j'ai voulu faire le grand saut, j'ai voulu installer KDE4.

Donc dans Adept, j'ai demander à  installer le méta paquet kde4, plus les différents paquets qu'on nous dis d'installer nas le wiki.
Mais un probleme est survenu lors de l'installation? Maintenant, dans Adept, il me dit que le paquet kde4 est cassé.

Que puis-je faire pour réparer ca ? (parce que, bien entendu, je n'ai pas d'entrée KDE4 dans KDM !!


Autre petite question bonus, est-ce que KDE 4.0.1 est utilisable ?

Merci d'avance pour vos suggestions ou réponses wink

Hors ligne

#2 Le 11/02/2008, à 11:22

Smarter

Re : kde4 : paquet cassé :'(

donne le retour de:

sudo dpkg --configure -a
sudo aptitude update && sudo aptitude full-upgrade

Au passage, installé kde4 c'est un peu bourrin, il dépend de tous les programmes kde4(et y'en a un paquet), je te conseille plutà´t d'installer kde4-core + d'autres trucs(voir la liste des paquets qui pourraient intégré un éventuel kubuntu-desktop-kde4 ici: https://wiki.ubuntu.com/Kubuntu/Todo )

Hors ligne

#3 Le 11/02/2008, à 11:39

tomtom

Re : kde4 : paquet cassé :'(

ok, merci, je ferai ca ce soir en rentrant chez moi et je donnerai le résultat

si ca marche, je réinstallerai kde4-core alors.

Hors ligne

#4 Le 11/02/2008, à 12:54

thibaut28

Re : kde4 : paquet cassé :'(

Salut à  vous deux, je viens de repasser sous ubuntu 7.10 (ppc) et je me demandais quels dépots utiliser pour l'installation de KDE4. Ayant vu dans la documentation ce dépot ci :

deb http://ppa.launchpad.net/kubuntu-members-kde4/ubuntu gutsy main

je l'ai rajouté au fichier source et à  mon avis j'ai un mélange de paquets kde4 gutsy avec ceux du nouveau dépots car j'obtiens beaucoup de messages d'erreur, exemple :

Dépaquetage de kde-icons-oxygen (à  partir de .../kde-icons-oxygen_4%3a4.0.0-0ubuntu1~gutsy1_all.deb) ...
dpkg : erreur de traitement de /var/cache/apt/archives/kde-icons-oxygen_4%3a4.0.0-0ubuntu1~gutsy1_all.deb (--unpack) :
 tentative de remplacement de « /usr/lib/kde4/share/icons/oxygen/128x128/apps/scribus.png », qui appartient aussi au paquet kde4base-data
dpkg-deb: sous-processus paste tué par le signal (Relais brisé (pipe))

Le remplacement d'une icà´ne pourrait être anodin si au final je ne me retrouvais pas avec ceci :

Des erreurs ont été rencontrées pendant l'exécution :
 /var/cache/apt/archives/kde-icons-oxygen_4%3a4.0.0-0ubuntu1~gutsy1_all.deb
 /var/cache/apt/archives/kdebase-runtime-data_4%3a4.0.0-0ubuntu1~gutsy1_all.deb
 /var/cache/apt/archives/dolphin-kde4_4%3a4.0.0-0ubuntu1~gutsy1_powerpc.deb
 /var/cache/apt/archives/kappfinder-kde4_4%3a4.0.0-0ubuntu1~gutsy1_powerpc.deb
 /var/cache/apt/archives/kdebase-data-kde4_4%3a4.0.0-0ubuntu1~gutsy1_all.deb
 /var/cache/apt/archives/kdepasswd-kde4_4%3a4.0.0-0ubuntu1~gutsy1_powerpc.deb
 /var/cache/apt/archives/kfind-kde4_4%3a4.0.0-0ubuntu1~gutsy1_powerpc.deb
 /var/cache/apt/archives/konqueror-nsplugins-kde4_4%3a4.0.0-0ubuntu1~gutsy1_powerpc.deb
 /var/cache/apt/archives/konqueror-kde4_4%3a4.0.0-0ubuntu1~gutsy1_powerpc.deb
 /var/cache/apt/archives/konsole-kde4_4%3a4.0.0-0ubuntu1~gutsy1_powerpc.deb
 /var/cache/apt/archives/kdepimlibs-data_4%3a4.0.0-0ubuntu1~gutsy1_all.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)

Un "sudo dpkg --configure -a" sur tout ceci donne en extrait :

sudo dpkg --configure -a
dpkg : des problèmes de dépendances empêchent la configuration de kdebase-kde4 :
 kdebase-kde4 dépend de dolphin-kde4 (>= 4:4.0.0-0ubuntu1~gutsy1) ; cependant :
  Le paquet dolphin-kde4 n'est pas installé.
 kdebase-kde4 dépend de kappfinder-kde4 (>= 4:4.0.0-0ubuntu1~gutsy1) ; cependant :
  Le paquet kappfinder-kde4 n'est pas installé.
 kdebase-kde4 dépend de kdebase-data-kde4 (>= 4:4.0.0-0ubuntu1~gutsy1) ; cependant :
  Le paquet kdebase-data-kde4 n'est pas installé.
 kdebase-kde4 dépend de kdepasswd-kde4 (>= 4:4.0.0-0ubuntu1~gutsy1) ; cependant :
  Le paquet kdepasswd-kde4 n'est pas installé.

Voilà , je ne sais pas si tu as les mêmes erreurs tomtom ?


Quis custodiet ipsos custodes ¿
Mon DeviantArt :)

Hors ligne

#5 Le 11/02/2008, à 13:20

Smarter

Re : kde4 : paquet cassé :'(

Tu utilises des paquets d'anciens dépôts, pour les supprimer:

sudo apt-get remove kdelibs5 kde4base-data kde4libs-data

Hors ligne

#6 Le 11/02/2008, à 13:21

tomtom

Re : kde4 : paquet cassé :'(

wow, beau chapelet d'erreurs ! je verrais ca ce soir :s

Hors ligne

#7 Le 11/02/2008, à 13:57

thibaut28

Re : kde4 : paquet cassé :'(

@Smarter : Justement je me demandais quel dépot utiliser ?Les dépots Gutsy ou le launchpad ? Les deux peuvent-ils cohabiter sans conflit ? wink Je désinstalle kde4 en ce moment, pour refaire une installation propre. Merci de ton aide smile

@Tomtom : Et encore je n'ai mis qu'un tiers des erreurs big_smile


Quis custodiet ipsos custodes ¿
Mon DeviantArt :)

Hors ligne

#8 Le 11/02/2008, à 14:00

tomtom

Re : kde4 : paquet cassé :'(

pour faire une installation propre, mais assez complete, installer kde4-core suffit ?

Hors ligne

#9 Le 11/02/2008, à 14:17

thibaut28

Re : kde4 : paquet cassé :'(

J'ai commencé par installer kde4 sous feisty en utilisant le dépot launchpad, puis je suis passé à  gutsy (certain paquets de kde4 restant bloqué sous feisty) et là  j'ai enlevé le launchpad croyant qu'il entrait en conflit avec les dépots de gutsy qui fournissent eux aussi kde4 : du coup c'est un sacré bazar roll J'ai fini par avoir un kde4 qui apparait dans GDM avec un super écran de chargement, plein de superbes fonds d'écrans mais pas moyen d'installer konqueror-kde4 et autres applications. Je crois que j'avais installé kde4-core. Là  j'enlève tout kde4 et puis je reinstalle le paquet kde4-core wink


Quis custodiet ipsos custodes ¿
Mon DeviantArt :)

Hors ligne

#10 Le 11/02/2008, à 20:20

Smarter

Re : kde4 : paquet cassé :'(

Les dépôts PPA ne rentre pas en conflits avec les dépôts officiels.

Hors ligne

#11 Le 11/02/2008, à 21:21

tomtom

Re : kde4 : paquet cassé :'(

bon alors :

je n'ai pas pu tester votre commande, parce qu'en allumant mon PC, grub ne trouvais plus le kernel... (rien que ca tongue)
Donc j'ai réinstallé une gutsy toute fraiche et la, je sais pas, c trop la merde, j'ai plein de trucs qui soulent... du coup, je pense passer a Hardy (est-ce que la prochaine version alpha de Hardy proposera un ISO avec uniquement KDE4 ?? tongue


Merci quand meme pour vos réponses, mais bon, je me retrouve avec un nubuntu tout cassé :s donc KDE4, ce ne sera pas pour tout de suite :s

Hors ligne

#12 Le 11/02/2008, à 21:36

thibaut28

Re : kde4 : paquet cassé :'(

@Smarter : Merci pour la réponse. En fait un des paquets pose problème, kdebase-runtime car il n'est pas disponible pour l'architecture ppc, du coup il est impossible d'installer kde4 sans casser un bon nombre de paquets et par conséquent bloquer apt sad

@tomtom : J'ai pas mal de bug sur Gutsy aussi, notamment pas de chargement du module pour mon disque dur lol et aucun périphérique usb qui fonctionnent (plus de bluetooth, plus de clé usb, plus de souris smile )


Quis custodiet ipsos custodes ¿
Mon DeviantArt :)

Hors ligne

#13 Le 12/02/2008, à 01:09

jajaX

Re : kde4 : paquet cassé :'(

salut

il existe (existait) pas un livecd kubuntu gusty avec KDE4 ?


@+ jajaX [Membre de Breizhtux : LUG de Saint Brieuc]
ACER Aspire 8930G 904G50Bn sous Kubuntu 14.04 The Trusty Tahr (64 bits) & KDE SC 4.13.2/Amarok 2.8
ACER Aspire 5612 WLMI sous kubuntu 14.04 The Trusty Tahr (32 bits) & KDE SC 4.13.2/Amarok 2.8
HP dv7 2230f et HP Compaq NX6310 sous Kubuntu Precise Pangolin 12.04 (32 bits) & KDE SC 4.13.2/Amarok 2.8

En ligne

#14 Le 12/02/2008, à 02:53

dismantr

Re : kde4 : paquet cassé :'(

Si, mais une fois installée, la version du livecd n'est pas facilement utilisable (des paquets ne s'installent pas). De plus, KDE 4.0 n'est pas une version vraiment grand public (des fonctionnalités ne sont pas encore implémentées). Je te conseille d'attendre la version 4.1 en juillet.


Dismantr
Gentoo, Ubuntu, & Debian
OpenPGP key: 0x041746FB

Hors ligne

#15 Le 13/02/2008, à 22:10

tomtom

Re : kde4 : paquet cassé :'(

gutsy réinstallée, je me relance...

je suis mazo, c'est pas possible
mais j'aime tellement ca tongue

Hors ligne

#16 Le 13/02/2008, à 22:31

tomtom

Re : kde4 : paquet cassé :'(

ah, j'ai de nouveau eu l'erreur, voici le résultat de sudo dpkg --configure -a :

...
Processing triggers for libc6 ...
ldconfig deferred processing now taking place
Des erreurs ont été rencontrées pendant l'exécution :
 kdebase-kio-plugins
 konqueror
 konqueror-nsplugins

snif...

Et le fullupgrade me propose d'installer ces 2 paqquets non certifiés :
  dmsetup cryptsetup

Mais de toute facon, il n'arrive pas a les telecharger :s...

Adept me dis que kdebase-kio-plugins est cassé. Si le le supprime, il me retire konqueror, kubuntu-desktop, ... c'est plas glop.

Vous avez une solution, svp ?? snif

Hors ligne

#17 Le 13/02/2008, à 22:50

Smarter

Re : kde4 : paquet cassé :'(

tomtom: Faudrait savoir ce qu'il y a dans les trois petits points smile

Hors ligne

#18 Le 13/02/2008, à 22:56

tomtom

Re : kde4 : paquet cassé :'(

ben tiens, il me les a supprimés, ce con !! snif

du coup, je ne peut pas te dire :s
tu ne sais pas si on peut forcer l'installation d'une version d'un paquet ? genre, ne pas mettre a jour ce didjiou de kdebase-kio-plugins ?

Hors ligne

#19 Le 13/02/2008, à 23:39

tomtom

Re : kde4 : paquet cassé :'(

bon. j'ai retiré le dépot ppa, et j'ai reinstallé l'ancienne version du paquet.
En voulant réinstaller kubuntu-desktop, il me met une erreur.
Alors tant qu'a faire, autant que j'installe direct Hardy Alpha 4 tongue
(oui, je suis un warrior tongue )

Hors ligne

Haut de page ↑