Contenu | Rechercher | Menus

Annonce

Si vous rencontrez des soucis à rester connecté sur le forum (ou si vous avez perdu votre mot de passe) déconnectez-vous et reconnectez-vous depuis cette page, en cochant la case "Me connecter automatiquement lors de mes prochaines visites". Attention, le forum rencontre actuellement quelques difficultés. En cas d'erreur 502, il ne faut pas re-valider l'envoi d'un message ou l'ouverture d'une discussion, au risque de créer un doublon.

La section divers se réorganise ! De nouvelles sous-sections à venir. (plus d'infos + donner son avis)

#1 Le 21/12/2005, à 22:37

Gyscos

Installer à partir d'une tarballe

J'ai récupéré Unshield pour extraire les pilotes windowsien pour ensuite les utiliser avec ndiswrapper, mais... premier problème : j'arrive pas à installer ça.
J'ai extrait le tout de l'archive .tar.gz, et ensuite on me dit de faire :

cd <nom de repertoire>
./configure
make
make install

J'arrive bien à accéder au repertoire, le ./configure affiche pas mal de ligne avec de NO mais bon, ca marche encore, mais quand je fais le make il me dis qu'il ne trouve pas le makefile...
Pareil pour make install.
Le repertoire contient un fichier makefile.arm et un makefile.ini (et pleins d'autres fichiers) mais pas de makefile tout court comme je l'avais vu dans certaines autres tarballes...
Quelqu'un saurait ce qui ne va pas ?...


Stranger passing in the street, by chance two separate glances meet.
And I am you and what I see is me...

Hors ligne

#2 Le 24/12/2005, à 14:34

tasbin54

Re : Installer à partir d'une tarballe

cd <nom de repertoire>
./configure
make
make install

Tu as en fait récupérer les sources et ces commandes compilent le programme.
Si tu es débutant je te déconseille au début sauf en cas d'obligation de compiler ce programme d'essayer de le choper sur synaptic.


Concernant les messages avec des NO cela signifie que la compilation na pas été un succès.


Souvent il sagit de prolèmes de dépendances.

En effet pour compiler un programme A tu as besoin du programme C,D...d'une libraire E...

Dans ton cas si tu as fait une installation par défaut, il te manque surement des compilateurs de base tel que gcc (compilateur C) etc..


Sous un terminal tape:

sudo apt-get install build-essential

Cela te permet d'installer les compilateurs et d'autres choses nécessaires pour pas mal de compilation.


Relance tes commandes de compilation.

Regarde les lignes ou il ya un no, en général cest quil lui manque quelquechose, le nom est mentionné.
Essaie ensuite de télécharger ce programme/libraire manquante via synaptic.

Normalement en recompilant par la suite tu devrais avoir de moins en moins d'erreurs
Réitère le processus tant quil ya des messages d'erreurs.

SI cela ne marche pas poste ICI MEME les messages d'erreur.

P.S: il me semble que apt-get source.. et apt-build gère tres bien ces problèmes de dépendances et compilation comme un grand??

#3 Le 24/12/2005, à 14:44

Gyscos

Re : Installer à partir d'une tarballe

Youpi il manquait juste gcc et un ou deux autres truc qui ressemblaient ^^
J'ai juste eu à les cocher avec synaptic, et la compilation a marché.
Merci beaucoup ^_^


Stranger passing in the street, by chance two separate glances meet.
And I am you and what I see is me...

Hors ligne

Haut de page ↑