Contenu | Rechercher | Menus

Annonce

Si vous rencontrez des soucis à rester connecté sur le forum (ou si vous avez perdu votre mot de passe) déconnectez-vous et reconnectez-vous depuis cette page, en cochant la case "Me connecter automatiquement lors de mes prochaines visites".
Test de l'ISO d'Ubuntu francophone : nous avons besoin de testeurs pour la version francophone d'Ubuntu 14.04. Liens et informations ici.

#1 Le 19/02/2008, à 05:16

sk8glad

gtk-qt engine pour kde4

Pour ceux que ça intéresse, en attendant que le dev du fameux gtk-qt engine de kde3 est fini de porter son appli vers kde4, un autre dev a sorti un équivalent pour kde4 (moins intégré et non présent dans system settings) qui marche :
http://www.kde-apps.org/content/show.ph … 6691b0cdf5

Hors ligne

#2 Le 19/02/2008, à 17:02

dj003

Re : gtk-qt engine pour kde4

J'ai essayé de faire fonctionner cette application, mais je n'arrive pas à avoir un thème ressemblant à celui de kde sur les applications gtk. Quelqu'un aurait-il réussi à avoir la bonne apparence dans les application gtk?

Hors ligne

#3 Le 19/02/2008, à 19:34

sk8glad

Re : gtk-qt engine pour kde4

En fait il faut télécharger le thème qt4, puis télécharger le binaire (c'est plus simple). Décompresse le thème dans ~.themes/ , puis exécute le binaire et choisis le thème qt, puis coche use current kde style et apply colors to gtk applications, et clique sur ok et ferme ta fenêtre. Il faudra peut-être que tu redémarres kde. lance firefox et voilà.

Hors ligne

#4 Le 20/02/2008, à 12:33

dj003

Re : gtk-qt engine pour kde4

Je viens de faire ce que tu m'as dit mais ça ne fonctionne pas. Firefox devient tout blanc, on ne voit plus les menus surlignés et les boutons sont tout blanc et carré.

Hors ligne

#5 Le 20/02/2008, à 17:13

flouzy

Re : gtk-qt engine pour kde4

Bonjour,

Bon j'ai moi aussi eu du mal à  le faire marcher ce theme qt4. Tout d'abord, le plugin intégré dans dolphin ne décompresse que le 1er niveau de l'archive 'qt4.tar.gz' (soit un répertoire vide et un fichier), donc utiliser un programme comme file-roller pour le décompresser et vérifier que le dossier gtk-2.0 ne soit pas vide (je ne sais pas si Ark pose problème).

Ensuite, j'avais des erreurs quand je lançais des programmes gnome en ligne de commande. D'après ce que j'ai compris et les erreurs retournées par le terminal, ce theme doit utiliser un moteur pixmap.

En recherchant 'gtk pixmap engine' dans synaptic, j'ai installé 2 des paquets retournés (un contenait concernait un certain 'pixbuf engine'). Ce n'est qu'après l'installation de ces paquets que mes applis gnome se sont toutes décorées en kde4 smile

Tout ceci n'est pas très précis, mais bon, j'ai fait ca un peu vite et je pensais pas vraiment que ca marcherait... tongue

---
Edit : alors les paquets que j'ai installés sont :
gtk2-engines-pixbuf, gtk2-engines-qtpixmap, gtk2-engines-sapwood

Voilà , je ne pas aider plus.

Dernière modification par flouzy (Le 20/02/2008, à 17:27)

Hors ligne

#6 Le 20/02/2008, à 17:30

sk8glad

Re : gtk-qt engine pour kde4

Oui j'avais oublié. Il faut installer gtk-engines-pixmap & gtk2-engines-pixbuf

Hors ligne

#7 Le 20/02/2008, à 21:33

dj003

Re : gtk-qt engine pour kde4

Merci flouzy et sk8glad
Une fois les paquets gtk2-engines-pixbuf, gtk2-engines-qtpixmap et gtk2-engines-sapwood installés, ça fonctionne effectivement.

sk8glad, le paquet gtk-engines-pixmap n'existe pas je pense que tu voulais dire gtk2-engines-qtpixmap.

Hors ligne

#8 Le 20/02/2008, à 22:11

sk8glad

Re : gtk-qt engine pour kde4

content pour toi que ça marche

Hors ligne

Haut de page ↑