Contenu | Rechercher | Menus

Annonce

Si vous rencontrez des soucis à rester connecté sur le forum (ou si vous avez perdu votre mot de passe) déconnectez-vous et reconnectez-vous depuis cette page, en cochant la case "Me connecter automatiquement lors de mes prochaines visites".

#1 Le 17/12/2005, à 17:38

nicolasi

[Résolu] segmentation fault d'applis avec nvidia 8174

Bonjour à tous,

Je viens d'installer les dernier drivers nvidia (8174) via le script NVIDIA-Linux-x86-1.0-8174-pkg1.run.
J ai dû me rabattre sur cette solution car les packages nvidia-glx faisaient planter mon systeme (tout etait figé sauf la souris).

Avant d'avoir installé le driver j'avais viré les paquets ayant rapport avec nvidia.

Tout semble fonctionner sauf quelques applis qui crashent lamentablement au demarrage et qui me renvoient un "segmentation fault".
Les applis concernées: amarok, xmms et mplayer

Cela semble concerner le son, mais j'arrive à écouter de la musique via ogg123 et mpg321.

J'utilise une kubuntu breezy et mon xorg.conf ressemble à ca:

Section "Device"
        Identifier      "NVIDIA Corporation NV17 [GeForce4 MX 440]"
        Driver          "nvidia"
        BusID           "PCI:1:0:0"
        Option      "RenderAccel" "true"
        Option      "backingstore" "true"
        Option "AllowGLXWithComposite" "True"
EndSection

Section "DRI"
        Mode    0666
EndSection

Section "Extensions"
    Option "Composite" "Enable"
    Option "RENDER" "Enable"
EndSection

Mais je ne pense pas que ma config de xorg soit le pb car même avec le driver nv les applis plantent toujours...

Les applis se remettent à fonctionner après avoir desinstallé les drivers proprio.

Est-ce que quelqu'un aurait une idée sur l'origine de ces plantages??? j ai googlé dans tous les sens mais je n ai rien trouvé...

#2 Le 19/12/2005, à 17:33

nicolasi

Re : [Résolu] segmentation fault d'applis avec nvidia 8174

Salut et merci de ta réponse smile

Ma carte n a pas été overclocké, j essaie juste de faire marcher la 3D.
Aves les packages d'ubuntu j avais le phénomène de "freeze + souris qui bouge quand même".
C est pour ca que j ai installé les derniers drivers 8174 qui ne sont pas dispo en package.
Et avec ceux-ci la 3D semble fonctionner mais certaines applis, elles, ne fonctionnent plus...

Je vais faire de nouveaux tests en compilant ces applis à la main pour voir si elles continuent de crasher...

De plus, non, ma carte n a pas été overclockée.

Merci de ton aide

Nicolas

#3 Le 19/12/2005, à 18:19

nicolasi

Re : [Résolu] segmentation fault d'applis avec nvidia 8174

Bon , je viens d'essayer avec les sources officielles de mplayer et ca fonctionne sans pb...

Je vais maintenant faire un test avec les packages source

#4 Le 20/12/2005, à 17:34

nicolasi

Re : [Résolu] segmentation fault d'applis avec nvidia 8174

J ai compilé et installé le package source de mplayer pour k6 et aucun plantage à signaler.

Il semble que les packages binaires de mplayer, xine, xmms et amarok n'aiment pas une des bibliotheques installée avec le driver nvidia 8174.

Si une ame charitable avait une idée, parce que là, moi, je seche...

Voila ma config:

noyau: 2.6.12-10-k7

lspci   
0000:00:00.0 Host bridge: VIA Technologies, Inc. VT8375 [KM266/KL266] Host Bridge
0000:00:01.0 PCI bridge: VIA Technologies, Inc. VT8633 [Apollo Pro266 AGP]
0000:00:0a.0 Communication controller: Conexant HSF 56k HSFi Modem (rev 01)
0000:00:0b.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL-8139/8139C/8139C+ (rev 10)
0000:00:10.0 USB Controller: VIA Technologies, Inc. VT82xxxxx UHCI USB 1.1 Controller (rev 80)
0000:00:10.1 USB Controller: VIA Technologies, Inc. VT82xxxxx UHCI USB 1.1 Controller (rev 80)
0000:00:10.2 USB Controller: VIA Technologies, Inc. VT82xxxxx UHCI USB 1.1 Controller (rev 80)
0000:00:10.3 USB Controller: VIA Technologies, Inc. USB 2.0 (rev 82)
0000:00:11.0 ISA bridge: VIA Technologies, Inc. VT8235 ISA Bridge
0000:00:11.1 IDE interface: VIA Technologies, Inc. VT82C586A/B/VT82C686/A/B/VT823x/A/C PIPC Bus Master IDE (rev 06)
0000:00:11.5 Multimedia audio controller: VIA Technologies, Inc. VT8233/A/8235/8237 AC97 Audio Controller (rev 50)
0000:01:00.0 VGA compatible controller: nVidia Corporation NV17 [GeForce4 MX 440] (rev a3)

#5 Le 27/12/2005, à 19:01

nicolasi

Re : [Résolu] segmentation fault d'applis avec nvidia 8174

Ca y est, j ai trouvé!

un strace de xmms me donnait entre autres:
open("/usr/lib/tls/libnvidia-tls.so.1", O_RDONLY) = -1 EACCES (Permission denied)

Et en effet, les droits du repertoire /usr/lib/tls n'etaient pas bons:
/usr/lib/tls# ll
total 64K
drwx------    2 root root 4.0K Dec 27 17:33 ./

Ca venait du fait que j avais installé les drivers nvidia en root et non pas par sudo (un pb de umask probablement).

J ai donc changé les droits et tout remarche nickel smile

Merci à ceux qui ont pris le temps de me lire et/ou repondre

Haut de page ↑