Contenu | Rechercher | Menus

Annonce

Si vous rencontrez des soucis à rester connecté sur le forum (ou si vous avez perdu votre mot de passe) déconnectez-vous et reconnectez-vous depuis cette page, en cochant la case "Me connecter automatiquement lors de mes prochaines visites".

#1 Le 04/01/2014, à 23:15

freddo28

[Résolu] Crash Ubuntu au changement d'utilisateur

Bonjour @Tous,

J'ai le problème suivant depuis mon passage à la 13.10:

Lorsque je suis sous ubuntu avec une session ouverte et que je souhaite changer d'utilisateur, mon serveur X crash.
Le ctrl + alt + F1 ne fonctionne pas. Je suis obligé d'arrêter mon portable avec le bouton marche/Arrêt.

Ce que j'ai remarqué, et c'est peut-être lié : sur l'écran de connexion, le multi-écran est actif.
Sur ma session j'ai désactivé le second écran (qui d'ailleurs n'est pas connecté physiquement ???).
Pour info, lors de l'installation de 13.10, les paramètres d'affichage ont changé en activant le second écran sur toutes les sessions utilisateur ( sessions utilisateur qui existaient en 13.04).

Je suis sur un portable Toshiba P870-31c équipé d'une carte Nvidia Nvidia GeForce GT 630M.
Il existe une sortie HDMI sur le côté du portable.
Il détecte un second écran alors qu'il n'y en a pas de connecté.

Quelqu'un peut-il m'aider ?

Dernière modification par freddo28 (Le 25/02/2014, à 09:41)


Ubuntu 13.10
Tosh P870-31C

Hors ligne

#2 Le 04/01/2014, à 23:18

jeanjd63

Re : [Résolu] Crash Ubuntu au changement d'utilisateur

Salut

Que donne un :
sudo  lspci  -nnv | grep  -i video

@+

Hors ligne

#3 Le 04/01/2014, à 23:53

freddo28

Re : [Résolu] Crash Ubuntu au changement d'utilisateur

hello jeanjd63,

La commande ne renvoit rien.
SI je remplace video par VGA :

00:02.0 VGA compatible controller [0300]: Intel Corporation 3rd Gen Core processor Graphics Controller [8086:0166] (rev 09) (prog-if 00 [VGA controller])
01:00.0 VGA compatible controller [0300]: NVIDIA Corporation GF108M [GeForce GT 630M] [10de:0de9] (rev a1) (prog-if 00 [VGA controller])

Ubuntu 13.10
Tosh P870-31C

Hors ligne

#4 Le 05/01/2014, à 09:12

jeanjd63

Re : [Résolu] Crash Ubuntu au changement d'utilisateur

Tu es concerné par Bumblebee

Dernière modification par jeanjd63 (Le 05/01/2014, à 09:27)

Hors ligne

#5 Le 05/01/2014, à 11:08

freddo28

Re : [Résolu] Crash Ubuntu au changement d'utilisateur

Bonjour jeanjd63,

Concernant ta réponse :

jeanjd63 a écrit :

Tu es concerné par Bumblebee

J'avais installé Bumblebee en 13.04 et ça me faisait un message d'erreur que je n'ai pas réussi à résoudre.
La solution bumblebee me semble être un paliatif en attendant un support 100% d'optimus.

Il me semble que le pilote nouveau est sur la bonne voie.

Dans tout les cas, je ne vois pas pourquoi le serveur X crash au changement d'utilisateur alors que je n'ai pas le problème en ouvrant /fermant des sessions les unes après les autres.

Par contre sais-tu désactiver le multi-écrans sur lightdm ou par défaut au démarrage du serveur X ?

Voici mon xrandr :

Screen 0: minimum 320 x 200, current 1600 x 900, maximum 32767 x 32767
LVDS1 connected primary 1600x900+0+0 (normal left inverted right x axis y axis) 382mm x 214mm
   1600x900       60.1*+
   1440x900       59.9  
   1360x768       59.8     60.0  
   1152x864       60.0  
   1024x768       60.0  
   800x600        60.3     56.2  
   640x480        59.9  
VGA1 disconnected (normal left inverted right x axis y axis)
HDMI1 disconnected (normal left inverted right x axis y axis)
DP1 disconnected (normal left inverted right x axis y axis)
VIRTUAL1 disconnected (normal left inverted right x axis y axis)
VGA-2 connected (normal left inverted right x axis y axis)
   1024x768       60.0  
   800x600        60.3     56.2  
   848x480        60.0  
   640x480        59.9  
  1024x768 (0x43)   65.0MHz
        h: width  1024 start 1048 end 1184 total 1344 skew    0 clock   48.4KHz
        v: height  768 start  771 end  777 total  806           clock   60.0Hz
  800x600 (0x44)   40.0MHz
        h: width   800 start  840 end  968 total 1056 skew    0 clock   37.9KHz
        v: height  600 start  601 end  605 total  628           clock   60.3Hz
  800x600 (0x45)   36.0MHz
        h: width   800 start  824 end  896 total 1024 skew    0 clock   35.2KHz
        v: height  600 start  601 end  603 total  625           clock   56.2Hz

Dernière modification par freddo28 (Le 05/01/2014, à 11:29)


Ubuntu 13.10
Tosh P870-31C

Hors ligne

#6 Le 05/01/2014, à 11:51

freddo28

Re : [Résolu] Crash Ubuntu au changement d'utilisateur

J'ai trouvé pour désactiver le multi-éran sur lightdm ici : http://askubuntu.com/questions/360886/p … fore-login

Mais ça ne résout pas le problème du crash au changement de user !
Donc fausse piste.


Ubuntu 13.10
Tosh P870-31C

Hors ligne

#7 Le 05/01/2014, à 20:22

freddo28

Re : [Résolu] Crash Ubuntu au changement d'utilisateur


Ubuntu 13.10
Tosh P870-31C

Hors ligne

#8 Le 07/01/2014, à 16:01

freddo28

Re : [Résolu] Crash Ubuntu au changement d'utilisateur

Up, d'autres ont le même souci ?


Ubuntu 13.10
Tosh P870-31C

Hors ligne

#9 Le 07/01/2014, à 16:18

Coeur Noir

Re : [Résolu] Crash Ubuntu au changement d'utilisateur

Ici aussi sur 13.10, ça crashe au changement d'utilisateur.

Ça ne crashe pas si on ferme une session pour en ouvrir une autre.

(driver libre, chipset graphique intel HD4600, un seul écran)

Dernière modification par Coeur Noir (Le 07/01/2014, à 16:27)

Hors ligne

#10 Le 25/02/2014, à 09:39

freddo28

Re : [Résolu] Crash Ubuntu au changement d'utilisateur

slt
j'ai finalement installé bumblebee.
C'est résolu


Ubuntu 13.10
Tosh P870-31C

Hors ligne

#11 Le 28/03/2014, à 14:10

wiltur

Re : [Résolu] Crash Ubuntu au changement d'utilisateur

J'ai aussi le soucis si je me déconnecte ou si je veux changer d'utilisateur (je suis sous gnome, pas untiy, mais peu importe ça le fait aussi avec cinnamon, xfce, etc)
Si j'utilise le pilote Nouveau pas de soucis, en revanche avec les pilots proprios ça merdoie.

01:00.0 VGA compatible controller: NVIDIA Corporation GT218M [GeForce 315M] (rev a2)

à priori pas de bumblebee pour moi. (portable Toshiba Satellite C670-130)

Une idée ? car si les driver nouveau fonctionne assez bien, c'est pas encore ça pour tout (pas de réglage de la luminosité par exemple) et puis ça l’accélération 3D n'est pas aussi bonne non plus .


Microsoft est à l'informatique ce que TF1 est à la culture. :)

Hors ligne

Haut de page ↑