Contenu | Rechercher | Menus

Annonce

Si vous rencontrez des soucis à rester connecté sur le forum (ou si vous avez perdu votre mot de passe) déconnectez-vous et reconnectez-vous depuis cette page, en cochant la case "Me connecter automatiquement lors de mes prochaines visites".
Test de l'ISO d'Ubuntu francophone : nous avons besoin de testeurs pour la version francophone d'Ubuntu 14.04. Liens et informations ici.

Attention, une faille de sécurité dans bash a récemment été rapportée, il est recommandé de mettre à jour son système (plus de détails)

#1 Le 13/12/2005, à 14:42

kaoul

[résolu]CUPS ne semble pas marcher... Impossible d'install/imprim

Bonjour,

tout est dans le titre, je n'arrive pas à comprendre pourquoi il m'est impossible d'installer des imprimantes et donc d'imprimer.
Printing manager de kde se lance et affiche "Initializing manager". Rien ne se passe , obligé de killer le gestionnaire (où attendre env. 20 minutes lol que le gestionnaire renvoie une erreur du genre "Impossible de joindre CUPS").
Alors j'installe gnome-cups-manager et je le lance :

sudo gnome-cups-manager

Même histoire, rien ne se passe, j'ai aucune erreur/info.
J'ai aussi essayé

ps | grep cups

qui ne renvoie rien.

Quelqu'un m'avais montré comment redémarrer cups (j'ai oublié la commande, un truc du genre /etc/.../cups restart) et  il me renvoie que le restart de cups est OK. Pourtant, mon problème persiste.

Voilà, si vous pouviez m'aider... Sur la 5.04 je n'avais pas ce problème.
D'avance merci (comme d'hab je compte sur vous wink)

Dernière modification par kaoul (Le 28/01/2006, à 18:58)


Mon entreprise de référencement ecommerce

Hors ligne

#2 Le 15/12/2005, à 23:48

kaoul

Re : [résolu]CUPS ne semble pas marcher... Impossible d'install/imprim

up sad


Mon entreprise de référencement ecommerce

Hors ligne

#3 Le 16/12/2005, à 19:47

bernez

Re : [résolu]CUPS ne semble pas marcher... Impossible d'install/imprim

Une solution serait de désinstaller complètement cups avec synaptic puis de le réinstaller avec toutes les dépendances. hmm


vyé kanari ka fè bonsoup.
Kenavo. A galon !

Hors ligne

#4 Le 21/12/2005, à 14:16

kaoul

Re : [résolu]CUPS ne semble pas marcher... Impossible d'install/imprim

J'ai desinstallé/reinstallé cupssys (serveur cups) et cups-client (client cups) et il n'y a aucun changement sad

help il faut absoluement que j'imprime du boulot sad


Mon entreprise de référencement ecommerce

Hors ligne

#5 Le 21/12/2005, à 19:48

bernez

Re : [résolu]CUPS ne semble pas marcher... Impossible d'install/imprim

Tu n'as pas touché à ton

/etc/cups/cupsd.conf

? sad
Tu as fait

 sudo /etc/init.d/cupsys restart

? sad
Tu peux faire sinon

sudo /etc/init.d/cupsys force-reload

pour voir roll

Vérifie alors si le démon cupsd est lancé :

ps ax | grep cups

, tu auras une ligne comme ça :

11094 ?        SNs    0:18 /usr/sbin/cupsd -F

sinon le lancer par

sudo cupsd -F

Sinon je ne vois pas sad


vyé kanari ka fè bonsoup.
Kenavo. A galon !

Hors ligne

#6 Le 22/12/2005, à 10:25

kaoul

Re : [résolu]CUPS ne semble pas marcher... Impossible d'install/imprim

ba non pas touché à cupsys.conf

/etc/init.d/cupsys restart (j'avais deja essayé) et /etc/init.d/cupsys force-reload donnent :
* Restarting Common Unix Printing System: cupsd       [ ok ]

ps ax | grep cups donne :
8876 pts/1    R+     0:00 grep cups

Donc tu vois pas ? sad
C'est relou là grrrrrrrr j'ai jamais autant piétiné à résoudre un pb sur ubuntu.


Mon entreprise de référencement ecommerce

Hors ligne

#7 Le 22/12/2005, à 12:02

gouby

Re : [résolu]CUPS ne semble pas marcher... Impossible d'install/imprim

si tu as réinstallé breezy sur hoary essaye de regarder ton fichier kdeprintrc dans /home/ton_nom/.kde/share/config et supprime le, ce sont tes préférences (c'est dans les fichiers cachés)


Proc: AMD Phenom II X4 965 Black Edition   CM: Gigabyte GA-790XTA-UD4 (AMD 790X) - ATX  CG:  GeForce GTX 460   Ram: 8 Go (kit 4x 2 Go) DDR3-SDRAM PC3-10600
Ubuntu 13.04 -

Hors ligne

#8 Le 23/12/2005, à 21:24

kaoul

Re : [résolu]CUPS ne semble pas marcher... Impossible d'install/imprim

J'ai installé breezy avec un apt-get upgrade effectivement wink
J'ai donc supprimé kdeprintrc.

Le print manager se lance, bloque SEULEMENT quelques secondes sur "initializing manager" puis balance ce message d'amour :
"Unable to retrieve the printer list. Error message received from manager:
Connection to CUPS server failed. Check that the CUPS server is correctly installed and running. Error: connection refused."

Si je veux passer en mode administrateur pour installer une imprimante, ca remet "initializing manager" pendant plusieurs minutes. J'en suis au même point qu'au début grâce à ta manip. C'est déja ca... Donc ca vien de kde?

Dernière modification par kaoul (Le 23/12/2005, à 21:28)


Mon entreprise de référencement ecommerce

Hors ligne

#9 Le 23/12/2005, à 22:00

gouby

Re : [résolu]CUPS ne semble pas marcher... Impossible d'install/imprim

/home/gouby/.kde/share/apps/kdeprint j'avais aussi supprimer les fichiers de ce dossier, après ma mise à jour par synaptic


Proc: AMD Phenom II X4 965 Black Edition   CM: Gigabyte GA-790XTA-UD4 (AMD 790X) - ATX  CG:  GeForce GTX 460   Ram: 8 Go (kit 4x 2 Go) DDR3-SDRAM PC3-10600
Ubuntu 13.04 -

Hors ligne

#10 Le 24/12/2005, à 11:56

kaoul

Re : [résolu]CUPS ne semble pas marcher... Impossible d'install/imprim

Je n'ai rien dans le dossier kdeprint, il est vide.

J'ai essayé de lancer Print Jobs (cups) dans le menu de kde, il s'ouvre mais plante au bout de quelques secondes... Il ne répond plus.

J'ai essayé de lancer quelques commandes sur cups en console, par exemple :
cupsdconf : La console semble ne plus rien faire... Il ne se passe rien !


Mon entreprise de référencement ecommerce

Hors ligne

#11 Le 27/12/2005, à 19:43

deadpsyko

Re : [résolu]CUPS ne semble pas marcher... Impossible d'install/imprim

Bah, quand je vérifie qu'il marche, j'ai :

deadpsyko@station1:~$ ps ax | grep cups
8635 pts/0    S+     0:00 grep cups

Quand je le démarre, ca me dit rien ...

Mais quand je revérifie, pareil

Dernière modification par deadpsyko (Le 27/12/2005, à 19:56)

Hors ligne

#12 Le 27/12/2005, à 21:48

kaoul

Re : [résolu]CUPS ne semble pas marcher... Impossible d'install/imprim

Bon, ba puisque personne ne peux m'aider, je vais faire un tour sur ubuntu anglais, sinon changer de distrib mad


Mon entreprise de référencement ecommerce

Hors ligne

#13 Le 27/12/2005, à 22:23

cal

Re : [résolu]CUPS ne semble pas marcher... Impossible d'install/imprim

et ton syslog tu n'as rien ?

Hors ligne

#14 Le 28/12/2005, à 15:32

kaoul

Re : [résolu]CUPS ne semble pas marcher... Impossible d'install/imprim

C'est à dire, quelle commande dois-je tapper pour avoir le contenu de mon 'syslog' ?
Faut-il que je vous copie-colle les lignes s'ajoutant lorsque j'essaie de restar cups ? lorsque je lance le gestionnaire d'impression ?

Merci.


PS : D'après ce que j'ai trouvé pour syslog, ya du réseau, moi je ne cherche pas à imprimer à distance. Juste à lancer le gestionnaire pour pouvoir installer une imprimante sur port parallel.

Dernière modification par kaoul (Le 28/12/2005, à 15:34)


Mon entreprise de référencement ecommerce

Hors ligne

#15 Le 28/12/2005, à 21:56

cal

Re : [résolu]CUPS ne semble pas marcher... Impossible d'install/imprim

pour le syslog tu fais :
tail -f /var/log/syslog
tu relance le service cupsd (dans une autre console) et tu veras les messages relatif à cela défilé dans syslog (au mileu d'autre message peut être)

Hors ligne

#16 Le 29/12/2005, à 13:46

kaoul

Re : [résolu]CUPS ne semble pas marcher... Impossible d'install/imprim

erwin@ubuntu:~$ sudo /etc/init.d/cupsys restart
Password:
 * Restarting Common Unix Printing System: cupsd                         [ ok ]

Absoluement rien dans le syslog !


Mon entreprise de référencement ecommerce

Hors ligne

#17 Le 29/12/2005, à 16:04

wanamoa

Re : [résolu]CUPS ne semble pas marcher... Impossible d'install/imprim

Bonjour,

Si cela peut aider, j'ai eu le même genre de souci: impossible d'imprimer. J'ai résolu le problème en me donnant les droits directement sur /dev/usb/usb0 ou un truc du genre qui pointait sur mon imprimante.
Depuis, cela tourne impeccable. Il y a tout de même des trucs étranges avec la gestion des droits sous Ubuntu...


Ciao.


Mon Dieu...Pourvu qu'il n'arrive rien...

Hors ligne

#18 Le 29/12/2005, à 16:22

bernez

Re : [résolu]CUPS ne semble pas marcher... Impossible d'install/imprim

Tu as les mêmes droits que moi ?

ls -l /dev/usb/lp0
crw-rw----  1 root lp 180, 0 2005-12-29 10:05 /dev/usb/lp0

En tant qu'utilisateur je me suis mis dans le groupe lpadmin wink mais je pense y être automatiquement (tapper groups).
Est-ce que dans system-->administration-->utilisateurs-groupes puis onglet groupes puis recherche lp dans la liste (GID 7) puis sélectionne ce cette ligne puis propriétés et tu dois voir dans la nouvelle fenêtre à droite "membres du groupe" cupsys. Sinon je ne sais pas trop que dire pour le moment hmm


vyé kanari ka fè bonsoup.
Kenavo. A galon !

Hors ligne

#19 Le 29/12/2005, à 16:26

wanamoa

Re : [résolu]CUPS ne semble pas marcher... Impossible d'install/imprim

En réalité, j'ai fait un petit chmod 777 sur le fichier...j'avoue ne pas m'être trop cassé la tête mais ça me saoulait et je devais absolument imprimer.  5pour info je tourne sous Kubuntu).


Mon Dieu...Pourvu qu'il n'arrive rien...

Hors ligne

#20 Le 29/12/2005, à 18:51

kaoul

Re : [résolu]CUPS ne semble pas marcher... Impossible d'install/imprim

Bon alors d'abord MERCI de porter votre attention à mon problème !
Je suis aussi sur Kubuntu.

J'ai fais le chmod 777 sur /dev/lp0 mais bon... Sans espoire, d'ailleur ca ne change rien.

Je pense (dites moi si je me trompe) que vous êtes à coté de la plaque concernant le problème. Il ne m'est pas impossible d'imprimer (enfin indirectement)... Il m'est impossible de lancer l'outil de configuration des imprimantes. Cela n'a rien à voir avec l'imprimante !! Qu'elle soit en lp ou usb on s'en fou puisque je peux même pas installer le pilote hmm

Encore merci ! J'ai vraiment besoin d'imprimer, dans quelques jours je formate parceque là je ne peux plus attendre :x


Mon entreprise de référencement ecommerce

Hors ligne

#21 Le 29/12/2005, à 21:24

cal

Re : [résolu]CUPS ne semble pas marcher... Impossible d'install/imprim

bon je viens de regarder un peu plus en détails là
déjà les logs vont dans /var/log/cups/error_log c'est donc celui là qu'il faut plutôt regarder
ensuite si il n'y a rien d'explicite dans ce log, tu peux editer le fichier /etc/cups/cupsd.conf et changer le log level et le mettre a debug2 (ligne avec LogLevel)

Hors ligne

#22 Le 30/12/2005, à 16:32

joseph

Re : [résolu]CUPS ne semble pas marcher... Impossible d'install/imprim

Si j'ai bien compris, il faut d'abord créer une cofiguration pour ton imprimante, aller dans un navigateur sous
http://localhost:631 et choisir la détection automatique, ensuite y a qu'a suivre..
(Le pb du "y a qu'a" je ne me souviens plus comment je l'avais resolu)

#23 Le 30/12/2005, à 16:49

Joseph Tux

Re : [résolu]CUPS ne semble pas marcher... Impossible d'install/imprim

CUPS administration: quel mot de passe ?

Avant, j'étais sous woody, et avec qtcups je disposais d'une interface permanente ( à chaque demande d'impression, quel que soit le logiciel ) ou je pouvais confortablement choisir parmi diverses configuration d'imprimante ( format papier, noir&blanc/niveaux de gris/couleurs, resolutions de qualités diverses, nature du papier, orientation .. )
J'avais surtout le choix parmi diverses configurations préétablies.
QTcups a disparu avec Sarge, ( plus maintenu et pb de sécurité je crois ) et n'est donc pas non plus dans ubuntu breezy

Question principale:
Je voudrais retrouver ce confort, mais,
1ère étape, pour reconfigurer mon imprimante, l'interface d'administration (  avec: http://localhost:631 ) me demande un nom et un mot de passe. Soit je l'ai oublié, soit il y en a un par défaut que j'ignore... ça n'est pas celui de l'utilisateur ni celui de root.
Comment faire ? ( j'ai désinstallé complètement cups-client et cups-bsd et réinstallé en vain )

Question subsidiaire:
Comment remplacer QTcups pour gérer facilement, en tant qu' utilisateur de n'importe quel logiciel, une "collections" de configurations ?

Merci pour votre aide.


Il faut bien être un peu félé pour laisser passer la lumière

Hors ligne

#24 Le 30/12/2005, à 21:23

cal

Re : [résolu]CUPS ne semble pas marcher... Impossible d'install/imprim

juste pour le probème d'accès a cups par browser, ya le message "Les tâches administratives ont été désactivées pour des raisons de sécurité. Veuillez utiliser le menu Poste de travail System > Administration > Impression" en haut de la page, donc c'est pour ca que tu ne peux pas y accéder

Hors ligne

#25 Le 30/12/2005, à 21:59

Joseph Tux

Re : [résolu]CUPS ne semble pas marcher... Impossible d'install/imprim

Cela est déja fait, reste faisable (sans mot de passe)
Le problème N°2, c'est qu'on ne peut, de cette façon, paramétrer qu'un seul profil
La résolution du pb N°1 résolverait-elle cette question ?
Merci de t'interesser à mon problème

PS j'ai cru poster cette question indépendamment, après avoir mis mon grain de sel à la file discussion précédente, désolé ( il se trouve que cela traite aussi de cups, car je cherchais une solution quand je suis "tombé" ici...


Il faut bien être un peu félé pour laisser passer la lumière

Hors ligne

Haut de page ↑