Contenu | Rechercher | Menus

Annonce

Si vous rencontrez des soucis à rester connecté sur le forum (ou si vous avez perdu votre mot de passe) déconnectez-vous et reconnectez-vous depuis cette page, en cochant la case "Me connecter automatiquement lors de mes prochaines visites".
Test de l'ISO d'Ubuntu francophone : nous avons besoin de testeurs pour la version francophone d'Ubuntu 14.04. Liens et informations ici.

#1 Le 20/01/2014, à 15:20

fabricen26

Mise a jour de R

Salut à vous. j'ai installé le logiciel R avec un "apt-get install r-base" mais la version de R qui a été installé est la 2.14 . Mais moi je voudrais avoir une version a jour notamment la 3.0.2. Comment faire pour y parvenir a faire cette mise à jour?

Hors ligne

#2 Le 20/01/2014, à 16:27

jeanjd63

Re : Mise a jour de R

Slut

Quelle est ta version ubuntu ?
La version r-base 3.0.2-1ubuntu1 est pour trusty  (14.04)

Hors ligne

#3 Le 21/01/2014, à 04:46

fabricen26

Re : Mise a jour de R

Salut à vous j'utilise Ubuntu 12.04 LTS

Hors ligne

#4 Le 21/01/2014, à 10:51

Domeee

Re : Mise a jour de R

Bonjour,
c'est le problème des versions LTS : seules les mises à jour de sécurité sont faites sur les logiciels, pas les mises à jour de fonctionnalités. Et 5 ans c'est long.
=> tu upgrades ton système ou tu restes avec ta vieillerie...
Par contre, pour un logiciel comme R, tu as peut-être possibilité d'avoir une version récente via un ppa ou qq chose comme ça. (ex : Xcas fait ça)
Mais bon, pas sûr, pour Octave par exemple, à moins de compiler les sources (et donc d'avoir de potentiels ennuis de dépendances), tu es obligé de rester avec la version liée à ton système.
Domeee

Hors ligne

#5 Le 28/04/2014, à 12:21

Domeee

Re : Mise a jour de R

Je redéterre ce topic qui peut servir à d'autres utilisateurs.
J'ai cherché une solution du même accabit pour parer à un bug très gênant de Gnumeric dans les version *buntu 14.04 : mettre à jour avec une version plus récente mais n'existant pas dans les dépôts officiels.

ATTENTION : cette manip peut endommager votre système (si c'est une LTS de travail, prudence !!!)
Il faut aller sur le site des dépôts debian dans les versions expérimentales (épithète soft pour "instables" !) : sid et/ou jessie, et pêcher des archives .deb
Pour R, c'est ici.
Il faudra bien évidemment aller voir les dépendances (ici : r-base-core...)
Le pb, ce sont justement les dépendances... Si on reste dans la même famille de logiciel (r-base et r-base-core par ex), tout va bien. Si on attaque des bibliothèques plus générales, mieux vaut arrêter le processus.
Ma manip pour Gnumeric a très bien marché pour la version 14.04 (4 archives spécifiques à charger et installer), j'ai tenté l'aventure avec la 13.04, il y a beaucoup d'autres dépendances à satisfaire et là, ça craint un peu pour le reste du système. Normalement, vous avez des messages d'erreur de dépendances non satisfaites.
La manip est simple : une fois les différentes archives téléchargées, allez dans votre dossier home, créez un dossier que vous nommerez "toto" (ou autre qui vous fait plaisir) et mettez ces archives dedans. Ensuite, ouvrez une console (ctrl+alt+T) et tapez :

cd toto
sudo dpkg -i *.deb

Si tout se passe bien et que les dépendances ne sont pas trop importantes, vous avez un logiciel dernier cri disponible

Hors ligne

Haut de page ↑