Contenu | Rechercher | Menus

Annonce

Si vous rencontrez des soucis à rester connecté sur le forum (ou si vous avez perdu votre mot de passe) déconnectez-vous et reconnectez-vous depuis cette page, en cochant la case "Me connecter automatiquement lors de mes prochaines visites".
Test de l'ISO d'Ubuntu francophone : nous avons besoin de testeurs pour la version francophone d'Ubuntu 14.04. Liens et informations ici.

Attention, une faille de sécurité dans bash a récemment été rapportée, il est recommandé de mettre à jour son système (plus de détails)

#1 Le 17/05/2007, à 10:57

jobherzt

[Astuce] Problemes de SWAP

Comme je vois pas mal de messages portant sur des freezes/ralentissement sous efisty, que j'ai eu le meme genre de pb et que je viens apparemment de trouver une solution, j'en fait profiter...

disons qu'une fois le probleme identifié, la soluce coule de source, mais je n'avais pas pensé a chercher de ce coté la, alors bon, si ca peut aider smile

j'avais regulierement des tres fort ralentissement du systeme, notamment sur des choses un peu gourmande en memoire : essentiellement en affichant des PDF consequents, ou lors d'installation de logiciels via apt. ma souris devenait saccadée, plus rien ne reagissait, ca devenait ingerable, je finissais par redemarrer en force.

et je me suis finalement rendu compte que depuis ma mise a jour dapper -> feisty... je n'avais plus de swap !!! la faut au passage au systeme avec les UUID (http://doc.ubuntu-fr.org/uuid_et_label)

donc la solution :

on repere la partition SWAP :

jobert@jobertLaptop:~$ sudo fdisk -l

Disque /dev/sda: 80.0 Go, 80026361856 octets
255 têtes, 63 secteurs/piste, 9729 cylindres
Unités = cylindres de 16065 * 512 = 8225280 octets

Périphérique Amorce    Début         Fin      Blocs    Id  Système
/dev/sda1            9419        9729     2498107+  12  Compaq diagnostics
/dev/sda2   *           1        2618    21029053+  83  Linux
/dev/sda3            2718        9418    53825782+   b  W95 FAT32
/dev/sda4            2619        2717      795217+  82  Linux swap / Solaris

la c'est donc sda4. on affiche la liste des UUID :

jobert@jobertLaptop:~$ ls -l /dev/disk/by-uuid/
total 0
lrwxrwxrwx 1 root root 17 2007-05-17 10:46 0E4E-05CE -> ../../mapper/sda1
lrwxrwxrwx 1 root root 17 2007-05-17 10:46 7ca29c57-1da1-4c57-bd78-f20341cee606 -> ../../mapper/sda4
lrwxrwxrwx 1 root root 17 2007-05-17 10:46 b5db7fd3-7171-46b8-ba1a-937494ec8194 -> ../../mapper/sda2
lrwxrwxrwx 1 root root 17 2007-05-17 10:46 E88E-1BA5 -> ../../mapper/sda3

on repere donc l'UUID qui correspond a sda4.

ensuite, on edite le fichier /etc/fstab, et on met le bon UUID (ici : 7ca29c57-1da1-4c57-bd78-f20341cee606) pour la swap.

voila, a toutes fins utiles !

Dernière modification par jobherzt (Le 17/05/2007, à 11:20)

Hors ligne

#2 Le 17/05/2007, à 11:18

poum

Re : [Astuce] Problemes de SWAP

Je confirme : j'ai eu la même !
Mais j'ai du regénérer une signature avec mkswap.


Nobody fucks with the Jesus !
http://philippe.poumaroux.free.fr

Hors ligne

#3 Le 17/05/2007, à 11:19

jobherzt

Re : [Astuce] Problemes de SWAP

poum a écrit :

Mais j'ai du regénérer une signature avec mkswap.

j'ai vu ca dans la doc en lien avec des problemes d'hibernation, mais je n'ai pas compris l'interet de regenerer une signature, plutot que de recuperer celle existante et de la mettre la ou il faut ?

Hors ligne

#4 Le 29/05/2007, à 18:57

poum

Re : [Astuce] Problemes de SWAP

L'intérêt principal c'est que ça marche ;-)

Quand je reprenais simplement la signature existante, j'avais toujours mon erreur de signature non reconnue...


Nobody fucks with the Jesus !
http://philippe.poumaroux.free.fr

Hors ligne

#5 Le 20/06/2007, à 14:19

crackers

Re : [Astuce] Problemes de SWAP

Avec la commande "top" je me retrouve avec ça

Swap:        0k total,        0k used,        0k free,    76124k cached

J'en déduit donc que le problème est le même.

mais en faisant "sudo fdisk -l"

j'obtient ça

Disque /dev/sda: 163.9 Go, 163928604672 octets
255 têtes, 63 secteurs/piste, 19929 cylindres
Unités = cylindres de 16065 * 512 = 8225280 octets

Périphérique Amorce    Début         Fin      Blocs    Id  Système
/dev/sda1   *           1       11005    88397631    7  HPFS/NTFS
/dev/sda2           11006       13530    20282062+  83  Linux
/dev/sda3           13531       19929    51399967+  83  Linux

Je n'arrive pas à repérer ma partition swap et ne peut donc pas continuer à résoudre mon problème.
Pour info je suis sur ubuntu studio...
Merci à ceux qui pourront m'aider je suis nouveau sur linux et plein de bonne volonté mais ces ralentissements me prennent la tête :D

#6 Le 20/06/2007, à 16:09

crackers

Re : [Astuce] Problemes de SWAP

Bon après quelques heures de recherche supplémentaire je me suis rendu compte que lors de l'installation je n'avait tout simplement pas crée de partition swap, donc je viens de réinstaller ubuntu et maintenant c'est nickel.

#7 Le 01/07/2007, à 13:33

Toins31

Re : [Astuce] Problemes de SWAP

Moi j'ai le bon uuid mais le swap ne marche pas.
0% tout le temps...

Auriez vous des idées pour moi?

Hors ligne

#8 Le 01/07/2007, à 17:30

strataoïde

Re : [Astuce] Problemes de SWAP

peut-être pourrais-tu reposter ton fstab sur le forum?
Mais avant que ton ordi freezze et pour que tu puisses travailler à l'aise.
sudo swapon   -l /dev/nomdelapartitionswap,logiquementsda4


la commande la plus utile sous linux? man bien sur!

Hors ligne

#9 Le 07/07/2007, à 17:59

ryokan

Re : [Astuce] Problemes de SWAP

Merci pour ce tuto Jobhertz, grace à toi mon problème de ralentissement est
enfin résolu...
J'ai connu ce problème juste après la mise à jour du kernel vers 2.6.20-16 et
je pensai que c'était dû à cette nouvelle version du noyau.
Je suis revenu à l'ancien (2.6.20-15) pour connaître encore ces problèmes
de " freezing "...
Finalement, je suis tombé dans mes recherches sur ton message et le tuto qui a
tout de suite débloqué la situation.

conclusion : méfions-nous des mises à jour...

Dernière modification par ryokan (Le 07/07/2007, à 18:08)

Hors ligne

#10 Le 27/11/2007, à 01:19

th0mas

Re : [Astuce] Problemes de SWAP

bordel, ça doit faire des mois que mon swap n'est plus monté...
D'o๠mes freezes à  répétitions sur des trucs à  la con (ouverture de pdf etc...), sans raison apparente.
Et en plus, maintenant je suis sous Gutsy...
Bref, merci google "swap ubuntu problème"
Merci à  vous !

Pendant que j'y suis, je viens de lire ici-même que pour une RAM supérieure ou égale à  512Mo, un SWAP de 400Mo est largement suffisant.
http://doc.ubuntu-fr.org/windows/swap
Jusqu'ici, ma RAM faisant 512, j'avais fait mon swap à  1024Mo. Est-ce que je peux réduire à  400Mo sans encombre (je fais un peu d'applis vidéos qui pompent ?

Vous validez ?

Dernière modification par th0mas (Le 27/11/2007, à 01:23)

Hors ligne

#11 Le 27/11/2007, à 10:40

k-o-x

Re : [Astuce] Problemes de SWAP

th0mas a écrit :

Jusqu'ici, ma RAM faisant 512, j'avais fait mon swap à  1024Mo. Est-ce que je peux réduire à  400Mo sans encombre (je fais un peu d'applis vidéos qui pompent ?

Vous validez ?

Bah, je pense que ça devrait passer; cela dit, ça coûte pas grand chose de tester (désactive le swap, redimensionne la partition avec fdisk, réactive, et balance de la video) smile

Hors ligne

#12 Le 06/12/2007, à 22:36

r17777

Re : [Astuce] Problemes de SWAP

'soir à toutes et tous!

j'ai exactement les mêmes symptômes que vous décrivez tous ici...

Un ralentissement sévère du pc lors d'affichage de pdf lourd, de surf avec plein de pages ouvertes..etc, qui se traduit par des grosses saccades du pointeur de la souris, les fenêtres qui réagissent dix plombes après la guerre, et tout ça sans activité du proc , mais par contre avec une activité disque dur énorme!

Sur l'applet moniteur système de gnome le proc est au calme plat mais l'histogramme du disque dur ressemble à un vrai film d'horreur !  lol
et effectivement moi aussi il m'arrive de céder souvent à la tentation du "CTRL+ ALT +BACKSPACE". hmm
donc SVP, délivrez moi du mal ! lol

En fait je débarque ici car je vien de faire une modif en virant la mention "quiet"  du boot dans mon menu.lst de grub...

du coup j'ai tout de suite vu lors du boot:

activating swap    [fail]

hé hop une petite recherche "gutsy activer swap" m'a mené ici.


par contre moi aussi j'ai le bon UUID dans mon fstab  mais ma swap ne marche pas pour autant! 

mon disque Gutsy (celui qui m'intéresse) est le 200go, le 500Go est un stockage, et le 80go est mon Dapper de secours.
je vous copie colle les truc dans leurs intégralités au cas ou vous y veriez des éventuels contradictions ou conflits possibles...

r17777@P4P800-Gutsy:~$  sudo fdisk -l
[sudo] password for r17777:

Disque /dev/sda: 80.0 Go, 80026361856 octets
255 heads, 63 sectors/track, 9729 cylinders
Units = cylindres of 16065 * 512 = 8225280 bytes
Disk identifier: 0xf7f9f6b4

Périphérique Amorce    Début         Fin      Blocs    Id  Système
/dev/sda1   *           1        1275    10241406    c  W95 FAT32 (LBA)
/dev/sda2            1276        9729    67906755   83  Linux

Disque /dev/sdb: 500.1 Go, 500107862016 octets
255 heads, 63 sectors/track, 60801 cylinders
Units = cylindres of 16065 * 512 = 8225280 bytes
Disk identifier: 0x00077e28

Périphérique Amorce    Début         Fin      Blocs    Id  Système
/dev/sdb1               1       60801   488384001    b  W95 FAT32

Disque /dev/sdc: 200.0 Go, 200049647616 octets
255 heads, 63 sectors/track, 24321 cylinders
Units = cylindres of 16065 * 512 = 8225280 bytes
Disk identifier: 0x5bba3783

Périphérique Amorce    Début         Fin      Blocs    Id  Système
/dev/sdc1   *           1        1946    15631213+   c  W95 FAT32 (LBA)
/dev/sdc2            1947        3915    15815992+  83  Linux
/dev/sdc3            3916        4170     2048287+  82  Linux swap / Solaris
/dev/sdc4            4171       24321   161862907+   b  W95 FAT32

V'là mon fstab


# /etc/fstab: static file system information.
#
#les partitions XP sont commentées pour ne pas apparaitre aux démarages
#
# <file system> <mount point>   <type>  <options>       <dump>  <pass>
proc            /proc           proc    defaults        0       0
#
# partition XP sur 200Go(sdc) fat32
# /dev/sdc1
#UUID=784C-9D7A  /media/200Go-XP     vfat    defaults,utf8,umask=007,gid=46 0       1
#
# partition home de Gustsy sur 200Go(sdc) ext3 
# /dev/sdc2
UUID=5ab10f8f-3f50-4090-b707-11a0d7ec1aeb /               ext3    defaults,errors=remount-ro 0       1
#
# Partition Swap de Gutsy sur 200Go(sdc) swap
# /dev/sdc3
UUID=54d2fb7d-b44d-4ebf-ac4c-7b49403cda53 none            swap    sw              0       0
#
# partition Temporaire sur 200Go(sdc) fat32
# /dev/sdc4
UUID=467D-1A99  /media/200Go-Temporaire     vfat    defaults,utf8,umask=007,gid=46 0       1
#
# partition  Stokage en partage Gutsy Feisty XP 500Go(sdb) fat32
# /dev/sdb1 
UUID=4656-AA78  /media/500Go-Stockage    vfat    defaults,utf8,umask=007,gid=46 0     1
#
# partition Dapper home en partage avec Gutsy 80Go(sda) ext2
# /dev/sda2
UUID=9254966f-da37-4820-b3be-d0343f61d501   /media/80Go-Dapper               ext2    defaults,errors=remount-ro 0       1
#
# partition Windows XP en partage avec Gutsy 80Go(sda) fat32
# /dev/sda1
#UUID=2F2D-19EB   /media/80Go-XP    vfat    defaults,utf8,umask=007,gid=46 0     1
#
# montage automatique des disque cd-dvd rom et disquette
/dev/scd0       /media/cdrom0   udf,iso9660 user,noauto,exec 0       0
/dev/fd0        /media/floppy0  auto    rw,user,noauto,exec 0       0

puis la commande ls -l /dev/disk/by-uuid/

r17777@P4P800-Gutsy:~$  ls -l /dev/disk/by-uuid/
total 0
lrwxrwxrwx 1 root root 10 2007-12-06 20:43 2F2D-19EB -> ../../sda1
lrwxrwxrwx 1 root root 10 2007-12-06 20:43 4656-AA78 -> ../../sdb1
lrwxrwxrwx 1 root root 10 2007-12-06 20:43 467D-1A99 -> ../../sdc4
lrwxrwxrwx 1 root root 10 2007-12-06 20:43 54d2fb7d-b44d-4ebf-ac4c-7b49403cda53 -> ../../sdc3
lrwxrwxrwx 1 root root 10 2007-12-06 20:43 5ab10f8f-3f50-4090-b707-11a0d7ec1aeb -> ../../sdc2
lrwxrwxrwx 1 root root 10 2007-12-06 20:43 784C-9D7A -> ../../sdc1
lrwxrwxrwx 1 root root 10 2007-12-06 20:43 9254966f-da37-4820-b3be-d0343f61d501 -> ../../sda2

puis enfin le resultat de la commande sudo swapon -l /dev/sdc3:


r17777@P4P800-Gutsy:~$ sudo swapon -l /dev/sdc3
[sudo] password for r17777:
swapon: option invalide -- l
usage: swapon [-hV]
       swapon -a [-e] [-v]
       swapon [-v] [-p priorité] spécial|ÉTIQUETTE=nom_du_volume ...
       swapon [-s]

qui ne me parait pas très probante ... hmm

bon ben j'vois plus que faire là .... sad

une piste?
j'ai me*dé quelque part?

un grand merkiiiiii d'avance ... cool

Dernière modification par r17777 (Le 07/12/2007, à 11:40)


Energie: pAnser les fuites pour pEnser la suite! :-°
Faites un geste pour l'environnement, fermez vos fenètres/windows et adoptez un pingouin! ;-)
Portable Fujitsu Siemens XI2528  (Ubuntu 12.04 /64bits) + admin tant bien que mal de divers ordis Ubuntu et ordinausores avec OS libres léger (chez des proches) + 1 serveur Nas QNAP TS-109 PRO (toujours pas sorti du carton)

Hors ligne

#13 Le 08/12/2007, à 15:56

r17777

Re : [Astuce] Problemes de SWAP

up? roll


Energie: pAnser les fuites pour pEnser la suite! :-°
Faites un geste pour l'environnement, fermez vos fenètres/windows et adoptez un pingouin! ;-)
Portable Fujitsu Siemens XI2528  (Ubuntu 12.04 /64bits) + admin tant bien que mal de divers ordis Ubuntu et ordinausores avec OS libres léger (chez des proches) + 1 serveur Nas QNAP TS-109 PRO (toujours pas sorti du carton)

Hors ligne

#14 Le 08/12/2007, à 18:31

Kanor

Re : [Astuce] Problemes de SWAP

J'ai peut étre une idée c'est que ta partition swap n'est pas partitionné en swap wink
Installe gparted
C'est un programme très pratique mais assez dangeraux aussi
trouve ta partition swap (si elle a un carré noir à  coté bon hypothèse est bonne )clique droite
et sélectionne formater en swap (ne te trompe pas de partition )
et enfin reclique droite et sélectionne swapon

Hors ligne

#15 Le 10/12/2007, à 15:25

r17777

Re : [Astuce] Problemes de SWAP

Merci Kanor!

Franchement pour tout t'avouer j'y croyais pas ... mais bon .. faut tjrs tout vérifier ...

Donc effectivement la swap n'était pas bien formatée ! un truc de ouf!  hmm

Etrange pourtant je me suis bien efforcer de la personnaliser (au moins du cà´té de son volume) lors de l'install propre et à  neuf de Gutsy (après une Feisty qui foirait trop sur mon PC+ formatage) ....

Alors ou est la subtilité qui m'aurait échapé lors de cette install ???

Y'en à  t'il vraiment une, ou est ce plus un prb lié à  Gutsy?

Honnètement je pencherais plus pour un prb de Gutsy vu le nombre de personnes qui ont apparement bien cherché et galeré sur ce prb de ralentissement de bécanne sans "exitation" du proc .. mais avec un affolement du hdd!

En tous cas je viens de rebooter et "activating  Sawp     = OK"   big_smile  cool

Bon plus qu'à  tester si j'ai tjrs des ralentissement maintenant ..  wink

Merci encore...


Energie: pAnser les fuites pour pEnser la suite! :-°
Faites un geste pour l'environnement, fermez vos fenètres/windows et adoptez un pingouin! ;-)
Portable Fujitsu Siemens XI2528  (Ubuntu 12.04 /64bits) + admin tant bien que mal de divers ordis Ubuntu et ordinausores avec OS libres léger (chez des proches) + 1 serveur Nas QNAP TS-109 PRO (toujours pas sorti du carton)

Hors ligne

#16 Le 11/12/2007, à 20:15

gg06

Re : [Astuce] Problemes de SWAP

Génial mes pb de temps de réponses sont apparemment résolus en mettant à  jour mon fichier stab pour le swap.
Par contre je me suis aperçu que j'avais 2 partitions swap ; c'est vrai que j'ai fait beaucoup de manips (install, desinstall d'Ubuntu) .
Puis-je supprimer cette 2eme partion et comment ?

Hors ligne

#17 Le 24/05/2011, à 20:20

spinoziste

Re : [Astuce] Problemes de SWAP

SAlut à tous .

Possedant un EEEpc j'aimerais pouvoir activer le swap . Or malgré l'attention que j'ai porté sur la Doc Swap rien à faire .

J'ai beau activer la partition swap elle n'est utilisée qu'à 0% systematiquement .

LE UUID est proprement renseigné dans mon /etc/fstab et dans mon /etc/initramfs-tools/conf.d/resume Or rien à faire le Swap ne charge rien .

Ma RAM tournant en moyenne à 38% pour une utilisation basique c'est assez embarassant .

J'ai donc renseigné le fichier : /etc/sysctl.conf comme specifié dans la doc en mettant la valeur à 80 (cad declenchement à partir de 80% de RAM libre=20% utilisée) Or rine à faire ce maudit swap ne veut pas se declencher
pourtant il dit etre activé .

Gparted me renvoie une partition swap à priori propre et active .
EDIT :fautes d'orthographe


Que faire docteur ?

Merci d'avance wink

Dernière modification par spinoziste (Le 24/05/2011, à 20:57)


Nous mourrons tous .

Hors ligne

#18 Le 24/05/2011, à 20:30

kikislater

Re : [Astuce] Problemes de SWAP

swapon -a
C'est 20 que tu dois mettre pas 80 !
Puis un renvoit d'un top après le swapon dans le terminal pour voir où ça en est ...

Dernière modification par kikislater (Le 24/05/2011, à 20:35)

Hors ligne

#19 Le 24/05/2011, à 20:55

spinoziste

Re : [Astuce] Problemes de SWAP

merci kikislater .

Mais si j'ai bien compris la DOc

DOc a écrit :

Par défaut, Ubuntu est réglé de cette façon :

À partir de 40% d'utilisation de la RAM (donc 60% de libre), le noyau peut se délester sur la swap.

Donc si l'on veut un declenchement du swap à partir de 80% de libre il faut mettre = 80 non ?

Puisque :

cat /proc/sys/vm/swappiness

renvoie : 60

ça veut bien dire que :

DOc a écrit :

Par défaut, Ubuntu est réglé de cette façon :

À partir de 40% d'utilisation de la RAM (donc 60% de libre), le noyau peut se délester sur la swap.


Nous mourrons tous .

Hors ligne

#20 Le 25/05/2011, à 09:22

kikislater

Re : [Astuce] Problemes de SWAP

Non si tu lis la suite :

doc ubuntu a écrit :

Pour que ces changements deviennent permanents (à chaque démarrage), vous devez éditer le fichier /etc/sysctl.conf et y ajouter la ligne suivante:

vm.swappiness = 20
Plus d'infos sur cette manipulation sur ce site (Fr) ou celui-ci (En)

psychederic recommande : 10 avec 2 à 3Gb de Ram; 20 pour les pc avec disques SSD rapides. Avec 0 le SWAP sera utilisé en dernier recours (préférable pour les disques durs et SSD lents)

et dans mon top j'ai ça  avec comme valeur 15 (je suis avec un ssd)

Mem:  10257784k total,  3563596k used,  6694188k free,   190904k buffers
Swap:  4194296k total,        0k used,  4194296k free,   843876k cached

Ce qui veut bien dire que mon swap ne s'est pas encore déclenché alors que j'utilise plus de 15% de ma ram ! Il se déclenchera à 85% d'utilisation de ma ram

Hors ligne

#21 Le 06/02/2014, à 15:20

joe_mannix

Re : [Astuce] Problemes de SWAP

Bonjour à tous,

je relance une vieille discussion qui me paraît inachevée car j'ai moi aussi un problème de swap qui ne se déclenche jamais, même quand l'utilisation de ma RAM monte à quasiment 100%, ce qui m'est arrivé récemment.

L'utilisation du swap devrait se déclencher à partir de 40% d'utilisation de la RAM :

pierre@pierre-OptiPlex-9020:~$ cat /proc/sys/vm/swappiness 
60

En ce moment précis, je suis à plus de 60% d'utilisation de la RAM et le swap n'est toujours pas mis à contribution :

top - 14:13:15 up  5:18,  4 users,  load average: 0,17, 0,23, 0,23
Tasks: 249 total,   1 running, 244 sleeping,   4 stopped,   0 zombie
%Cpu(s):  0,8 us,  0,7 sy,  0,0 ni, 98,5 id,  0,1 wa,  0,0 hi,  0,0 si,  0,0 st
KiB Mem:   8083188 total,  5019988 used,  3063200 free,   250032 buffers
KiB Swap:  7102460 total,        0 used,  7102460 free,  2229892 cached

Je viens de lire cette discussion ainsi que celle-ci mais je ne trouve pas de solution à mon problème.

Voici le résultat de la commande fdisk :

pierre@pierre-OptiPlex-9020:~$ sudo fdisk -l

Disk /dev/sda: 500.1 GB, 500107862016 bytes
255 têtes, 63 secteurs/piste, 60801 cylindres, total 976773168 secteurs
Unités = secteurs de 1 * 512 = 512 octets
Taille de secteur (logique / physique) : 512 octets / 4096 octets
taille d'E/S (minimale / optimale) : 4096 octets / 4096 octets
Identifiant de disque : 0xa1baaa5d

Périphérique Amorçage  Début         Fin      Blocs    Id. Système
/dev/sda1   *        2048   122882047    61440000    7  HPFS/NTFS/exFAT
/dev/sda2       122882048   204802047    40960000   83  Linux
/dev/sda3       204802048   976773119   385985536    5  Étendue
/dev/sda5       204804096   655364095   225280000    7  HPFS/NTFS/exFAT
/dev/sda6       655366144   962566143   153600000   83  Linux
/dev/sda7       962568192   976773119     7102464   82  partition d'échange Linux / Solaris

Ensuite j'affiche la liste des UUID :

pierre@pierre-OptiPlex-9020:~$ ls -l /dev/disk/by-uuid/
total 0
lrwxrwxrwx 1 root root 10 févr.  6 08:54 246F85197290CBCB -> ../../sda1
lrwxrwxrwx 1 root root 10 févr.  6 08:54 2EDC0AD22900F047 -> ../../sda5
lrwxrwxrwx 1 root root 10 févr.  6 08:54 548c220b-77dc-43f1-b0ee-6059dd58c040 -> ../../sda2
lrwxrwxrwx 1 root root 10 févr.  6 09:15 8a8afd6c-93a9-4cc9-b2eb-9a9923e31eb5 -> ../../sda7
lrwxrwxrwx 1 root root 10 févr.  6 08:54 e189d3ea-aa8d-4449-abd5-7bcca81c9f95 -> ../../sda6

Et quand j'édite le fichier /etc/fstab :

# /etc/fstab: static file system information.
#
# <file system> <mount point>   <type>  <options>       <dump>  <pass>

#Entry for /dev/sda2 :
UUID=548c220b-77dc-43f1-b0ee-6059dd58c040       /       ext4    errors=remount-$
#Entry for /dev/sda5 :
UUID=2EDC0AD22900F047   /media/Winux    ntfs    defaults,nls=utf8,umask=000,uid$
#Entry for /dev/sda6 :
UUID=e189d3ea-aa8d-4449-abd5-7bcca81c9f95       /home   ext4    defaults       $
#Entry for /dev/sda7 :
UUID=8a8afd6c-93a9-4cc9-b2eb-9a9923e31eb5       none    swap    sw      0      $

ce qui semble indiquer que la partition swap est à la bonne adresse.

Gparted affiche que sda7 est bien une partition de type linux-swap (avec un carré rouge bordeaux).

La commande glxinfo me renvoie yes :

pierre@pierre-OptiPlex-9020:~$ glxinfo | grep rendering
direct rendering: Yes

Et la commande swapon -s renvoie un résultat normal aussi :

pierre@pierre-OptiPlex-9020:~$ swapon -s
Filename				Type		Size	Used	Priority
/dev/sda7                               partition	7102460	0	-1

Quelqu'un a une idée de ce qui ne va pas ?

Merci d'avance !

Hors ligne

#22 Le 22/03/2014, à 21:43

JBF

Re : [Astuce] Problemes de SWAP

joe_mannix a écrit :

En ce moment précis, je suis à plus de 60% d'utilisation de la RAM et le swap n'est toujours pas mis à contribution : [...]
Je viens de lire cette discussion ainsi que celle-ci mais je ne trouve pas de solution à mon problème.

C'est peut-être parce qu'il n'y a pas de problème. Pourquoi veux-tu utiliser le swap s'il n'est pas nécessaire ? La RAM disponible est faite pour être utilisée.

JBF


LibreOffice : http://fr.libreoffice.org/ (téléchargement, documentation, FAQ, assistance, contribuer, ...)

Hors ligne

Haut de page ↑