Contenu | Rechercher | Menus

Annonce

Si vous rencontrez des soucis à rester connecté sur le forum (ou si vous avez perdu votre mot de passe) déconnectez-vous et reconnectez-vous depuis cette page, en cochant la case "Me connecter automatiquement lors de mes prochaines visites".
Test de l'ISO d'Ubuntu francophone : nous avons besoin de testeurs pour la version francophone d'Ubuntu 14.04. Liens et informations ici.

Attention, une faille de sécurité dans bash a récemment été rapportée, il est recommandé de mettre à jour son système (plus de détails)

#1 Le 15/02/2014, à 18:38

bruno78

carte Tyan Tachyon 9600pro

Bonjour,

Je viens d'installer ubuntu 12.04 sur mon pc qui date de 2003. Ayant testé Youtube via mozilla firefox je me suis aperçu que je ne pouvais lire les vidéo malgré la présence du plugin flash player (shocwave flash 11.2.202.306).

ma carte graphique pouvant être en cause je me suis aperçu qu'en paramètres système j'obtenais carte graphique inconnue; expérience standart tandis que la commande LSPCI mentionnait : display controller : [amd/ati] rv350 [radeon 9550/9600/x1050 series]

1) je ne comprend pas que le premier la déclare incunnue alors que la seconde semble l'identifier
2) comment puis je savoir si le driver installé est correct et sinon ou puis le trouver?

je vous remercie pour votre aide

cdlt

Hors ligne

#2 Le 16/02/2014, à 12:03

Julius22

Re : carte Tyan Tachyon 9600pro

Bonjour,
   Je pense que le système reconnaît bien ta carte. Pour autant, un pilote n'est pas forcément installé. Tu devrais commencer à regarder la documentation de ce site, à commencer par la page carte_graphique. Si tu as besoin de plus de précisions, n'hésite pas à en demander. wink


Membre de l'April (www.april.org)
Pour éviter de perdre vos données, utilisez des formats ouverts (cf. www.formats-ouverts.org).
Regardez l'utilisation moyenne de votre processeur et pensez à BOINC.

Hors ligne

#3 Le 16/02/2014, à 12:31

linoll

Re : carte Tyan Tachyon 9600pro

Cette vieille génération de cartes graphiques ATI n'est désormais gérée que par des pilotes libres (intégrés à Ubuntu qui désigne donc ça comme "expérience standard", expression anglo-merdique il faut bien reconnaître). La firme AMD qui a racheté ATI il y a déjà pas mal de temps préfère rémunérer quelques développeurs à contribuer à faire progresser des pilotes ouverts ("open-source" c'est à dire non vérouillés si tu préfères) que tout le monde peut et pourra donc améliorer perpétuellement... Inutile donc de chercher un pilote additif propriétaire à ajouter et tant mieux pour tout le monde car un pilote fermé sur un système open-source est FORCÉMENT perturbateur et beuguogène en plus de ne pas être pérenne.

Quand tu nous parles de la version Ubuntu 12.04 on pourrait craindre que tu n'ais pas la mise à jour actuelle 12.04.4 qui justement améliorerait nettement le pilotage de ta carte par rapport au pilote intégré à l'époque de la version initiale 12.04.0 . Qu'en est-il ? As-tu fait l'installation avec une version Ubuntu téléchargée tout récemment sur un site officiel, ou récupérée depuis plus longtemps... ?

Pour ton cas le problème avec le Flashplugin (propriétaire, fermé, perturbateur donc) pourrait aussi bien venir du processeur central qui ne gèrerait pas les instructions Intel SSE2, (par exemple si c'est un AMD Athlon XP ou Duron, c'est à dire d'avant la génération 64 bits "Venice", en 2005 environ, ou alors un Intel mais alors encore plus vieux).

Pourrais-tu donc nous préciser exavtement ce qu'est ce CPU ?
Si mon diagnostic est bon il y aura tout de mème une solution logicielle à "bricoler" pour contourner cette stupide mesure d'obsolescence programmée due au flashplugin Adobe actuel, mais je te l'indiquerai le moment venu...



Post scriptum très secondaire : si tu veux que l'identification de ta carte soit mieux relayée dans l'info système il te faut ajouter un tout petit utilitaire qui n'est pas intégré par défaut à l'installation : le paquet logiciel mesa-utils . Donc en faisant par exemple

sudo apt-get install mesa-utils

puis en quittant ta session graphique pour la rouvrir et voir apparaitre le nom de ta carte graphique dans les informations système... (pas vraiment crucial quand on sait trouver cette info par un autre biais comme tu nous l'as montré).

Dernière modification par linoll (Le 16/02/2014, à 12:38)

Hors ligne

#4 Le 16/02/2014, à 15:00

bruno78

Re : carte Tyan Tachyon 9600pro

Bonjour Julius22, Linoll,

Merci pour votre réponse.

Oui julius j'ai regardé la documentation qui m'a permis de corriger un certain nombre de point et notamment d'adapter mon Grub. Mais concernant ma carte j'avoue que je suis un peu perdu (j'ai même cherché dans la logitech dans laquelle j'ai trouvé 3 X-orgxserver AMD/ATI radeon driver display driver (Quantal/raring/saucy) que je n'ai pas installé faute d'avoir toutes les connaissances nécessaires sur leurs effets et sur la version la plus adaptée).

Voici le résumé que me donne "hardinfo" (ma version est bien une 12.04.4 résultat des upgrades successif de la version 9.10 originale)
-Computer-
Processor        : AMD Athlon(tm) XP
Memory        : 1543MB (456MB used)
Operating System        : Ubuntu 12.04.4 LTS
User Name        : bureau (bureau)
Date/Time        : dim. 16 févr. 2014 13:36:16 CET
-Display-
Resolution        : 1680x1050 pixels
OpenGL Renderer        : Unknown
X11 Vendor        : The X.Org Foundation
-Multimedia-
Audio Adapter        : NFORCE - NVidia nForce2
Audio Adapter        : MPU-401 UART - MPU-401 UART
-Input Devices-
Power Button
Power Button
Microsoft Basic Optical Mouse
Microsoft® Office Keyboard
Microsoft® Office Keyboard
-Printers (CUPS)-
Epson-Stylus-SX210
HP-LaserJet-6p        : <i>Default</i>
-SCSI Disks-
ATA SAMSUNG SP2514N
_NEC DVD_RW ND-1300A
PIONEER DVD-ROM DVD-120S


Voici les composants de mon pc (un régal pour les antiquaires puisque datant de 2003)

carte mère : asus a7n8x deluxe nvidia nforce2
Co process : AMD Cpu XP2500+ (barton)
carte graphique : Tyan Tachyon RADEON 9600 pro

merci pour votre aide

cdlt

Bruno78

Hors ligne

#5 Le 16/02/2014, à 16:58

linoll

Re : carte Tyan Tachyon 9600pro

Ce n'est donc pas de ta carte graphique ni de son pilotage que vient de problème, c'est du processeur Athlon XP qui ne gère pas les instructions SSE2 nécéssaires au plugin Adobe Flash actuel.

Il va donc falloir que tu installes manuellement la version 11.1.102.62 obsolète du plugin qui passait encore sans SSE2 à l'époque, comme suit :
D'abord purger le plugin actuellement en place :

sudo apt-get purge flashplug*

Ensuite le téléchargement du plugin obsolète voulu la commande est

wget http://luccio_script.perso.sfr.fr/libflashplayer.so

Un répertoire /plugins/ n'existe pas forcément encore dans ton dossier /.mozilla/ et il faut donc commencer par le recréer ainsi :

mkdir /.mozilla/plugins

et pour y placer le plugin téléchargé utilisable par Firefox tu peux enfin faire :

cp libflashplayer.so ~/.mozilla/plugins/libflashplayer.so

Pour être sûr de bien reproduire ces commandes tu peux copier-coller dans ta fenêtre de terminal.

Qu'est-ce que ça donne ? (si Firefox était resté ouvert il faut évidemment le relancer pour voir le résultat, mais autant le fermer avant toute la manip).

Hors ligne

#6 Le 16/02/2014, à 17:31

bruno78

Re : carte Tyan Tachyon 9600pro

oups cela bloque là :

Un répertoire /plugins/ n'existe pas forcément encore dans ton dossier /.mozilla/ et il faut donc commencer par le recréer ainsi : mkdir /.mozilla/plugins

mkdir: impossible de créer le répertoire «/.mozilla/plugins»: Aucun fichier ou dossier de ce type

Et il est vrai que je n'ai pas de directory .mozilla. Dois je le faire en 2 étapes?

ps : le fait que" l'opengl renderer" soit inconnu dans ma config me surprend tout de même

Hors ligne

#7 Le 16/02/2014, à 18:07

linoll

Re : carte Tyan Tachyon 9600pro

Pardon, j'aurais du écrire

mkdir ~/.mozilla/plugins

En effet c'est un répertoire qui doit être à la racine de ton dossier personnel d'utilisateur, dont je ne connais pas le nom (mais depuis lequel je suppose que tu exécutes les commandes), et non pas à la racine du système).

Hors ligne

#8 Le 16/02/2014, à 18:33

bruno78

Re : carte Tyan Tachyon 9600pro

Voila opération faite ainsi que redémarrage de firefox. Et en effet cela fonctionne, après activation, (pub yahoo, youtube) en me signalant que mon plugin est obsolète et vulnérable.

Donc je suppose qu'il faut que je prenne garde à ne pas le mettre à jour.

La question de la lecture de vidéo sous firefox est résolue, Merci !

Par contre, pour tester ma carte vidéo et sa config, je me suis amusé à télécharger un jeu (openarena) qui me retourne une erreur couldn't load opengl subsystem ce qui semble cohérent avec le résumé de config posté plus haut. Est ce lié au driver de la carte ou à une histoire de "DirectX"  (désolé d'employer une expression windows roll)

Hors ligne

#9 Le 16/02/2014, à 19:29

linoll

Re : carte Tyan Tachyon 9600pro

Pour ce qui est de la vulnérabilité de ton plugin obsolète... rassures-toi, le plugin actuel est lui aussi vulnérable (mais ça ne s'affiche pas dans le navigateur tant qu'Adobe ne propose pas une mise à jour qui résout tous les problèmes du monde... et s'avère vulnérable quelques heures plus tard... en résumer Adobe Flash est vulnérable par conception.

Pour ce qui est de ton accélération graphique OpenGL il faudrait que tu nous colles le rapport des commandes

glxinfo | grep OpenGL

ainsi que de

glxinfo | grep rendering

et de

glxinfo | grep version

et aussi de

glxinfo | grep vendor

Hors ligne

#10 Le 16/02/2014, à 19:30

linoll

Re : carte Tyan Tachyon 9600pro

Et puis j'oubliais aussi :

uname -a

Hors ligne

#11 Le 16/02/2014, à 20:01

bruno78

Re : carte Tyan Tachyon 9600pro

En effet les plugin Adobe...... si l'on pouvais s'en passer

Voici les rapport:

bureau@bureau-desktop:~$ glxinfo | grep OpenGL
Xlib:  extension "GLX" missing on display ":0.0".
Xlib:  extension "GLX" missing on display ":0.0".
Xlib:  extension "GLX" missing on display ":0.0".
Xlib:  extension "GLX" missing on display ":0.0".
Xlib:  extension "GLX" missing on display ":0.0".
Error: couldn't find RGB GLX visual or fbconfig
Xlib:  extension "GLX" missing on display ":0.0".
Xlib:  extension "GLX" missing on display ":0.0".
Xlib:  extension "GLX" missing on display ":0.0".
Xlib:  extension "GLX" missing on display ":0.0".
Xlib:  extension "GLX" missing on display ":0.0".
Xlib:  extension "GLX" missing on display ":0.0".
Xlib:  extension "GLX" missing on display ":0.0".

bureau@bureau-desktop:~$ glxinfo | grep rendering
Xlib:  extension "GLX" missing on display ":0.0".
Xlib:  extension "GLX" missing on display ":0.0".
Xlib:  extension "GLX" missing on display ":0.0".
Xlib:  extension "GLX" missing on display ":0.0".
Xlib:  extension "GLX" missing on display ":0.0".
Error: couldn't find RGB GLX visual or fbconfig
Xlib:  extension "GLX" missing on display ":0.0".
Xlib:  extension "GLX" missing on display ":0.0".
Xlib:  extension "GLX" missing on display ":0.0".
Xlib:  extension "GLX" missing on display ":0.0".
Xlib:  extension "GLX" missing on display ":0.0".
Xlib:  extension "GLX" missing on display ":0.0".
Xlib:  extension "GLX" missing on display ":0.0".

bureau@bureau-desktop:~$ glxinfo | grep version
Xlib:  extension "GLX" missing on display ":0.0".
Xlib:  extension "GLX" missing on display ":0.0".
Xlib:  extension "GLX" missing on display ":0.0".
Xlib:  extension "GLX" missing on display ":0.0".
Xlib:  extension "GLX" missing on display ":0.0".
Error: couldn't find RGB GLX visual or fbconfig
Xlib:  extension "GLX" missing on display ":0.0".
Xlib:  extension "GLX" missing on display ":0.0".
Xlib:  extension "GLX" missing on display ":0.0".
Xlib:  extension "GLX" missing on display ":0.0".
Xlib:  extension "GLX" missing on display ":0.0".
Xlib:  extension "GLX" missing on display ":0.0".
Xlib:  extension "GLX" missing on display ":0.0".

bureau@bureau-desktop:~$ glxinfo | grep vendor
Xlib:  extension "GLX" missing on display ":0.0".
Xlib:  extension "GLX" missing on display ":0.0".
Xlib:  extension "GLX" missing on display ":0.0".
Xlib:  extension "GLX" missing on display ":0.0".
Xlib:  extension "GLX" missing on display ":0.0".
Error: couldn't find RGB GLX visual or fbconfig
Xlib:  extension "GLX" missing on display ":0.0".
Xlib:  extension "GLX" missing on display ":0.0".
Xlib:  extension "GLX" missing on display ":0.0".
Xlib:  extension "GLX" missing on display ":0.0".
Xlib:  extension "GLX" missing on display ":0.0".
Xlib:  extension "GLX" missing on display ":0.0".
Xlib:  extension "GLX" missing on display ":0.0".

bureau@bureau-desktop:~$ uname -a
Linux bureau-desktop 3.2.0-58-generic #88-Ubuntu SMP Tue Dec 3 17:40:43 UTC 2013 i686 athlon i386 GNU/Linux

voila

Hors ligne

#12 Le 16/02/2014, à 20:49

linoll

Re : carte Tyan Tachyon 9600pro

Ah ouais !

Donc on va avoir de la marge pour améliorer ton pilotage graphique car actuellement il n'y en a pas de pilotage spécifique à ta carte, il y a juste un pilotage logiciel donc forcément lent et ralentisseur au possible !

En voyant aussi ta version de noyau linux il parait clair que tou ça est du au long parcours de migration de version en version depuis la 9.04... ce qui laisse des traces merdiques concernant les vieilles configurations obsolètes avec les nouveaux composants graphiques...

Donc, faisons déjà :

sudo rm /etc/X11/xorg.conf

et redémarrons l'ordi pour voir ce que ça donne... Il y aura d'autres améliorations à apporter ensuite mais pour l'instant, une fois redémarré tu peux nous envoyer de nouveau les rapports des commandes glxinfo... précédentes, elles devraient enfin être plus instructives.

Hors ligne

#13 Le 16/02/2014, à 21:01

bruno78

Re : carte Tyan Tachyon 9600pro

Je trouvais en effet que la machine était lente

petit soucis le système me répond
xorg.conf introuvable donc dur de le supprimer

par contre on touve un directory xorg.conf.d dans /usr/share/X11

Dernière modification par bruno78 (Le 16/02/2014, à 21:44)

Hors ligne

#14 Le 16/02/2014, à 22:34

linoll

Re : carte Tyan Tachyon 9600pro

Voyons ce que donne

sudo apt-get purge fglrx*

puis

sudo apt-get install xserver-xorg-video-radeon

puis un redémarrage de l'ordi.

Hors ligne

#15 Le 17/02/2014, à 11:14

bruno78

Re : carte Tyan Tachyon 9600pro

Bonjour,

sudo apt-get purge fglrx* me renvoie que :
Le paquet fglrx n'est pas installé, et ne peut donc être supprimé
Le paquet fglrx-amdcccle n'est pas installé, et ne peut donc être supprimé
Le paquet fglrx-amdcccle-experimental-12 n'est pas installé, et ne peut donc être supprimé
Le paquet fglrx-amdcccle-experimental-13 n'est pas installé, et ne peut donc être supprimé
Le paquet fglrx-amdcccle-experimental-9 n'est pas installé, et ne peut donc être supprimé
Le paquet fglrx-amdcccle-updates n'est pas installé, et ne peut donc être supprimé
Le paquet fglrx-dev n'est pas installé, et ne peut donc être supprimé
Le paquet fglrx-experimental-12 n'est pas installé, et ne peut donc être supprimé
Le paquet fglrx-experimental-12-dev n'est pas installé, et ne peut donc être supprimé
Le paquet fglrx-experimental-13 n'est pas installé, et ne peut donc être supprimé
Le paquet fglrx-experimental-13-dev n'est pas installé, et ne peut donc être supprimé
Le paquet fglrx-experimental-9 n'est pas installé, et ne peut donc être supprimé
Le paquet fglrx-experimental-9-dev n'est pas installé, et ne peut donc être supprimé
Le paquet fglrx-updates n'est pas installé, et ne peut donc être supprimé
Le paquet fglrx-updates-dev n'est pas installé, et ne peut donc être supprimé
Le paquet fglrx-pxpress n'est pas installé, et ne peut donc être supprimé
0 mis à jour, 0 nouvellement installés, 0 à enlever et 0 non mis à jour.

Hors ligne

#16 Le 17/02/2014, à 11:16

bruno78

Re : carte Tyan Tachyon 9600pro

et
sudo apt-get install xserver-xorg-video-radeon
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances       
Lecture des informations d'état... Fait
xserver-xorg-video-radeon est déjà la plus récente version disponible.
0 mis à jour, 0 nouvellement installés, 0 à enlever et 0 non mis à jour.
bureau@bureau-desktop:~$

Hors ligne

#17 Le 17/02/2014, à 13:00

linoll

Re : carte Tyan Tachyon 9600pro

Alors essayons en purgeant le système du pseudo-pilote passe-partout qui semble prendre la main sans qu'on lui ait demandé :

sudo apt-get purge xserver-xorg-video-vesa

(puis redémarrage).

Hors ligne

#18 Le 17/02/2014, à 13:46

bruno78

Re : carte Tyan Tachyon 9600pro

fait et redémarré

Hors ligne

#19 Le 17/02/2014, à 14:34

linoll

Re : carte Tyan Tachyon 9600pro

Et maintenant que dit

glxinfo | grep OpenGL

  ?

Hors ligne

#20 Le 17/02/2014, à 14:36

bruno78

Re : carte Tyan Tachyon 9600pro

toujours la même chose

bureau@bureau-desktop:~$ glxinfo | grep OpenGL
Xlib:  extension "GLX" missing on display ":0.0".
Xlib:  extension "GLX" missing on display ":0.0".
Xlib:  extension "GLX" missing on display ":0.0".
Xlib:  extension "GLX" missing on display ":0.0".
Xlib:  extension "GLX" missing on display ":0.0".
Error: couldn't find RGB GLX visual or fbconfig
Xlib:  extension "GLX" missing on display ":0.0".
Xlib:  extension "GLX" missing on display ":0.0".
Xlib:  extension "GLX" missing on display ":0.0".
Xlib:  extension "GLX" missing on display ":0.0".
Xlib:  extension "GLX" missing on display ":0.0".
Xlib:  extension "GLX" missing on display ":0.0".
Xlib:  extension "GLX" missing on display ":0.0".

Hors ligne

#21 Le 17/02/2014, à 14:47

linoll

Re : carte Tyan Tachyon 9600pro

Bon, alors essayons encore avec

sudo apt-get purge xserver-xorg-video-modesetting xserver-xorg-video-fbdev

Mais surtout avec

sudo apt-get install xserver-xorg-video-ati

avant de redémarrer

Dernière modification par linoll (Le 17/02/2014, à 14:48)

Hors ligne

#22 Le 17/02/2014, à 14:51

bruno78

Re : carte Tyan Tachyon 9600pro

voici :

bureau@bureau-desktop:~$ sudo apt-get purge xserver-xorg-video-modesetting xserver-xorg-video-fbdev
[sudo] password for bureau:
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances       
Lecture des informations d'état... Fait
Les paquets virtuels comme « xserver-xorg-video-modesetting » ne peuvent pas être supprimés
Les paquets suivants seront ENLEVÉS :
  xserver-xorg-video-fbdev*
0 mis à jour, 0 nouvellement installés, 1 à enlever et 0 non mis à jour.
Après cette opération, 81,9 ko d'espace disque seront libérés.
Souhaitez-vous continuer [O/n] ?

(Lecture de la base de données... 191100 fichiers et répertoires déjà installés.)
Suppression de xserver-xorg-video-fbdev ...
Traitement des actions différées (« triggers ») pour « man-db »...

Hors ligne

#23 Le 17/02/2014, à 14:58

linoll

Re : carte Tyan Tachyon 9600pro

Bien (peu importe si modesetting n'y était pas)... et la suite des opérations ?

Hors ligne

#24 Le 17/02/2014, à 15:01

bruno78

Re : carte Tyan Tachyon 9600pro

oups je n'avais pas vu la 2ème commande je le fais

Dernière modification par bruno78 (Le 17/02/2014, à 15:02)

Hors ligne

#25 Le 17/02/2014, à 15:02

linoll

Re : carte Tyan Tachyon 9600pro

Oui mais seulement une fois éxécutée l'installation de xserver-xorg-video-ati

Hors ligne

Haut de page ↑