Contenu | Rechercher | Menus

Annonce

Si vous rencontrez des soucis à rester connecté sur le forum (ou si vous avez perdu votre mot de passe) déconnectez-vous et reconnectez-vous depuis cette page, en cochant la case "Me connecter automatiquement lors de mes prochaines visites".
Test de l'ISO d'Ubuntu francophone : nous avons besoin de testeurs pour la version francophone d'Ubuntu 14.04. Liens et informations ici.

#1 Le 23/02/2014, à 23:50

peripetie

Bureau à distance - vino-serveur ne démarre pas

Bonjour,

Je voudrais passer une machine équipée de 12.04 en serveur. Comme je ne suis pas encore à l'aise avec la ligne de commande j'aimerais dans un premier temps pouvoir aussi utiliser Remmina ou Vinagre. J'ai donc installé vnc, xrdp, je les ai configuré, fail2ban meme si encore aucun domaine ne pointe dessus, et j'ai ouvert les ports 22 et 5900. Mais visiblement vino refuse de démarrer:

#/usr/lib/vino/vino-server

me renvoit le message:

(vino-server:2133): EggSMClient-CRITICAL **: egg_sm_client_set_mode: assertion `global_client == NULL || global_client_mode == EGG_SM_CLIENT_MODE_DISABLED' failed
23/02/2014 22:30:22 Autoprobing TCP port in (all) network interface
23/02/2014 22:30:22 Listening IPv6://[::]:5900
23/02/2014 22:30:22 Listening IPv4://0.0.0.0:5900
23/02/2014 22:30:22 Problems in NewSocketListenTCP()
23/02/2014 22:30:22 Listening IPv6://[::]:5901
23/02/2014 22:30:22 Listening IPv4://0.0.0.0:5901
23/02/2014 22:30:22 Autoprobing selected port 5901
23/02/2014 22:30:22 Advertising security type: 'TLS' (18)
23/02/2014 22:30:22 Re-binding socket to listen for VNC connections on TCP port 5901 in (all) interface
23/02/2014 22:30:22 Listening IPv6://[::]:5901
23/02/2014 22:30:22 Listening IPv4://0.0.0.0:5901
23/02/2014 22:30:22 Clearing securityTypes
23/02/2014 22:30:22 Advertising security type: 'TLS' (18)
23/02/2014 22:30:22 Clearing securityTypes
23/02/2014 22:30:22 Advertising security type: 'TLS' (18)
23/02/2014 22:30:22 Advertising authentication type: 'No Authentication' (1)
23/02/2014 22:30:22 Re-binding socket to listen for VNC connections on TCP port 5901 in (all) interface
23/02/2014 22:30:22 Listening IPv6://[::]:5901
23/02/2014 22:30:22 Listening IPv4://0.0.0.0:5901
23/02/2014 22:30:22 Clearing securityTypes
23/02/2014 22:30:22 Clearing authTypes
23/02/2014 22:30:22 Advertising security type: 'TLS' (18)
23/02/2014 22:30:22 Advertising authentication type: 'No Authentication' (1)
23/02/2014 22:30:22 Advertising security type: 'No Authentication' (1)

(vino-server:2133): LIBDBUSMENU-GLIB-WARNING **: Trying to remove a child that doesn't believe we're it's parent.

(vino-server:2133): LIBDBUSMENU-GLIB-WARNING **: Trying to remove a child that doesn't believe we're it's parent.

Qu'est ce que je fais mal s'il vous plait ?

Hors ligne

#2 Le 24/02/2014, à 00:11

Korak

Re : Bureau à distance - vino-serveur ne démarre pas

Bonjour,

Tu n'aurais pas plus de chance avec webmin?


OS: Ubuntu 14.04 64 bits + Windows 8.1 64 bits en dualboot (BIOS UEFI, Secure Boot activé et table de partitions GPT)
PC portable HP Pavilion g7-2335sb: Processeur: AMD A4-4300M APU   Carte graphique: AMD Radeon HD 7420G   Mémoire vive: 6 Go RAM
Je suis Parrain-Linux

En ligne

#3 Le 05/03/2014, à 03:09

peripetie

Re : Bureau à distance - vino-serveur ne démarre pas

Et bien pour l'heure toujours pas plus !

J'ai suivi le tuto à la lettre
J'ai installé les paquets nécéssaires
J'ai téléchargé et installé le paquet webmin
J'ai vérifié les dépendances (sudo apt-get install -f)
J'ai eu UN pépin. Un petit je pense: en changeant le mot de passe root de Webmin: le caractère  "&" qui faisait partie du mot de passe n'a pas été accepté. Alors du coup:

$ sudo /usr/share/webmin/changepass.pl /etc/webmin root xxxx&yyyy
[1] 8743
Updated password of Webmin user root
yyyy : commande introuvable
[1]+  Fini                    sudo /usr/share/webmin/changepass.pl /etc/webmin root xxxx
$

J'ai ai quand même conclu que le mot de passe root était changé ? Doit-il correspondre à sudo ?
J'ai ouvert le port 10000
La connexion ne peut plus se faire en http: refusée. Bon ! Va pour le https smile
Acceptation sans certificat (firefox), et page de login. Et là impossible de me logger !
2-3 tentatives, puis je passe en local. Mais pareil !
J'ai aussi essayé le mot de passe raccourci par la console. Sans plus de succès.
Et à force d'à force je me suis fait ramasser par Fail2Ban !!

Cette fois je me dis que c'est le sort qui s'acharne. J'avais pourtant croisé les doigts...
Je ne compte pas me servir de Webmin de façon automatique mais dans un premier temps un bureau déporté risque vraiment de me dépanner.
Et puis ce satané serveur est bruyant. Une jolie petite place tout à fait faite pour lui l'attend mais en attendant je suis obligé de le couper car je ne peux pas vivre avec. Et un serveur coupé toussa toussa

Alors voilà je patauge. Donc si quelqu'un savait me tirer de ce mauvais pas je lui en serait vraiment gré

Avec mes remerciements

Hors ligne

  • Accueil
  • » Forum
  • » XFCE
  • » Bureau à distance - vino-serveur ne démarre pas

Haut de page ↑