Contenu | Rechercher | Menus

Annonce

Si vous rencontrez des soucis à rester connecté sur le forum (ou si vous avez perdu votre mot de passe) déconnectez-vous et reconnectez-vous depuis cette page, en cochant la case "Me connecter automatiquement lors de mes prochaines visites". Attention, le forum rencontre actuellement quelques difficultés. En cas d'erreur 502, il ne faut pas re-valider l'envoi d'un message ou l'ouverture d'une discussion, au risque de créer un doublon.

La section divers se réorganise ! De nouvelles sous-sections à venir. (plus d'infos + donner son avis)

#1 Le 12/04/2014, à 11:23

TheKnux

Grub2 et ISO

Bonjour à tous big_smile

Je ne savais pas trop où mettre ça donc je l'ai mis ici hmm
Alors j'ai un léger soucis, j'ai décidé de faire une clé usb avec plusieurs OS dessus, pour cela j'ai installé Grub via ce tuto: http://www.pendrivelinux.com/boot-multi … ing-linux/ (Je me suis arrêté juste avant la partie IV)
Le léger soucis c'est que Ubuntu 13.10 / 64 ne démarre pas sad J'ai toutoulinux qui tourne bien, mais je n'arrive pas à mettre Ubuntu ni Bootrepair...
Voici mon grub.cfg:

set timeout=20
set default=1

menuentry "---- Distributions ----" {
  echo "Merci de choisir une option"
}

menuentry ".. Ubuntu 13.10 Saucy AMD64" {
    set isofile="/iso/ubuntu131064.iso"
    loopback loop $isofile
    echo "Loading vmlinuz.efi"
    linux (loop)/casper/vmlinuz.efi locale=fr_FR bootkbd=fr console-setup/layoutcode=fr iso-scan/filename=$isofile boot=casper noprompt quiet splash --
    echo "Loading initrd"
    initrd (loop)/casper/initrd.lz
    echo "Starting ..."
}

menuentry ".. ToutouLinux 5.5" {
 linux /toutou/vmlinuz
 initrd /toutou/initrd.gz
}

menuentry "---- Outils ----" {
  echo "Merci de choisir une option"
}

menuentry "Boot repair (x64)" {
 loopback loop /iso/boot-repair-disk-64bit.iso
 linux (loop)/casper/vmlinuz boot=casper iso-scan/filename=/iso/boot-repair-disk-64bit.iso noeject noprompt splash --
 initrd (loop)/casper/initrd.lz
}

Quand je lance Toutoulinux (Extrait dans /toutou/) ça marche mais quand je lance Ubuntu, j'ai "Loading vmlinuz.efi" puis "Loading initrd" et "Starting..." mais la plus rien ne se passe et la clé usb ne clignote pu.

Merci de ne pas me suggérer des logiciels comme MultiSystem, je souhaite le faire à la main wink

Merci d'avance


Intel Core i5-3570 (Ivy Bridge) - 8 Go ram - 1 To HD - Sapphire Radeon HD 7850 - KUbuntu 13.04 / Mageia 3

Hors ligne

#2 Le 12/04/2014, à 13:05

jamesbad000

Re : Grub2 et ISO

Bonjour. Au premier abord ce que tu as fait pour l'entrée Ubuntu 13.10 est correcte.
As tu vérifié que le live arrive à démarré de façon autonome sur le même PC, ou testé depuis la clef sur un autre PC ?
Si c'est un problème de compatibilité tu peux essayer en ajoutant un des paramètres suivant sur ta ligne kernel (Pas tous à la fois au moins dans un premier temps)
nomodset
noapic
nolapic
acpi=off
nodmraid

Tu peux aussi essayer de paramétrer ta ligne kernel en reprenant la façon de faire dans le fichier /boot/grub/loopback.cfg de l'iso. Tu va certainement te retrouver avec un clavier qwerty, mais ça permet de voir si ça fonctionne.


L'espace et le temps sont les modes par lesquels nous pensons, et non les conditions dans lesquelles nous vivons. (Signé Albert)

Hors ligne