Contenu | Rechercher | Menus

Annonce

Toute l'équipe d'ubuntu-fr vous souhaite un joyeux Noël et une bonne et heureuse année 2018.

Ubuntu 16.04 LTS
Commandez vos DVD et clés USB Ubuntu-fr !

Pour en savoir un peu plus sur l'équipe du forum.

Si vous avez des soucis pour rester connecté, déconnectez-vous puis reconnectez-vous depuis ce lien en cochant la case
Me connecter automatiquement lors de mes prochaines visites.

#1 Le 18/04/2014, à 16:03

AH798

Icone Wifi Lubuntu 14.04

Bonjour j'ai un souci je n'ai pas d'icone wifi sur ma barre des taches. J'ai bien essayer d'ajouter gestion des réseaux mais rien n'y fait.
Si vous avez une solution ça serait sympa !!
Merci d'avance

Hors ligne

#2 Le 18/04/2014, à 16:37

paeschli

Re : Icone Wifi Lubuntu 14.04

Je déconseille pour le moment d'installer Lubuntu 14.04 si vous avez êtes dépendant d'un réseau WiFi.

Essaye de lancer

nm-applet

dans le Terminal.

Le bug est confirmé: https://bugs.launchpad.net/ubuntu/+sour … ug/1308348


Intelligence is the ability to avoid doing work, yet getting the work done. - Linus Torvalds

Hors ligne

#3 Le 18/04/2014, à 16:45

metal-corpse

Re : Icone Wifi Lubuntu 14.04

J'espère que la solution va vite être trouvé, car j'ai par erreur défoncé mon 13.10, et vraiment la flemme de réinstaller lol.

Hors ligne

#4 Le 18/04/2014, à 20:57

AH798

Re : Icone Wifi Lubuntu 14.04

Effectivement ca merde à mort cette version Oo. Je repasse à la 13.10 parce que j'arrive à me connecter à aucun réseau wifi autre que celui que j'i du configurer pour l'installation.
Merci pour la commande mais je l'ai déjà essayer et ça change rien hmm

Hors ligne

#5 Le 18/04/2014, à 21:27

metal-corpse

Re : Icone Wifi Lubuntu 14.04

Je pense que le pb sera résolu d'ici quelque jour, le plus vite possible sera le mieux cela dit, et j'ai fait la même je suis repassé en 13.10

Hors ligne

#6 Le 19/04/2014, à 14:28

Pierrot86

Re : Icone Wifi Lubuntu 14.04

En attendant la correction du bug, il est possible d'avoir nm-applet au démarrage :

- Aller dans le menu "Préférences" > "Default apps for LXSession"
- Dans l'onglet "Autostart", sous "Manual autostarted applications", taper "nm-applet", et cliquer sur Ajouter.

Normalement, au prochain redémarrage, l'icône du wifi sera visible.

Hors ligne

#7 Le 20/04/2014, à 14:02

rom1725

Re : Icone Wifi Lubuntu 14.04

Je confirme, ça fonctionne, avec

sudo nm-applet 

(d'après le launchpad, si la commande n'est pas lancée en tant qu'administrateur (sudo), l'icône apparaît mais il est impossible de se connecter à un réseau wifi).

Dernière modification par rom1725 (Le 20/04/2014, à 19:56)

Hors ligne

#8 Le 20/04/2014, à 16:08

metal-corpse

Re : Icone Wifi Lubuntu 14.04

oui il t'affiche l'icone du réseau mais c'est tout, mais pas le wi-fi et ne te permet pas de voir l'ensemble des réseau wi-fi

Hors ligne

#9 Le 20/04/2014, à 19:50

rom1725

Re : Icone Wifi Lubuntu 14.04

metal-corpse a écrit :

oui il t'affiche l'icone du réseau mais c'est tout, mais pas le wi-fi et ne te permet pas de voir l'ensemble des réseau wi-fi

Si si. Enfin en tout cas chez moi ça a marché. L'icône est apparue, j'ai vu ma box et j'ai pu m'y connecter. T'as bien lancé la commande en root ?

Hors ligne

#10 Le 20/04/2014, à 21:28

eljoséoyo

Re : Icone Wifi Lubuntu 14.04

ça marche aussi avec Wifi  Radar, En attendant la correction du bug

Hors ligne

#11 Le 21/04/2014, à 00:52

metal-corpse

Re : Icone Wifi Lubuntu 14.04

Oui je l'ai fait en root, mais impossible de voir l'ensemble des réseau wi-fi disponible, ca m'a tellement gavé que j'ai remis la 13.10, un peu la flemme de retester la 14.04 si ca ne fonctionne toujours  pas....
quoique j'ai peut un autre DD sur le quel l'installer lol

Hors ligne

#12 Le 21/04/2014, à 06:19

Maumo13

Re : Icone Wifi Lubuntu 14.04

Confronté au même problème de wifi après mise à niveau de la 13.10 à la 14.04.
Mal m'en a prit, je suis revenu à la 13.10 qui est parfaite.
Il est donc préférable d'attendre la correction de ce dysfonctionnement avant de l'installer.

Hors ligne

#13 Le 21/04/2014, à 08:32

marcosinus

Re : Icone Wifi Lubuntu 14.04

Après la manip décrite par Pierrot86 (ajout de nm-applet dans l'autostart), puis une fermeture/ouverture de session, tout marche correctement.

Hors ligne

#14 Le 21/04/2014, à 21:42

Pierrot86

Re : Icone Wifi Lubuntu 14.04

Merci pour le retour.

Je rajouterai que lancer nm-applet en mode super-utilisateur pose des problèmes de permissions par la suite, qui rendent impossible l'utilisation en tant qu'utilisateur non administrateur.

Hors ligne

#15 Le 22/04/2014, à 08:42

rom1725

Re : Icone Wifi Lubuntu 14.04

Ah d'accord. Merci pour l'info.

Hors ligne

#16 Le 24/04/2014, à 18:14

MoriganPendragon

Re : Icone Wifi Lubuntu 14.04

La solution de rom1725 fonctionne pour rajouter l'applet, mais le wifi ne fonctionne pas correctement avec 14.04. Il détecte bien le réseau, mais ne demande jamais à s’authentifier et à saisir la clé, du coup bah ça vaut pas se connecter, sauf sur des trucs comme freewifi.

J'espère que ça sera bientôt rectifié.

Hors ligne

#17 Le 24/04/2014, à 18:58

Pierrot86

Re : Icone Wifi Lubuntu 14.04

Je ne suis pas certain, mais je me demande si le bug que tu décris pourrais justement être lié au fait d'avoir lancé nm-applet en mode root.

Hors ligne

#18 Le 24/04/2014, à 19:30

MoriganPendragon

Re : Icone Wifi Lubuntu 14.04

Effectivement

Alors après divers tests, voilà ce que ça donne chez moi
- en mode root : l’icône est là, mais impossible de saisir une clé pour une connec wifi, les hotspot fonctionnent
- en mode pas root, tout fonctionne, mais faut lancer à la main depuis le terminal
- au démarrage (préférence/default application for LXDE), là plus de réseau du tout smile

Du coup pour le moment je vais lancer l'applet a la main quand j'en ai besoin

Dernière modification par MoriganPendragon (Le 24/04/2014, à 19:30)

Hors ligne

#19 Le 24/04/2014, à 19:43

Pierrot86

Re : Icone Wifi Lubuntu 14.04

Lorsque tu tentes de le lancer au démarrage, en l'ajoutant dans l'onglet Autostart de "Default apps for LXSession", l'icône s'affiche-t-elle ou rien ne s'affiche du tout ?

Quand tu le lances en utilisateur normal depuis le terminal, des messages apparaissent-ils dans le terminal ?

Hors ligne

#20 Le 24/04/2014, à 20:41

MoriganPendragon

Re : Icone Wifi Lubuntu 14.04

Non, elle s'affiche pas, et j'ai une notification comme quoi j'ai été déconnecté.

Quand je le lance en mode normal et que je me connecte ça affiche ça :

(nm-applet:1812): GLib-GIO-CRITICAL **: g_settings_new_with_path: assertion 'path_is_valid (path)' failed

(nm-applet:1812): GLib-GIO-CRITICAL **: g_settings_get_value: assertion 'G_IS_SETTINGS (settings)' failed

(nm-applet:1812): GLib-CRITICAL **: g_variant_get_type: assertion 'value != NULL' failed

(nm-applet:1812): GLib-CRITICAL **: g_variant_type_is_subtype_of: assertion 'g_variant_type_check (type)' failed

(nm-applet:1812): GLib-CRITICAL **: g_variant_get_boolean: assertion 'g_variant_is_of_type (value, G_VARIANT_TYPE_BOOLEAN)' failed

(nm-applet:1812): GLib-CRITICAL **: g_variant_unref: assertion 'value != NULL' failed

(nm-applet:1812): GLib-GObject-CRITICAL **: g_object_unref: assertion 'G_IS_OBJECT (object)' failed

(nm-applet:1812): GLib-GIO-CRITICAL **: g_settings_new_with_path: assertion 'path_is_valid (path)' failed

(nm-applet:1812): GLib-GIO-CRITICAL **: g_settings_get_value: assertion 'G_IS_SETTINGS (settings)' failed

(nm-applet:1812): GLib-CRITICAL **: g_variant_get_type: assertion 'value != NULL' failed

(nm-applet:1812): GLib-CRITICAL **: g_variant_type_is_subtype_of: assertion 'g_variant_type_check (type)' failed

(nm-applet:1812): GLib-CRITICAL **: g_variant_get_boolean: assertion 'g_variant_is_of_type (value, G_VARIANT_TYPE_BOOLEAN)' failed

(nm-applet:1812): GLib-CRITICAL **: g_variant_unref: assertion 'value != NULL' failed

(nm-applet:1812): GLib-GObject-CRITICAL **: g_object_unref: assertion 'G_IS_OBJECT (object)' failed

(nm-applet:1812): GLib-GIO-CRITICAL **: g_settings_new_with_path: assertion 'path_is_valid (path)' failed

(nm-applet:1812): GLib-GIO-CRITICAL **: g_settings_get_value: assertion 'G_IS_SETTINGS (settings)' failed

(nm-applet:1812): GLib-CRITICAL **: g_variant_get_type: assertion 'value != NULL' failed

(nm-applet:1812): GLib-CRITICAL **: g_variant_type_is_subtype_of: assertion 'g_variant_type_check (type)' failed

(nm-applet:1812): GLib-CRITICAL **: g_variant_get_boolean: assertion 'g_variant_is_of_type (value, G_VARIANT_TYPE_BOOLEAN)' failed

(nm-applet:1812): GLib-CRITICAL **: g_variant_unref: assertion 'value != NULL' failed

(nm-applet:1812): GLib-GObject-CRITICAL **: g_object_unref: assertion 'G_IS_OBJECT (object)' failed

(nm-applet:1812): GLib-GIO-CRITICAL **: g_settings_new_with_path: assertion 'path_is_valid (path)' failed

(nm-applet:1812): GLib-GIO-CRITICAL **: g_settings_get_value: assertion 'G_IS_SETTINGS (settings)' failed

(nm-applet:1812): GLib-CRITICAL **: g_variant_get_type: assertion 'value != NULL' failed

(nm-applet:1812): GLib-CRITICAL **: g_variant_type_is_subtype_of: assertion 'g_variant_type_check (type)' failed

(nm-applet:1812): GLib-CRITICAL **: g_variant_get_boolean: assertion 'g_variant_is_of_type (value, G_VARIANT_TYPE_BOOLEAN)' failed

(nm-applet:1812): GLib-CRITICAL **: g_variant_unref: assertion 'value != NULL' failed

(nm-applet:1812): GLib-GObject-CRITICAL **: g_object_unref: assertion 'G_IS_OBJECT (object)' failed

(nm-applet:1812): GLib-GIO-CRITICAL **: g_settings_new_with_path: assertion 'path_is_valid (path)' failed

(nm-applet:1812): GLib-GIO-CRITICAL **: g_settings_get_value: assertion 'G_IS_SETTINGS (settings)' failed

(nm-applet:1812): GLib-CRITICAL **: g_variant_get_type: assertion 'value != NULL' failed

(nm-applet:1812): GLib-CRITICAL **: g_variant_type_is_subtype_of: assertion 'g_variant_type_check (type)' failed

(nm-applet:1812): GLib-CRITICAL **: g_variant_get_boolean: assertion 'g_variant_is_of_type (value, G_VARIANT_TYPE_BOOLEAN)' failed

(nm-applet:1812): GLib-CRITICAL **: g_variant_unref: assertion 'value != NULL' failed

(nm-applet:1812): GLib-GObject-CRITICAL **: g_object_unref: assertion 'G_IS_OBJECT (object)' failed

(nm-applet:1812): GLib-GIO-CRITICAL **: g_settings_new_with_path: assertion 'path_is_valid (path)' failed

(nm-applet:1812): GLib-GIO-CRITICAL **: g_settings_get_value: assertion 'G_IS_SETTINGS (settings)' failed

(nm-applet:1812): GLib-CRITICAL **: g_variant_get_type: assertion 'value != NULL' failed

(nm-applet:1812): GLib-CRITICAL **: g_variant_type_is_subtype_of: assertion 'g_variant_type_check (type)' failed

(nm-applet:1812): GLib-CRITICAL **: g_variant_get_boolean: assertion 'g_variant_is_of_type (value, G_VARIANT_TYPE_BOOLEAN)' failed

(nm-applet:1812): GLib-CRITICAL **: g_variant_unref: assertion 'value != NULL' failed

(nm-applet:1812): GLib-GObject-CRITICAL **: g_object_unref: assertion 'G_IS_OBJECT (object)' failed
^Cnm-applet-Message: PID 0 (we are 1812) sent signal 2, shutting down...

(nm-applet:1812): GLib-CRITICAL **: Source ID 86 was not found when attempting to remove it

Puis l’icône disparaît, mais ça me laisse quand même le temps de me connecter.

Dernière modification par MoriganPendragon (Le 24/04/2014, à 20:43)

Hors ligne

#21 Le 24/04/2014, à 21:54

Pierrot86

Re : Icone Wifi Lubuntu 14.04

Comme je le disais, le fait de lancer nm-applet en mode root (même une seule fois), entraîne des problèmes d'autorisations sur certains fichiers de configuration. Je me demande si ton problème est lié à ça ou non.

Peut-être qu'en réinstallant totalement network-manager-gnome (en passant par Synaptic, choisir "Supprimer complètement", puis réinstaller le paquet), cela résoudrait ton problème. Mais c'est vraiment sans garantie.

Hors ligne

#22 Le 25/04/2014, à 13:43

Nicolas St

Re : Icone Wifi Lubuntu 14.04

Mais en filaire, ça marche bien quand même? Je peux l'installer sur une machine qui n'utilise pas le wifi?


Desktop: HP Pavilion a6435 (Athlon64 2x 2,6Ghz, Radeon R7-240, Ram 4 Go, DD 500 Go) / Debian Stretch (XFCE)

Laptop: Packard-Bell EasyNote G1320 (Celeron 1,3 Ghz, ATI Mobility Radeon 9100 IGP, Ram 1,2 Go, DD 40 Go) / Debian Stretch

Hors ligne

#23 Le 26/04/2014, à 11:23

MoriganPendragon

Re : Icone Wifi Lubuntu 14.04

Oui, en filaire ça fonctionne très bien. En fait, je ne me suis rendu compte du problème que quand j'ai voulu me connecter en wifi. Je n'ai noté aucun soucis par connec Ethernet.

Alors après quelques essais, il semble que ça fonctionne :
- Suppression complète de network-manager-gnome depuis synaptic puis reboot
- MAJ des paquets puis réinstallation de network-manager-gnome et de tous les paquets conseillés depuis synaptic
- Ajout de nm-applet au démarrage ("Préférences" > "Default apps for LXSession", onglet "Autostart", "nm-applet", "Ajouter"
- Mise a jour de lubuntu (gestionnaire de MAJ) et redémarrage comme demandé

Si ça plante a nouveau je vous ferai signe, mais pour le moment, ça tiens.

Dernière modification par MoriganPendragon (Le 26/04/2014, à 11:54)

Hors ligne

#24 Le 27/04/2014, à 09:28

godziley

Re : Icone Wifi Lubuntu 14.04

MoriganPendragon a écrit :

Oui, en filaire ça fonctionne très bien. En fait, je ne me suis rendu compte du problème que quand j'ai voulu me connecter en wifi. Je n'ai noté aucun soucis par connec Ethernet.

Alors après quelques essais, il semble que ça fonctionne :
- Suppression complète de network-manager-gnome depuis synaptic puis reboot
- MAJ des paquets puis réinstallation de network-manager-gnome et de tous les paquets conseillés depuis synaptic
- Ajout de nm-applet au démarrage ("Préférences" > "Default apps for LXSession", onglet "Autostart", "nm-applet", "Ajouter"
- Mise a jour de lubuntu (gestionnaire de MAJ) et redémarrage comme demandé

Si ça plante a nouveau je vous ferai signe, mais pour le moment, ça tiens.

Merci MoriganPendragon ! J'ai essayé et cela fonctionne. A voir comment cela se comporte avec la future correction que nous proposera Ubuntu. Je fais signe également si ça plante. Bonne journée à tous.


Passez au libre !

Hors ligne

#25 Le 27/04/2014, à 09:44

Pierrot86

Re : Icone Wifi Lubuntu 14.04

Tant mieux si ça fonctionne.

En définitive, après l'installation de Lubuntu, il faut uniquement rajouter nm-applet au démarrage pour corriger le problème. Et surtout, ne pas lancer nm-applet en mode superutilisateur.

Hors ligne