Contenu | Rechercher | Menus

Annonce

Si vous rencontrez des soucis à rester connecté sur le forum (ou si vous avez perdu votre mot de passe) déconnectez-vous et reconnectez-vous depuis cette page, en cochant la case "Me connecter automatiquement lors de mes prochaines visites". Attention, le forum rencontre actuellement quelques difficultés. En cas d'erreur 502, il ne faut pas re-valider l'envoi d'un message ou l'ouverture d'une discussion, au risque de créer un doublon.

La section divers se réorganise ! De nouvelles sous-sections à venir. (plus d'infos + donner son avis)

#1 Le 01/04/2005, à 14:07

Kagou

[HOW-TO] : Installation des drivers 3d propriétaires pour ATI Radeon

Je vois un peu trop souvent des posts éparpillés sur ce sujet.
Voici la démarche à tenir pour installer les drivers de chez ATI en utilisant les paquets fournis par Ubuntu.

NOTA :
La méthode que vous pouvez trouver sur le net pour installer les tout derniers drivers ATI, en utilisant les rpm et en recompilant le module fglrx pour votre noyau fonctionne. MAIS, vous aurez des problèmes dès qu'il s'agira de mettre à jour xorg ou linux-restricted. Vous voila prévenu wink
Nous supposons que vous êtes sur une Hoary non bidouillée...

A l'aide de synaptic vous installez :
fglrx-control
xorg-driver-fglrx

Dans un deuxième temps nous allons installer, toujours grâce à synaptic le paquet contenant les modules non libres ("restricted"). Pour ce faire vous devez trouver quel est ou quels sont les noyaux que vous utilisez.

Sous synaptic vous recherchez les noyaux installés dont le nom commence par "linux-image-" (sous synaptic un paquet installé et marqué avec un carré vert)

Chez moi j'ai :
linux-image-2.6.10-5-k7
et
linux-image-k7

Vous notez les numéros de version de vos noyaux.

Toujours sous synaptic vous recherchez "linux-restricted-modules-" vous obtiendrez une liste de paquets disponibles.
Il vous faut choisir ceux dont les numéros correspondent aux numéros de vos noyaux.

Chez moi :
linux-restricted-modules-k7
et
linux-restricted-modules-2.6.10-5-k7

Vous les installez.

Dans un terminal vous lancez :

sudo gedit /etc/modules

et vous ajoutez comme premier module à charger au démarrage :

fglrx

voici mon fichier /etc/modules pour l'exemple :

# /etc/modules: kernel modules to load at boot time.
#
# This file contains the names of kernel modules that should be loaded
# at boot time, one per line. Lines beginning with "#" are ignored.
fglrx
ide-cd
ide-disk
ide-generic
lp
mousedev
psmouse
sbp2
sr_mod

Toujours dans un terminal :

sudo gedit /etc/X11/xorg.conf

Vous repérez la section [Device] et vous remplacez la ligne

      Driver      "ati"

par

      Driver      "fglrx"

Dans la section [Module]
commentez "Load "extmod" " et rajoutez des lignes afin d'avoir ceci:

#    Load    "extmod"
    SubSection "extmod"
        Option    "omit xfree86-dga"
    EndSubSection

Cela vous donne accès à xrandr, qui permet de changer la taille de l'écran sans redémarrer.

Le mieux maintenant est de complètement redémarrer pour vous assurer que tout fonctionne. Dans le cas négatif re-éditez le fichier xorg.conf et remettez "ati" ce qui vous permettra de revenir à X. (éditeurs disponibles en mode console : vi, vim, nano etc...)

Normalement tout est ok.
En cas de réussite, merci d'indiquer votre score à glxgears ("glxgears -printfps" si cela n'affiche rien) et à fgl_glxgears, le type de votre carte ATI, sa mémoire, votre processeur et sa RAM. Ainsi que la version des pilotes ATi en utilisant fireglcontrol.
Un utilitaire de configuration est disponible : fireglcontrol.

ÇA NE MARCHE TOUJOURS PAS ?!

dans votre /etc/modules mettez ceci en premier

agpgart
nvidia-agp # Ou bien le module selon votre chipset : intel-agp / via-agp / sis-agp
fglrx

Ensuite dans votre /etc/X11/xorg.conf
ajoutez l'option UseInternalAGPGART ou si elle est existante mettez la à "no"

Driver    "fglrx"
Option "UseInternalAGPGART" "no"

Vous devez redémarrer le PC.



Si vous avez des remarques/infos/problèmes/astuces merci de les faire partager sur ce post afin d'augmenter ce HOW-TO

Dernière modification par Kagou (Le 01/04/2005, à 20:26)


«black-out» du Net français

http://www.laquadrature.net/HADOPI

Hors ligne

#2 Le 01/04/2005, à 15:04

Keito

Re : [HOW-TO] : Installation des drivers 3d propriétaires pour ATI Radeon

J'ai un AMD Athlon 2600+, une Powercolor Radeon 9800 Pro 128 et une carte mere Abit NF7-s. J'ai d'installer :

linux-image-2.6.10-5-386
linux-image-2.6-386
linux-image-2.6.8.1-3-386
linux-image-386

Oui Oui, tout ca. C'est peut etre pour ca que cela ne marche pas ? Car je n'ai que ~350 fps à glxgears et n'ai pas l'acceleration 3D.

Dernière modification par Keito (Le 01/04/2005, à 15:06)

Hors ligne

#3 Le 01/04/2005, à 16:13

Kagou

Re : [HOW-TO] : Installation des drivers 3d propriétaires pour ATI Radeon

glxgears : 1342
fgl_glxgears : 285
driver ATI 8.08.25
AMD64 3400+
512 RAM
Carte ATI mobility 9600 M10 64Mo (portable)


«black-out» du Net français

http://www.laquadrature.net/HADOPI

Hors ligne

#4 Le 01/04/2005, à 16:18

Kagou

Re : [HOW-TO] : Installation des drivers 3d propriétaires pour ATI Radeon

Keito a écrit :

J'ai un AMD Athlon 2600+, une Powercolor Radeon 9800 Pro 128 et une carte mere Abit NF7-s. J'ai d'installer :

linux-image-2.6.10-5-386
linux-image-2.6-386
linux-image-2.6.8.1-3-386
linux-image-386

Oui Oui, tout ca. C'est peut etre pour ca que cela ne marche pas ? Car je n'ai que ~350 fps à glxgears et n'ai pas l'acceleration 3D.

Tu n'as pas "linux-restricted-2.6-386"  et "linux-restricted-2.6.8.1-3-386" d'installé ?
Tu n'es pas à jour non plus puisqu'en hoary les kernels sont plus récents.

Il faut mettre fglrx en première position dans ton /etc/modules et pas à la fin.

vérifie que le module fglrx est installé :

lsmod | grep fglrx

doit afficher un truc du style :

fglrx                 237312  7

Sinon donne nous ton fichier /etc/X11/xorg.conf

Dernière modification par Kagou (Le 01/04/2005, à 16:20)


«black-out» du Net français

http://www.laquadrature.net/HADOPI

Hors ligne

#5 Le 01/04/2005, à 16:33

doobs

Re : [HOW-TO] : Installation des drivers 3d propriétaires pour ATI Radeon

Carte : Radeon 9600 XT 128 Mo(ATI Technologies Inc RV350 AR [Radeon 9600])
Proc :Athlon XP 1600+
Ram :512 Mo


----------------
lsmod | grep fglrx
fglrx                 240192  24


----------------
linux-restricted-modules-2.6.10.4-1
linux-image-2.6.10-5-k7
fglrx-driver (2.6.8.1.3-7)


----------------
fireglcontrol
Driver Version : 8.08.25
OpenGL Version : 1.3.4769


----------------
glxgears :
10508 frames in 5.0 seconds = 2101.600 FPS
10510 frames in 5.0 seconds = 2102.000 FPS
10511 frames in 5.0 seconds = 2102.200 FPS
10507 frames in 5.0 seconds = 2101.400 FPS


----------------
fgl_glxgears :
1998 frames in 5.0 seconds = 399.600 FPS
1872 frames in 5.0 seconds = 374.400 FPS
2009 frames in 5.0 seconds = 401.800 FPS
2007 frames in 5.0 seconds = 401.400 FPS

Hors ligne

#6 Le 01/04/2005, à 17:10

Keito

Re : [HOW-TO] : Installation des drivers 3d propriétaires pour ATI Radeon

capture5ms.th.png
capture14px.th.png

DIte moi ce que je dois désinstaller et installer car je pense que je dois mettre à jour ca mais je sais pas quoi prendre ( peur de tout planter ). Sinon, j'ai mis fglrx au debut de /etc/modules

Dernière modification par Keito (Le 01/04/2005, à 17:13)

Hors ligne

#7 Le 01/04/2005, à 17:23

doobs

Re : [HOW-TO] : Installation des drivers 3d propriétaires pour ATI Radeon

Tu peux mettre :

linux-image-2.6.10-5-k7
linux-restricted-modules-2.6.10-5-k7

de toute facon, au prochain reboot, grub te proposera le choix de booter soit sur le nouveau noyau, soit sur l'ancien.

Hors ligne

#8 Le 01/04/2005, à 17:58

riri

Re : [HOW-TO] : Installation des drivers 3d propriétaires pour ATI Radeon

Comme on trouve pas mal de posts éparpillés là-dessus, je vous donne ma méthode et le résultat pour un AMD64, en Hoary (ma carte graphique est un ATI Radeon 9800 PRO).

1) J'apt-get les drivers fglrx pour xorg et les modules du noyau (restricted-modules).

2) je sauvegarde /etc/X11/xorg.conf (en xorg.conf.xorgdrv)

3) je lance fglrxconfig en répondant tout par défaut quand c'est possible.

4) Le fichier généré a des commentaires pour Xfree86 ! je me dis donc que leur utilitaire n'est pas très à jour. Soit :-)

5) Je renomme le XF86Config-4 en xorg.conf.fglrx

6) Et la mon astuce :-) : je fais un diff des deux fichiers (après avoir enlevé les commentaires d'aide) : diff -u xorg.conf.xorgdrv xorg.conf.fglrx > xorg.conf.diff . Je regarde les différences et je les reporte si besoin de l'ancien (xorg.conf.xorgdrv) vers le nouveau (xorg.conf.fglrx). L'intérêt de cette méthode est qu'on a toutes les options du driver renseignées.

7) Je modifie le fameux UseInternalAGPGART que je place à "no" ainsi que ForceGenericCPU que je mets aussi à "no"

8) Je teste, ça marche bien (mon test est l'économiseur d'écran Atunnel + glxgears) :-)

Voici le résultat (sauf que les tabulations ne sont pas bien rendues ici) :

Section "dri"
	Mode	0666
EndSection

Section "Module"
	Load	"dbe"

	Load	"extmod"
#	SubSection "extmod"
#		Option	"omit xfree86-dga"
#	EndSubSection

	Load	"type1"
	Load	"freetype"

	Load	"glx"
	Load	"dri"

	Load	"bitmap"
	Load	"int10"
	Load	"record"
#	Load	"speedo"
#	Load	"xtt"

#	Load	"ddc"	# not reported
#	Load	"vbe"	# not reported
EndSection

Section "Files"
	FontPath	"unix/:7100"			# local font server
	# if the local font server has problems, we can fall back on these
	FontPath	"/usr/lib/X11/fonts/misc"
#	FontPath	"/usr/lib/X11/fonts/cyrillic"
	FontPath	"/usr/lib/X11/fonts/100dpi/:unscaled"
	FontPath	"/usr/lib/X11/fonts/75dpi/:unscaled"
	FontPath	"/usr/lib/X11/fonts/Type1"
#	FontPath	"/usr/lib/X11/fonts/CID"
	FontPath	"/usr/lib/X11/fonts/100dpi"
	FontPath	"/usr/lib/X11/fonts/75dpi"
        # paths to defoma fonts
	FontPath	"/var/lib/defoma/x-ttcidfont-conf.d/dirs/TrueType"
#	FontPath	"/var/lib/defoma/x-ttcidfont-conf.d/dirs/CID"
EndSection

Section "InputDevice"
	Identifier	"UltraFlat"
	Driver		"keyboard"
	Option		"CoreKeyboard"
	Option		"AutoRepeat"		"500 30"
	Option		"XkbRules"		"xorg"
	Option		"XkbModel"		"pc105"
	Option		"XkbLayout"		"fr-latin9"
EndSection

Section "InputDevice"
	Identifier	"Logitech"
	Driver		"mouse"
	Option		"CorePointer"
	Option		"Device"		"/dev/input/mice"
	Option		"Protocol"		"ImPS/2"
	Option		"ZAxisMapping"		"4 5"
EndSection

Section "Monitor"
	Identifier	"Futura"
	Option		"DPMS"
	HorizSync	31.5 - 86.0
	VertRefresh	50 - 160
EndSection

Section "Device"
	Identifier	"Standard VGA"
	VendorName	"Unknown"
	BoardName	"Unknown"
	Driver		"vga"
EndSection

Section "Device"
	Identifier	"ATI Radeon 9800PRO"
	Driver		"fglrx"
	BusID		"PCI:1:0:0"
	Screen		0

	Option		"no_accel"		"no"
	Option		"no_dri"		"no"
	Option		"mtrr"			"off"

	Option		"DesktopSetup"		"0x00000000"
	Option		"MonitorLayout"		"AUTO, AUTO"
	Option		"IgnoreEDID"		"off"
	#Option		"Hsync2"		"unspecified"
	#Option		"VRefresh2"		"unspecified"
	#Option		"ScrenOverlap"		"0"

	Option		"NoTV"			"yes"
	#Option		"TVStandard"		"NTSC-M"
	#Option		"TVHSizeAdj"		"0"
	#Option		"TVVSizeAdj"		"0"
	#Option		"TVHPosAdj"		"0"
	#Option		"TVVPosAdj"		"0"
	#Option		"TVHStartAdj"		"0"
	#Option		"TVColorAdj"		"0"
	#Option		"GammaCorrectionI"	"0x00000000"
	#Option		"GammaCorrectionII"	"0x00000000"
	#Option		"Capabilities"		"0x00000000"
	#Option		"VideoOverlay"		"on"

	Option		"OpenGLOverlay"		"off"
	Option		"CenterMode"		"off"
	Option		"PseudoColorVisuals"	"off"

	Option		"Stereo"		"off"
	Option		"StereoSyncEnable"	"1"

	Option		"FSAAEnable"		"no"
	Option		"FSAAScale"		"1"
	Option		"FSAADisableGamma"	"no"
	Option		"FSAACustomizeMSPos"	"no"

	Option		"FSAAMSPosX0"		"0.000000"
	Option		"FSAAMSPosY0"		"0.000000"
	Option		"FSAAMSPosX1"		"0.000000"
	Option		"FSAAMSPosY1"		"0.000000"
	Option		"FSAAMSPosX2"		"0.000000"
	Option		"FSAAMSPosY2"		"0.000000"
	Option		"FSAAMSPosX3"		"0.000000"
	Option		"FSAAMSPosY3"		"0.000000"
	Option		"FSAAMSPosX4"		"0.000000"
	Option		"FSAAMSPosY4"		"0.000000"
	Option		"FSAAMSPosX5"		"0.000000"
	Option		"FSAAMSPosY5"		"0.000000"

	Option		"UseFastTLS"		"0"
	Option		"BlockSignalsOnLock"	"on"
	Option		"UseInternalAGPGART"	"no"
	Option		"ForceGenericCPU"	"no"
EndSection

Section "Screen"
	Identifier	"Default Screen"
	Device		"ATI Radeon 9800PRO"
	Monitor		"Futura"
	DefaultDepth	24
	Option		"BackingStore"

	SubSection "Display"
		Depth		1
		Modes		"1600x1200" "1400x1050" "1280x1024" "1152x864" "1024x768" "800x600" "640x480"
	EndSubSection
	SubSection "Display"
		Depth		4
		Modes		"1600x1200" "1400x1050" "1280x1024" "1152x864" "1024x768" "800x600" "640x480"
	EndSubSection
	SubSection "Display"
		Depth		8
		Modes		"1600x1200" "1400x1050" "1280x1024" "1152x864" "1024x768" "800x600" "640x480"
	EndSubSection
	SubSection "Display"
		Depth		15
		Modes		"1600x1200" "1400x1050" "1280x1024" "1152x864" "1024x768" "800x600" "640x480"
	EndSubSection
	SubSection "Display"
		Depth		16
		Modes		"1600x1200" "1400x1050" "1280x1024" "1152x864" "1024x768" "800x600" "640x480"
	EndSubSection
	SubSection "Display"
		Depth		24
		Modes		"1600x1200" "1400x1050" "1280x1024" "1152x864" "1024x768" "800x600" "640x480"
	EndSubSection
EndSection

Section "ServerLayout"
	Identifier	"Default Layout"
	Screen		"Default Screen"
	InputDevice	"UltraFlat"
	InputDevice	"Logitech"
EndSection

Si vous voyez des horreurs dans ce fichier de config, faite-le moi savoir :-)


riri - tulkluteur avertit.
La liberté d'une personne s'arrête où commence celle des autres.

Hors ligne

#9 Le 01/04/2005, à 18:23

O.

Re : [HOW-TO] : Installation des drivers 3d propriétaires pour ATI Radeon

ors@linolivier:~$ fgl_glxgears
1060 frames in 5.0 seconds = 212.000 FPS
1411 frames in 5.0 seconds = 282.200 FPS
1402 frames in 5.0 seconds = 280.400 FPS
1375 frames in 5.0 seconds = 275.000 FPS
1400 frames in 5.0 seconds = 280.000 FPS

ors@linolivier:~$ glxgears
fglrx                 240192  7

5580 frames in 5.0 seconds = 1116.000 FPS
5838 frames in 5.0 seconds = 1167.600 FPS
5887 frames in 5.0 seconds = 1177.400 FPS

Avec une Radeon 9600 256Mo
Mon processeur est un athlon XP2000+ à 1.4GHz (je crois)

Par contre je n'ai pas utilisé exactement la méthode décrite pour installer. J'ai utilisé fglrxconfig après avoir installé les paquets par Synaptic

Dernière modification par O. (Le 01/04/2005, à 18:24)


Erreur : pas de clavier détecté. Appuyer sur F1 pour continuer

Hors ligne

#10 Le 01/04/2005, à 19:07

coffee

Re : [HOW-TO] : Installation des drivers 3d propriétaires pour ATI Radeon

il y a eu des prix pour les 9600 ou quoi?


Nom d'un tupperware habillé en streetware mangeant de la confiture de pouère et qui se dite où est-ce que je suis ouère !
Tiens mon blog
Les blagues sous forme de fausses aides sont susceptible de ban (ex: rm)

Hors ligne

#11 Le 01/04/2005, à 20:21

Keito

Re : [HOW-TO] : Installation des drivers 3d propriétaires pour ATI Radeon

Carte : Radeon 9800 Pro 128 Mo (ATI Technologies Inc RV350 AR [Radeon 9800])
Proc :Athlon XP 2600+
Ram :512 Mo


----------------
lsmod | grep fglrx
fglrx                 229440  7

----------------
fireglcontrol
Driver Version : 8.08.25
OpenGL Version : 1.3.4769

----------------
glxgears :
16065 frames in 5.0 seconds = 3213.000 FPS
15997 frames in 5.0 seconds = 3199.400 FPS
15972 frames in 5.0 seconds = 3194.400 FPS

----------------
fgl_glxgears :
3086 frames in 5.0 seconds = 617.200 FPS
3266 frames in 5.0 seconds = 653.200 FPS
3255 frames in 5.0 seconds = 651.000 FPS

Hors ligne

#12 Le 02/04/2005, à 10:30

Paul Atreides

Re : [HOW-TO] : Installation des drivers 3d propriétaires pour ATI Radeon

Merci beaucoup à Kagou d'avoir fait ce post INDISPENSABLE ! Je pense même qu'il devrait figurer en sticky tellement ce problème concerne du monde (en gros tous les possesseurs de carte ATI, ça fait bcp !)

Même chez moi avec une modeste 9200SE (oui, j'ai honte) mes perfs ont sextuplé. Je les affiche quand même pour figurer dans le top-nul de ce post :
-------------
glxgears
8143 frames in 5.0 seconds = 1628.600 FPS
8144 frames in 5.0 seconds = 1628.800 FPS
8144 frames in 5.0 seconds = 1628.800 FPS
8145 frames in 5.0 seconds = 1629.000 FPS
8142 frames in 5.0 seconds = 1628.400 FPS

contre environ 271 FPS auparavant ! big_smile
---------------
fgl_glxgears
697 frames in 5.0 seconds = 139.400 FPS
760 frames in 5.0 seconds = 152.000 FPS
742 frames in 5.0 seconds = 148.400 FPS
760 frames in 5.0 seconds = 152.000 FPS
751 frames in 5.0 seconds = 150.200 FPS

Dernière modification par Paul Atreides (Le 02/04/2005, à 10:31)

Hors ligne

#13 Le 03/04/2005, à 10:28

themis

Re : [HOW-TO] : Installation des drivers 3d propriétaires pour ATI Radeon

moi il ne veux pas me lancer le module fglrx mais a priori c'est normal ma carte est une ATI Radeon igp 320m (sur portable) et elle ne figure pas dans les cartes compatible :'/

Hors ligne

#14 Le 04/04/2005, à 02:13

coffee

Re : [HOW-TO] : Installation des drivers 3d propriétaires pour ATI Radeon

il te reste le driver radeon quand même


Nom d'un tupperware habillé en streetware mangeant de la confiture de pouère et qui se dite où est-ce que je suis ouère !
Tiens mon blog
Les blagues sous forme de fausses aides sont susceptible de ban (ex: rm)

Hors ligne

#15 Le 04/04/2005, à 05:22

Kagou

Re : [HOW-TO] : Installation des drivers 3d propriétaires pour ATI Radeon

Regarde peut être du coté de dri sur sourceforge.


«black-out» du Net français

http://www.laquadrature.net/HADOPI

Hors ligne

#16 Le 04/04/2005, à 12:12

manatlan

Re : [HOW-TO] : Installation des drivers 3d propriétaires pour ATI Radeon

bon maintenant que tout le monde sait installé les drivers proprio de sa radeon.

Ce serait bien de regarder ce problème, à savoir : "savoir reveiller la carte ati radeon (fglrx) après un suspend-to-ram, ou suspend-to-disk (hibernation)" ...

http://www.ubuntulinux.org/wiki/HoaryPM

ça vous dirait pas de pouvoir booter en 4 secondes chronos ? (en suspend-to-ram)

Il semblerait que des gars(pros) ait déjà trouver comment faire pour contourner la mauvaise gestion de l'acpi des fglrx ...

n'y a t il pas un pro ubuntu qui voudrait faire un tuto/how-to pour qu'on puisse tous en bénéficier ?


"Oui, oui."
                -- Shakespeare (Richard III, Acte I, Scène IV)

Hors ligne

#17 Le 04/04/2005, à 13:16

Kagou

Re : [HOW-TO] : Installation des drivers 3d propriétaires pour ATI Radeon

Il faut apparemment ajouter "fglrx" dans /etc/defaults/acpi-support  dans la section modules. Ne pas oublier de décommenter "ACPI_SLEEP=true" si vous voulez en bénéficier. Et n'oubliez pas non plus de mettre "resume=/dev/hda5" (où hda5 est votre swap) en paramètre pour le kernel. Je teste ça et je vous tiens au courant.

Bon ça c'est la théorie mad
En fait vous avez le choix entre soit :
ça marche et vous utilisez "ati" et pas "fglrx" pour xorg (pas de 3D)
ça marche et vous utilisez "fglrx" mais sans le dri (pas de 3D)
ça marche pas et vous arrêtez d'essayer de mettre ce #$ù%"é de portable en hibernation lol

C'est comme avec les ombres, j'attends que les derniers drivers soient dispo dans la hoary. Mais pour le moment c'est :
Avec dri et donc 3D, mais sans ombres et transparences
Soit avec ombres et transparences mais sans dri, donc pas de 3D.... Mr ATI vous pourriez pas vous bouger !! sad


«black-out» du Net français

http://www.laquadrature.net/HADOPI

Hors ligne

#18 Le 05/04/2005, à 07:28

manatlan

Re : [HOW-TO] : Installation des drivers 3d propriétaires pour ATI Radeon

Kagou a écrit :

Il faut apparemment ajouter "fglrx" dans /etc/defaults/acpi-support  dans la section modules. Ne pas oublier de décommenter "ACPI_SLEEP=true" si vous voulez en bénéficier. Et n'oubliez pas non plus de mettre "resume=/dev/hda5" (où hda5 est votre swap) en paramètre pour le kernel. Je teste ça et je vous tiens au courant.

Alors ... des nouvelles ? un soluce, un tuto ?


"Oui, oui."
                -- Shakespeare (Richard III, Acte I, Scène IV)

Hors ligne

#19 Le 05/04/2005, à 07:39

Kagou

Re : [HOW-TO] : Installation des drivers 3d propriétaires pour ATI Radeon

Lit mieux mon dernier post wink

Concernant les ombres/transparences, même avec le tout dernier driver de chez ATI c'est pareil.
Il faut choisir entre 3D ou ombres+transparences .... mad


«black-out» du Net français

http://www.laquadrature.net/HADOPI

Hors ligne

#20 Le 05/04/2005, à 10:19

Titus

Re : [HOW-TO] : Installation des drivers 3d propriétaires pour ATI Radeon

Hum, une petite rédaction d'article pour résumer tout ça ? roll


Aucun de nous ne sait ce que nous savons tous, ensemble. Lao Tseu

Hors ligne

#21 Le 05/04/2005, à 10:37

Kagou

Re : [HOW-TO] : Installation des drivers 3d propriétaires pour ATI Radeon

Ca va viendre cool
J'attends quelques retours d'expérience avant smile


«black-out» du Net français

http://www.laquadrature.net/HADOPI

Hors ligne

#22 Le 05/04/2005, à 19:02

sly

Re : [HOW-TO] : Installation des drivers 3d propriétaires pour ATI Radeon

Bonlour à tous,

Pour ma part, la méthode la plus simple que j'ai trouvé, c'est de:
1. installer xorg-driver-fglrx via synaptic
2. sudo dpkg-reconfigure xserver-xorg
3. reboot

Et voilou.

BARTON 2500+
ATI 9200 128Mo

#23 Le 05/04/2005, à 19:35

thom

Re : [HOW-TO] : Installation des drivers 3d propriétaires pour ATI Radeon

Radeon 9600 Club 128 DDR, P4 2.8, 512

Voila ce que ça donne :

thom@ubuntu:~ $ fgl_glxgears
1073 frames in 5.0 seconds = 214.600 FPS
1327 frames in 5.0 seconds = 265.400 FPS
1332 frames in 5.0 seconds = 266.400 FPS
1331 frames in 5.0 seconds = 266.200 FPS
1339 frames in 5.0 seconds = 267.800 FPS
1322 frames in 5.0 seconds = 264.400 FPS
thom@ubuntu:~ $ glxgears
5934 frames in 5.0 seconds = 1186.800 FPS
6882 frames in 5.0 seconds = 1376.400 FPS
6874 frames in 5.0 seconds = 1374.800 FPS
6880 frames in 5.0 seconds = 1376.000 FPS
6880 frames in 5.0 seconds = 1376.000 FPS
6880 frames in 5.0 seconds = 1376.000 FPS
thom@ubuntu:~ $

-> Ubuntu on a Sony Vaio VNG-FS115B
-> Wificonfig is a little script aimed to ease the switching between networks, for people who have 2 network cards : a wired one and a wireless one.

Hors ligne

#24 Le 05/04/2005, à 20:06

Kagou

Re : [HOW-TO] : Installation des drivers 3d propriétaires pour ATI Radeon

sly a écrit :

Bonlour à tous,

Pour ma part, la méthode la plus simple que j'ai trouvé, c'est de:
1. installer xorg-driver-fglrx via synaptic
2. sudo dpkg-reconfigure xserver-xorg
3. reboot

Et voilou.

BARTON 2500+
ATI 9200 128Mo

je serai très curieux de voir tes résultats avec glxgears et fgl_glxgears


«black-out» du Net français

http://www.laquadrature.net/HADOPI

Hors ligne

#25 Le 06/04/2005, à 17:06

newportable

Re : [HOW-TO] : Installation des drivers 3d propriétaires pour ATI Radeon

Salut les loutres wink
J'essaie d'installer ubuntu sur le T42 d'un pôte, mais impossible d'installer les drivers avec ca mobility 7500 sous hoary en suivant le tuto. Ce qui m'inquiète c'est que la carte n'est pas marqué comme supporté par le driver  dans synaptic!!! Y a quand même moyen d'avoir une accélération graphique, parce que moi qui lui parle de tuxracer depuis quelques jours ce m'emmerde...
Merci d'avance

Hors ligne

Haut de page ↑