Contenu | Rechercher | Menus

Annonce

Si vous rencontrez des soucis à rester connecté sur le forum (ou si vous avez perdu votre mot de passe) déconnectez-vous et reconnectez-vous depuis cette page, en cochant la case "Me connecter automatiquement lors de mes prochaines visites".
Test de l'ISO d'Ubuntu francophone : nous avons besoin de testeurs pour la version francophone d'Ubuntu 14.04. Liens et informations ici.

#1 Le 15/05/2014, à 08:32

mlefeuvre

La connexion a échouée - Serveur Lamp

Bonjour,
J'ai récemment fait une mise à jour d'Ubuntu (14.04) sur la machine où il y a mon serveur LAMP.
Malheureusement, depuis cette mise  jour, plus moyen d'avoir accès à phpmyadmin, ni mes pages Web ...

Merci de votre aide.

Hors ligne

#2 Le 15/05/2014, à 10:20

Filador

Re : La connexion a échouée - Serveur Lamp

Bonjour,

Tu es surement passé à Apache 2.7.*, pour me le confirmer, peux-tu faire un :

apache2 -v

et me donner le retour.

Merci

Hors ligne

#3 Le 15/05/2014, à 10:38

casperfr

Re : La connexion a échouée - Serveur Lamp

ya de grande change quand faisant l'install par défaut il est une version 2.7x d'apache,
quoi qu'il en soit le est a refaire d'après tous mes tests cela ce produits depuis la version 13.04 d'ubuntu


pour une édition 14.04 d'ubuntu quand tu installes apache l'emplacement par défaut est /var/www/html
il faudrait donc pour accédé a phpmyadmin

sudo ln -s /usr/share/phpmyadmin /var/www/html

c'est ce qui est a faire pour toi,

a titre d'information
pour édition anterieur de ubuntu 14.04 il faudrait donc pour accédé a phpmyadmin faire

sudo ln -s /usr/share/phpmyadmin /var/www

pour un xampp le dossier de travail est /opt/lampp/htdocs/
donc le lien est

sudo ln -s /usr/share/phpmyadmin /opt/lampp/htdocs/

Hors ligne

#4 Le 15/05/2014, à 14:17

bruno

Re : La connexion a échouée - Serveur Lamp

Bonjour,

@ casperfr : comment peux-tu donner ces conseils ? tu ne sais rien de sa configuration, ses hôtes virtuels et où son stockés ses sites. À proscrire donc.

Pour information Apache est en version 2.4 (et non 2.7) depuis Ubuntu 13.10, et effectivement il y a des changements de configuration entre la version 2.2 (fournie avec Ubuntu 12.04 LTS et jusqu' à les 13.04) qui peuvent bloquer le fonctionnement lors d'une mise à jour.

Pour phpmyadmin :

- vérifier la présence du fichier /etc/phpmyadmin/apache.conf
- vérifier le présence d'un lien symbolique vers ce fichier dans /etc/apache2/conf-available/ en tapant :

ls -l /etc/apache2/conf-available/phpmyadmin.conf

Sil n'existe pas, il faut le créer :

sudo ln -s  /etc/phpmyadmin/apache.conf /etc/apache2/conf-available/phpmyadmin.conf

puis activer la configuration :

sudo a2enconf phpmyadmin 

et recharger apache :

sudo service apache2  reload

Pour les sites il faut nous donner ta configuration, c'est  à dire le(s) hôte(s) virtuels(s) actifs présents dans /etc/apache2/sites-enabbled

Dernière modification par bruno (Le 15/05/2014, à 14:17)

Hors ligne

#5 Le 15/05/2014, à 15:36

casperfr

Re : La connexion a échouée - Serveur Lamp

Bonjour Bruno,
je donne se conseil par ce que sur le forum ubuntu-fr, un utilisateur n'ayant plus accès a phpmyadmin pour la meme raison évoqué c'est a dire la mise a jour, a décortiqué le howto de phpmyadmin ou il est indiqué qu'il faut faire un lien symbolique, cette utilisateur a demander la marche a suivre pour effectué ce lien symbolique, je n'ai pas cherché plus loin j'ai donné les lignes de commande pour effectué ce lien symbolique, je n'ai pas cherché a savoir si cette information venais bien du howto de phpmyadmin, quand on me pose la question de savoir comment accédé a phpmyadmin alors qu'il vient d'etre installé je donne la ligne de commande pour créé ce lien symbolique c'est tout,
quand cela est possible je suis le premier a dire de ne pas faire de lien symbolique, maintenant il y a la simplicité d'usage de compréhension.
il est indiqué sur le premier post, que phpmyadmin fonctionnait avant, puis plus d'accès suite a la mise a jour vers ubuntu 14.04.
si un fichier conf existait avant la mise a jour, celui ci doit existé après (en toute logique) c'est pour cela que je me suis dis que comme le passage a ubuntu 14.04 ayant changé le dossier de travail par défaut d'apache, le lien qui existait précédement ne fonctionne plus, pour moi je penses donc qu'il y avait déja un lien symbolique dans /var/www et qu'il suffit donc de le déplacer vers le nouveau dossier de travail /var/www/html

Hors ligne

#6 Le 15/05/2014, à 16:07

bruno

Re : La connexion a échouée - Serveur Lamp

Ok, c'était une méthode ancienne.

Le problème c'est que sur Debian ou Ubuntu ce n'est pas ainsi que c'est configuré par défaut lors de l'installation du paquet phpmyadmin (en tout cas depuis un bon bout de temps).
Les mainteneurs des paquets Debian proposent en général des configuration par défaut très logiques et sécurisées.
Il faut donc éviter de faire cela avec un lien symbolique et surtout pour tout ce qui est configuration il vaut mieux se référer en premier lieu au documentation à jour de Debian et/ou Ubuntu.

Comme je l'ai indiqué l'accès à phpmyadmin est configuré dans le fichier /etc/phpmyadmin/apache.conf grâce à une Directive Alias qui fait pointer /phpmyadmin sur /usr/sahre/phmyadmin.

Ce qui a changé lors du passage à la version 2.4 d'Apache c'est surtout que les fichiers et liens symboliques qui étaient dans /etc/apapache2/conf.d ne sont plus pris en compte. À la place il y a une nouvelle arborescence conf-available / conf/enabled similaire à ce qui se fait pour les hôtes virtuels avec site-available / site enabled.

Hors ligne

#7 Le 26/05/2014, à 08:14

dodovolant

Re : La connexion a échouée - Serveur Lamp

Bonjour,
je suis dans le cas de réinstaller tout l'ensemble "lamp / phpmyadmin" sur la 14.04 (32bits), j'ai bien compris le nouvel adresage /var/www/html et j'y ai collé mes sites. Et la liste s'affiche bien dans http://localhost....
Et grâce aux conseils de Bruno j'arrive bien à la page d'ouverture de phpMyadmin, mais les identifiants de connexion sont-ils 'prédéterminés'? Si j'en tape comme pour une 'création' de nouvel utilisateur j'ai le message surligné en rouge

La connexion au controluser tel que défini dans votre configuration a échoué. 

Or je n'ai pas encore 'fait de configuration'.... j'ai testé bêtement un root/root qui n'a rien donné non plus....
Un avis?

Dernière modification par dodovolant (Le 26/05/2014, à 08:16)


hiroshima45, tchernobyl86, windows2000, Vista12 (mois!! mdr)
(piqué ailleurs:) si microsoft invente un truc qui "plante pas"... ce sera un clou !!
sites : nivoyousnisoumis.re - dodosvolants.free.fr
sur facebook : Dod Ovolant

Hors ligne

#8 Le 26/05/2014, à 09:33

bruno

Re : La connexion a échouée - Serveur Lamp

Normalement phpmyadmin te demande de définir un mot de passe à l'installation.

Si tu as raté cette étape, tu peux la retrouver en faisant :

sudo dpkg-reconfigure phpmyadmin

Hors ligne

Haut de page ↑