Contenu | Rechercher | Menus

Annonce

Si vous rencontrez des soucis à rester connecté sur le forum (ou si vous avez perdu votre mot de passe) déconnectez-vous et reconnectez-vous depuis cette page, en cochant la case "Me connecter automatiquement lors de mes prochaines visites".
Test de l'ISO d'Ubuntu francophone : nous avons besoin de testeurs pour la version francophone d'Ubuntu 14.04. Liens et informations ici.

Attention, une faille de sécurité dans bash a récemment été rapportée, il est recommandé de mettre à jour son système (plus de détails) *** mise à jour 12/10/2014 ***

#1 Le 19/05/2014, à 10:27

retrogame

Squid, SquidGuard, ActiveDirectory

Bonjour

Je rencontre un problème de configuration. Je pense que c'est simplement un problème de .conf, un paramètre  manquant ou faux.

Sur le serveur Proxy

J'ai installé l'ActiveDirectory, il fonctionne parfaitement, apache2, webmin, clamav, squid et squidguard, sarg.

Voici dans le fichier log les erreurs que je rencontre.

2014-05-19 09:28:01 [2822] init urllist /var/lib/squidguard/db//blacklists/porn/urls
2014-05-19 09:28:01 [2822] init domainlist /var/lib/squidguard/db//blacklists/agressif/domains
2014-05-19 09:28:01 [2822] init urllist /var/lib/squidguard/db//blacklists/agressif/urls
2014-05-19 09:28:01 [2822] (squidGuard): can't open userlist /var/lib/squidguard/db//users/internet: No such file or directory
2014-05-19 09:28:01 [2822] (squidGuard): can't open userlist /var/lib/squidguard/db//users/internetvip: No such file or directory
2014-05-19 09:28:01 [2822] Added User: root
2014-05-19 09:28:01 [2822] Added User: proxy
2014-05-19 09:28:01 [2822] destblock local missing active content, set inactive
2014-05-19 09:28:01 [2822] squidGuard 1.4 started (1400484435.048)
2014-05-19 09:28:01 [2822] Info: recalculating alarm in 9119 seconds
2014-05-19 09:28:01 [2822] squidGuard ready for requests (1400484481.847)
2014-05-19 09:28:04 [2821] init urllist /var/lib/squidguard/db//blacklists/porn/urls
2014-05-19 09:28:04 [2821] init domainlist /var/lib/squidguard/db//blacklists/agressif/domains
2014-05-19 09:28:04 [2821] init urllist /var/lib/squidguard/db//blacklists/agressif/urls
2014-05-19 09:28:04 [2821] (squidGuard): can't open userlist /var/lib/squidguard/db//users/internet: No such file or directory
2014-05-19 09:28:04 [2821] (squidGuard): can't open userlist /var/lib/squidguard/db//users/internetvip: No such file or directory
2014-05-19 09:28:04 [2821] Added User: root
2014-05-19 09:28:04 [2821] Added User: proxy
2014-05-19 09:28:04 [2821] destblock local missing active content, set inactive
2014-05-19 09:28:04 [2821] squidGuard 1.4 started (1400484435.047)
2014-05-19 09:28:04 [2821] Info: recalculating alarm in 9116 seconds
2014-05-19 09:28:04 [2821] squidGuard ready for requests (1400484484.775)
2014-05-19 09:28:05 [2820] init urllist /var/lib/squidguard/db//blacklists/porn/urls
2014-05-19 09:28:05 [2820] init domainlist /var/lib/squidguard/db//blacklists/agressif/domains
2014-05-19 09:28:05 [2820] init urllist /var/lib/squidguard/db//blacklists/agressif/urls
2014-05-19 09:28:05 [2820] (squidGuard): can't open userlist /var/lib/squidguard/db//users/internet: No such file or directory
2014-05-19 09:28:05 [2820] (squidGuard): can't open userlist /var/lib/squidguard/db//users/internetvip: No such file or directory
2014-05-19 09:28:05 [2820] Added User: root
2014-05-19 09:28:05 [2820] Added User: proxy
2014-05-19 09:28:05 [2820] destblock local missing active content, set inactive
2014-05-19 09:28:05 [2820] squidGuard 1.4 started (1400484435.048)
2014-05-19 09:28:05 [2820] Info: recalculating alarm in 9115 seconds
2014-05-19 09:28:05 [2820] squidGuard ready for requests (1400484485.708)

Les erreurs sont les même à chaque fois. SquidGuard ne peut pas ouvrir la userliste car le répertoire n’existe pas.
Internet et internetVip sont les 2 groupes que j'utilise pour différencier les accès des utilisateurs.

La blacklist vient de l'université de Toulouse je crois.

Je rappel que le proxy fonctionne bien, je l'utilise pour la navigation cependant il ne filtre rien et ne prend pas en compte la blacklist alors que c'est le but du jeu^^.

Merci de votre aide si vous avez besoin d'autre fichier dite le moi. Merci à bientôt

Dernière modification par retrogame (Le 19/05/2014, à 10:28)

Hors ligne

#2 Le 19/05/2014, à 12:07

Sniijz

Re : Squid, SquidGuard, ActiveDirectory

Bonjour Retrogame,

Désolé de te redemander mais ton problème m'intrigue ^^'
Le proxy a bien été paramétré pour la navigation, mais est ce que tu l'as paramétré sur ton Shell?

Sinon apparemment c'est qu'il ne trouve pas ta liste d'utilisateurs, est tu sur de ton arborescence ?
C'est normal le double slash après "db" dans "/var/lib/squidguard/db//users/internet" ?

Amicalement,

Sniijz.


- Raspberry Pi Class B sous Raspbian
- Laptop Asus XDAF5 sous Xubuntu 13.10 / Voyager 12.04 / Win8
- iMac 20" 9,1 Intel Core 2 Duo, 2GO DDR3 SDRAM, NVIDIA GeForce 9400M, DD 320GB
- PC Assemblé i3-2100, MSI B75A-G43, 8GO DDR3 SDRAM, Nvidia Geforce GTX 560, DD WD 1To.

Hors ligne

Haut de page ↑