Contenu | Rechercher | Menus

Annonce

Si vous rencontrez des soucis à rester connecté sur le forum (ou si vous avez perdu votre mot de passe) déconnectez-vous et reconnectez-vous depuis cette page, en cochant la case "Me connecter automatiquement lors de mes prochaines visites".

#1 Le 28/04/2008, à 08:29

Hoper

[Resolu] Faire un espace dans l'editeur SPE !?

Bonjour,

J'essaye de me mettre un tout petit peu à python.
J'ai vu ici que certain utilisaient SPE, et j'ai donc voulu l'essayer.
C'est vrai qu'il a l'air plutot sympatique... mais je bloc sur un truc tout bête :

quand je tape du code, je ne sais pas faire un espace !?
Quand je tape sur la barre espace, il essaye de faire de la complétion automatique.
Alors quand je suis en train de taper une commande, ok c'est sympa, mais quand je veux
juste taper du texte ca fait pareil.... un simple :
print "bonjour à tous"
est impossible car je ne peut pas faire l'espace apres bonjour.
J'ai essayé dans les options de désactiver tout ce qui pouvait avoir trait à cette complétion
automatique mais je n'ai pas encore trouvé....

Voila.... Merci d'avance smile

Dernière modification par Hoper (Le 30/04/2008, à 12:34)


Mes tutos et coups de gueule :
http://hoper.dnsalias.net/tdc/

Hors ligne

#2 Le 30/04/2008, à 09:32

Hoper

Re : [Resolu] Faire un espace dans l'editeur SPE !?

Bon... j'ai au moins compris pourquoi j'avais pas de réponses...
J'imagine que chez tout le monde la touche espace fonctionne très bien et que donc personne ne voit de quoi je parle.

En effet je me suis apercu d'un truc vraiment bizarre.
Si au lieu de lancer spe sur mon poste directement, je me conecte sur ce meme pc a distance via ssh -X et que je le lance, alors la plus de problèmes tout fonctionne.
Et la... moi j'y comprend rien. Pourtant, tout tourne, tout est lancé sur la meme machine.. ce n'est que l'affichage qui se fait sur un autre serveur X...
Donc la vraiment je bloque totalement. Je ne vois pas du tout comment analyser le problème. Sauf si quelqu'un a une idée génial, je pense que ca va rapidement se terminer par une ré-installation complete de ma machine...


Mes tutos et coups de gueule :
http://hoper.dnsalias.net/tdc/

Hors ligne

#3 Le 30/04/2008, à 10:37

valAa

Re : [Resolu] Faire un espace dans l'editeur SPE !?

salut salut !!

je n'utilise pas SPE mais ... Code::Blocks, et j'avais exactement le même problème !
la solution, je l'ai trouvée ici
http://forum.ubuntu-fr.org/viewtopic.php?pid=1710880

alors si jamais c'est le même problème avec SPE, ça peut marcher...

Hors ligne

#4 Le 30/04/2008, à 10:40

Hoper

Re : [Resolu] Faire un espace dans l'editeur SPE !?

Cool smile Ca pourrait expliquer que ca fonctionne sur un serveur X et pas sur l'autre... Je test ca à midi et je te tiens au courant.
Un grand merci à toi ! Tu viens très probablement de m'eviter une ré-installe.

Serais-ce abusé de te demander de m'expliquer comment tu as pu arriver à trouver ca !?? Qu'est ce qui a bien pu te faire penser à commenter cette ligne précisément ? Sachant que la barre espace fonctionne pour n'importe quel autre appli etc...


Mes tutos et coups de gueule :
http://hoper.dnsalias.net/tdc/

Hors ligne

#5 Le 30/04/2008, à 10:46

valAa

Re : [Resolu] Faire un espace dans l'editeur SPE !?

oulaa, moi pour trouver la solution, j'ai juste tapé "Codeblocks espace" dans la recherche du forum... big_smile

la vraie soluce nous vient d'un invité... voire le post plus haut.:)
en bref, ça vient d'un bug sur la disposition du clavier "fr oss"... ça doit donc pouvoir se régler aussi en passant par les paramètres du clavier et en changeant de variante...

Dernière modification par valAa (Le 30/04/2008, à 10:50)

Hors ligne

#6 Le 30/04/2008, à 12:35

Hoper

Re : [Resolu] Faire un espace dans l'editeur SPE !?

C'est bon !
Vraiment merci d'avoir pris le temps de répondre, j'aurai jamais trouvé sinon...
espace et spe ca donnait rien du tout sous google...


Mes tutos et coups de gueule :
http://hoper.dnsalias.net/tdc/

Hors ligne

#7 Le 19/02/2013, à 13:44

D13

Re : [Resolu] Faire un espace dans l'editeur SPE !?

j'ai eu ce soucis avec SPE sur ubuntu 12.04 (precise), le problème a été résolut de manière graphique :
fenêtre paramètre système / agencement du clavier / option.../ Utiliser la barre d'espacement pour insérer une espace insécable, ensuite sélectionner "L'espace habituelle quelque-soit le niveau".

Une fois l'option cocher, en démarrant spe le problème été résolut.

Hors ligne

Haut de page ↑