Contenu | Rechercher | Menus

Annonce

Si vous rencontrez des soucis à rester connecté sur le forum (ou si vous avez perdu votre mot de passe) déconnectez-vous et reconnectez-vous depuis cette page, en cochant la case "Me connecter automatiquement lors de mes prochaines visites".
Test de l'ISO d'Ubuntu francophone : nous avons besoin de testeurs pour la version francophone d'Ubuntu 14.04. Liens et informations ici.

Attention, une faille de sécurité dans bash a récemment été rapportée, il est recommandé de mettre à jour son système (plus de détails) *** mise à jour 12/10/2014 ***

#1 Le 22/06/2014, à 09:15

Voron

Mark of the ninja sur steam ne se lance plus

Bonjour,

J'ai un problème pour jouer à Mark of the ninja via steam. Vendredi ça marchait parfaitement et samedi, le jeu ne se lance même plus. J'ai essayé pas mal de chose, comme vérifier l'intégrité du cache (steam à détecté un problème, téléchargé les fichiers manquants mais rien ne change), réinstaller le jeu, réinstaller steam, vérifier que l’exécution de ninja.sh était autorisée...
Quand je lance le sh en console j'ai ceci:

dlopen failed trying to load:
/home/xxx/.local/share/Steam/ubuntu12_32/steamclient.sowith error:
libtier0_s.so: cannot open shared object file: No such file or directory
[S_API FAIL] SteamAPI_Init() failed; Sys_LoadModule failed to load: /home/xxx/.local/share/Steam/ubuntu12_32/steamclient.so
[S_API FAIL] SteamAPI_Init() failed; unable to locate a running instance of Steam, or a local steamclient.dll.
ninja.sh : ligne 3 :  3966 Erreur de segmentation  (core dumped) ./ninja-bin32

J'ai trouvé un début de piste : http://www.jpichon.net/blog/2014/05/steam-on-linux/
Mais ça n'a rien changé non plus. Bref je bloque!

Je tourne sous Ubuntu 12.04.

Quelqu'un sait comment régler le problème? Merci d'avance!

Voron.

Hors ligne

#2 Le 22/06/2014, à 12:57

abelthorne

Re : Mark of the ninja sur steam ne se lance plus

Tout ce que je peux te dire, c'est que le jeu marche chez moi. Ce n'est donc pas un problème général suite à une màj qui aurait tout cassé, par exemple.

Quand tu dis que tu as réinstallé Steam, tu veux dire depuis les dépôts ? Si c'est le cas, ça ne sert à peu près à rien vu qu'il stocke ses données dans ton dossier utilisateur. Essaie d'aller dans /home/xxx/.local/share/Steam et supprime tout sauf SteamApps et userdata. Ensuite, relance steam depuis un terminal.

Hors ligne

#3 Le 22/06/2014, à 20:02

Voron

Re : Mark of the ninja sur steam ne se lance plus

J'ai effectivement réinstallé steam via les dépôts, mais j'ai aussi penser à supprimer le répertoire .local/Steam/ ...

Maintenant que j'y pense, j'ai installé un autre jeu via PlayOnLinux, qui m'a mis à jour Wine... mais je pense pas que Mark of the ninja passe par wine... Je n'y comprend rien sad

Hors ligne

#4 Le 22/06/2014, à 20:11

abelthorne

Re : Mark of the ninja sur steam ne se lance plus

Non, il n'utilise pas Wine. Et si c'était le cas, il aurait sa propre version intégrée, indépendante de celle du système.

Pas de problèmes avec d'autres jeux Steam ?

Hors ligne

#5 Le 22/06/2014, à 20:46

Voron

Re : Mark of the ninja sur steam ne se lance plus

J'ai tester tout les jeux que j'ai installés actuellement, ils marchent tous.

Hors ligne

#6 Le 23/06/2014, à 11:05

abelthorne

Re : Mark of the ninja sur steam ne se lance plus

Il y a un truc auquel je n'avais pas fait attention dans ton message : tu lances le jeu directement sans passer par Steam. Si tu lances Steam depuis un terminal (commande steam) et qu'avec tu lances le jeu, même message d'erreur que la dernière ligne ?

Et si tu vas dans le dossier du jeu pour lancer le binaire plutôt que le script ?

cd $HOME/.local/share/Steam/SteamApps/common/mark_of_the_ninja/bin
./ninja-bin32

Hors ligne

#7 Le 23/06/2014, à 13:58

Voron

Re : Mark of the ninja sur steam ne se lance plus

Le lancement du binaire donne la même erreur que le sh.

J'ai lancer steam depuis la console, puis le jeu:

Game update: AppID 214560 "Mark of the Ninja", ProcID 4431, IP 0.0.0.0:0
ERROR: ld.so: object '/home/thomas/.local/share/Steam/ubuntu12_32/gameoverlayrenderer.so' from LD_PRELOAD cannot be preloaded: ignored.
ERROR: ld.so: object '/home/thomas/.local/share/Steam/ubuntu12_64/gameoverlayrenderer.so' from LD_PRELOAD cannot be preloaded: ignored.
Setting breakpad minidump AppID = 214560
Steam_SetMinidumpSteamID:  Caching Steam ID:  76561198063117823 [API loaded no]
X Error of failed request:  BadValue (integer parameter out of range for operation)
  Major opcode of failed request:  129 (XFree86-VidModeExtension)
  Minor opcode of failed request:  10 (XF86VidModeSwitchToMode)
  Value in failed request:  0x261
  Serial number of failed request:  143
  Current serial number in output stream:  145
Game removed: AppID 214560 "Mark of the Ninja", ProcID 4433 

Hors ligne

#8 Le 23/06/2014, à 14:16

abelthorne

Re : Mark of the ninja sur steam ne se lance plus

Qu'est-ce que tu as comme puce graphique ? Quel pilote est-ce que tu utilises ?

Hors ligne

#9 Le 23/06/2014, à 15:54

Voron

Re : Mark of the ninja sur steam ne se lance plus

Mon carte graphique est une 9600 GT, et le pilote, je l'ai installé via le panneau "Pilotes additionnels" (version 331-updates).

C'est possible qu'il soit pas à jour ou qu'il marche mal d'ailleurs, j'ai parfois des ralentissements sur les pages web. Mais bon la dernière fois que j'ai changé de driver ça a mal fini...

Hors ligne

#10 Le 23/06/2014, à 16:38

abelthorne

Re : Mark of the ninja sur steam ne se lance plus

Non, je me disais que tu avais peut-être installé un pilote libre encore en développement dont une mise à jour aurait pu expliquer le problème mais ce n'est pas le cas.

Hors ligne

#11 Le 23/06/2014, à 19:50

love2hate

Re : Mark of the ninja sur steam ne se lance plus

Bonjour tu peut essayer lancer le jeux avec l'option '-enablelog', me semble que sa doit creer un log plus detailler dans  ~/.klei/ninja/log/rendering.log

PS sa marche avec le build de l'humble, pour steam aucune idee, a test !!


1984 was not supposed to be an instruction manual
Some "poor" wine screencast http://www.youtube.com/user/2m42hy/videos?view=0

Hors ligne

Haut de page ↑