Contenu | Rechercher | Menus

Annonce

Si vous rencontrez des soucis à rester connecté sur le forum (ou si vous avez perdu votre mot de passe) déconnectez-vous et reconnectez-vous depuis cette page, en cochant la case "Me connecter automatiquement lors de mes prochaines visites". Attention, le forum rencontre actuellement quelques difficultés. En cas d'erreur 502, il ne faut pas re-valider l'envoi d'un message ou l'ouverture d'une discussion, au risque de créer un doublon.

La section divers se réorganise ! De nouvelles sous-sections à venir. (plus d'infos + donner son avis)

#1 Le 24/06/2014, à 09:15

Donaldus

[Résolu]Unity, Locale : clavier non reconnu complètement

Bonjour,

Sous Ubuntu 14.04 en anglais, mes entrées claviers (clavier Belge, UTF-8 fr_BE) se comportent étrangement pour les caractères spéciaux dans Unity (et Google Chrome mais je pense que c'est lié). Néanmoins, tout autre application fonctionne parfaitement (Open Office, Kile, Gedit, Terminal, ...)

Pour mieux illustrer tout cela :
Les touches de 1 à 0 devraient retourner & é " ' ( § è ! ç à
Dans Chrome : &2"'(67!90
Dash Unity : & " ' ( !

J'ai essayé

sudo dpkg-reconfigure locales
Generating locales...
  en_AG.UTF-8... done
  en_AU.UTF-8... done
  en_BW.UTF-8... done
  en_CA.UTF-8... done
  en_DK.UTF-8... done
  en_GB.UTF-8... done
  en_HK.UTF-8... done
  en_IE.UTF-8... done
  en_IN.UTF-8... done
  en_NG.UTF-8... done
  en_NZ.UTF-8... done
  en_PH.UTF-8... done
  en_SG.UTF-8... done
  en_US.UTF-8... done
  en_ZA.UTF-8... done
  en_ZM.UTF-8... done
  en_ZW.UTF-8... done
  fr_BE.UTF-8... up-to-date
  fr_CA.UTF-8... up-to-date
  fr_CH.UTF-8... up-to-date
  fr_FR.UTF-8... up-to-date
  fr_LU.UTF-8... up-to-date
$ locale
LANG=en_IN
LANGUAGE=en_IN:en
LC_CTYPE="en_IN"
LC_NUMERIC=fr_BE.UTF-8
LC_TIME=fr_BE.UTF-8
LC_COLLATE="en_IN"
LC_MONETARY=fr_BE.UTF-8
LC_MESSAGES="en_IN"
LC_PAPER=fr_BE.UTF-8
LC_NAME=fr_BE.UTF-8
LC_ADDRESS=fr_BE.UTF-8
LC_TELEPHONE=fr_BE.UTF-8
LC_MEASUREMENT=fr_BE.UTF-8
LC_IDENTIFICATION=fr_BE.UTF-8
LC_ALL=

J'ai essayé la solution suivante :

rm -rf .cache/ibus .config/ibus .config/dconf

Une solution pour avoir un clavier fonctionnel sous chrome est de le lancer de la manière suivante :

ANG=fr_BE.utf8 google-chrome

Le clavier est pourtant configuré en tant que clavier belge. J'ai essayé de le supprimer et de le remettre, sans résultat encore.

D'avance, merci pour votre aide!


EDIT :
Problème réglé avec la commande suivante :

sudo dpkg-reconfigure keyboard-configuration 

Dernière modification par Donaldus (Le 24/06/2014, à 12:45)

Hors ligne

  • Accueil
  • » Forum
  • » Unity
  • » [Résolu]Unity, Locale : clavier non reconnu complètement

Haut de page ↑